]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- real cc should be >= 3.4
[packages/llvm.git] / llvm.spec
CommitLineData
aa11c230 1Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 2Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 3Name: llvm
633c6443 4Version: 2.3
aa11c230 5Release: 0.1
6License: University of Illinois/NCSA Open Source License
7Group: Development/Languages
aa11c230 8Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.tar.gz
633c6443 9# Source0-md5: 17254d72863b7fa005f3fb327aea3439
aa11c230 10Patch0: %{name}-dirs.patch
2326a99f
JB
11URL: http://llvm.org/
12BuildRequires: gcc >= 5:3.4
356a0bbd
ER
13# gcc4 might be installed, but not current __cc
14%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
15BuildRequires: __cc >= 3.4
16%endif
aa11c230 17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
356a0bbd 19%define _sysconfdir /etc/%{name}
021b3c3d 20
aa11c230 21%description
22LLVM is a compiler infrastructure designed for compile-time,
23link-time, runtime, and idle-time optimization of programs from
24arbitrary programming languages. LLVM is written in C++ and has been
25developed since 2000 at the University of Illinois and Apple. It
26currently supports compilation of C and C++ programs, using front-ends
27derived from GCC 4.0.1. A new front-end for the C family of languages
28is in development. The compiler infrastructure includes mirror sets of
29programming tools as well as libraries with equivalent functionality.
30
2326a99f
JB
31%description -l pl.UTF-8
32LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
33czasu kompilowania, linkowania, działania i bezczynności programów w
34dowolnych językach programowania. Jest napisana w C++, rozwijana od
35roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
36kompilację programów w C i C++ przy użyciu frontendów wywodzących się
37z GCC 4.0.1. W trakcie tworzenia jest nowy frontend do języków z
38rodziny C. Infrastruktura kompilatora zawiera lustrzane zestawy
39narzędzi programistycznych oraz biblioteki z odpowiadającą narzędziom
40funkcjonalnością.
41
aa11c230 42%prep
43%setup -q
44%patch0 -p0
45
46%build
47%configure \
48 --enable-optimized \
49 --enable-assertions
50
51%{__make} tools-only
52
53%install
54rm -rf $RPM_BUILD_ROOT
55
56%{__make} install \
57 DESTDIR=$RPM_BUILD_ROOT
58
021b3c3d 59find $RPM_BUILD_ROOT -name .dir |xargs rm -f
60
aa11c230 61%clean
62rm -rf $RPM_BUILD_ROOT
63
2326a99f
JB
64%post -p /sbin/ldconfig
65%postun -p /sbin/ldconfig
aa11c230 66
67%files
68%defattr(644,root,root,755)
69%doc CREDITS.TXT LICENSE.TXT README.txt docs
a9beeab5
JB
70%attr(755,root,root) %{_bindir}/bugpoint
71%attr(755,root,root) %{_bindir}/gccas
72%attr(755,root,root) %{_bindir}/gccld
73%attr(755,root,root) %{_bindir}/llc
74%attr(755,root,root) %{_bindir}/lli
75%attr(755,root,root) %{_bindir}/llvm-*
76%attr(755,root,root) %{_bindir}/llvm2cpp
77%attr(755,root,root) %{_bindir}/llvmc
78%attr(755,root,root) %{_bindir}/opt
021b3c3d 79%dir %{_sysconfdir}
a9beeab5
JB
80%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/c
81%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/c++
82%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/cpp
83%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/cxx
84%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/ll
85%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/st
86%{_libdir}/LLVM*.o
87%{_libdir}/libLLVM*.a
88# just example?
89%attr(755,root,root) %{_libdir}/LLVMHello.so*
90%{_libdir}/LLVMHello.la
91%{_libdir}/LLVMHello.a
aa11c230 92%{_includedir}/llvm
021b3c3d 93%{_includedir}/llvm-c
a9beeab5
JB
94%{_mandir}/man1/bugpoint.1*
95%{_mandir}/man1/llc.1*
96%{_mandir}/man1/lli.1*
97%{_mandir}/man1/llvm-*.1*
98%{_mandir}/man1/llvm2cpp.1*
99%{_mandir}/man1/llvmc.1*
100%{_mandir}/man1/llvmgcc.1*
101%{_mandir}/man1/llvmgxx.1*
102%{_mandir}/man1/opt.1*
103%{_mandir}/man1/stkrc.1*
104%{_mandir}/man1/tblgen.1*
This page took 0.04536 seconds and 4 git commands to generate.