]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- pl
[packages/llvm.git] / llvm.spec
CommitLineData
aa11c230 1Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 2Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 3Name: llvm
4Version: 2.1
5Release: 0.1
6License: University of Illinois/NCSA Open Source License
7Group: Development/Languages
aa11c230 8Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: b930e7213b37acc934d0d163cf13af18
10Patch0: %{name}-dirs.patch
2326a99f
JB
11URL: http://llvm.org/
12BuildRequires: gcc >= 5:3.4
aa11c230 13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
021b3c3d 15%define _sysconfdir /etc/%{name}
16
aa11c230 17%description
18LLVM is a compiler infrastructure designed for compile-time,
19link-time, runtime, and idle-time optimization of programs from
20arbitrary programming languages. LLVM is written in C++ and has been
21developed since 2000 at the University of Illinois and Apple. It
22currently supports compilation of C and C++ programs, using front-ends
23derived from GCC 4.0.1. A new front-end for the C family of languages
24is in development. The compiler infrastructure includes mirror sets of
25programming tools as well as libraries with equivalent functionality.
26
2326a99f
JB
27%description -l pl.UTF-8
28LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
29czasu kompilowania, linkowania, działania i bezczynności programów w
30dowolnych językach programowania. Jest napisana w C++, rozwijana od
31roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
32kompilację programów w C i C++ przy użyciu frontendów wywodzących się
33z GCC 4.0.1. W trakcie tworzenia jest nowy frontend do języków z
34rodziny C. Infrastruktura kompilatora zawiera lustrzane zestawy
35narzędzi programistycznych oraz biblioteki z odpowiadającą narzędziom
36funkcjonalnością.
37
aa11c230 38%prep
39%setup -q
40%patch0 -p0
41
42%build
43%configure \
44 --enable-optimized \
45 --enable-assertions
46
47%{__make} tools-only
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%{__make} install \
53 DESTDIR=$RPM_BUILD_ROOT
54
021b3c3d 55find $RPM_BUILD_ROOT -name .dir |xargs rm -f
56
aa11c230 57%clean
58rm -rf $RPM_BUILD_ROOT
59
2326a99f
JB
60%post -p /sbin/ldconfig
61%postun -p /sbin/ldconfig
aa11c230 62
63%files
64%defattr(644,root,root,755)
65%doc CREDITS.TXT LICENSE.TXT README.txt docs
66%attr(755,root,root) %{_bindir}/*
021b3c3d 67%dir %{_sysconfdir}
68%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/*
aa11c230 69%{_libdir}/*.o
70%{_libdir}/*.a
71%{_libdir}/*.la
72%attr(755,root,root) %{_libdir}/*.so*
73%{_includedir}/llvm
021b3c3d 74%{_includedir}/llvm-c
aa11c230 75%{_mandir}/man?/llvm*
This page took 0.098238 seconds and 4 git commands to generate.