]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- initial, nfy
[packages/llvm.git] / llvm.spec
CommitLineData
aa11c230 1Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2Name: llvm
3Version: 2.1
4Release: 0.1
5License: University of Illinois/NCSA Open Source License
6Group: Development/Languages
7URL: http://llvm.org/
8Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: b930e7213b37acc934d0d163cf13af18
10Patch0: %{name}-dirs.patch
11BuildRequires: gcc >= 3.4
12Requires: /sbin/ldconfig
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%description
16LLVM is a compiler infrastructure designed for compile-time,
17link-time, runtime, and idle-time optimization of programs from
18arbitrary programming languages. LLVM is written in C++ and has been
19developed since 2000 at the University of Illinois and Apple. It
20currently supports compilation of C and C++ programs, using front-ends
21derived from GCC 4.0.1. A new front-end for the C family of languages
22is in development. The compiler infrastructure includes mirror sets of
23programming tools as well as libraries with equivalent functionality.
24
25%prep
26%setup -q
27%patch0 -p0
28
29%build
30%configure \
31 --enable-optimized \
32 --enable-assertions
33
34%{__make} tools-only
35
36%install
37rm -rf $RPM_BUILD_ROOT
38
39%{__make} install \
40 DESTDIR=$RPM_BUILD_ROOT
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%post -p /sbin/ldconfig
46
47%postun -p /sbin/ldconfig
48
49%files
50%defattr(644,root,root,755)
51%doc CREDITS.TXT LICENSE.TXT README.txt docs
52%attr(755,root,root) %{_bindir}/*
53%{_libdir}/*.o
54%{_libdir}/*.a
55%{_libdir}/*.la
56%attr(755,root,root) %{_libdir}/*.so*
57%{_includedir}/llvm
58%{_mandir}/man?/llvm*
This page took 0.063167 seconds and 4 git commands to generate.