]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- package config, remove not needed .dir files
[packages/llvm.git] / llvm.spec
CommitLineData
aa11c230 1Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2Name: llvm
3Version: 2.1
4Release: 0.1
5License: University of Illinois/NCSA Open Source License
6Group: Development/Languages
7URL: http://llvm.org/
8Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: b930e7213b37acc934d0d163cf13af18
10Patch0: %{name}-dirs.patch
11BuildRequires: gcc >= 3.4
12Requires: /sbin/ldconfig
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
021b3c3d 15%define _sysconfdir /etc/%{name}
16
aa11c230 17%description
18LLVM is a compiler infrastructure designed for compile-time,
19link-time, runtime, and idle-time optimization of programs from
20arbitrary programming languages. LLVM is written in C++ and has been
21developed since 2000 at the University of Illinois and Apple. It
22currently supports compilation of C and C++ programs, using front-ends
23derived from GCC 4.0.1. A new front-end for the C family of languages
24is in development. The compiler infrastructure includes mirror sets of
25programming tools as well as libraries with equivalent functionality.
26
27%prep
28%setup -q
29%patch0 -p0
30
31%build
32%configure \
33 --enable-optimized \
34 --enable-assertions
35
36%{__make} tools-only
37
38%install
39rm -rf $RPM_BUILD_ROOT
40
41%{__make} install \
42 DESTDIR=$RPM_BUILD_ROOT
43
021b3c3d 44find $RPM_BUILD_ROOT -name .dir |xargs rm -f
45
aa11c230 46%clean
47rm -rf $RPM_BUILD_ROOT
48
49%post -p /sbin/ldconfig
50
51%postun -p /sbin/ldconfig
52
53%files
54%defattr(644,root,root,755)
55%doc CREDITS.TXT LICENSE.TXT README.txt docs
56%attr(755,root,root) %{_bindir}/*
021b3c3d 57%dir %{_sysconfdir}
58%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/*
aa11c230 59%{_libdir}/*.o
60%{_libdir}/*.a
61%{_libdir}/*.la
62%attr(755,root,root) %{_libdir}/*.so*
63%{_includedir}/llvm
021b3c3d 64%{_includedir}/llvm-c
aa11c230 65%{_mandir}/man?/llvm*
This page took 0.03835 seconds and 4 git commands to generate.