]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- fixed previous commit msg
[packages/llvm.git] / llvm.spec
CommitLineData
aa11c230 1Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 2Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 3Name: llvm
633c6443 4Version: 2.3
aa11c230 5Release: 0.1
6License: University of Illinois/NCSA Open Source License
7Group: Development/Languages
aa11c230 8Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.tar.gz
633c6443 9# Source0-md5: 17254d72863b7fa005f3fb327aea3439
aa11c230 10Patch0: %{name}-dirs.patch
2326a99f
JB
11URL: http://llvm.org/
12BuildRequires: gcc >= 5:3.4
aa11c230 13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
021b3c3d 15%define _sysconfdir /etc/%{name}
16
aa11c230 17%description
18LLVM is a compiler infrastructure designed for compile-time,
19link-time, runtime, and idle-time optimization of programs from
20arbitrary programming languages. LLVM is written in C++ and has been
21developed since 2000 at the University of Illinois and Apple. It
22currently supports compilation of C and C++ programs, using front-ends
23derived from GCC 4.0.1. A new front-end for the C family of languages
24is in development. The compiler infrastructure includes mirror sets of
25programming tools as well as libraries with equivalent functionality.
26
2326a99f
JB
27%description -l pl.UTF-8
28LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
29czasu kompilowania, linkowania, działania i bezczynności programów w
30dowolnych językach programowania. Jest napisana w C++, rozwijana od
31roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
32kompilację programów w C i C++ przy użyciu frontendów wywodzących się
33z GCC 4.0.1. W trakcie tworzenia jest nowy frontend do języków z
34rodziny C. Infrastruktura kompilatora zawiera lustrzane zestawy
35narzędzi programistycznych oraz biblioteki z odpowiadającą narzędziom
36funkcjonalnością.
37
aa11c230 38%prep
39%setup -q
40%patch0 -p0
41
42%build
43%configure \
44 --enable-optimized \
45 --enable-assertions
46
47%{__make} tools-only
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%{__make} install \
53 DESTDIR=$RPM_BUILD_ROOT
54
021b3c3d 55find $RPM_BUILD_ROOT -name .dir |xargs rm -f
56
aa11c230 57%clean
58rm -rf $RPM_BUILD_ROOT
59
2326a99f
JB
60%post -p /sbin/ldconfig
61%postun -p /sbin/ldconfig
aa11c230 62
63%files
64%defattr(644,root,root,755)
65%doc CREDITS.TXT LICENSE.TXT README.txt docs
a9beeab5
JB
66%attr(755,root,root) %{_bindir}/bugpoint
67%attr(755,root,root) %{_bindir}/gccas
68%attr(755,root,root) %{_bindir}/gccld
69%attr(755,root,root) %{_bindir}/llc
70%attr(755,root,root) %{_bindir}/lli
71%attr(755,root,root) %{_bindir}/llvm-*
72%attr(755,root,root) %{_bindir}/llvm2cpp
73%attr(755,root,root) %{_bindir}/llvmc
74%attr(755,root,root) %{_bindir}/opt
021b3c3d 75%dir %{_sysconfdir}
a9beeab5
JB
76%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/c
77%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/c++
78%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/cpp
79%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/cxx
80%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/ll
81%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/st
82%{_libdir}/LLVM*.o
83%{_libdir}/libLLVM*.a
84# just example?
85%attr(755,root,root) %{_libdir}/LLVMHello.so*
86%{_libdir}/LLVMHello.la
87%{_libdir}/LLVMHello.a
aa11c230 88%{_includedir}/llvm
021b3c3d 89%{_includedir}/llvm-c
a9beeab5
JB
90%{_mandir}/man1/bugpoint.1*
91%{_mandir}/man1/llc.1*
92%{_mandir}/man1/lli.1*
93%{_mandir}/man1/llvm-*.1*
94%{_mandir}/man1/llvm2cpp.1*
95%{_mandir}/man1/llvmc.1*
96%{_mandir}/man1/llvmgcc.1*
97%{_mandir}/man1/llvmgxx.1*
98%{_mandir}/man1/opt.1*
99%{_mandir}/man1/stkrc.1*
100%{_mandir}/man1/tblgen.1*
This page took 0.064664 seconds and 4 git commands to generate.