]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- md5
[packages/llvm.git] / llvm.spec
CommitLineData
bc88141a 1#
d015c902
PS
2# TODO:
3# - fix include search path to support libdir/gcc/platform/version/include.
4# current error: /usr/include/wchar.h:39:11: fatal error: 'stdarg.h' file not found# include <stdarg.h>
5#
9556f4c9
ER
6# Conditional build:
7%bcond_without ocaml # ocaml binding
8132e62b 8%bcond_with apidocs # The doxygen docs are HUGE, so they are not built by default.
dd9350c7 9%bcond_without man # man pages
8132e62b 10%bcond_with tests # run tests
9556f4c9
ER
11
12%ifarch s390 s390x sparc64
13# No ocaml on these arches
14%undefine with_ocaml
15%endif
16
aa11c230 17Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 18Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 19Name: llvm
1628dc68
AM
20Version: 3.3
21Release: 1
aa11c230 22License: University of Illinois/NCSA Open Source License
23Group: Development/Languages
dd9350c7 24#Source0Download: http://llvm.org/releases/download.html
f981d747 25Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
20b37d4a 26# Source0-md5: 40564e1dc390f9844f1711c08b08e391
ebde279d 27Patch0: %{name}-config.patch
d997b14b 28# Data files should be installed with timestamps preserved
ebde279d
JB
29Patch1: %{name}-2.6-timestamp.patch
30Patch2: %{name}-pld.patch
2326a99f 31URL: http://llvm.org/
ebde279d
JB
32BuildRequires: autoconf >= 2.60
33BuildRequires: automake >= 1:1.9.6
bc88141a 34BuildRequires: bash
d997b14b 35BuildRequires: bison
d997b14b 36BuildRequires: flex
dd9350c7
JB
37BuildRequires: gcc >= 5:3.4
38# gcc4 might be installed, but not current __cc
39%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
40BuildRequires: __cc >= 3.4
9556f4c9 41%endif
d997b14b 42BuildRequires: groff
bc88141a 43BuildRequires: libltdl-devel
ebde279d 44BuildRequires: libtool >= 2:1.5.22
d997b14b
AM
45BuildRequires: libstdc++-devel >= 5:3.4
46BuildRequires: ocaml-ocamldoc
8132e62b 47BuildRequires: perl-base >= 1:5.6
8c156e7d 48BuildRequires: perl-tools-pod
49BuildRequires: rpm-pythonprov
dd9350c7
JB
50%{?with_man:BuildRequires: sphinx-pdg}
51%if %{with apidocs}
52BuildRequires: doxygen
53BuildRequires: graphviz
54%endif
55%if %{with tests}
56BuildRequires: dejagnu
57BuildRequires: python
58BuildRequires: tcl-devel
356a0bbd 59%endif
8c514f23 60Requires: %{name}-libs = %{version}-%{release}
9556f4c9
ER
61# LLVM is not supported on PPC64
62# http://llvm.org/bugs/show_bug.cgi?id=3729
63ExcludeArch: ppc64
aa11c230 64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
356a0bbd 66%define _sysconfdir /etc/%{name}
021b3c3d 67
9556f4c9
ER
68%define specflags_ppc -fno-var-tracking-assignments
69
6832a5c5
ER
70# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
71%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
72
aa11c230 73%description
74LLVM is a compiler infrastructure designed for compile-time,
75link-time, runtime, and idle-time optimization of programs from
76arbitrary programming languages. LLVM is written in C++ and has been
77developed since 2000 at the University of Illinois and Apple. It
621ec11f
JB
78currently supports compilation of C and C++ programs using clang
79frontend.
aa11c230 80
2326a99f
JB
81%description -l pl.UTF-8
82LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
83czasu kompilowania, linkowania, działania i bezczynności programów w
84dowolnych językach programowania. Jest napisana w C++, rozwijana od
85roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
621ec11f 86kompilację programów w C i C++ przy użyciu frontendu clang.
2326a99f 87
8c514f23
JB
88%package libs
89Summary: LLVM shared library
90Summary(pl.UTF-8): Biblioteka współdzielona LLVM-a
91Group: Libraries
92Conflicts: llvm < 3.2
93
94%description libs
95LLVM shared library.
96
97%description libs -l pl.UTF-8
98Biblioteka współdzielona LLVM-a.
99
bc88141a 100%package devel
621ec11f
JB
101Summary: Static libraries and header files for LLVM
102Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
bc88141a 103Group: Development/Languages
8c514f23 104Requires: %{name}-libs = %{version}-%{release}
bc88141a
ER
105Requires: libstdc++-devel >= 6:3.4
106
107%description devel
621ec11f
JB
108This package contains static libraries and header files needed to
109develop new native programs that use the LLVM infrastructure.
110
111%description devel -l pl.UTF-8
112Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
113potrzebne do tworzenia nowych programów natywnych wykorzystujących
114infrastrukturę LLVM.
bc88141a 115
9556f4c9
ER
116%package doc
117Summary: Documentation for LLVM
621ec11f 118Summary(pl.UTF-8): Dokumentacja do LLVM-a
9556f4c9
ER
119Group: Documentation
120# does not require base
bc88141a 121
9556f4c9
ER
122%description doc
123Documentation for the LLVM compiler infrastructure.
bc88141a 124
621ec11f
JB
125%description doc -l pl.UTF-8
126Dokumentacja do infrastruktury kompilatorów LLVM.
127
9556f4c9
ER
128%package apidocs
129Summary: API documentation for LLVM
621ec11f 130Summary(pl.UTF-8): Dokumentacja API LLVM-a
9556f4c9
ER
131Group: Development/Languages
132Requires: %{name}-doc = %{version}-%{release}
bc88141a 133
9556f4c9
ER
134%description apidocs
135API documentation for the LLVM compiler infrastructure.
bc88141a 136
621ec11f
JB
137%description apidocs -l pl.UTF-8
138Dokumentacja API infrastruktury kompilatorów LLVM.
139
d997b14b
AM
140%package -n clang
141Summary: A C language family frontend for LLVM
621ec11f 142Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
d997b14b
AM
143License: NCSA
144Group: Development/Languages
8c514f23 145Requires: %{name} = %{version}-%{release}
d997b14b
AM
146
147%description -n clang
148clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
149of a crane or goose. 3. C-language family front-end toolkit.
150
151The goal of the Clang project is to create a new C, C++, Objective C
152and Objective C++ front-end for the LLVM compiler. Its tools are built
153as libraries and designed to be loosely-coupled and extendable.
154
621ec11f
JB
155%description -n clang -l pl.UTF-8
156clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
157piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
158z rodziny C.
159
160Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
161LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
162budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
163i rozszerzaniu.
164
d997b14b
AM
165%package -n clang-analyzer
166Summary: A source code analysis framework
621ec11f 167Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
d997b14b
AM
168License: NCSA
169Group: Development/Languages
170Requires: clang = %{version}-%{release}
171# not picked up automatically since files are currently not instaled
172# in standard Python hierarchies yet
173Requires: python
174
175%description -n clang-analyzer
176The Clang Static Analyzer consists of both a source code analysis
177framework and a standalone tool that finds bugs in C and Objective-C
178programs. The standalone tool is invoked from the command-line, and is
179intended to run in tandem with a build of a project or code base.
180
621ec11f
JB
181%description -n clang-analyzer -l pl.UTF-8
182Clang Static Analyzer składa się ze szkieletu do analizy kodu
183źródłowego oraz samodzielnego narzędzia znajdującego błędy w
184programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
185myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
186
9556f4c9 187%package -n clang-devel
621ec11f
JB
188Summary: Header files for Clang
189Summary(pl.UTF-8): Pliki nagłówkowe Clanga
9556f4c9 190Group: Development/Languages
8c514f23 191Requires: %{name}-devel = %{version}-%{release}
9556f4c9
ER
192Requires: clang = %{version}-%{release}
193
194%description -n clang-devel
195This package contains header files for the Clang compiler.
196
621ec11f
JB
197%description -n clang-devel -l pl.UTF-8
198Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
199
9556f4c9
ER
200%package -n clang-doc
201Summary: Documentation for Clang
621ec11f 202Summary(pl.UTF-8): Dokumentacja do Clanga
9556f4c9
ER
203Group: Documentation
204Requires: %{name} = %{version}-%{release}
205
206%description -n clang-doc
207Documentation for the Clang compiler front-end.
208
621ec11f
JB
209%description -n clang-doc -l pl.UTF-8
210Dokumentacja do frontendu kompilatora Clang.
211
9556f4c9
ER
212%package -n clang-apidocs
213Summary: API documentation for Clang
621ec11f 214Summary(pl.UTF-8): Dokumentacja API Clanga
9556f4c9
ER
215Group: Development/Languages
216Requires: clang-doc = %{version}-%{release}
217
218%description -n clang-apidocs
219API documentation for the Clang compiler.
220
621ec11f
JB
221%description -n clang-apidocs -l pl.UTF-8
222Dokumentacja API kompilatora Clang.
223
9556f4c9
ER
224%package ocaml
225Summary: OCaml binding for LLVM
621ec11f
JB
226Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
227Group: Libraries
9556f4c9
ER
228Requires: %{name} = %{version}-%{release}
229%requires_eq ocaml-runtime
230
621ec11f 231%description ocaml
9556f4c9
ER
232OCaml binding for LLVM.
233
621ec11f
JB
234%description ocaml -l pl.UTF-8
235Wiązanie OCamla do LLVM-a.
236
9556f4c9 237%package ocaml-devel
621ec11f
JB
238Summary: Development files for LLVM OCaml binding
239Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
9556f4c9
ER
240Group: Development/Libraries
241Requires: %{name}-devel = %{version}-%{release}
242Requires: %{name}-ocaml = %{version}-%{release}
243
244%description ocaml-devel
245The llvm-ocaml-devel package contains libraries and signature files
621ec11f
JB
246for developing applications that use llvm-ocaml binding.
247
248%description ocaml-devel -l pl.UTF-8
249Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
250wykorzystujących wiązanie llvm-ocaml.
251
9556f4c9
ER
252%package ocaml-doc
253Summary: Documentation for LLVM's OCaml binding
621ec11f 254Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
9556f4c9
ER
255Group: Documentation
256Requires: %{name}-ocaml = %{version}-%{release}
257
258%description ocaml-doc
259HTML documentation for LLVM's OCaml binding.
260
621ec11f
JB
261%description ocaml-doc -l pl.UTF-8
262Dokumentacja HTML wiązania OCamla do LLVM-a.
263
aa11c230 264%prep
1628dc68 265%setup -q -n %{name}-%{version}.src
ebde279d
JB
266%patch0 -p1
267%patch1 -p1
268%patch2 -p1
ce9cc204 269
19f21eee 270# configure does not properly specify libdir
3a1d4bb3 271%{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
3a1d4bb3 272%{__sed} -i 's|/lib/|/%{_lib}/|' lib/Support/Unix/Path.inc
9206c2b1
JB
273# clang resources
274%{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
275%{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
19f21eee 276
bacc8b96
ER
277grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
278 s,^#!.*bin/env python,#!%{__python},
279 s,^#!.*bin/env perl,#!%{__perl},
280}'
281
9556f4c9 282install -d obj
aa11c230 283
284%build
ebde279d
JB
285cd autoconf
286%{__aclocal} -I m4
287%{__autoconf} -o ../configure configure.ac
288cd ..
289%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
290
d997b14b 291# Disabling assertions now, rec. by pure and needed for OpenGTL
9556f4c9 292# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
d997b14b 293#
bc88141a 294# bash specific 'test a < b'
9556f4c9 295cd obj
d997b14b 296bash ../%configure \
bc88141a 297 --datadir=%{_datadir}/%{name}-%{version} \
632f3287 298 --disable-assertions \
d997b14b 299%ifarch %{ix86}
632f3287 300 --disable-pic \
9556f4c9 301%endif
632f3287
JB
302 --disable-static \
303 --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
304 --enable-debug-runtime \
9556f4c9
ER
305%if %{with apidocs}
306 --enable-doxygen \
d997b14b 307%endif
25189042 308 --enable-experimental-targets=R600 \
bc88141a 309 --enable-jit \
aa11c230 310 --enable-optimized \
bc88141a
ER
311 --enable-shared \
312 --with-pic
313
1628dc68
AM
314# hack so it will find own headers
315install -d Release
316ln -s lib Release/lib64
317
d997b14b 318%{__make} \
1628dc68 319 VERBOSE=1 \
0a0b7076 320 REQUIRES_RTTI=1 \
d997b14b 321 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
aa11c230 322
827664e9 323%if %{with tests}
9556f4c9
ER
324%{__make} check 2>&1 | tee llvm-testlog.txt
325%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
326%endif
327
dd9350c7
JB
328cd ..
329
330%if %{with man}
331%{__make} -C docs -f Makefile.sphinx man
332%endif
333
aa11c230 334%install
335rm -rf $RPM_BUILD_ROOT
9556f4c9 336%{__make} -C obj -j1 install \
d997b14b 337 PROJ_docsdir=/moredocs \
aa11c230 338 DESTDIR=$RPM_BUILD_ROOT
339
d997b14b 340# Static analyzer not installed by default:
9556f4c9
ER
341# http://clang-analyzer.llvm.org/installation#OtherPlatforms
342install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b
AM
343# create launchers
344for f in scan-{build,view}; do
9556f4c9
ER
345 ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
346 cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b 347done
dd9350c7 348%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
8132e62b
JB
349%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
350%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
351%py_postclean %{_libdir}/clang-analyzer/scan-view
d997b14b 352
dd9350c7
JB
353%if %{with man}
354install -d $RPM_BUILD_ROOT%{_mandir}/man1
355cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
356# these tools are not installed
357%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
358%endif
359
d997b14b 360# Move documentation back to build directory
d997b14b
AM
361rm -rf moredocs
362mv $RPM_BUILD_ROOT/moredocs .
ebde279d
JB
363%{__rm} -v moredocs/*.tar.gz
364%{__rm} -v moredocs/ocamldoc/html/*.tar.gz
9556f4c9
ER
365
366# and separate the apidoc
367%if %{with apidocs}
368rm -rf apidoc clang-apidoc
369mv moredocs/html/doxygen apidoc
370cp -a tools/clang/docs/doxygen/html clang-apidoc
371%endif
d997b14b
AM
372
373# And prepare Clang documentation
d997b14b 374rm -rf clang-docs
9556f4c9 375install -d clang-docs
827664e9 376for f in LICENSE.TXT NOTES.txt README.txt; do
9556f4c9 377 ln tools/clang/$f clang-docs
d997b14b 378done
021b3c3d 379
6832a5c5 380# Get rid of erroneously installed example files.
ebde279d 381%{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
6832a5c5 382
d997b14b
AM
383# remove documentation makefiles:
384# they require the build directory to work
9556f4c9
ER
385rm -rf moredocs/examples
386cp -a examples moredocs/examples
387find moredocs/examples -name Makefile | xargs -0r rm -f
6832a5c5 388
aa11c230 389%clean
390rm -rf $RPM_BUILD_ROOT
391
8c514f23
JB
392%post libs -p /sbin/ldconfig
393%postun libs -p /sbin/ldconfig
aa11c230 394
395%files
396%defattr(644,root,root,755)
8132e62b 397%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
a9beeab5 398%attr(755,root,root) %{_bindir}/bugpoint
a9beeab5
JB
399%attr(755,root,root) %{_bindir}/llc
400%attr(755,root,root) %{_bindir}/lli
8132e62b
JB
401%attr(755,root,root) %{_bindir}/llvm-ar
402%attr(755,root,root) %{_bindir}/llvm-as
403%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
827664e9 404%attr(755,root,root) %{_bindir}/llvm-cov
8132e62b
JB
405%attr(755,root,root) %{_bindir}/llvm-diff
406%attr(755,root,root) %{_bindir}/llvm-dis
827664e9 407%attr(755,root,root) %{_bindir}/llvm-dwarfdump
8132e62b 408%attr(755,root,root) %{_bindir}/llvm-extract
8132e62b
JB
409%attr(755,root,root) %{_bindir}/llvm-link
410%attr(755,root,root) %{_bindir}/llvm-mc
dd9350c7 411%attr(755,root,root) %{_bindir}/llvm-mcmarkup
8132e62b
JB
412%attr(755,root,root) %{_bindir}/llvm-nm
413%attr(755,root,root) %{_bindir}/llvm-objdump
414%attr(755,root,root) %{_bindir}/llvm-prof
415%attr(755,root,root) %{_bindir}/llvm-ranlib
f981d747 416%attr(755,root,root) %{_bindir}/llvm-readobj
827664e9
PS
417%attr(755,root,root) %{_bindir}/llvm-rtdyld
418%attr(755,root,root) %{_bindir}/llvm-size
f981d747 419%attr(755,root,root) %{_bindir}/llvm-stress
1628dc68 420%attr(755,root,root) %{_bindir}/llvm-symbolizer
827664e9 421%attr(755,root,root) %{_bindir}/llvm-tblgen
a7973f21 422%attr(755,root,root) %{_bindir}/macho-dump
8132e62b 423%attr(755,root,root) %{_bindir}/opt
a9beeab5 424%{_mandir}/man1/bugpoint.1*
a7973f21 425%{_mandir}/man1/lit.1*
a9beeab5
JB
426%{_mandir}/man1/llc.1*
427%{_mandir}/man1/lli.1*
8132e62b
JB
428%{_mandir}/man1/llvm-ar.1*
429%{_mandir}/man1/llvm-as.1*
430%{_mandir}/man1/llvm-bcanalyzer.1*
f981d747 431%{_mandir}/man1/llvm-cov.1*
8132e62b
JB
432%{_mandir}/man1/llvm-diff.1*
433%{_mandir}/man1/llvm-dis.1*
434%{_mandir}/man1/llvm-extract.1*
8132e62b
JB
435%{_mandir}/man1/llvm-link.1*
436%{_mandir}/man1/llvm-nm.1*
437%{_mandir}/man1/llvm-prof.1*
438%{_mandir}/man1/llvm-ranlib.1*
f981d747 439%{_mandir}/man1/llvm-stress.1*
1628dc68 440%{_mandir}/man1/llvm-symbolizer.1*
a9beeab5 441%{_mandir}/man1/opt.1*
dd9350c7 442%{_mandir}/man1/tblgen.1*
bc88141a 443
8c514f23
JB
444%files libs
445%defattr(644,root,root,755)
446%attr(755,root,root) %{_libdir}/libLLVM-%{version}svn.so
447
bc88141a
ER
448%files devel
449%defattr(644,root,root,755)
450%attr(755,root,root) %{_bindir}/llvm-config
827664e9 451%attr(755,root,root) %{_libdir}/libprofile_rt.so
8132e62b 452%{_libdir}/libLLVM*.a
827664e9 453%{_libdir}/libprofile_rt.a
1655c8b5 454%ifarch %{x8664}
0a8510f2 455%attr(755,root,root) %{_libdir}/BugpointPasses.so
19f21eee 456%attr(755,root,root) %{_libdir}/libLTO.so
8132e62b 457%{_libdir}/libLTO.a
1655c8b5 458%endif
8132e62b
JB
459%{_includedir}/llvm
460%{_includedir}/llvm-c
461%{_mandir}/man1/llvm-config.1*
bc88141a 462
9556f4c9
ER
463%files doc
464%defattr(644,root,root,755)
465%doc moredocs/examples moredocs/html
466
467%if %{with apidocs}
468%files apidocs
469%defattr(644,root,root,755)
470%doc apidoc/*
471%endif
472
d997b14b 473%files -n clang
bc88141a 474%defattr(644,root,root,755)
827664e9 475%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
dd9350c7 476%attr(755,root,root) %{_bindir}/c-index-test
8132e62b
JB
477%attr(755,root,root) %{_bindir}/clang
478%attr(755,root,root) %{_bindir}/clang++
dd9350c7 479%attr(755,root,root) %{_bindir}/clang-check
1628dc68 480%attr(755,root,root) %{_bindir}/clang-format
827664e9 481%attr(755,root,root) %{_bindir}/clang-tblgen
b3a27ca2 482%attr(755,root,root) %{_libdir}/libclang.so
493e5485 483%{_libdir}/clang
8132e62b 484%{_mandir}/man1/clang.1*
d997b14b
AM
485
486%files -n clang-analyzer
bc88141a 487%defattr(644,root,root,755)
d997b14b
AM
488%attr(755,root,root) %{_bindir}/scan-build
489%attr(755,root,root) %{_bindir}/scan-view
dd9350c7 490%{_mandir}/man1/scan-build.1*
ae49e501 491%dir %{_libdir}/clang-analyzer
d997b14b 492
9556f4c9
ER
493%dir %{_libdir}/clang-analyzer/scan-build
494%{_libdir}/clang-analyzer/scan-build/*.css
495%{_libdir}/clang-analyzer/scan-build/*.js
496%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
497%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
498
8132e62b
JB
499%dir %{_libdir}/clang-analyzer/scan-view
500%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
501%{_libdir}/clang-analyzer/scan-view/Resources
502%{_libdir}/clang-analyzer/scan-view/*.py[co]
503
9556f4c9
ER
504%files -n clang-devel
505%defattr(644,root,root,755)
8132e62b 506%{_libdir}/libclang*.a
9556f4c9
ER
507%{_includedir}/clang
508%{_includedir}/clang-c
509
510%files -n clang-doc
511%defattr(644,root,root,755)
8132e62b 512%doc tools/clang/docs/*.{css,html,png,txt}
9556f4c9
ER
513
514%if %{with apidocs}
515%files -n clang-apidocs
516%defattr(644,root,root,755)
517%doc clang-apidoc/*
518%endif
519
520%if %{with ocaml}
d997b14b
AM
521%files ocaml
522%defattr(644,root,root,755)
bc8a0b58 523%{_libdir}/ocaml/META.llvm
8132e62b
JB
524%{_libdir}/ocaml/llvm*.cma
525%{_libdir}/ocaml/llvm*.cmi
d997b14b
AM
526
527%files ocaml-devel
528%defattr(644,root,root,755)
bc8a0b58 529%{_libdir}/libllvm*.a
8132e62b
JB
530%{_libdir}/ocaml/libLLVM*.a
531%{_libdir}/ocaml/libllvm*.a
532%{_libdir}/ocaml/llvm*.a
533%{_libdir}/ocaml/llvm*.cmx*
534%{_libdir}/ocaml/llvm*.mli
9556f4c9
ER
535
536%files ocaml-doc
537%defattr(644,root,root,755)
538%doc moredocs/ocamldoc/html/*
539%endif
This page took 0.116156 seconds and 4 git commands to generate.