]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- more md5
[packages/llvm.git] / llvm.spec
CommitLineData
bc88141a 1#
d015c902
PS
2# TODO:
3# - fix include search path to support libdir/gcc/platform/version/include.
4# current error: /usr/include/wchar.h:39:11: fatal error: 'stdarg.h' file not found# include <stdarg.h>
5#
9556f4c9
ER
6# Conditional build:
7%bcond_without ocaml # ocaml binding
8132e62b 8%bcond_with apidocs # The doxygen docs are HUGE, so they are not built by default.
dd9350c7 9%bcond_without man # man pages
8132e62b 10%bcond_with tests # run tests
9556f4c9
ER
11
12%ifarch s390 s390x sparc64
13# No ocaml on these arches
14%undefine with_ocaml
15%endif
16
aa11c230 17Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 18Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 19Name: llvm
1628dc68
AM
20Version: 3.3
21Release: 1
aa11c230 22License: University of Illinois/NCSA Open Source License
23Group: Development/Languages
dd9350c7 24#Source0Download: http://llvm.org/releases/download.html
f981d747 25Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
20b37d4a 26# Source0-md5: 40564e1dc390f9844f1711c08b08e391
c999855f 27Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.gz
b49f1db3 28# Source1-md5: 8284891e3e311829b8e44ac813d0c9ef
ebde279d 29Patch0: %{name}-config.patch
d997b14b 30# Data files should be installed with timestamps preserved
ebde279d
JB
31Patch1: %{name}-2.6-timestamp.patch
32Patch2: %{name}-pld.patch
2326a99f 33URL: http://llvm.org/
ebde279d
JB
34BuildRequires: autoconf >= 2.60
35BuildRequires: automake >= 1:1.9.6
bc88141a 36BuildRequires: bash
d997b14b 37BuildRequires: bison
d997b14b 38BuildRequires: flex
dd9350c7
JB
39BuildRequires: gcc >= 5:3.4
40# gcc4 might be installed, but not current __cc
41%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
42BuildRequires: __cc >= 3.4
9556f4c9 43%endif
d997b14b 44BuildRequires: groff
bc88141a 45BuildRequires: libltdl-devel
ebde279d 46BuildRequires: libtool >= 2:1.5.22
d997b14b
AM
47BuildRequires: libstdc++-devel >= 5:3.4
48BuildRequires: ocaml-ocamldoc
8132e62b 49BuildRequires: perl-base >= 1:5.6
8c156e7d 50BuildRequires: perl-tools-pod
51BuildRequires: rpm-pythonprov
dd9350c7
JB
52%{?with_man:BuildRequires: sphinx-pdg}
53%if %{with apidocs}
54BuildRequires: doxygen
55BuildRequires: graphviz
56%endif
57%if %{with tests}
58BuildRequires: dejagnu
59BuildRequires: python
60BuildRequires: tcl-devel
356a0bbd 61%endif
8c514f23 62Requires: %{name}-libs = %{version}-%{release}
9556f4c9
ER
63# LLVM is not supported on PPC64
64# http://llvm.org/bugs/show_bug.cgi?id=3729
65ExcludeArch: ppc64
aa11c230 66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
356a0bbd 68%define _sysconfdir /etc/%{name}
021b3c3d 69
9556f4c9
ER
70%define specflags_ppc -fno-var-tracking-assignments
71
6832a5c5
ER
72# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
73%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
74
aa11c230 75%description
76LLVM is a compiler infrastructure designed for compile-time,
77link-time, runtime, and idle-time optimization of programs from
78arbitrary programming languages. LLVM is written in C++ and has been
79developed since 2000 at the University of Illinois and Apple. It
621ec11f
JB
80currently supports compilation of C and C++ programs using clang
81frontend.
aa11c230 82
2326a99f
JB
83%description -l pl.UTF-8
84LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
85czasu kompilowania, linkowania, działania i bezczynności programów w
86dowolnych językach programowania. Jest napisana w C++, rozwijana od
87roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
621ec11f 88kompilację programów w C i C++ przy użyciu frontendu clang.
2326a99f 89
8c514f23
JB
90%package libs
91Summary: LLVM shared library
92Summary(pl.UTF-8): Biblioteka współdzielona LLVM-a
93Group: Libraries
94Conflicts: llvm < 3.2
95
96%description libs
97LLVM shared library.
98
99%description libs -l pl.UTF-8
100Biblioteka współdzielona LLVM-a.
101
bc88141a 102%package devel
621ec11f
JB
103Summary: Static libraries and header files for LLVM
104Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
bc88141a 105Group: Development/Languages
8c514f23 106Requires: %{name}-libs = %{version}-%{release}
bc88141a
ER
107Requires: libstdc++-devel >= 6:3.4
108
109%description devel
621ec11f
JB
110This package contains static libraries and header files needed to
111develop new native programs that use the LLVM infrastructure.
112
113%description devel -l pl.UTF-8
114Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
115potrzebne do tworzenia nowych programów natywnych wykorzystujących
116infrastrukturę LLVM.
bc88141a 117
9556f4c9
ER
118%package doc
119Summary: Documentation for LLVM
621ec11f 120Summary(pl.UTF-8): Dokumentacja do LLVM-a
9556f4c9
ER
121Group: Documentation
122# does not require base
bc88141a 123
9556f4c9
ER
124%description doc
125Documentation for the LLVM compiler infrastructure.
bc88141a 126
621ec11f
JB
127%description doc -l pl.UTF-8
128Dokumentacja do infrastruktury kompilatorów LLVM.
129
9556f4c9
ER
130%package apidocs
131Summary: API documentation for LLVM
621ec11f 132Summary(pl.UTF-8): Dokumentacja API LLVM-a
9556f4c9
ER
133Group: Development/Languages
134Requires: %{name}-doc = %{version}-%{release}
bc88141a 135
9556f4c9
ER
136%description apidocs
137API documentation for the LLVM compiler infrastructure.
bc88141a 138
621ec11f
JB
139%description apidocs -l pl.UTF-8
140Dokumentacja API infrastruktury kompilatorów LLVM.
141
d997b14b
AM
142%package -n clang
143Summary: A C language family frontend for LLVM
621ec11f 144Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
d997b14b
AM
145License: NCSA
146Group: Development/Languages
8c514f23 147Requires: %{name} = %{version}-%{release}
d997b14b
AM
148
149%description -n clang
150clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
151of a crane or goose. 3. C-language family front-end toolkit.
152
153The goal of the Clang project is to create a new C, C++, Objective C
154and Objective C++ front-end for the LLVM compiler. Its tools are built
155as libraries and designed to be loosely-coupled and extendable.
156
621ec11f
JB
157%description -n clang -l pl.UTF-8
158clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
159piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
160z rodziny C.
161
162Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
163LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
164budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
165i rozszerzaniu.
166
d997b14b
AM
167%package -n clang-analyzer
168Summary: A source code analysis framework
621ec11f 169Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
d997b14b
AM
170License: NCSA
171Group: Development/Languages
172Requires: clang = %{version}-%{release}
173# not picked up automatically since files are currently not instaled
174# in standard Python hierarchies yet
175Requires: python
176
177%description -n clang-analyzer
178The Clang Static Analyzer consists of both a source code analysis
179framework and a standalone tool that finds bugs in C and Objective-C
180programs. The standalone tool is invoked from the command-line, and is
181intended to run in tandem with a build of a project or code base.
182
621ec11f
JB
183%description -n clang-analyzer -l pl.UTF-8
184Clang Static Analyzer składa się ze szkieletu do analizy kodu
185źródłowego oraz samodzielnego narzędzia znajdującego błędy w
186programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
187myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
188
9556f4c9 189%package -n clang-devel
621ec11f
JB
190Summary: Header files for Clang
191Summary(pl.UTF-8): Pliki nagłówkowe Clanga
9556f4c9 192Group: Development/Languages
8c514f23 193Requires: %{name}-devel = %{version}-%{release}
9556f4c9
ER
194Requires: clang = %{version}-%{release}
195
196%description -n clang-devel
197This package contains header files for the Clang compiler.
198
621ec11f
JB
199%description -n clang-devel -l pl.UTF-8
200Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
201
9556f4c9
ER
202%package -n clang-doc
203Summary: Documentation for Clang
621ec11f 204Summary(pl.UTF-8): Dokumentacja do Clanga
9556f4c9
ER
205Group: Documentation
206Requires: %{name} = %{version}-%{release}
207
208%description -n clang-doc
209Documentation for the Clang compiler front-end.
210
621ec11f
JB
211%description -n clang-doc -l pl.UTF-8
212Dokumentacja do frontendu kompilatora Clang.
213
9556f4c9
ER
214%package -n clang-apidocs
215Summary: API documentation for Clang
621ec11f 216Summary(pl.UTF-8): Dokumentacja API Clanga
9556f4c9
ER
217Group: Development/Languages
218Requires: clang-doc = %{version}-%{release}
219
220%description -n clang-apidocs
221API documentation for the Clang compiler.
222
621ec11f
JB
223%description -n clang-apidocs -l pl.UTF-8
224Dokumentacja API kompilatora Clang.
225
9556f4c9
ER
226%package ocaml
227Summary: OCaml binding for LLVM
621ec11f
JB
228Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
229Group: Libraries
9556f4c9
ER
230Requires: %{name} = %{version}-%{release}
231%requires_eq ocaml-runtime
232
621ec11f 233%description ocaml
9556f4c9
ER
234OCaml binding for LLVM.
235
621ec11f
JB
236%description ocaml -l pl.UTF-8
237Wiązanie OCamla do LLVM-a.
238
9556f4c9 239%package ocaml-devel
621ec11f
JB
240Summary: Development files for LLVM OCaml binding
241Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
9556f4c9
ER
242Group: Development/Libraries
243Requires: %{name}-devel = %{version}-%{release}
244Requires: %{name}-ocaml = %{version}-%{release}
245
246%description ocaml-devel
247The llvm-ocaml-devel package contains libraries and signature files
621ec11f
JB
248for developing applications that use llvm-ocaml binding.
249
250%description ocaml-devel -l pl.UTF-8
251Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
252wykorzystujących wiązanie llvm-ocaml.
253
9556f4c9
ER
254%package ocaml-doc
255Summary: Documentation for LLVM's OCaml binding
621ec11f 256Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
9556f4c9
ER
257Group: Documentation
258Requires: %{name}-ocaml = %{version}-%{release}
259
260%description ocaml-doc
261HTML documentation for LLVM's OCaml binding.
262
621ec11f
JB
263%description ocaml-doc -l pl.UTF-8
264Dokumentacja HTML wiązania OCamla do LLVM-a.
265
aa11c230 266%prep
c999855f
AM
267%setup -q -a1 -n %{name}-%{version}.src
268mv cfe-%{version}.src tools/clang
ebde279d
JB
269%patch0 -p1
270%patch1 -p1
271%patch2 -p1
ce9cc204 272
19f21eee 273# configure does not properly specify libdir
3a1d4bb3 274%{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
3a1d4bb3 275%{__sed} -i 's|/lib/|/%{_lib}/|' lib/Support/Unix/Path.inc
9206c2b1
JB
276# clang resources
277%{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
278%{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
19f21eee 279
bacc8b96
ER
280grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
281 s,^#!.*bin/env python,#!%{__python},
282 s,^#!.*bin/env perl,#!%{__perl},
283}'
284
9556f4c9 285install -d obj
aa11c230 286
287%build
ebde279d
JB
288cd autoconf
289%{__aclocal} -I m4
290%{__autoconf} -o ../configure configure.ac
291cd ..
292%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
293
d997b14b 294# Disabling assertions now, rec. by pure and needed for OpenGTL
9556f4c9 295# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
d997b14b 296#
bc88141a 297# bash specific 'test a < b'
9556f4c9 298cd obj
d997b14b 299bash ../%configure \
bc88141a 300 --datadir=%{_datadir}/%{name}-%{version} \
632f3287 301 --disable-assertions \
d997b14b 302%ifarch %{ix86}
632f3287 303 --disable-pic \
9556f4c9 304%endif
632f3287
JB
305 --disable-static \
306 --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
307 --enable-debug-runtime \
9556f4c9
ER
308%if %{with apidocs}
309 --enable-doxygen \
d997b14b 310%endif
25189042 311 --enable-experimental-targets=R600 \
bc88141a 312 --enable-jit \
aa11c230 313 --enable-optimized \
bc88141a
ER
314 --enable-shared \
315 --with-pic
316
d997b14b 317%{__make} \
1628dc68 318 VERBOSE=1 \
0a0b7076 319 REQUIRES_RTTI=1 \
d997b14b 320 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
aa11c230 321
827664e9 322%if %{with tests}
9556f4c9
ER
323%{__make} check 2>&1 | tee llvm-testlog.txt
324%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
325%endif
326
dd9350c7
JB
327cd ..
328
329%if %{with man}
330%{__make} -C docs -f Makefile.sphinx man
331%endif
332
aa11c230 333%install
334rm -rf $RPM_BUILD_ROOT
9556f4c9 335%{__make} -C obj -j1 install \
d997b14b 336 PROJ_docsdir=/moredocs \
aa11c230 337 DESTDIR=$RPM_BUILD_ROOT
338
d997b14b 339# Static analyzer not installed by default:
9556f4c9
ER
340# http://clang-analyzer.llvm.org/installation#OtherPlatforms
341install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b
AM
342# create launchers
343for f in scan-{build,view}; do
9556f4c9
ER
344 ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
345 cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b 346done
dd9350c7 347%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
8132e62b
JB
348%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
349%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
350%py_postclean %{_libdir}/clang-analyzer/scan-view
d997b14b 351
dd9350c7
JB
352%if %{with man}
353install -d $RPM_BUILD_ROOT%{_mandir}/man1
354cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
355# these tools are not installed
356%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
357%endif
358
d997b14b 359# Move documentation back to build directory
d997b14b
AM
360rm -rf moredocs
361mv $RPM_BUILD_ROOT/moredocs .
ebde279d
JB
362%{__rm} -v moredocs/*.tar.gz
363%{__rm} -v moredocs/ocamldoc/html/*.tar.gz
9556f4c9
ER
364
365# and separate the apidoc
366%if %{with apidocs}
367rm -rf apidoc clang-apidoc
368mv moredocs/html/doxygen apidoc
369cp -a tools/clang/docs/doxygen/html clang-apidoc
370%endif
d997b14b
AM
371
372# And prepare Clang documentation
d997b14b 373rm -rf clang-docs
9556f4c9 374install -d clang-docs
827664e9 375for f in LICENSE.TXT NOTES.txt README.txt; do
9556f4c9 376 ln tools/clang/$f clang-docs
d997b14b 377done
021b3c3d 378
6832a5c5 379# Get rid of erroneously installed example files.
ebde279d 380%{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
6832a5c5 381
d997b14b
AM
382# remove documentation makefiles:
383# they require the build directory to work
9556f4c9
ER
384rm -rf moredocs/examples
385cp -a examples moredocs/examples
386find moredocs/examples -name Makefile | xargs -0r rm -f
6832a5c5 387
aa11c230 388%clean
389rm -rf $RPM_BUILD_ROOT
390
8c514f23
JB
391%post libs -p /sbin/ldconfig
392%postun libs -p /sbin/ldconfig
aa11c230 393
394%files
395%defattr(644,root,root,755)
8132e62b 396%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
a9beeab5 397%attr(755,root,root) %{_bindir}/bugpoint
a9beeab5
JB
398%attr(755,root,root) %{_bindir}/llc
399%attr(755,root,root) %{_bindir}/lli
8132e62b
JB
400%attr(755,root,root) %{_bindir}/llvm-ar
401%attr(755,root,root) %{_bindir}/llvm-as
402%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
827664e9 403%attr(755,root,root) %{_bindir}/llvm-cov
8132e62b
JB
404%attr(755,root,root) %{_bindir}/llvm-diff
405%attr(755,root,root) %{_bindir}/llvm-dis
827664e9 406%attr(755,root,root) %{_bindir}/llvm-dwarfdump
8132e62b 407%attr(755,root,root) %{_bindir}/llvm-extract
8132e62b
JB
408%attr(755,root,root) %{_bindir}/llvm-link
409%attr(755,root,root) %{_bindir}/llvm-mc
dd9350c7 410%attr(755,root,root) %{_bindir}/llvm-mcmarkup
8132e62b
JB
411%attr(755,root,root) %{_bindir}/llvm-nm
412%attr(755,root,root) %{_bindir}/llvm-objdump
413%attr(755,root,root) %{_bindir}/llvm-prof
414%attr(755,root,root) %{_bindir}/llvm-ranlib
f981d747 415%attr(755,root,root) %{_bindir}/llvm-readobj
827664e9
PS
416%attr(755,root,root) %{_bindir}/llvm-rtdyld
417%attr(755,root,root) %{_bindir}/llvm-size
f981d747 418%attr(755,root,root) %{_bindir}/llvm-stress
1628dc68 419%attr(755,root,root) %{_bindir}/llvm-symbolizer
827664e9 420%attr(755,root,root) %{_bindir}/llvm-tblgen
a7973f21 421%attr(755,root,root) %{_bindir}/macho-dump
8132e62b 422%attr(755,root,root) %{_bindir}/opt
a9beeab5 423%{_mandir}/man1/bugpoint.1*
a7973f21 424%{_mandir}/man1/lit.1*
a9beeab5
JB
425%{_mandir}/man1/llc.1*
426%{_mandir}/man1/lli.1*
8132e62b
JB
427%{_mandir}/man1/llvm-ar.1*
428%{_mandir}/man1/llvm-as.1*
429%{_mandir}/man1/llvm-bcanalyzer.1*
f981d747 430%{_mandir}/man1/llvm-cov.1*
8132e62b
JB
431%{_mandir}/man1/llvm-diff.1*
432%{_mandir}/man1/llvm-dis.1*
433%{_mandir}/man1/llvm-extract.1*
8132e62b
JB
434%{_mandir}/man1/llvm-link.1*
435%{_mandir}/man1/llvm-nm.1*
436%{_mandir}/man1/llvm-prof.1*
437%{_mandir}/man1/llvm-ranlib.1*
c999855f 438%{_mandir}/man1/llvm-readobj.1*
f981d747 439%{_mandir}/man1/llvm-stress.1*
1628dc68 440%{_mandir}/man1/llvm-symbolizer.1*
a9beeab5 441%{_mandir}/man1/opt.1*
dd9350c7 442%{_mandir}/man1/tblgen.1*
bc88141a 443
8c514f23
JB
444%files libs
445%defattr(644,root,root,755)
c999855f 446%attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
8c514f23 447
bc88141a
ER
448%files devel
449%defattr(644,root,root,755)
450%attr(755,root,root) %{_bindir}/llvm-config
827664e9 451%attr(755,root,root) %{_libdir}/libprofile_rt.so
8132e62b 452%{_libdir}/libLLVM*.a
827664e9 453%{_libdir}/libprofile_rt.a
1655c8b5 454%ifarch %{x8664}
0a8510f2 455%attr(755,root,root) %{_libdir}/BugpointPasses.so
19f21eee 456%attr(755,root,root) %{_libdir}/libLTO.so
8132e62b 457%{_libdir}/libLTO.a
1655c8b5 458%endif
8132e62b
JB
459%{_includedir}/llvm
460%{_includedir}/llvm-c
461%{_mandir}/man1/llvm-config.1*
bc88141a 462
9556f4c9
ER
463%files doc
464%defattr(644,root,root,755)
465%doc moredocs/examples moredocs/html
466
467%if %{with apidocs}
468%files apidocs
469%defattr(644,root,root,755)
470%doc apidoc/*
471%endif
472
d997b14b 473%files -n clang
bc88141a 474%defattr(644,root,root,755)
827664e9 475%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
dd9350c7 476%attr(755,root,root) %{_bindir}/c-index-test
8132e62b
JB
477%attr(755,root,root) %{_bindir}/clang
478%attr(755,root,root) %{_bindir}/clang++
dd9350c7 479%attr(755,root,root) %{_bindir}/clang-check
1628dc68 480%attr(755,root,root) %{_bindir}/clang-format
827664e9 481%attr(755,root,root) %{_bindir}/clang-tblgen
b3a27ca2 482%attr(755,root,root) %{_libdir}/libclang.so
493e5485 483%{_libdir}/clang
8132e62b 484%{_mandir}/man1/clang.1*
d997b14b
AM
485
486%files -n clang-analyzer
bc88141a 487%defattr(644,root,root,755)
d997b14b
AM
488%attr(755,root,root) %{_bindir}/scan-build
489%attr(755,root,root) %{_bindir}/scan-view
dd9350c7 490%{_mandir}/man1/scan-build.1*
ae49e501 491%dir %{_libdir}/clang-analyzer
d997b14b 492
9556f4c9
ER
493%dir %{_libdir}/clang-analyzer/scan-build
494%{_libdir}/clang-analyzer/scan-build/*.css
495%{_libdir}/clang-analyzer/scan-build/*.js
496%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
497%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
498
8132e62b
JB
499%dir %{_libdir}/clang-analyzer/scan-view
500%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
501%{_libdir}/clang-analyzer/scan-view/Resources
502%{_libdir}/clang-analyzer/scan-view/*.py[co]
503
9556f4c9
ER
504%files -n clang-devel
505%defattr(644,root,root,755)
8132e62b 506%{_libdir}/libclang*.a
9556f4c9
ER
507%{_includedir}/clang
508%{_includedir}/clang-c
509
510%files -n clang-doc
511%defattr(644,root,root,755)
8132e62b 512%doc tools/clang/docs/*.{css,html,png,txt}
9556f4c9
ER
513
514%if %{with apidocs}
515%files -n clang-apidocs
516%defattr(644,root,root,755)
517%doc clang-apidoc/*
518%endif
519
520%if %{with ocaml}
d997b14b
AM
521%files ocaml
522%defattr(644,root,root,755)
bc8a0b58 523%{_libdir}/ocaml/META.llvm
8132e62b
JB
524%{_libdir}/ocaml/llvm*.cma
525%{_libdir}/ocaml/llvm*.cmi
d997b14b
AM
526
527%files ocaml-devel
528%defattr(644,root,root,755)
bc8a0b58 529%{_libdir}/libllvm*.a
8132e62b
JB
530%{_libdir}/ocaml/libLLVM*.a
531%{_libdir}/ocaml/libllvm*.a
532%{_libdir}/ocaml/llvm*.a
533%{_libdir}/ocaml/llvm*.cmx*
534%{_libdir}/ocaml/llvm*.mli
9556f4c9
ER
535
536%files ocaml-doc
537%defattr(644,root,root,755)
538%doc moredocs/ocamldoc/html/*
539%endif
This page took 0.099887 seconds and 4 git commands to generate.