]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- rel 1
[packages/llvm.git] / llvm.spec
CommitLineData
6df3b432
JB
1# TODO:
2# - move and package:
3# %{_datadir}/clang/clang-format-sublime.py - sublime plugin
4# %{_datadir}/clang/clang-format.el - emacs mode
5# %{_datadir}/clang/clang-format.py - vim plugin
6# - no content in doc package (it used to contain parts of clang apidocs and some examples)
bc88141a 7#
9556f4c9 8# Conditional build:
5a7ac479 9%bcond_without lldb # LLDB debugger
b0068ae4 10%bcond_without polly # Polly cache-locality optimization, auto-parallelism and vectorization
5a7ac479 11%bcond_without rt # compiler-rt libraries
6df3b432 12%bcond_without ocaml # OCaml binding
b0068ae4 13%bcond_without doc # HTML docs and man pages
5a7ac479 14%bcond_with apidocs # doxygen docs (HUGE, so they are not built by default)
8132e62b 15%bcond_with tests # run tests
9556f4c9 16
4ba3b2b3
JB
17# No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
18%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
9556f4c9
ER
19%undefine with_ocaml
20%endif
21
aa11c230 22Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 23Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 24Name: llvm
41876fe7 25Version: 3.7.0
17961b8c 26Release: 1
aa11c230 27License: University of Illinois/NCSA Open Source License
28Group: Development/Languages
dd9350c7 29#Source0Download: http://llvm.org/releases/download.html
b883cf1e 30Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
41876fe7 31# Source0-md5: b98b9495e5655a672d6cb83e1a180f8e
b883cf1e 32Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
41876fe7 33# Source1-md5: 8f9d27335e7331cf0a4711e952f21f01
b883cf1e 34Source2: http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
41876fe7 35# Source2-md5: 383c10affd513026f08936b5525523f5
b883cf1e 36Source3: http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
41876fe7 37# Source3-md5: e5931740400d1dc3e7db4c7ba2ceff68
b883cf1e 38Source4: http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
41876fe7 39# Source4-md5: 32f93ffc9cc7e042df22089761558f8b
b883cf1e 40Source5: http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
41876fe7 41# Source5-md5: d5a87dacb65d981a427a536f6964642e
ba1cf74d 42Source6: http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
41876fe7 43# Source6-md5: 91bd593a67293d84dad0bf11845546c2
3c402b7e 44Patch0: %{name}-lld-link.patch
9f7b77bd
JR
45Patch1: %{name}-pld.patch
46Patch2: libdir.patch
47Patch3: x32-gcc-toolchain.patch
48Patch4: gcc5.patch
303f4f9e 49Patch5: debuginfo-fix.patch
2326a99f 50URL: http://llvm.org/
bc88141a 51BuildRequires: bash
d997b14b 52BuildRequires: bison
ac5fd320 53BuildRequires: cmake
d997b14b 54BuildRequires: flex
dd9350c7
JB
55BuildRequires: gcc >= 5:3.4
56# gcc4 might be installed, but not current __cc
57%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
58BuildRequires: __cc >= 3.4
9556f4c9 59%endif
2bbd0701
JR
60%ifarch x32
61BuildRequires: glibc-devel(x86_64)
62%endif
d997b14b 63BuildRequires: groff
bc88141a 64BuildRequires: libltdl-devel
d997b14b 65BuildRequires: libstdc++-devel >= 5:3.4
2bbd0701 66%if %{with ocaml}
c6c890ee 67BuildRequires: ocaml-ctypes-devel >= 0.4
2bbd0701 68BuildRequires: ocaml-findlib
77c13dab 69BuildRequires: ocaml-ocamldoc
2bbd0701
JR
70BuildRequires: ocaml-ounit
71%endif
8132e62b 72BuildRequires: perl-base >= 1:5.6
8c156e7d 73BuildRequires: perl-tools-pod
74BuildRequires: rpm-pythonprov
b0068ae4 75%{?with_doc:BuildRequires: sphinx-pdg}
b883cf1e
JB
76BuildRequires: tar >= 1:1.22
77BuildRequires: xz
dd9350c7
JB
78%if %{with apidocs}
79BuildRequires: doxygen
80BuildRequires: graphviz
81%endif
82%if %{with tests}
83BuildRequires: dejagnu
84BuildRequires: python
85BuildRequires: tcl-devel
356a0bbd 86%endif
b883cf1e 87%if %{with lldb}
c6c890ee 88BuildRequires: epydoc
64f4e87f
JB
89%ifarch i386 i486
90BuildRequires: libatomic-devel
91%endif
b883cf1e
JB
92BuildRequires: libedit-devel
93BuildRequires: libxml2-devel >= 2
94BuildRequires: ncurses-ext-devel
95BuildRequires: python-devel >= 2
c6c890ee 96BuildRequires: swig-python
b883cf1e 97%endif
b0068ae4
JB
98%if %{with polly}
99BuildRequires: cloog-isl-devel
b883cf1e 100# >= 0.18.2-2
b0068ae4 101BuildRequires: gmp-devel
2bbd0701 102BuildRequires: isl-devel >= 0.14
b883cf1e 103# optional
3eca6fe9 104BuildRequires: pluto-devel
b883cf1e 105BuildRequires: scoplib-devel >= 0.2.1-2
b0068ae4
JB
106#cuda-devel
107%endif
8c514f23 108Requires: %{name}-libs = %{version}-%{release}
9556f4c9
ER
109# LLVM is not supported on PPC64
110# http://llvm.org/bugs/show_bug.cgi?id=3729
111ExcludeArch: ppc64
aa11c230 112BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
356a0bbd 114%define _sysconfdir /etc/%{name}
021b3c3d 115
9556f4c9
ER
116%define specflags_ppc -fno-var-tracking-assignments
117
6832a5c5
ER
118# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
119%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
120
4a1d21cc
JR
121# clang doesn't know it, and leaving it here would pollute llvm-config
122%define filterout_c -fvar-tracking-assignments
123%define filterout_cxx -fvar-tracking-assignments
124%define filterout_ccpp -fvar-tracking-assignments
125
6df3b432
JB
126# std::__once_call, std::__once_callable non-function symbols
127%define skip_post_check_so liblldAArch64ELFTarget.so.* liblldARMELFTarget.so.* liblldHexagonELFTarget.so.* liblldMipsELFTarget.so.* liblldb.so.*
128
aa11c230 129%description
130LLVM is a compiler infrastructure designed for compile-time,
131link-time, runtime, and idle-time optimization of programs from
132arbitrary programming languages. LLVM is written in C++ and has been
133developed since 2000 at the University of Illinois and Apple. It
621ec11f
JB
134currently supports compilation of C and C++ programs using clang
135frontend.
aa11c230 136
2326a99f
JB
137%description -l pl.UTF-8
138LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
139czasu kompilowania, linkowania, działania i bezczynności programów w
140dowolnych językach programowania. Jest napisana w C++, rozwijana od
141roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
621ec11f 142kompilację programów w C i C++ przy użyciu frontendu clang.
2326a99f 143
8c514f23
JB
144%package libs
145Summary: LLVM shared library
146Summary(pl.UTF-8): Biblioteka współdzielona LLVM-a
147Group: Libraries
148Conflicts: llvm < 3.2
149
150%description libs
151LLVM shared library.
152
153%description libs -l pl.UTF-8
154Biblioteka współdzielona LLVM-a.
155
bc88141a 156%package devel
621ec11f
JB
157Summary: Static libraries and header files for LLVM
158Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
bc88141a 159Group: Development/Languages
8c514f23 160Requires: %{name}-libs = %{version}-%{release}
bc88141a
ER
161Requires: libstdc++-devel >= 6:3.4
162
163%description devel
621ec11f
JB
164This package contains static libraries and header files needed to
165develop new native programs that use the LLVM infrastructure.
166
167%description devel -l pl.UTF-8
168Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
169potrzebne do tworzenia nowych programów natywnych wykorzystujących
170infrastrukturę LLVM.
bc88141a 171
9556f4c9
ER
172%package doc
173Summary: Documentation for LLVM
621ec11f 174Summary(pl.UTF-8): Dokumentacja do LLVM-a
9556f4c9
ER
175Group: Documentation
176# does not require base
bc88141a 177
9556f4c9
ER
178%description doc
179Documentation for the LLVM compiler infrastructure.
bc88141a 180
621ec11f
JB
181%description doc -l pl.UTF-8
182Dokumentacja do infrastruktury kompilatorów LLVM.
183
9556f4c9
ER
184%package apidocs
185Summary: API documentation for LLVM
621ec11f 186Summary(pl.UTF-8): Dokumentacja API LLVM-a
9556f4c9
ER
187Group: Development/Languages
188Requires: %{name}-doc = %{version}-%{release}
bc88141a 189
9556f4c9
ER
190%description apidocs
191API documentation for the LLVM compiler infrastructure.
bc88141a 192
621ec11f
JB
193%description apidocs -l pl.UTF-8
194Dokumentacja API infrastruktury kompilatorów LLVM.
195
b0068ae4
JB
196%package polly
197Summary: Polyhedral optimizations for LLVM
198Summary(pl.UTF-8): Optymalizacje wielościanowe dla LLVM-a
199Group: Development/Tools
200URL: http://polly.llvm.org/
201Requires: %{name} = %{version}-%{release}
202
203%description polly
204Polly is a high-level loop and data-locality optimizer and
205optimization infrastructure for LLVM. It uses an abstract mathematical
206representation based on integer polyhedra to analyze and optimize the
207memory access pattern of a program.
208
209%description polly -l pl.UTF-8
210Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
211optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
212reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
213do analizy i optymalizacji wzorców dostępu do pamięci przez program.
214
215%package polly-devel
216Summary: Header files for LLVM Polly optimization infrastructure
217Summary(pl.UTF-8): Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
218Group: Development/Libraries
219URL: http://polly.llvm.org/
220Requires: %{name}-devel = %{version}-%{release}
221Requires: %{name}-polly = %{version}-%{release}
222
223%description polly-devel
224Header files for LLVM Polly optimization infrastructure.
225
226%description polly-devel -l pl.UTF-8
227Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
228
d997b14b
AM
229%package -n clang
230Summary: A C language family frontend for LLVM
621ec11f 231Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
d997b14b
AM
232License: NCSA
233Group: Development/Languages
8c514f23 234Requires: %{name} = %{version}-%{release}
d997b14b
AM
235
236%description -n clang
237clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
238of a crane or goose. 3. C-language family front-end toolkit.
239
240The goal of the Clang project is to create a new C, C++, Objective C
241and Objective C++ front-end for the LLVM compiler. Its tools are built
242as libraries and designed to be loosely-coupled and extendable.
243
621ec11f
JB
244%description -n clang -l pl.UTF-8
245clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
246piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
247z rodziny C.
248
249Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
250LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
251budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
252i rozszerzaniu.
253
d997b14b
AM
254%package -n clang-analyzer
255Summary: A source code analysis framework
621ec11f 256Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
d997b14b
AM
257License: NCSA
258Group: Development/Languages
259Requires: clang = %{version}-%{release}
260# not picked up automatically since files are currently not instaled
261# in standard Python hierarchies yet
262Requires: python
263
264%description -n clang-analyzer
265The Clang Static Analyzer consists of both a source code analysis
266framework and a standalone tool that finds bugs in C and Objective-C
267programs. The standalone tool is invoked from the command-line, and is
268intended to run in tandem with a build of a project or code base.
269
621ec11f
JB
270%description -n clang-analyzer -l pl.UTF-8
271Clang Static Analyzer składa się ze szkieletu do analizy kodu
272źródłowego oraz samodzielnego narzędzia znajdującego błędy w
273programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
274myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
275
9556f4c9 276%package -n clang-devel
621ec11f
JB
277Summary: Header files for Clang
278Summary(pl.UTF-8): Pliki nagłówkowe Clanga
9556f4c9 279Group: Development/Languages
8c514f23 280Requires: %{name}-devel = %{version}-%{release}
9556f4c9
ER
281Requires: clang = %{version}-%{release}
282
283%description -n clang-devel
284This package contains header files for the Clang compiler.
285
621ec11f
JB
286%description -n clang-devel -l pl.UTF-8
287Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
288
9556f4c9
ER
289%package -n clang-doc
290Summary: Documentation for Clang
621ec11f 291Summary(pl.UTF-8): Dokumentacja do Clanga
9556f4c9
ER
292Group: Documentation
293Requires: %{name} = %{version}-%{release}
294
295%description -n clang-doc
296Documentation for the Clang compiler front-end.
297
621ec11f
JB
298%description -n clang-doc -l pl.UTF-8
299Dokumentacja do frontendu kompilatora Clang.
300
9556f4c9
ER
301%package -n clang-apidocs
302Summary: API documentation for Clang
621ec11f 303Summary(pl.UTF-8): Dokumentacja API Clanga
9556f4c9
ER
304Group: Development/Languages
305Requires: clang-doc = %{version}-%{release}
306
307%description -n clang-apidocs
308API documentation for the Clang compiler.
309
621ec11f
JB
310%description -n clang-apidocs -l pl.UTF-8
311Dokumentacja API kompilatora Clang.
312
b0068ae4
JB
313%package -n clang-tools-extra
314Summary: Extra tools for Clang
315Summary(pl.UTF-8): Dodatkowe narzędzia do kompilatora Clang
316Group: Development/Tools
317URL: http://clang.llvm.org/docs/ClangTools.html
318Requires: clang = %{version}-%{release}
319
320%description -n clang-tools-extra
321Extra tools for Clang.
322
323%description -n clang-tools-extra -l pl.UTF-8
324Dodatkowe narzędzia do kompilatora Clang.
325
ba1cf74d
JB
326%package -n lld
327Summary: The LLVM linker
328Summary(pl.UTF-8): Konsolidator z projektu LLVM
329Group: Development/Libraries
330URL: http://lld.llvm.org/
331Requires: %{name} = %{version}-%{release}
332
333%description -n lld
334lld is a new set of modular code for creating linker tools.
335
336%description -n lld -l pl.UTF-8
337lld to nowy zbiór modularnego kodu do tworzenia narzędzi
338konsolidujących.
339
340%package -n lld-devel
341Summary: Development files for LLD linker tools
342Summary(pl.UTF-8): Pliki programistyczne narzędzi konsolidujących LLD
343Group: Development/Tools
344URL: http://lld.llvm.org/
345Requires: %{name}-devel = %{version}-%{release}
346
347%description -n lld-devel
348Development files for LLD linker tools.
349
350%description -n lld-devel -l pl.UTF-8
351Pliki programistyczne narzędzi konsolidujących LLD.
352
5a7ac479
JB
353%package -n lldb
354Summary: Next generation high-performance debugger
355Summary(pl.UTF-8): Wydajny debugger nowej generacji
356Group: Development/Debuggers
ba1cf74d 357URL: http://lldb.llvm.org/
5a7ac479
JB
358Requires: %{name} = %{version}-%{release}
359
360%description -n lldb
361LLDB is a next generation, high-performance debugger. It is built as a
362set of reusable components which highly leverage existing libraries in
363the larger LLVM Project, such as the Clang expression parser and LLVM
364disassembler.
365
366%description -n lldb -l pl.UTF-8
367LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
368komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
369w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
370disasembler LLVM.
371
372%package -n lldb-devel
ba1cf74d
JB
373Summary: Development files for LLDB debugger
374Summary(pl.UTF-8): Pliki programistyczne debuggera LLDB
5a7ac479 375Group: Development/Libraries
ba1cf74d 376URL: http://lldb.llvm.org/
5a7ac479
JB
377Requires: %{name}-devel = %{version}-%{release}
378Requires: clang-devel = %{version}-%{release}
379Requires: lldb = %{version}-%{release}
380
381%description -n lldb-devel
ba1cf74d 382Development files for LLDB debugger.
5a7ac479
JB
383
384%description -n lldb-devel -l pl.UTF-8
ba1cf74d 385Pliki programistyczne debuggera LLDB.
5a7ac479 386
9556f4c9
ER
387%package ocaml
388Summary: OCaml binding for LLVM
621ec11f
JB
389Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
390Group: Libraries
9556f4c9
ER
391Requires: %{name} = %{version}-%{release}
392%requires_eq ocaml-runtime
393
621ec11f 394%description ocaml
9556f4c9
ER
395OCaml binding for LLVM.
396
621ec11f
JB
397%description ocaml -l pl.UTF-8
398Wiązanie OCamla do LLVM-a.
399
9556f4c9 400%package ocaml-devel
621ec11f
JB
401Summary: Development files for LLVM OCaml binding
402Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
9556f4c9
ER
403Group: Development/Libraries
404Requires: %{name}-devel = %{version}-%{release}
405Requires: %{name}-ocaml = %{version}-%{release}
406
407%description ocaml-devel
408The llvm-ocaml-devel package contains libraries and signature files
621ec11f
JB
409for developing applications that use llvm-ocaml binding.
410
411%description ocaml-devel -l pl.UTF-8
412Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
413wykorzystujących wiązanie llvm-ocaml.
414
9556f4c9
ER
415%package ocaml-doc
416Summary: Documentation for LLVM's OCaml binding
621ec11f 417Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
9556f4c9
ER
418Group: Documentation
419Requires: %{name}-ocaml = %{version}-%{release}
420
421%description ocaml-doc
422HTML documentation for LLVM's OCaml binding.
423
621ec11f
JB
424%description ocaml-doc -l pl.UTF-8
425Dokumentacja HTML wiązania OCamla do LLVM-a.
426
aa11c230 427%prep
ba1cf74d 428%setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
c999855f 429mv cfe-%{version}.src tools/clang
b883cf1e
JB
430%{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
431%{?with_lldb:mv lldb-%{version}.src tools/lldb}
432%{?with_polly:mv polly-%{version}.src tools/polly}
433mv clang-tools-extra-%{version}.src tools/clang/tools/extra
ba1cf74d 434mv lld-%{version}.src tools/lld
5a7ac479 435
3c402b7e 436%patch0 -p1
9f7b77bd 437%patch1 -p1
ebde279d 438%patch2 -p1
9f7b77bd
JR
439%patch3 -p1
440%patch4 -p1
303f4f9e 441%patch5 -p1
ce9cc204 442
ab05cf08 443%{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
19f21eee 444
bacc8b96
ER
445grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
446 s,^#!.*bin/env python,#!%{__python},
447 s,^#!.*bin/env perl,#!%{__perl},
448}'
449
d756c460 450%build
41876fe7 451install -d build
ebde279d 452
d997b14b 453# Disabling assertions now, rec. by pure and needed for OpenGTL
9556f4c9 454# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
41876fe7 455cd build
5e689738 456CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
2bbd0701 457
41876fe7
JR
458%{cmake} ../ \
459%ifarch %{x8664}
460 -DLLVM_LIBDIR_SUFFIX:STRING=64 \
461%endif
462%ifarch x32
463 -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
464%endif
d997b14b 465%ifarch %{ix86}
41876fe7 466 -DLLVM_ENABLE_PIC:BOOL=OFF \
9556f4c9
ER
467%endif
468%if %{with apidocs}
41876fe7 469 -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
d997b14b 470%endif
41876fe7
JR
471%if %{with doc}
472 -DLLVM_ENABLE_SPHINX:BOOL=ON \
473%endif
474 -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
475 -DLLVM_ENABLE_CXX1Y:BOOL=ON \
82174e17 476 -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
41876fe7
JR
477 -DBUILD_SHARED_LIBS:BOOL=ON
478
d997b14b 479%{__make} \
1628dc68 480 VERBOSE=1 \
0a0b7076 481 REQUIRES_RTTI=1 \
d997b14b 482 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
aa11c230 483
827664e9 484%if %{with tests}
9556f4c9
ER
485%{__make} check 2>&1 | tee llvm-testlog.txt
486%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
487%endif
488
b0068ae4 489%if %{with doc}
41876fe7
JR
490%{__make} -C docs docs-llvm-html
491%{__make} -C docs docs-llvm-man
c6c890ee 492%if %{with ocaml}
41876fe7 493%{__make} -C docs ocaml_doc
c6c890ee 494%endif
41876fe7
JR
495%{__make} -C tools/clang/docs docs-clang-html
496%{__make} -C tools/clang/docs docs-clang-man
497%{__make} -C tools/lld/docs docs-lld-html
498%{__make} -C tools/lldb/docs lldb-python-doc
499%{__make} -C tools/lldb/docs lldb-cpp-doc
6df3b432 500%{__make} -C ../tools/clang/tools/extra/docs html
dd9350c7
JB
501%endif
502
aa11c230 503%install
504rm -rf $RPM_BUILD_ROOT
41876fe7 505%{__make} -C build install \
aa11c230 506 DESTDIR=$RPM_BUILD_ROOT
507
6df3b432
JB
508# only some .pyc files are created by make install
509%py_comp $RPM_BUILD_ROOT%{py_sitedir}
510%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
511
d997b14b 512# Static analyzer not installed by default:
9556f4c9
ER
513# http://clang-analyzer.llvm.org/installation#OtherPlatforms
514install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b
AM
515# create launchers
516for f in scan-{build,view}; do
9556f4c9
ER
517 ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
518 cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b 519done
41876fe7 520install -d $RPM_BUILD_ROOT%{_mandir}/man1
dd9350c7 521%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
8132e62b
JB
522%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
523%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
524%py_postclean %{_libdir}/clang-analyzer/scan-view
4ba3b2b3
JB
525# not this OS
526%{__rm} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/*.bat
d997b14b 527
6df3b432
JB
528# not installed by cmake buildsystem
529install build/bin/clang-query $RPM_BUILD_ROOT%{_bindir}
530install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
531
b0068ae4 532%if %{with doc}
6df3b432 533cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
b883cf1e
JB
534# these tools are not installed
535%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
b0068ae4
JB
536# make links
537echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
dd9350c7
JB
538%endif
539
d997b14b 540# Move documentation back to build directory
2bbd0701 541%if %{with ocaml}
6df3b432
JB
542rm -rf ocamldocs
543mv $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
2bbd0701 544%endif
9556f4c9
ER
545
546# and separate the apidoc
547%if %{with apidocs}
6df3b432
JB
548rm -rf clang-apidoc
549cp -a build/tools/clang/docs/html clang-apidoc
9556f4c9 550%endif
d997b14b
AM
551
552# And prepare Clang documentation
d997b14b 553rm -rf clang-docs
9556f4c9 554install -d clang-docs
827664e9 555for f in LICENSE.TXT NOTES.txt README.txt; do
9556f4c9 556 ln tools/clang/$f clang-docs
d997b14b 557done
021b3c3d 558
6832a5c5 559# Get rid of erroneously installed example files.
6df3b432
JB
560%{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
561# test?
562%{__rm} $RPM_BUILD_ROOT%{_bindir}/llvm-c-test
563# not this OS
564%{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
6832a5c5 565
aa11c230 566%clean
567rm -rf $RPM_BUILD_ROOT
568
8c514f23
JB
569%post libs -p /sbin/ldconfig
570%postun libs -p /sbin/ldconfig
aa11c230 571
5a7ac479
JB
572%post -n clang -p /sbin/ldconfig
573%postun -n clang -p /sbin/ldconfig
574
6df3b432
JB
575%post -n clang-tools-extra -p /sbin/ldconfig
576%postun -n clang-tools-extra -p /sbin/ldconfig
577
5a7ac479
JB
578%post -n lldb -p /sbin/ldconfig
579%postun -n lldb -p /sbin/ldconfig
580
aa11c230 581%files
582%defattr(644,root,root,755)
8132e62b 583%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
a9beeab5 584%attr(755,root,root) %{_bindir}/bugpoint
a9beeab5
JB
585%attr(755,root,root) %{_bindir}/llc
586%attr(755,root,root) %{_bindir}/lli
8132e62b
JB
587%attr(755,root,root) %{_bindir}/llvm-ar
588%attr(755,root,root) %{_bindir}/llvm-as
589%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
827664e9 590%attr(755,root,root) %{_bindir}/llvm-cov
8132e62b
JB
591%attr(755,root,root) %{_bindir}/llvm-diff
592%attr(755,root,root) %{_bindir}/llvm-dis
4ba3b2b3 593%attr(755,root,root) %{_bindir}/llvm-dsymutil
827664e9 594%attr(755,root,root) %{_bindir}/llvm-dwarfdump
8132e62b 595%attr(755,root,root) %{_bindir}/llvm-extract
6df3b432 596%attr(755,root,root) %{_bindir}/llvm-lib
8132e62b 597%attr(755,root,root) %{_bindir}/llvm-link
3c402b7e
JB
598%ifarch %{x8664} x32
599%attr(755,root,root) %{_bindir}/llvm-lto
600%endif
8132e62b 601%attr(755,root,root) %{_bindir}/llvm-mc
dd9350c7 602%attr(755,root,root) %{_bindir}/llvm-mcmarkup
8132e62b
JB
603%attr(755,root,root) %{_bindir}/llvm-nm
604%attr(755,root,root) %{_bindir}/llvm-objdump
b883cf1e 605%attr(755,root,root) %{_bindir}/llvm-profdata
8132e62b 606%attr(755,root,root) %{_bindir}/llvm-ranlib
f981d747 607%attr(755,root,root) %{_bindir}/llvm-readobj
827664e9
PS
608%attr(755,root,root) %{_bindir}/llvm-rtdyld
609%attr(755,root,root) %{_bindir}/llvm-size
f981d747 610%attr(755,root,root) %{_bindir}/llvm-stress
1628dc68 611%attr(755,root,root) %{_bindir}/llvm-symbolizer
827664e9 612%attr(755,root,root) %{_bindir}/llvm-tblgen
41876fe7
JR
613%attr(755,root,root) %{_bindir}/llvm-cxxdump
614%attr(755,root,root) %{_bindir}/llvm-pdbdump
a7973f21 615%attr(755,root,root) %{_bindir}/macho-dump
4ba3b2b3 616%attr(755,root,root) %{_bindir}/obj2yaml
8132e62b 617%attr(755,root,root) %{_bindir}/opt
4ba3b2b3
JB
618%attr(755,root,root) %{_bindir}/verify-uselistorder
619%attr(755,root,root) %{_bindir}/yaml2obj
b0068ae4 620%if %{with doc}
a9beeab5 621%{_mandir}/man1/bugpoint.1*
a7973f21 622%{_mandir}/man1/lit.1*
a9beeab5
JB
623%{_mandir}/man1/llc.1*
624%{_mandir}/man1/lli.1*
8132e62b
JB
625%{_mandir}/man1/llvm-ar.1*
626%{_mandir}/man1/llvm-as.1*
627%{_mandir}/man1/llvm-bcanalyzer.1*
f981d747 628%{_mandir}/man1/llvm-cov.1*
8132e62b
JB
629%{_mandir}/man1/llvm-diff.1*
630%{_mandir}/man1/llvm-dis.1*
b883cf1e 631%{_mandir}/man1/llvm-dwarfdump.1*
8132e62b 632%{_mandir}/man1/llvm-extract.1*
8132e62b
JB
633%{_mandir}/man1/llvm-link.1*
634%{_mandir}/man1/llvm-nm.1*
b883cf1e 635%{_mandir}/man1/llvm-profdata.1*
8132e62b 636%{_mandir}/man1/llvm-ranlib.1*
c999855f 637%{_mandir}/man1/llvm-readobj.1*
f981d747 638%{_mandir}/man1/llvm-stress.1*
1628dc68 639%{_mandir}/man1/llvm-symbolizer.1*
a9beeab5 640%{_mandir}/man1/opt.1*
dd9350c7 641%{_mandir}/man1/tblgen.1*
b0068ae4 642%endif
bc88141a 643
8c514f23
JB
644%files libs
645%defattr(644,root,root,755)
6df3b432
JB
646%attr(755,root,root) %{_libdir}/libLLVM*.so.%{version}
647%attr(755,root,root) %ghost %{_libdir}/libLLVM*.so.3.7
3c402b7e
JB
648%ifarch %{x8664} x32
649%attr(755,root,root) %{_libdir}/libLTO.so.%{version}
650%attr(755,root,root) %ghost %{_libdir}/libLTO.so.3.7
651%endif
8c514f23 652
bc88141a
ER
653%files devel
654%defattr(644,root,root,755)
655%attr(755,root,root) %{_bindir}/llvm-config
6df3b432 656%attr(755,root,root) %{_libdir}/libLLVM*.so
0a8510f2 657%attr(755,root,root) %{_libdir}/BugpointPasses.so
6df3b432 658%ifarch %{x8664} x32
19f21eee 659%attr(755,root,root) %{_libdir}/libLTO.so
1655c8b5 660%endif
8132e62b
JB
661%{_includedir}/llvm
662%{_includedir}/llvm-c
b883cf1e
JB
663%dir %{_datadir}/llvm
664%{_datadir}/llvm/cmake
b0068ae4 665%if %{with doc}
8132e62b 666%{_mandir}/man1/llvm-config.1*
b0068ae4 667%endif
bc88141a 668
6df3b432
JB
669#%files doc
670#%defattr(644,root,root,755)
9556f4c9
ER
671
672%if %{with apidocs}
673%files apidocs
674%defattr(644,root,root,755)
675%doc apidoc/*
676%endif
677
b0068ae4
JB
678%if %{with polly}
679%files polly
680%defattr(644,root,root,755)
681%doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
682%attr(755,root,root) %{_libdir}/LLVMPolly.so
6df3b432 683%attr(755,root,root) %{_libdir}/libPolly.so
b0068ae4
JB
684
685%files polly-devel
686%defattr(644,root,root,755)
b0068ae4
JB
687%{_includedir}/polly
688%endif
689
d997b14b 690%files -n clang
bc88141a 691%defattr(644,root,root,755)
827664e9 692%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
8132e62b
JB
693%attr(755,root,root) %{_bindir}/clang
694%attr(755,root,root) %{_bindir}/clang++
6df3b432 695%attr(755,root,root) %{_bindir}/clang-3.7
dd9350c7 696%attr(755,root,root) %{_bindir}/clang-check
6df3b432 697%attr(755,root,root) %{_bindir}/clang-cl
1628dc68 698%attr(755,root,root) %{_bindir}/clang-format
6df3b432
JB
699%attr(755,root,root) %{_bindir}/git-clang-format
700%attr(755,root,root) %{_libdir}/libclang*.so.%{version}
701%attr(755,root,root) %ghost %{_libdir}/libclang*.so.3.7
5a7ac479
JB
702%dir %{_libdir}/clang
703%dir %{_libdir}/clang/%{version}
704%{_libdir}/clang/%{version}/include
705%if %{with rt}
c6c890ee 706%ifarch %{ix86} %{x8664}
5a7ac479 707%{_libdir}/clang/%{version}/lib
6df3b432 708%{_libdir}/clang/%{version}/asan_blacklist.txt
c6c890ee
JB
709%endif
710%ifarch %{x8664}
3c402b7e
JB
711%{_libdir}/clang/%{version}/dfsan_abilist.txt
712%{_libdir}/clang/%{version}/msan_blacklist.txt
713%endif
5a7ac479 714%endif
3c402b7e
JB
715%dir %{_datadir}/clang
716%{_datadir}/clang/clang-format-diff.py
d997b14b
AM
717
718%files -n clang-analyzer
bc88141a 719%defattr(644,root,root,755)
d997b14b
AM
720%attr(755,root,root) %{_bindir}/scan-build
721%attr(755,root,root) %{_bindir}/scan-view
dd9350c7 722%{_mandir}/man1/scan-build.1*
ae49e501 723%dir %{_libdir}/clang-analyzer
d997b14b 724
9556f4c9
ER
725%dir %{_libdir}/clang-analyzer/scan-build
726%{_libdir}/clang-analyzer/scan-build/*.css
727%{_libdir}/clang-analyzer/scan-build/*.js
728%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
729%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
730
8132e62b
JB
731%dir %{_libdir}/clang-analyzer/scan-view
732%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
733%{_libdir}/clang-analyzer/scan-view/Resources
734%{_libdir}/clang-analyzer/scan-view/*.py[co]
735
9556f4c9
ER
736%files -n clang-devel
737%defattr(644,root,root,755)
6df3b432 738%attr(755,root,root) %{_libdir}/libclang*.so
3c402b7e 739%ifarch %{ix86} # ???
6df3b432 740%{_libdir}/libclang.a
3c402b7e 741%endif
9556f4c9
ER
742%{_includedir}/clang
743%{_includedir}/clang-c
744
745%files -n clang-doc
746%defattr(644,root,root,755)
41876fe7 747%doc tools/clang/docs/*.{html,png,txt}
9556f4c9
ER
748
749%if %{with apidocs}
750%files -n clang-apidocs
751%defattr(644,root,root,755)
752%doc clang-apidoc/*
753%endif
754
b0068ae4
JB
755%files -n clang-tools-extra
756%defattr(644,root,root,755)
6df3b432 757%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt} tools/clang/tools/extra/docs/_build/html/{*.html,*.js,_static}
b0068ae4
JB
758%attr(755,root,root) %{_bindir}/clang-apply-replacements
759%attr(755,root,root) %{_bindir}/clang-modernize
b883cf1e 760%attr(755,root,root) %{_bindir}/clang-query
4ba3b2b3 761%attr(755,root,root) %{_bindir}/clang-rename
b0068ae4
JB
762%attr(755,root,root) %{_bindir}/clang-tidy
763%attr(755,root,root) %{_bindir}/pp-trace
6df3b432
JB
764%attr(755,root,root) %{_libdir}/libmodernizeCore.so.%{version}
765%attr(755,root,root) %ghost %{_libdir}/libmodernizeCore.so.3.7
766# -devel?
767%attr(755,root,root) %{_libdir}/libmodernizeCore.so
b0068ae4 768
ba1cf74d
JB
769%files -n lld
770%defattr(644,root,root,755)
771%doc tools/lld/{LICENSE.TXT,README.md}
772%attr(755,root,root) %{_bindir}/lld
6df3b432
JB
773%attr(755,root,root) %{_libdir}/liblld[ACDEHMPRXY]*.so.%{version}
774%attr(755,root,root) %ghost %{_libdir}/liblld[ACDEHMPRXY]*.so.3.7
ba1cf74d
JB
775
776%files -n lld-devel
777%defattr(644,root,root,755)
6df3b432 778%attr(755,root,root) %{_libdir}/liblld[ACDEHMPRXY]*.so
ba1cf74d
JB
779%{_includedir}/lld
780
5a7ac479
JB
781%if %{with lldb}
782%files -n lldb
783%defattr(644,root,root,755)
6df3b432 784%attr(755,root,root) %{_bindir}/argdumper
5a7ac479 785%attr(755,root,root) %{_bindir}/lldb
6df3b432 786%attr(755,root,root) %{_bindir}/lldb-%{version}
b883cf1e 787%attr(755,root,root) %{_bindir}/lldb-mi
6df3b432
JB
788%attr(755,root,root) %{_bindir}/lldb-mi-%{version}
789%attr(755,root,root) %{_bindir}/lldb-server
790%attr(755,root,root) %{_bindir}/lldb-server-%{version}
791%attr(755,root,root) %{_libdir}/liblldb.so.%{version}
792%attr(755,root,root) %ghost %{_libdir}/liblldb.so.3.7
b883cf1e 793%dir %{py_sitedir}/lldb
41876fe7 794%attr(755,root,root) %{py_sitedir}/lldb/argdumper
6df3b432
JB
795%{py_sitedir}/lldb/formatters
796%{py_sitedir}/lldb/runtime
797%{py_sitedir}/lldb/utils
798%{py_sitedir}/lldb/__init__.py[co]
799%{py_sitedir}/lldb/embedded_interpreter.py[co]
b883cf1e
JB
800%attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
801%attr(755,root,root) %{py_sitedir}/readline.so
5a7ac479
JB
802
803%files -n lldb-devel
804%defattr(644,root,root,755)
6df3b432 805%attr(755,root,root) %{_libdir}/liblldb.so
5a7ac479
JB
806%{_libdir}/liblldb*.a
807%{_includedir}/lldb
808%endif
809
9556f4c9 810%if %{with ocaml}
d997b14b
AM
811%files ocaml
812%defattr(644,root,root,755)
11b6f380
JB
813%{_libdir}/ocaml/META.llvm*
814%attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
8132e62b
JB
815%{_libdir}/ocaml/llvm*.cma
816%{_libdir}/ocaml/llvm*.cmi
d997b14b
AM
817
818%files ocaml-devel
819%defattr(644,root,root,755)
8132e62b
JB
820%{_libdir}/ocaml/libllvm*.a
821%{_libdir}/ocaml/llvm*.a
822%{_libdir}/ocaml/llvm*.cmx*
9556f4c9
ER
823
824%files ocaml-doc
825%defattr(644,root,root,755)
6df3b432 826%doc ocamldocs/*
9556f4c9 827%endif
This page took 0.333066 seconds and 4 git commands to generate.