]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- updated to 3.4.2
[packages/llvm.git] / llvm.spec
CommitLineData
bc88141a 1#
9556f4c9 2# Conditional build:
5a7ac479
JB
3%bcond_without lldb # LLDB debugger
4%bcond_without rt # compiler-rt libraries
5%bcond_without ocaml # OCaml binding
dd9350c7 6%bcond_without man # man pages
5a7ac479 7%bcond_with apidocs # doxygen docs (HUGE, so they are not built by default)
8132e62b 8%bcond_with tests # run tests
9556f4c9
ER
9
10%ifarch s390 s390x sparc64
11# No ocaml on these arches
12%undefine with_ocaml
13%endif
14
aa11c230 15Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 16Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 17Name: llvm
e3083bc4 18Version: 3.4.2
1628dc68 19Release: 1
aa11c230 20License: University of Illinois/NCSA Open Source License
21Group: Development/Languages
dd9350c7 22#Source0Download: http://llvm.org/releases/download.html
f981d747 23Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
e3083bc4 24# Source0-md5: a20669f75967440de949ac3b1bad439c
c999855f 25Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.gz
e3083bc4 26# Source1-md5: 87945973b7c73038871c5f849a818588
5a7ac479
JB
27Source2: http://llvm.org/releases/3.4/compiler-rt-3.4.src.tar.gz
28# Source2-md5: 7938353e3a3bda85733a165e7ac4bb84
29Source3: http://llvm.org/releases/3.4/lldb-3.4.src.tar.gz
30# Source3-md5: 7ed60a0463f9fdfa20db7109d4624cee
ebde279d 31Patch0: %{name}-config.patch
d997b14b 32# Data files should be installed with timestamps preserved
ebde279d
JB
33Patch1: %{name}-2.6-timestamp.patch
34Patch2: %{name}-pld.patch
2326a99f 35URL: http://llvm.org/
ebde279d
JB
36BuildRequires: autoconf >= 2.60
37BuildRequires: automake >= 1:1.9.6
bc88141a 38BuildRequires: bash
d997b14b 39BuildRequires: bison
d997b14b 40BuildRequires: flex
dd9350c7
JB
41BuildRequires: gcc >= 5:3.4
42# gcc4 might be installed, but not current __cc
43%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
44BuildRequires: __cc >= 3.4
9556f4c9 45%endif
d997b14b 46BuildRequires: groff
bc88141a 47BuildRequires: libltdl-devel
ebde279d 48BuildRequires: libtool >= 2:1.5.22
d997b14b
AM
49BuildRequires: libstdc++-devel >= 5:3.4
50BuildRequires: ocaml-ocamldoc
8132e62b 51BuildRequires: perl-base >= 1:5.6
8c156e7d 52BuildRequires: perl-tools-pod
53BuildRequires: rpm-pythonprov
dd9350c7
JB
54%{?with_man:BuildRequires: sphinx-pdg}
55%if %{with apidocs}
56BuildRequires: doxygen
57BuildRequires: graphviz
58%endif
59%if %{with tests}
60BuildRequires: dejagnu
61BuildRequires: python
62BuildRequires: tcl-devel
356a0bbd 63%endif
8c514f23 64Requires: %{name}-libs = %{version}-%{release}
9556f4c9
ER
65# LLVM is not supported on PPC64
66# http://llvm.org/bugs/show_bug.cgi?id=3729
67ExcludeArch: ppc64
aa11c230 68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
356a0bbd 70%define _sysconfdir /etc/%{name}
021b3c3d 71
9556f4c9
ER
72%define specflags_ppc -fno-var-tracking-assignments
73
6832a5c5
ER
74# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
75%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
76
aa11c230 77%description
78LLVM is a compiler infrastructure designed for compile-time,
79link-time, runtime, and idle-time optimization of programs from
80arbitrary programming languages. LLVM is written in C++ and has been
81developed since 2000 at the University of Illinois and Apple. It
621ec11f
JB
82currently supports compilation of C and C++ programs using clang
83frontend.
aa11c230 84
2326a99f
JB
85%description -l pl.UTF-8
86LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
87czasu kompilowania, linkowania, działania i bezczynności programów w
88dowolnych językach programowania. Jest napisana w C++, rozwijana od
89roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
621ec11f 90kompilację programów w C i C++ przy użyciu frontendu clang.
2326a99f 91
8c514f23
JB
92%package libs
93Summary: LLVM shared library
94Summary(pl.UTF-8): Biblioteka współdzielona LLVM-a
95Group: Libraries
96Conflicts: llvm < 3.2
97
98%description libs
99LLVM shared library.
100
101%description libs -l pl.UTF-8
102Biblioteka współdzielona LLVM-a.
103
bc88141a 104%package devel
621ec11f
JB
105Summary: Static libraries and header files for LLVM
106Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
bc88141a 107Group: Development/Languages
8c514f23 108Requires: %{name}-libs = %{version}-%{release}
bc88141a
ER
109Requires: libstdc++-devel >= 6:3.4
110
111%description devel
621ec11f
JB
112This package contains static libraries and header files needed to
113develop new native programs that use the LLVM infrastructure.
114
115%description devel -l pl.UTF-8
116Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
117potrzebne do tworzenia nowych programów natywnych wykorzystujących
118infrastrukturę LLVM.
bc88141a 119
9556f4c9
ER
120%package doc
121Summary: Documentation for LLVM
621ec11f 122Summary(pl.UTF-8): Dokumentacja do LLVM-a
9556f4c9
ER
123Group: Documentation
124# does not require base
bc88141a 125
9556f4c9
ER
126%description doc
127Documentation for the LLVM compiler infrastructure.
bc88141a 128
621ec11f
JB
129%description doc -l pl.UTF-8
130Dokumentacja do infrastruktury kompilatorów LLVM.
131
9556f4c9
ER
132%package apidocs
133Summary: API documentation for LLVM
621ec11f 134Summary(pl.UTF-8): Dokumentacja API LLVM-a
9556f4c9
ER
135Group: Development/Languages
136Requires: %{name}-doc = %{version}-%{release}
bc88141a 137
9556f4c9
ER
138%description apidocs
139API documentation for the LLVM compiler infrastructure.
bc88141a 140
621ec11f
JB
141%description apidocs -l pl.UTF-8
142Dokumentacja API infrastruktury kompilatorów LLVM.
143
d997b14b
AM
144%package -n clang
145Summary: A C language family frontend for LLVM
621ec11f 146Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
d997b14b
AM
147License: NCSA
148Group: Development/Languages
8c514f23 149Requires: %{name} = %{version}-%{release}
d997b14b
AM
150
151%description -n clang
152clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
153of a crane or goose. 3. C-language family front-end toolkit.
154
155The goal of the Clang project is to create a new C, C++, Objective C
156and Objective C++ front-end for the LLVM compiler. Its tools are built
157as libraries and designed to be loosely-coupled and extendable.
158
621ec11f
JB
159%description -n clang -l pl.UTF-8
160clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
161piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
162z rodziny C.
163
164Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
165LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
166budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
167i rozszerzaniu.
168
d997b14b
AM
169%package -n clang-analyzer
170Summary: A source code analysis framework
621ec11f 171Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
d997b14b
AM
172License: NCSA
173Group: Development/Languages
174Requires: clang = %{version}-%{release}
175# not picked up automatically since files are currently not instaled
176# in standard Python hierarchies yet
177Requires: python
178
179%description -n clang-analyzer
180The Clang Static Analyzer consists of both a source code analysis
181framework and a standalone tool that finds bugs in C and Objective-C
182programs. The standalone tool is invoked from the command-line, and is
183intended to run in tandem with a build of a project or code base.
184
621ec11f
JB
185%description -n clang-analyzer -l pl.UTF-8
186Clang Static Analyzer składa się ze szkieletu do analizy kodu
187źródłowego oraz samodzielnego narzędzia znajdującego błędy w
188programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
189myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
190
9556f4c9 191%package -n clang-devel
621ec11f
JB
192Summary: Header files for Clang
193Summary(pl.UTF-8): Pliki nagłówkowe Clanga
9556f4c9 194Group: Development/Languages
8c514f23 195Requires: %{name}-devel = %{version}-%{release}
9556f4c9
ER
196Requires: clang = %{version}-%{release}
197
198%description -n clang-devel
199This package contains header files for the Clang compiler.
200
621ec11f
JB
201%description -n clang-devel -l pl.UTF-8
202Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
203
9556f4c9
ER
204%package -n clang-doc
205Summary: Documentation for Clang
621ec11f 206Summary(pl.UTF-8): Dokumentacja do Clanga
9556f4c9
ER
207Group: Documentation
208Requires: %{name} = %{version}-%{release}
209
210%description -n clang-doc
211Documentation for the Clang compiler front-end.
212
621ec11f
JB
213%description -n clang-doc -l pl.UTF-8
214Dokumentacja do frontendu kompilatora Clang.
215
9556f4c9
ER
216%package -n clang-apidocs
217Summary: API documentation for Clang
621ec11f 218Summary(pl.UTF-8): Dokumentacja API Clanga
9556f4c9
ER
219Group: Development/Languages
220Requires: clang-doc = %{version}-%{release}
221
222%description -n clang-apidocs
223API documentation for the Clang compiler.
224
621ec11f
JB
225%description -n clang-apidocs -l pl.UTF-8
226Dokumentacja API kompilatora Clang.
227
5a7ac479
JB
228%package -n lldb
229Summary: Next generation high-performance debugger
230Summary(pl.UTF-8): Wydajny debugger nowej generacji
231Group: Development/Debuggers
232Requires: %{name} = %{version}-%{release}
233
234%description -n lldb
235LLDB is a next generation, high-performance debugger. It is built as a
236set of reusable components which highly leverage existing libraries in
237the larger LLVM Project, such as the Clang expression parser and LLVM
238disassembler.
239
240%description -n lldb -l pl.UTF-8
241LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
242komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
243w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
244disasembler LLVM.
245
246%package -n lldb-devel
247Summary: Header files for LLDB
248Summary(pl.UTF-8): Pliki nagłówkowe LLDB
249Group: Development/Libraries
250Requires: %{name}-devel = %{version}-%{release}
251Requires: clang-devel = %{version}-%{release}
252Requires: lldb = %{version}-%{release}
253
254%description -n lldb-devel
255Header files for LLDB.
256
257%description -n lldb-devel -l pl.UTF-8
258Pliki nagłówkowe LLDB.
259
9556f4c9
ER
260%package ocaml
261Summary: OCaml binding for LLVM
621ec11f
JB
262Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
263Group: Libraries
9556f4c9
ER
264Requires: %{name} = %{version}-%{release}
265%requires_eq ocaml-runtime
266
621ec11f 267%description ocaml
9556f4c9
ER
268OCaml binding for LLVM.
269
621ec11f
JB
270%description ocaml -l pl.UTF-8
271Wiązanie OCamla do LLVM-a.
272
9556f4c9 273%package ocaml-devel
621ec11f
JB
274Summary: Development files for LLVM OCaml binding
275Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
9556f4c9
ER
276Group: Development/Libraries
277Requires: %{name}-devel = %{version}-%{release}
278Requires: %{name}-ocaml = %{version}-%{release}
279
280%description ocaml-devel
281The llvm-ocaml-devel package contains libraries and signature files
621ec11f
JB
282for developing applications that use llvm-ocaml binding.
283
284%description ocaml-devel -l pl.UTF-8
285Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
286wykorzystujących wiązanie llvm-ocaml.
287
9556f4c9
ER
288%package ocaml-doc
289Summary: Documentation for LLVM's OCaml binding
621ec11f 290Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
9556f4c9
ER
291Group: Documentation
292Requires: %{name}-ocaml = %{version}-%{release}
293
294%description ocaml-doc
295HTML documentation for LLVM's OCaml binding.
296
621ec11f
JB
297%description ocaml-doc -l pl.UTF-8
298Dokumentacja HTML wiązania OCamla do LLVM-a.
299
aa11c230 300%prep
5a7ac479 301%setup -q -n %{name}-%{version}.src -a1 -a2 -a3
c999855f 302mv cfe-%{version}.src tools/clang
5a7ac479
JB
303%{?with_rt:mv compiler-rt-3.4 projects/compiler-rt}
304%{?with_lldb:mv lldb-3.4 tools/lldb}
305
ebde279d
JB
306%patch0 -p1
307%patch1 -p1
308%patch2 -p1
ce9cc204 309
19f21eee 310# configure does not properly specify libdir
3a1d4bb3 311%{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
9206c2b1
JB
312# clang resources
313%{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
314%{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
19f21eee 315
bacc8b96
ER
316grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
317 s,^#!.*bin/env python,#!%{__python},
318 s,^#!.*bin/env perl,#!%{__perl},
319}'
320
9556f4c9 321install -d obj
aa11c230 322
323%build
ebde279d
JB
324cd autoconf
325%{__aclocal} -I m4
326%{__autoconf} -o ../configure configure.ac
327cd ..
328%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
329
d997b14b 330# Disabling assertions now, rec. by pure and needed for OpenGTL
9556f4c9 331# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
d997b14b 332#
bc88141a 333# bash specific 'test a < b'
9556f4c9 334cd obj
d997b14b 335bash ../%configure \
bc88141a 336 --datadir=%{_datadir}/%{name}-%{version} \
632f3287 337 --disable-assertions \
5a7ac479 338 --enable-cxx11 \
d997b14b 339%ifarch %{ix86}
632f3287 340 --disable-pic \
9556f4c9 341%endif
632f3287
JB
342 --disable-static \
343 --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
344 --enable-debug-runtime \
9556f4c9
ER
345%if %{with apidocs}
346 --enable-doxygen \
d997b14b 347%endif
25189042 348 --enable-experimental-targets=R600 \
bc88141a 349 --enable-jit \
aa11c230 350 --enable-optimized \
bc88141a
ER
351 --enable-shared \
352 --with-pic
353
d997b14b 354%{__make} \
1628dc68 355 VERBOSE=1 \
0a0b7076 356 REQUIRES_RTTI=1 \
d997b14b 357 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
aa11c230 358
827664e9 359%if %{with tests}
9556f4c9
ER
360%{__make} check 2>&1 | tee llvm-testlog.txt
361%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
362%endif
363
dd9350c7
JB
364cd ..
365
366%if %{with man}
367%{__make} -C docs -f Makefile.sphinx man
368%endif
369
aa11c230 370%install
371rm -rf $RPM_BUILD_ROOT
9556f4c9 372%{__make} -C obj -j1 install \
d997b14b 373 PROJ_docsdir=/moredocs \
aa11c230 374 DESTDIR=$RPM_BUILD_ROOT
375
d997b14b 376# Static analyzer not installed by default:
9556f4c9
ER
377# http://clang-analyzer.llvm.org/installation#OtherPlatforms
378install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b
AM
379# create launchers
380for f in scan-{build,view}; do
9556f4c9
ER
381 ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
382 cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b 383done
dd9350c7 384%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
8132e62b
JB
385%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
386%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
387%py_postclean %{_libdir}/clang-analyzer/scan-view
d997b14b 388
dd9350c7
JB
389%if %{with man}
390install -d $RPM_BUILD_ROOT%{_mandir}/man1
391cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
392# these tools are not installed
393%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
394%endif
395
d997b14b 396# Move documentation back to build directory
d997b14b
AM
397rm -rf moredocs
398mv $RPM_BUILD_ROOT/moredocs .
ebde279d
JB
399%{__rm} -v moredocs/*.tar.gz
400%{__rm} -v moredocs/ocamldoc/html/*.tar.gz
9556f4c9
ER
401
402# and separate the apidoc
403%if %{with apidocs}
404rm -rf apidoc clang-apidoc
405mv moredocs/html/doxygen apidoc
406cp -a tools/clang/docs/doxygen/html clang-apidoc
407%endif
d997b14b
AM
408
409# And prepare Clang documentation
d997b14b 410rm -rf clang-docs
9556f4c9 411install -d clang-docs
827664e9 412for f in LICENSE.TXT NOTES.txt README.txt; do
9556f4c9 413 ln tools/clang/$f clang-docs
d997b14b 414done
021b3c3d 415
6832a5c5 416# Get rid of erroneously installed example files.
ebde279d 417%{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
6832a5c5 418
11b6f380
JB
419echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
420# llvm-prof has been removed before LLVM 3.4
421%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/llvm-prof.1
422
d997b14b
AM
423# remove documentation makefiles:
424# they require the build directory to work
9556f4c9
ER
425rm -rf moredocs/examples
426cp -a examples moredocs/examples
427find moredocs/examples -name Makefile | xargs -0r rm -f
6832a5c5 428
aa11c230 429%clean
430rm -rf $RPM_BUILD_ROOT
431
8c514f23
JB
432%post libs -p /sbin/ldconfig
433%postun libs -p /sbin/ldconfig
aa11c230 434
5a7ac479
JB
435%post -n clang -p /sbin/ldconfig
436%postun -n clang -p /sbin/ldconfig
437
438%post -n lldb -p /sbin/ldconfig
439%postun -n lldb -p /sbin/ldconfig
440
aa11c230 441%files
442%defattr(644,root,root,755)
8132e62b 443%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
a9beeab5 444%attr(755,root,root) %{_bindir}/bugpoint
a9beeab5
JB
445%attr(755,root,root) %{_bindir}/llc
446%attr(755,root,root) %{_bindir}/lli
11b6f380 447%attr(755,root,root) %{_bindir}/lli-child-target
8132e62b
JB
448%attr(755,root,root) %{_bindir}/llvm-ar
449%attr(755,root,root) %{_bindir}/llvm-as
450%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
827664e9 451%attr(755,root,root) %{_bindir}/llvm-cov
8132e62b
JB
452%attr(755,root,root) %{_bindir}/llvm-diff
453%attr(755,root,root) %{_bindir}/llvm-dis
827664e9 454%attr(755,root,root) %{_bindir}/llvm-dwarfdump
8132e62b 455%attr(755,root,root) %{_bindir}/llvm-extract
8132e62b
JB
456%attr(755,root,root) %{_bindir}/llvm-link
457%attr(755,root,root) %{_bindir}/llvm-mc
dd9350c7 458%attr(755,root,root) %{_bindir}/llvm-mcmarkup
8132e62b
JB
459%attr(755,root,root) %{_bindir}/llvm-nm
460%attr(755,root,root) %{_bindir}/llvm-objdump
8132e62b 461%attr(755,root,root) %{_bindir}/llvm-ranlib
f981d747 462%attr(755,root,root) %{_bindir}/llvm-readobj
827664e9
PS
463%attr(755,root,root) %{_bindir}/llvm-rtdyld
464%attr(755,root,root) %{_bindir}/llvm-size
f981d747 465%attr(755,root,root) %{_bindir}/llvm-stress
1628dc68 466%attr(755,root,root) %{_bindir}/llvm-symbolizer
827664e9 467%attr(755,root,root) %{_bindir}/llvm-tblgen
a7973f21 468%attr(755,root,root) %{_bindir}/macho-dump
8132e62b 469%attr(755,root,root) %{_bindir}/opt
a9beeab5 470%{_mandir}/man1/bugpoint.1*
a7973f21 471%{_mandir}/man1/lit.1*
a9beeab5
JB
472%{_mandir}/man1/llc.1*
473%{_mandir}/man1/lli.1*
8132e62b
JB
474%{_mandir}/man1/llvm-ar.1*
475%{_mandir}/man1/llvm-as.1*
476%{_mandir}/man1/llvm-bcanalyzer.1*
f981d747 477%{_mandir}/man1/llvm-cov.1*
8132e62b
JB
478%{_mandir}/man1/llvm-diff.1*
479%{_mandir}/man1/llvm-dis.1*
480%{_mandir}/man1/llvm-extract.1*
8132e62b
JB
481%{_mandir}/man1/llvm-link.1*
482%{_mandir}/man1/llvm-nm.1*
8132e62b 483%{_mandir}/man1/llvm-ranlib.1*
c999855f 484%{_mandir}/man1/llvm-readobj.1*
f981d747 485%{_mandir}/man1/llvm-stress.1*
1628dc68 486%{_mandir}/man1/llvm-symbolizer.1*
a9beeab5 487%{_mandir}/man1/opt.1*
dd9350c7 488%{_mandir}/man1/tblgen.1*
bc88141a 489
8c514f23
JB
490%files libs
491%defattr(644,root,root,755)
c999855f 492%attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
11b6f380 493%attr(755,root,root) %{_libdir}/libLLVM-3.4.so
8c514f23 494
bc88141a
ER
495%files devel
496%defattr(644,root,root,755)
497%attr(755,root,root) %{_bindir}/llvm-config
8132e62b 498%{_libdir}/libLLVM*.a
1655c8b5 499%ifarch %{x8664}
0a8510f2 500%attr(755,root,root) %{_libdir}/BugpointPasses.so
19f21eee 501%attr(755,root,root) %{_libdir}/libLTO.so
8132e62b 502%{_libdir}/libLTO.a
1655c8b5 503%endif
8132e62b
JB
504%{_includedir}/llvm
505%{_includedir}/llvm-c
506%{_mandir}/man1/llvm-config.1*
bc88141a 507
9556f4c9
ER
508%files doc
509%defattr(644,root,root,755)
510%doc moredocs/examples moredocs/html
511
512%if %{with apidocs}
513%files apidocs
514%defattr(644,root,root,755)
515%doc apidoc/*
516%endif
517
d997b14b 518%files -n clang
bc88141a 519%defattr(644,root,root,755)
827664e9 520%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
dd9350c7 521%attr(755,root,root) %{_bindir}/c-index-test
8132e62b
JB
522%attr(755,root,root) %{_bindir}/clang
523%attr(755,root,root) %{_bindir}/clang++
dd9350c7 524%attr(755,root,root) %{_bindir}/clang-check
1628dc68 525%attr(755,root,root) %{_bindir}/clang-format
827664e9 526%attr(755,root,root) %{_bindir}/clang-tblgen
b3a27ca2 527%attr(755,root,root) %{_libdir}/libclang.so
5a7ac479
JB
528%dir %{_libdir}/clang
529%dir %{_libdir}/clang/%{version}
530%{_libdir}/clang/%{version}/include
531%if %{with rt}
532%{_libdir}/clang/%{version}/lib
533%endif
8132e62b 534%{_mandir}/man1/clang.1*
d997b14b
AM
535
536%files -n clang-analyzer
bc88141a 537%defattr(644,root,root,755)
d997b14b
AM
538%attr(755,root,root) %{_bindir}/scan-build
539%attr(755,root,root) %{_bindir}/scan-view
dd9350c7 540%{_mandir}/man1/scan-build.1*
ae49e501 541%dir %{_libdir}/clang-analyzer
d997b14b 542
9556f4c9
ER
543%dir %{_libdir}/clang-analyzer/scan-build
544%{_libdir}/clang-analyzer/scan-build/*.css
545%{_libdir}/clang-analyzer/scan-build/*.js
546%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
547%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
548
8132e62b
JB
549%dir %{_libdir}/clang-analyzer/scan-view
550%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
551%{_libdir}/clang-analyzer/scan-view/Resources
552%{_libdir}/clang-analyzer/scan-view/*.py[co]
553
9556f4c9
ER
554%files -n clang-devel
555%defattr(644,root,root,755)
8132e62b 556%{_libdir}/libclang*.a
9556f4c9
ER
557%{_includedir}/clang
558%{_includedir}/clang-c
559
560%files -n clang-doc
561%defattr(644,root,root,755)
8132e62b 562%doc tools/clang/docs/*.{css,html,png,txt}
9556f4c9
ER
563
564%if %{with apidocs}
565%files -n clang-apidocs
566%defattr(644,root,root,755)
567%doc clang-apidoc/*
568%endif
569
5a7ac479
JB
570%if %{with lldb}
571%files -n lldb
572%defattr(644,root,root,755)
573%attr(755,root,root) %{_bindir}/lldb
574%attr(755,root,root) %{_bindir}/lldb-platform
575%attr(755,root,root) %{_libdir}/liblldb.so
576
577%files -n lldb-devel
578%defattr(644,root,root,755)
579%{_libdir}/liblldb*.a
580%{_includedir}/lldb
581%endif
582
9556f4c9 583%if %{with ocaml}
d997b14b
AM
584%files ocaml
585%defattr(644,root,root,755)
11b6f380
JB
586%{_libdir}/ocaml/META.llvm*
587%attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
8132e62b
JB
588%{_libdir}/ocaml/llvm*.cma
589%{_libdir}/ocaml/llvm*.cmi
d997b14b
AM
590
591%files ocaml-devel
592%defattr(644,root,root,755)
bc8a0b58 593%{_libdir}/libllvm*.a
8132e62b
JB
594%{_libdir}/ocaml/libLLVM*.a
595%{_libdir}/ocaml/libllvm*.a
596%{_libdir}/ocaml/llvm*.a
597%{_libdir}/ocaml/llvm*.cmx*
598%{_libdir}/ocaml/llvm*.mli
9556f4c9
ER
599
600%files ocaml-doc
601%defattr(644,root,root,755)
602%doc moredocs/ocamldoc/html/*
603%endif
This page took 0.236669 seconds and 4 git commands to generate.