]> git.pld-linux.org Git - packages/llvm.git/blame - llvm.spec
- updated to 3.4.1
[packages/llvm.git] / llvm.spec
CommitLineData
bc88141a 1#
d015c902
PS
2# TODO:
3# - fix include search path to support libdir/gcc/platform/version/include.
4# current error: /usr/include/wchar.h:39:11: fatal error: 'stdarg.h' file not found# include <stdarg.h>
5#
9556f4c9
ER
6# Conditional build:
7%bcond_without ocaml # ocaml binding
8132e62b 8%bcond_with apidocs # The doxygen docs are HUGE, so they are not built by default.
dd9350c7 9%bcond_without man # man pages
8132e62b 10%bcond_with tests # run tests
9556f4c9
ER
11
12%ifarch s390 s390x sparc64
13# No ocaml on these arches
14%undefine with_ocaml
15%endif
16
aa11c230 17Summary: The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
2326a99f 18Summary(pl.UTF-8): Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
aa11c230 19Name: llvm
11b6f380 20Version: 3.4.1
1628dc68 21Release: 1
aa11c230 22License: University of Illinois/NCSA Open Source License
23Group: Development/Languages
dd9350c7 24#Source0Download: http://llvm.org/releases/download.html
f981d747 25Source0: http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
11b6f380 26# Source0-md5: b90697f4de35563ad6c35924defa8dd1
c999855f 27Source1: http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.gz
11b6f380 28# Source1-md5: c64fdc567383211c9ac212d6f7b69263
ebde279d 29Patch0: %{name}-config.patch
d997b14b 30# Data files should be installed with timestamps preserved
ebde279d
JB
31Patch1: %{name}-2.6-timestamp.patch
32Patch2: %{name}-pld.patch
11b6f380 33Patch3: %{name}-destdir.patch
2326a99f 34URL: http://llvm.org/
ebde279d
JB
35BuildRequires: autoconf >= 2.60
36BuildRequires: automake >= 1:1.9.6
bc88141a 37BuildRequires: bash
d997b14b 38BuildRequires: bison
d997b14b 39BuildRequires: flex
dd9350c7
JB
40BuildRequires: gcc >= 5:3.4
41# gcc4 might be installed, but not current __cc
42%if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
43BuildRequires: __cc >= 3.4
9556f4c9 44%endif
d997b14b 45BuildRequires: groff
bc88141a 46BuildRequires: libltdl-devel
ebde279d 47BuildRequires: libtool >= 2:1.5.22
d997b14b
AM
48BuildRequires: libstdc++-devel >= 5:3.4
49BuildRequires: ocaml-ocamldoc
8132e62b 50BuildRequires: perl-base >= 1:5.6
8c156e7d 51BuildRequires: perl-tools-pod
52BuildRequires: rpm-pythonprov
dd9350c7
JB
53%{?with_man:BuildRequires: sphinx-pdg}
54%if %{with apidocs}
55BuildRequires: doxygen
56BuildRequires: graphviz
57%endif
58%if %{with tests}
59BuildRequires: dejagnu
60BuildRequires: python
61BuildRequires: tcl-devel
356a0bbd 62%endif
8c514f23 63Requires: %{name}-libs = %{version}-%{release}
9556f4c9
ER
64# LLVM is not supported on PPC64
65# http://llvm.org/bugs/show_bug.cgi?id=3729
66ExcludeArch: ppc64
aa11c230 67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
356a0bbd 69%define _sysconfdir /etc/%{name}
021b3c3d 70
9556f4c9
ER
71%define specflags_ppc -fno-var-tracking-assignments
72
6832a5c5
ER
73# strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
74%define _noautostrip .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
75
aa11c230 76%description
77LLVM is a compiler infrastructure designed for compile-time,
78link-time, runtime, and idle-time optimization of programs from
79arbitrary programming languages. LLVM is written in C++ and has been
80developed since 2000 at the University of Illinois and Apple. It
621ec11f
JB
81currently supports compilation of C and C++ programs using clang
82frontend.
aa11c230 83
2326a99f
JB
84%description -l pl.UTF-8
85LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
86czasu kompilowania, linkowania, działania i bezczynności programów w
87dowolnych językach programowania. Jest napisana w C++, rozwijana od
88roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
621ec11f 89kompilację programów w C i C++ przy użyciu frontendu clang.
2326a99f 90
8c514f23
JB
91%package libs
92Summary: LLVM shared library
93Summary(pl.UTF-8): Biblioteka współdzielona LLVM-a
94Group: Libraries
95Conflicts: llvm < 3.2
96
97%description libs
98LLVM shared library.
99
100%description libs -l pl.UTF-8
101Biblioteka współdzielona LLVM-a.
102
bc88141a 103%package devel
621ec11f
JB
104Summary: Static libraries and header files for LLVM
105Summary(pl.UTF-8): Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
bc88141a 106Group: Development/Languages
8c514f23 107Requires: %{name}-libs = %{version}-%{release}
bc88141a
ER
108Requires: libstdc++-devel >= 6:3.4
109
110%description devel
621ec11f
JB
111This package contains static libraries and header files needed to
112develop new native programs that use the LLVM infrastructure.
113
114%description devel -l pl.UTF-8
115Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
116potrzebne do tworzenia nowych programów natywnych wykorzystujących
117infrastrukturę LLVM.
bc88141a 118
9556f4c9
ER
119%package doc
120Summary: Documentation for LLVM
621ec11f 121Summary(pl.UTF-8): Dokumentacja do LLVM-a
9556f4c9
ER
122Group: Documentation
123# does not require base
bc88141a 124
9556f4c9
ER
125%description doc
126Documentation for the LLVM compiler infrastructure.
bc88141a 127
621ec11f
JB
128%description doc -l pl.UTF-8
129Dokumentacja do infrastruktury kompilatorów LLVM.
130
9556f4c9
ER
131%package apidocs
132Summary: API documentation for LLVM
621ec11f 133Summary(pl.UTF-8): Dokumentacja API LLVM-a
9556f4c9
ER
134Group: Development/Languages
135Requires: %{name}-doc = %{version}-%{release}
bc88141a 136
9556f4c9
ER
137%description apidocs
138API documentation for the LLVM compiler infrastructure.
bc88141a 139
621ec11f
JB
140%description apidocs -l pl.UTF-8
141Dokumentacja API infrastruktury kompilatorów LLVM.
142
d997b14b
AM
143%package -n clang
144Summary: A C language family frontend for LLVM
621ec11f 145Summary(pl.UTF-8): Frontend LLVM-a do języków z rodziny C
d997b14b
AM
146License: NCSA
147Group: Development/Languages
8c514f23 148Requires: %{name} = %{version}-%{release}
d997b14b
AM
149
150%description -n clang
151clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
152of a crane or goose. 3. C-language family front-end toolkit.
153
154The goal of the Clang project is to create a new C, C++, Objective C
155and Objective C++ front-end for the LLVM compiler. Its tools are built
156as libraries and designed to be loosely-coupled and extendable.
157
621ec11f
JB
158%description -n clang -l pl.UTF-8
159clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
160piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
161z rodziny C.
162
163Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
164LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
165budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
166i rozszerzaniu.
167
d997b14b
AM
168%package -n clang-analyzer
169Summary: A source code analysis framework
621ec11f 170Summary(pl.UTF-8): Szkielet do analizy kodu źródłowego
d997b14b
AM
171License: NCSA
172Group: Development/Languages
173Requires: clang = %{version}-%{release}
174# not picked up automatically since files are currently not instaled
175# in standard Python hierarchies yet
176Requires: python
177
178%description -n clang-analyzer
179The Clang Static Analyzer consists of both a source code analysis
180framework and a standalone tool that finds bugs in C and Objective-C
181programs. The standalone tool is invoked from the command-line, and is
182intended to run in tandem with a build of a project or code base.
183
621ec11f
JB
184%description -n clang-analyzer -l pl.UTF-8
185Clang Static Analyzer składa się ze szkieletu do analizy kodu
186źródłowego oraz samodzielnego narzędzia znajdującego błędy w
187programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
188myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
189
9556f4c9 190%package -n clang-devel
621ec11f
JB
191Summary: Header files for Clang
192Summary(pl.UTF-8): Pliki nagłówkowe Clanga
9556f4c9 193Group: Development/Languages
8c514f23 194Requires: %{name}-devel = %{version}-%{release}
9556f4c9
ER
195Requires: clang = %{version}-%{release}
196
197%description -n clang-devel
198This package contains header files for the Clang compiler.
199
621ec11f
JB
200%description -n clang-devel -l pl.UTF-8
201Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
202
9556f4c9
ER
203%package -n clang-doc
204Summary: Documentation for Clang
621ec11f 205Summary(pl.UTF-8): Dokumentacja do Clanga
9556f4c9
ER
206Group: Documentation
207Requires: %{name} = %{version}-%{release}
208
209%description -n clang-doc
210Documentation for the Clang compiler front-end.
211
621ec11f
JB
212%description -n clang-doc -l pl.UTF-8
213Dokumentacja do frontendu kompilatora Clang.
214
9556f4c9
ER
215%package -n clang-apidocs
216Summary: API documentation for Clang
621ec11f 217Summary(pl.UTF-8): Dokumentacja API Clanga
9556f4c9
ER
218Group: Development/Languages
219Requires: clang-doc = %{version}-%{release}
220
221%description -n clang-apidocs
222API documentation for the Clang compiler.
223
621ec11f
JB
224%description -n clang-apidocs -l pl.UTF-8
225Dokumentacja API kompilatora Clang.
226
9556f4c9
ER
227%package ocaml
228Summary: OCaml binding for LLVM
621ec11f
JB
229Summary(pl.UTF-8): Wiązanie OCamla do LLVM-a
230Group: Libraries
9556f4c9
ER
231Requires: %{name} = %{version}-%{release}
232%requires_eq ocaml-runtime
233
621ec11f 234%description ocaml
9556f4c9
ER
235OCaml binding for LLVM.
236
621ec11f
JB
237%description ocaml -l pl.UTF-8
238Wiązanie OCamla do LLVM-a.
239
9556f4c9 240%package ocaml-devel
621ec11f
JB
241Summary: Development files for LLVM OCaml binding
242Summary(pl.UTF-8): Pliki programistyczne wiązania OCamla do LLVM-a
9556f4c9
ER
243Group: Development/Libraries
244Requires: %{name}-devel = %{version}-%{release}
245Requires: %{name}-ocaml = %{version}-%{release}
246
247%description ocaml-devel
248The llvm-ocaml-devel package contains libraries and signature files
621ec11f
JB
249for developing applications that use llvm-ocaml binding.
250
251%description ocaml-devel -l pl.UTF-8
252Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
253wykorzystujących wiązanie llvm-ocaml.
254
9556f4c9
ER
255%package ocaml-doc
256Summary: Documentation for LLVM's OCaml binding
621ec11f 257Summary(pl.UTF-8): Dokumentacja wiązania OCamla do LLVM-a
9556f4c9
ER
258Group: Documentation
259Requires: %{name}-ocaml = %{version}-%{release}
260
261%description ocaml-doc
262HTML documentation for LLVM's OCaml binding.
263
621ec11f
JB
264%description ocaml-doc -l pl.UTF-8
265Dokumentacja HTML wiązania OCamla do LLVM-a.
266
aa11c230 267%prep
c999855f
AM
268%setup -q -a1 -n %{name}-%{version}.src
269mv cfe-%{version}.src tools/clang
ebde279d
JB
270%patch0 -p1
271%patch1 -p1
272%patch2 -p1
11b6f380 273%patch3 -p1
ce9cc204 274
19f21eee 275# configure does not properly specify libdir
3a1d4bb3 276%{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
9206c2b1
JB
277# clang resources
278%{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
279%{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
19f21eee 280
bacc8b96
ER
281grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
282 s,^#!.*bin/env python,#!%{__python},
283 s,^#!.*bin/env perl,#!%{__perl},
284}'
285
9556f4c9 286install -d obj
aa11c230 287
288%build
ebde279d
JB
289cd autoconf
290%{__aclocal} -I m4
291%{__autoconf} -o ../configure configure.ac
292cd ..
293%{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
294
d997b14b 295# Disabling assertions now, rec. by pure and needed for OpenGTL
9556f4c9 296# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
d997b14b 297#
bc88141a 298# bash specific 'test a < b'
9556f4c9 299cd obj
d997b14b 300bash ../%configure \
bc88141a 301 --datadir=%{_datadir}/%{name}-%{version} \
632f3287 302 --disable-assertions \
d997b14b 303%ifarch %{ix86}
632f3287 304 --disable-pic \
9556f4c9 305%endif
632f3287
JB
306 --disable-static \
307 --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
308 --enable-debug-runtime \
9556f4c9
ER
309%if %{with apidocs}
310 --enable-doxygen \
d997b14b 311%endif
25189042 312 --enable-experimental-targets=R600 \
bc88141a 313 --enable-jit \
aa11c230 314 --enable-optimized \
bc88141a
ER
315 --enable-shared \
316 --with-pic
317
d997b14b 318%{__make} \
1628dc68 319 VERBOSE=1 \
0a0b7076 320 REQUIRES_RTTI=1 \
d997b14b 321 OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
aa11c230 322
827664e9 323%if %{with tests}
9556f4c9
ER
324%{__make} check 2>&1 | tee llvm-testlog.txt
325%{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
326%endif
327
dd9350c7
JB
328cd ..
329
330%if %{with man}
331%{__make} -C docs -f Makefile.sphinx man
332%endif
333
aa11c230 334%install
335rm -rf $RPM_BUILD_ROOT
9556f4c9 336%{__make} -C obj -j1 install \
d997b14b 337 PROJ_docsdir=/moredocs \
aa11c230 338 DESTDIR=$RPM_BUILD_ROOT
339
d997b14b 340# Static analyzer not installed by default:
9556f4c9
ER
341# http://clang-analyzer.llvm.org/installation#OtherPlatforms
342install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b
AM
343# create launchers
344for f in scan-{build,view}; do
9556f4c9
ER
345 ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
346 cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
d997b14b 347done
dd9350c7 348%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
8132e62b
JB
349%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
350%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
351%py_postclean %{_libdir}/clang-analyzer/scan-view
d997b14b 352
dd9350c7
JB
353%if %{with man}
354install -d $RPM_BUILD_ROOT%{_mandir}/man1
355cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
356# these tools are not installed
357%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
358%endif
359
d997b14b 360# Move documentation back to build directory
d997b14b
AM
361rm -rf moredocs
362mv $RPM_BUILD_ROOT/moredocs .
ebde279d
JB
363%{__rm} -v moredocs/*.tar.gz
364%{__rm} -v moredocs/ocamldoc/html/*.tar.gz
9556f4c9
ER
365
366# and separate the apidoc
367%if %{with apidocs}
368rm -rf apidoc clang-apidoc
369mv moredocs/html/doxygen apidoc
370cp -a tools/clang/docs/doxygen/html clang-apidoc
371%endif
d997b14b
AM
372
373# And prepare Clang documentation
d997b14b 374rm -rf clang-docs
9556f4c9 375install -d clang-docs
827664e9 376for f in LICENSE.TXT NOTES.txt README.txt; do
9556f4c9 377 ln tools/clang/$f clang-docs
d997b14b 378done
021b3c3d 379
6832a5c5 380# Get rid of erroneously installed example files.
ebde279d 381%{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
6832a5c5 382
11b6f380
JB
383echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
384# llvm-prof has been removed before LLVM 3.4
385%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/llvm-prof.1
386
d997b14b
AM
387# remove documentation makefiles:
388# they require the build directory to work
9556f4c9
ER
389rm -rf moredocs/examples
390cp -a examples moredocs/examples
391find moredocs/examples -name Makefile | xargs -0r rm -f
6832a5c5 392
aa11c230 393%clean
394rm -rf $RPM_BUILD_ROOT
395
8c514f23
JB
396%post libs -p /sbin/ldconfig
397%postun libs -p /sbin/ldconfig
aa11c230 398
399%files
400%defattr(644,root,root,755)
8132e62b 401%doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
a9beeab5 402%attr(755,root,root) %{_bindir}/bugpoint
a9beeab5
JB
403%attr(755,root,root) %{_bindir}/llc
404%attr(755,root,root) %{_bindir}/lli
11b6f380 405%attr(755,root,root) %{_bindir}/lli-child-target
8132e62b
JB
406%attr(755,root,root) %{_bindir}/llvm-ar
407%attr(755,root,root) %{_bindir}/llvm-as
408%attr(755,root,root) %{_bindir}/llvm-bcanalyzer
827664e9 409%attr(755,root,root) %{_bindir}/llvm-cov
8132e62b
JB
410%attr(755,root,root) %{_bindir}/llvm-diff
411%attr(755,root,root) %{_bindir}/llvm-dis
827664e9 412%attr(755,root,root) %{_bindir}/llvm-dwarfdump
8132e62b 413%attr(755,root,root) %{_bindir}/llvm-extract
8132e62b
JB
414%attr(755,root,root) %{_bindir}/llvm-link
415%attr(755,root,root) %{_bindir}/llvm-mc
dd9350c7 416%attr(755,root,root) %{_bindir}/llvm-mcmarkup
8132e62b
JB
417%attr(755,root,root) %{_bindir}/llvm-nm
418%attr(755,root,root) %{_bindir}/llvm-objdump
8132e62b 419%attr(755,root,root) %{_bindir}/llvm-ranlib
f981d747 420%attr(755,root,root) %{_bindir}/llvm-readobj
827664e9
PS
421%attr(755,root,root) %{_bindir}/llvm-rtdyld
422%attr(755,root,root) %{_bindir}/llvm-size
f981d747 423%attr(755,root,root) %{_bindir}/llvm-stress
1628dc68 424%attr(755,root,root) %{_bindir}/llvm-symbolizer
827664e9 425%attr(755,root,root) %{_bindir}/llvm-tblgen
a7973f21 426%attr(755,root,root) %{_bindir}/macho-dump
8132e62b 427%attr(755,root,root) %{_bindir}/opt
a9beeab5 428%{_mandir}/man1/bugpoint.1*
a7973f21 429%{_mandir}/man1/lit.1*
a9beeab5
JB
430%{_mandir}/man1/llc.1*
431%{_mandir}/man1/lli.1*
8132e62b
JB
432%{_mandir}/man1/llvm-ar.1*
433%{_mandir}/man1/llvm-as.1*
434%{_mandir}/man1/llvm-bcanalyzer.1*
f981d747 435%{_mandir}/man1/llvm-cov.1*
8132e62b
JB
436%{_mandir}/man1/llvm-diff.1*
437%{_mandir}/man1/llvm-dis.1*
438%{_mandir}/man1/llvm-extract.1*
8132e62b
JB
439%{_mandir}/man1/llvm-link.1*
440%{_mandir}/man1/llvm-nm.1*
8132e62b 441%{_mandir}/man1/llvm-ranlib.1*
c999855f 442%{_mandir}/man1/llvm-readobj.1*
f981d747 443%{_mandir}/man1/llvm-stress.1*
1628dc68 444%{_mandir}/man1/llvm-symbolizer.1*
a9beeab5 445%{_mandir}/man1/opt.1*
dd9350c7 446%{_mandir}/man1/tblgen.1*
bc88141a 447
8c514f23
JB
448%files libs
449%defattr(644,root,root,755)
c999855f 450%attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
11b6f380 451%attr(755,root,root) %{_libdir}/libLLVM-3.4.so
8c514f23 452
bc88141a
ER
453%files devel
454%defattr(644,root,root,755)
455%attr(755,root,root) %{_bindir}/llvm-config
8132e62b 456%{_libdir}/libLLVM*.a
1655c8b5 457%ifarch %{x8664}
0a8510f2 458%attr(755,root,root) %{_libdir}/BugpointPasses.so
19f21eee 459%attr(755,root,root) %{_libdir}/libLTO.so
8132e62b 460%{_libdir}/libLTO.a
1655c8b5 461%endif
8132e62b
JB
462%{_includedir}/llvm
463%{_includedir}/llvm-c
464%{_mandir}/man1/llvm-config.1*
bc88141a 465
9556f4c9
ER
466%files doc
467%defattr(644,root,root,755)
468%doc moredocs/examples moredocs/html
469
470%if %{with apidocs}
471%files apidocs
472%defattr(644,root,root,755)
473%doc apidoc/*
474%endif
475
d997b14b 476%files -n clang
bc88141a 477%defattr(644,root,root,755)
827664e9 478%doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
dd9350c7 479%attr(755,root,root) %{_bindir}/c-index-test
8132e62b
JB
480%attr(755,root,root) %{_bindir}/clang
481%attr(755,root,root) %{_bindir}/clang++
dd9350c7 482%attr(755,root,root) %{_bindir}/clang-check
1628dc68 483%attr(755,root,root) %{_bindir}/clang-format
827664e9 484%attr(755,root,root) %{_bindir}/clang-tblgen
b3a27ca2 485%attr(755,root,root) %{_libdir}/libclang.so
493e5485 486%{_libdir}/clang
8132e62b 487%{_mandir}/man1/clang.1*
d997b14b
AM
488
489%files -n clang-analyzer
bc88141a 490%defattr(644,root,root,755)
d997b14b
AM
491%attr(755,root,root) %{_bindir}/scan-build
492%attr(755,root,root) %{_bindir}/scan-view
dd9350c7 493%{_mandir}/man1/scan-build.1*
ae49e501 494%dir %{_libdir}/clang-analyzer
d997b14b 495
9556f4c9
ER
496%dir %{_libdir}/clang-analyzer/scan-build
497%{_libdir}/clang-analyzer/scan-build/*.css
498%{_libdir}/clang-analyzer/scan-build/*.js
499%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
500%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
501
8132e62b
JB
502%dir %{_libdir}/clang-analyzer/scan-view
503%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
504%{_libdir}/clang-analyzer/scan-view/Resources
505%{_libdir}/clang-analyzer/scan-view/*.py[co]
506
9556f4c9
ER
507%files -n clang-devel
508%defattr(644,root,root,755)
8132e62b 509%{_libdir}/libclang*.a
9556f4c9
ER
510%{_includedir}/clang
511%{_includedir}/clang-c
512
513%files -n clang-doc
514%defattr(644,root,root,755)
8132e62b 515%doc tools/clang/docs/*.{css,html,png,txt}
9556f4c9
ER
516
517%if %{with apidocs}
518%files -n clang-apidocs
519%defattr(644,root,root,755)
520%doc clang-apidoc/*
521%endif
522
523%if %{with ocaml}
d997b14b
AM
524%files ocaml
525%defattr(644,root,root,755)
11b6f380
JB
526%{_libdir}/ocaml/META.llvm*
527%attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
8132e62b
JB
528%{_libdir}/ocaml/llvm*.cma
529%{_libdir}/ocaml/llvm*.cmi
d997b14b
AM
530
531%files ocaml-devel
532%defattr(644,root,root,755)
bc8a0b58 533%{_libdir}/libllvm*.a
8132e62b
JB
534%{_libdir}/ocaml/libLLVM*.a
535%{_libdir}/ocaml/libllvm*.a
536%{_libdir}/ocaml/llvm*.a
537%{_libdir}/ocaml/llvm*.cmx*
538%{_libdir}/ocaml/llvm*.mli
9556f4c9
ER
539
540%files ocaml-doc
541%defattr(644,root,root,755)
542%doc moredocs/ocamldoc/html/*
543%endif
This page took 0.156311 seconds and 4 git commands to generate.