]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
up to 1.2.1
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2 2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
f2d911f2 3# - apply patches to libprojectM.spec and use
6b78beb2
ER
4# - package for kde4 stuff (or nuke them):
5# /usr/share/kde4/services/clementine-feed.protocol
6# /usr/share/kde4/services/clementine-itms.protocol
7# /usr/share/kde4/services/clementine-itpc.protocol
8# /usr/share/kde4/services/clementine-zune.protocol
2c687024 9#
10# Conditional build:
c6f8dd12 11%bcond_without static_sqlite # with static sqlite3
3834eb29 12%bcond_with static_projectm # with static projectM
aa506418 13%bcond_with libspotify # build with system libspotify instead of downloading blob
58fa3d37 14%bcond_without tests # build without tests
0b056df0 15
064e709c 16%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 17Summary: A music player and library organiser
df3c0ac1 18Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 19Name: clementine
1aea93ea
ER
20Version: 1.2.1
21Release: 1
bf1e6952
ER
22License: GPL v3 and GPL v2+
23Group: Applications/Multimedia
bf272879 24Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
1aea93ea 25# Source0-md5: 5d079e12f5925845cc7e38ce2f4a1e20
f823a794 26Patch0: desktop-install.patch
10ecf727 27Patch1: unbundle-po.patch
68fe38b0 28Patch3: %{name}-dt_categories.patch
5fe14c9e 29Patch4: %{name}-mygpo.patch
58fa3d37 30Patch5: %{name}-desktop.patch
1aea93ea 31URL: http://www.clementine-player.org/
64d9867e
ER
32BuildRequires: QtCore-devel >= %{qtver}
33BuildRequires: QtDBus-devel >= %{qtver}
34BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 35BuildRequires: QtIOCompressor-devel
64d9867e
ER
36BuildRequires: QtNetwork-devel >= %{qtver}
37BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 38BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
39BuildRequires: QtSql-devel >= %{qtver}
40%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
41BuildRequires: QtXml-devel >= %{qtver}
7dce7848 42BuildRequires: QtXmlPatterns-devel >= %{qtver}
bf1e6952 43BuildRequires: boost-devel
7279ad3f 44BuildRequires: cmake >= 2.6
58fa3d37 45BuildRequires: desktop-file-utils
f823a794 46#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 47BuildRequires: gettext-devel
f823a794 48%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 49BuildRequires: glib2-devel
dbbdd85a
JK
50BuildRequires: gstreamer0.10-devel
51BuildRequires: gstreamer0.10-plugins-base-devel
bf1e6952 52BuildRequires: gtest-devel
aa506418
ER
53BuildRequires: libcdio-devel
54BuildRequires: libchromaprint-devel
8f83a8c0 55BuildRequires: libgpod-devel >= 0.7.92
fbe6cce5 56BuildRequires: libimobiledevice-devel >= 1.1.5
2eedc3b1 57BuildRequires: libindicate-qt-devel
e0ba0da9 58BuildRequires: liblastfm-devel >= 0.3.3
8f83a8c0 59BuildRequires: libmtp-devel
1aea93ea 60BuildRequires: libmygpo-qt-devel >= 1.0.7
8f83a8c0 61BuildRequires: libplist-devel
f823a794 62%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 63BuildRequires: libqxt-devel
aa506418 64%{?with_libspotify:BuildRequires: libspotify-devel >= 12.1.45}
8f83a8c0 65BuildRequires: libxml2-devel
75ec0859 66BuildRequires: pkgconfig
2eedc3b1 67BuildRequires: pkgconfig
e0ba0da9 68BuildRequires: protobuf-devel
49968d1b 69BuildRequires: qca-devel
e0ba0da9 70BuildRequires: qjson-devel
64d9867e 71BuildRequires: qt4-build >= %{qtver}
b6199a83 72BuildRequires: qt4-linguist
73BuildRequires: qt4-qmake
7aaa97de 74BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 75BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 76BuildRequires: sed >= 4.0
6f798db9 77BuildRequires: sparsehash-devel
742e4e0a 78%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 79BuildRequires: taglib-devel >= 1.6
8f83a8c0 80BuildRequires: usbmuxd-devel
726826ed 81Requires(post,postun): desktop-file-utils
23941661
AF
82Requires(post,postun): gtk-update-icon-cache
83Requires(post,postun): hicolor-icon-theme
acb98f48 84Requires: QtSingleApplication >= 2.6-4
64d9867e 85%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
dbbdd85a 86Requires: gstreamer0.10-audio-effects-base
862961b4 87Requires: gstreamer0.10-mad
cb052d79 88Suggests: gstreamer0.10-flac
f2d911f2
ER
89# while we do not link (yet), we use datafiles
90Requires: libprojectM
bf1e6952
ER
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
f2d911f2
ER
93# see libprojectM.spec for explanation
94%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
95
bf1e6952
ER
96%description
97Clementine is a modern music player and library organiser. It is
98largely a port of Amarok 1.4, with some features rewritten to take
99advantage of Qt4.
100
df3c0ac1
ZU
101%description -l hu.UTF-8
102Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
103az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
104a Qt4 előnyeit.
105
bf1e6952 106%prep
862961b4 107%setup -q
f2d911f2 108%patch0 -p1
10ecf727 109%patch1 -p1
68fe38b0 110%patch3 -p1
5fe14c9e 111%patch4 -p1
58fa3d37 112%patch5 -p1
bf1e6952 113
1aea93ea
ER
114# Remove all 3rdparty libraries except:
115# - universalchardet - not available as a separate library.
116# - libprojectM - ?
117# - sah2 - ?
118# - libechonest - ?
119# - qocoa - ?
120# - qsqlite - ?
5fe14c9e
ER
121mv 3rdparty 3rdparty.keep
122install -d 3rdparty
1aea93ea 123mv 3rdparty.keep/{sha2,libechonest,qocoa%{?with_static_sqlite:,qsqlite}%{?with_static_projectm:,libprojectM}} 3rdparty
bf1e6952 124
7279ad3f 125# Don't build tests. They require gmock
f2d911f2 126sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
ea86e9d9
BZ
127# remove -Wall
128sed -i -e 's/-Wall//' src/CMakeLists.txt
064e709c
JR
129# ...and -Werror
130sed -i -e 's/-Werror//' src/CMakeLists.txt
bf1e6952
ER
131
132%build
133install -d build
7aaa97de 134install -d build/src/translations
bf1e6952 135cd build
6b78beb2
ER
136# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
137CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
88ca6f4b 138%cmake \
f2d911f2 139 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794 140 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
862961b4 141 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
f823a794
ER
142 -DUSE_SYSTEM_QXT=ON \
143 -DUSE_SYSTEM_PROJECTM=ON \
742e4e0a 144 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 145 ..
bf1e6952
ER
146%{__make}
147
58fa3d37
ER
148%if %{with tests}
149desktop-file-validate ../dist/%{name}.desktop
150%endif
151
bf1e6952
ER
152%install
153rm -rf $RPM_BUILD_ROOT
154%{__make} -C build install \
155 DESTDIR=$RPM_BUILD_ROOT
156
f823a794
ER
157rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
158
dbbdd85a
JK
159# not in our glibc?
160rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
161
10ecf727
ER
162%find_lang %{name} --with-qm
163
23f69c7b 164install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
58fa3d37
ER
165cp -p dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
166cp -p dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
23f69c7b 167
bf1e6952
ER
168%clean
169rm -rf $RPM_BUILD_ROOT
170
726826ed
ER
171%post
172%update_desktop_database_post
2eedc3b1 173%update_icon_cache hicolor
726826ed
ER
174
175%postun
176%update_desktop_database_postun
2eedc3b1 177%update_icon_cache hicolor
726826ed 178
10ecf727 179%files -f %{name}.lang
bf1e6952 180%defattr(644,root,root,755)
e0ba0da9 181%doc Changelog
bf1e6952 182%attr(755,root,root) %{_bindir}/clementine
dbbdd85a 183%attr(755,root,root) %{_bindir}/clementine-tagreader
bf1e6952 184%{_desktopdir}/clementine.desktop
7279ad3f 185%{_pixmapsdir}/clementine.png
23f69c7b
BZ
186%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
187%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.051097 seconds and 4 git commands to generate.