]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- up to 0.7 rc1
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2
ER
2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3# -- Building engines: gst
4# -- Skipping engines: vlc xine qt-phonon
5# The following engines are NOT supported by clementine developers:
6# vlc xine qt-phonon
7# - apply patches to libprojectM.spec and use
0b056df0 8# - make engines pluggable not statically linked, then could enable the bconds
2c687024 9#
10# Conditional build:
0b056df0
ER
11%bcond_with engine_xine # without xine engine
12%bcond_with engine_vlc # without vlc engine
13%bcond_with engine_qt_phonon # without qt-phonon engine
2c687024 14%bcond_without engine_gstreamer # without gstreamer engine
c6f8dd12 15%bcond_without static_sqlite # with static sqlite3
aca708d9 16%bcond_with static_projectm # with static projectM
0b056df0 17
d8982c6f 18%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 19Summary: A music player and library organiser
df3c0ac1 20Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 21Name: clementine
f9288316
BZ
22Version: 0.7
23Release: 0.rc1.1
bf1e6952
ER
24License: GPL v3 and GPL v2+
25Group: Applications/Multimedia
f823a794 26URL: http://www.clementine-player.org/
f9288316
BZ
27Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}rc1.tar.gz
28# Source0-md5: a13a226975e12b425606db99a74d8424
f823a794 29Patch0: desktop-install.patch
10ecf727 30Patch1: unbundle-po.patch
64d9867e
ER
31BuildRequires: QtCore-devel >= %{qtver}
32BuildRequires: QtDBus-devel >= %{qtver}
33BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 34BuildRequires: QtIOCompressor-devel
64d9867e
ER
35BuildRequires: QtNetwork-devel >= %{qtver}
36BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 37BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
38BuildRequires: QtSql-devel >= %{qtver}
39%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
40BuildRequires: QtXml-devel >= %{qtver}
bf1e6952 41BuildRequires: boost-devel
7279ad3f 42BuildRequires: cmake >= 2.6
f823a794 43#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 44BuildRequires: gettext-devel
f823a794 45%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 46BuildRequires: glib2-devel
aca708d9 47%{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
bf1e6952 48BuildRequires: gtest-devel
8f83a8c0
ER
49BuildRequires: libgpod-devel >= 0.7.92
50BuildRequires: libimobiledevice-devel
2eedc3b1 51BuildRequires: libindicate-qt-devel
bf1e6952 52BuildRequires: liblastfm-devel
8f83a8c0 53BuildRequires: libmtp-devel
8f83a8c0 54BuildRequires: libplist-devel
f823a794 55%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 56BuildRequires: libqxt-devel
8f83a8c0 57BuildRequires: libxml2-devel
aca708d9 58%{?with_engine_phonon:BuildRequires: phonon-devel}
75ec0859 59BuildRequires: pkgconfig
2eedc3b1 60BuildRequires: pkgconfig
64d9867e 61BuildRequires: qt4-build >= %{qtver}
b6199a83 62BuildRequires: qt4-linguist
63BuildRequires: qt4-qmake
7aaa97de 64BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 65BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 66BuildRequires: sed >= 4.0
742e4e0a 67%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 68BuildRequires: taglib-devel >= 1.6
8f83a8c0 69BuildRequires: usbmuxd-devel
aca708d9
ER
70%{?with_engine_vlc:BuildRequires: vlc-devel}
71%{?with_engine_xine:BuildRequires: xine-lib-devel}
726826ed 72Requires(post,postun): desktop-file-utils
23941661
AF
73Requires(post,postun): gtk-update-icon-cache
74Requires(post,postun): hicolor-icon-theme
acb98f48 75Requires: QtSingleApplication >= 2.6-4
64d9867e 76%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
4282eb18 77Requires: gstreamer-audio-effects-base
f2d911f2
ER
78# while we do not link (yet), we use datafiles
79Requires: libprojectM
bf1e6952
ER
80BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
f2d911f2
ER
82# see libprojectM.spec for explanation
83%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
84
bf1e6952
ER
85%description
86Clementine is a modern music player and library organiser. It is
87largely a port of Amarok 1.4, with some features rewritten to take
88advantage of Qt4.
89
df3c0ac1
ZU
90%description -l hu.UTF-8
91Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
92az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
93a Qt4 előnyeit.
94
bf1e6952 95%prep
f9288316 96%setup -q -n %{name}-%{version}rc1
f2d911f2 97%patch0 -p1
10ecf727 98%patch1 -p1
bf1e6952
ER
99
100# We already don't use these but just to make sure
f2d911f2 101rm -rf 3rdparty/gmock
742e4e0a 102%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
103rm -rf 3rdparty/qtsingleapplication
104rm -rf 3rdparty/qxt
105rm -rf 3rdparty/qtiocompressor
aca708d9 106%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 107
7279ad3f 108# Don't build tests. They require gmock
f2d911f2 109sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
110
111%build
112install -d build
7aaa97de 113install -d build/src/translations
bf1e6952 114cd build
88ca6f4b 115%cmake \
f2d911f2 116 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794
ER
117 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
118 -DUSE_SYSTEM_QXT=ON \
119 -DUSE_SYSTEM_PROJECTM=ON \
2c687024 120 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
121 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
122 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 123 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
742e4e0a 124 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 125 ..
bf1e6952
ER
126%{__make}
127
128%install
129rm -rf $RPM_BUILD_ROOT
130%{__make} -C build install \
131 DESTDIR=$RPM_BUILD_ROOT
132
f823a794
ER
133rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
134
10ecf727
ER
135%find_lang %{name} --with-qm
136
bf1e6952
ER
137%clean
138rm -rf $RPM_BUILD_ROOT
139
726826ed
ER
140%post
141%update_desktop_database_post
2eedc3b1 142%update_icon_cache hicolor
726826ed
ER
143
144%postun
145%update_desktop_database_postun
2eedc3b1 146%update_icon_cache hicolor
726826ed 147
10ecf727 148%files -f %{name}.lang
bf1e6952
ER
149%defattr(644,root,root,755)
150%doc Changelog TODO
151%attr(755,root,root) %{_bindir}/clementine
152%{_desktopdir}/clementine.desktop
7279ad3f 153%{_pixmapsdir}/clementine.png
This page took 0.098897 seconds and 4 git commands to generate.