]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- QtSingleApplication runtime dep as well
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
2c687024 2# - add missing BRs
f2d911f2
ER
3# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4# -- Building engines: gst
5# -- Skipping engines: vlc xine qt-phonon
6# The following engines are NOT supported by clementine developers:
7# vlc xine qt-phonon
8# - apply patches to libprojectM.spec and use
0b056df0 9# - make engines pluggable not statically linked, then could enable the bconds
2c687024 10#
11# Conditional build:
0b056df0
ER
12%bcond_with engine_xine # without xine engine
13%bcond_with engine_vlc # without vlc engine
14%bcond_with engine_qt_phonon # without qt-phonon engine
2c687024 15%bcond_without engine_gstreamer # without gstreamer engine
c6f8dd12 16%bcond_without static_sqlite # with static sqlite3
aca708d9 17%bcond_with static_projectm # with static projectM
0b056df0 18
bf1e6952 19Summary: A music player and library organiser
df3c0ac1 20Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 21Name: clementine
f823a794
ER
22Version: 0.5
23Release: 0.1
bf1e6952
ER
24License: GPL v3 and GPL v2+
25Group: Applications/Multimedia
f823a794 26URL: http://www.clementine-player.org/
2c687024 27Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
f823a794
ER
28# Source0-md5: 59a94906394c7e22da567841770dab86
29Patch0: desktop-install.patch
30Patch1: no-private_header.patch
b6199a83 31BuildRequires: QtCore-devel
32BuildRequires: QtDBus-devel
33BuildRequires: QtGui-devel
f2d911f2 34BuildRequires: QtIOCompressor-devel
b6199a83 35BuildRequires: QtNetwork-devel
36BuildRequires: QtOpenGL-devel
f823a794 37BuildRequires: QtSingleApplication-devel >= 2.6-3
b6199a83 38BuildRequires: QtSql-devel
aca708d9 39%{?with_tests:BuildRequires: QtTest-devel}
bf1e6952 40BuildRequires: boost-devel
7279ad3f 41BuildRequires: cmake >= 2.6
aca708d9 42#BuildRequires: desktop-file-utils
f823a794 43#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 44BuildRequires: gettext-devel
f823a794 45%{?with_static_projectm:BuildRequires: glew-devel}
aca708d9
ER
46%{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
47%{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
bf1e6952
ER
48BuildRequires: gtest-devel
49BuildRequires: liblastfm-devel
50BuildRequires: libnotify-devel
f823a794 51%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 52BuildRequires: libqxt-devel
f2d911f2 53#BuildRequires: libqxt-devel >= 0.6.0-0.2
bf1e6952 54BuildRequires: notification-daemon
aca708d9 55%{?with_engine_phonon:BuildRequires: phonon-devel}
75ec0859 56BuildRequires: pkgconfig
bf1e6952 57BuildRequires: qt4-build
b6199a83 58BuildRequires: qt4-linguist
59BuildRequires: qt4-qmake
f823a794 60BuildRequires: rpmbuild(macros) >= 1.577
bf1e6952 61BuildRequires: sed >= 4.0
742e4e0a 62%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 63BuildRequires: taglib-devel >= 1.6
aca708d9
ER
64%{?with_engine_vlc:BuildRequires: vlc-devel}
65%{?with_engine_xine:BuildRequires: xine-lib-devel}
726826ed 66Requires(post,postun): desktop-file-utils
742e4e0a 67%{!?with_static_sqlite:Requires: QtSql-sqlite3}
f2d911f2 68# while we do not link (yet), we use datafiles
83fccbcf 69Requires: QtSingleApplication >= 2.6-3
f2d911f2 70Requires: libprojectM
bf1e6952
ER
71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
f2d911f2
ER
73# see libprojectM.spec for explanation
74%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
75
bf1e6952
ER
76%description
77Clementine is a modern music player and library organiser. It is
78largely a port of Amarok 1.4, with some features rewritten to take
79advantage of Qt4.
80
df3c0ac1
ZU
81%description -l hu.UTF-8
82Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
83az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
84a Qt4 előnyeit.
85
bf1e6952
ER
86%prep
87%setup -q
f2d911f2 88%patch0 -p1
f823a794 89%patch1 -p1
bf1e6952
ER
90
91# We already don't use these but just to make sure
f2d911f2 92rm -rf 3rdparty/gmock
742e4e0a 93%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
94rm -rf 3rdparty/qtsingleapplication
95rm -rf 3rdparty/qxt
96rm -rf 3rdparty/qtiocompressor
aca708d9 97%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 98
7279ad3f 99# Don't build tests. They require gmock
f2d911f2 100sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
101
102%build
103install -d build
104cd build
88ca6f4b 105%cmake \
f2d911f2 106 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794
ER
107 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
108 -DUSE_SYSTEM_QXT=ON \
109 -DUSE_SYSTEM_PROJECTM=ON \
2c687024 110 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
111 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
112 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 113 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
742e4e0a 114 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 115 ..
bf1e6952
ER
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120%{__make} -C build install \
121 DESTDIR=$RPM_BUILD_ROOT
122
f823a794
ER
123rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
124
bf1e6952
ER
125%clean
126rm -rf $RPM_BUILD_ROOT
127
726826ed
ER
128%post
129%update_desktop_database_post
130
131%postun
132%update_desktop_database_postun
133
bf1e6952
ER
134%files
135%defattr(644,root,root,755)
136%doc Changelog TODO
137%attr(755,root,root) %{_bindir}/clementine
138%{_desktopdir}/clementine.desktop
7279ad3f 139%{_pixmapsdir}/clementine.png
This page took 0.051022 seconds and 4 git commands to generate.