]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- up to 0.4.2
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
2c687024 2# - add missing BRs
f2d911f2
ER
3# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4# -- Building engines: gst
5# -- Skipping engines: vlc xine qt-phonon
6# The following engines are NOT supported by clementine developers:
7# vlc xine qt-phonon
8# - apply patches to libprojectM.spec and use
2c687024 9#
10# Conditional build:
11%bcond_without engine_xine # without xine engine
12%bcond_without engine_vlc # without vlc engine
75ec0859 13%bcond_without engine_qt_phonon # without qt-phonon engine
2c687024 14%bcond_without engine_gstreamer # without gstreamer engine
15#
bf1e6952 16Summary: A music player and library organiser
df3c0ac1 17Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 18Name: clementine
f2d911f2 19Version: 0.4.2
2c687024 20Release: 0.1
bf1e6952
ER
21License: GPL v3 and GPL v2+
22Group: Applications/Multimedia
23URL: http://code.google.com/p/clementine-player
2c687024 24Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
f2d911f2 25# Source0-md5: c6819b0d2a8324f1d686fb5a3b1d287b
bf1e6952 26Patch0: %{name}-dont-bundle-external-lib.patch
7279ad3f 27Patch2: desktop-install.patch
b6199a83 28BuildRequires: QtCore-devel
29BuildRequires: QtDBus-devel
30BuildRequires: QtGui-devel
f2d911f2 31BuildRequires: QtIOCompressor-devel
b6199a83 32BuildRequires: QtNetwork-devel
33BuildRequires: QtOpenGL-devel
88ca6f4b 34BuildRequires: QtSingleApplication-devel
b6199a83 35BuildRequires: QtSql-devel
36BuildRequires: QtTest-devel
bf1e6952 37BuildRequires: boost-devel
7279ad3f 38BuildRequires: cmake >= 2.6
bf1e6952 39BuildRequires: desktop-file-utils
75ec0859 40BuildRequires: gettext-devel
41BuildRequires: gstreamer-devel
f2d911f2
ER
42BuildRequires: gstreamer-devel >= 0.10
43BuildRequires: gstreamer-plugins-base-devel >= 0.10
bf1e6952
ER
44BuildRequires: gtest-devel
45BuildRequires: liblastfm-devel
46BuildRequires: libnotify-devel
f2d911f2 47#BuildRequires: libprojectM-devel
bf1e6952 48BuildRequires: libqxt-devel
f2d911f2 49#BuildRequires: libqxt-devel >= 0.6.0-0.2
bf1e6952 50BuildRequires: notification-daemon
75ec0859 51BuildRequires: phonon-devel
52BuildRequires: pkgconfig
bf1e6952 53BuildRequires: qt4-build
b6199a83 54BuildRequires: qt4-linguist
55BuildRequires: qt4-qmake
726826ed 56BuildRequires: rpmbuild(macros) >= 1.198
bf1e6952
ER
57BuildRequires: sed >= 4.0
58BuildRequires: sqlite-devel
b6199a83 59BuildRequires: sqlite3-devel
f2d911f2 60BuildRequires: taglib-devel >= 1.6
75ec0859 61BuildRequires: vlc-devel
bf1e6952 62BuildRequires: xine-lib-devel
726826ed 63Requires(post,postun): desktop-file-utils
df3c0ac1 64Requires: QtSql-sqlite3
f2d911f2
ER
65# while we do not link (yet), we use datafiles
66Requires: libprojectM
bf1e6952
ER
67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
f2d911f2
ER
69# see libprojectM.spec for explanation
70%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
71
bf1e6952
ER
72%description
73Clementine is a modern music player and library organiser. It is
74largely a port of Amarok 1.4, with some features rewritten to take
75advantage of Qt4.
76
df3c0ac1
ZU
77%description -l hu.UTF-8
78Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
79az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
80a Qt4 előnyeit.
81
bf1e6952
ER
82%prep
83%setup -q
f2d911f2 84%patch0 -p1
29df970b 85%patch2 -p1
bf1e6952
ER
86
87# We already don't use these but just to make sure
f2d911f2
ER
88rm -rf 3rdparty/gmock
89rm -rf 3rdparty/qsqlite
90rm -rf 3rdparty/qtsingleapplication
91rm -rf 3rdparty/qxt
92rm -rf 3rdparty/qtiocompressor
bf1e6952 93
7279ad3f 94# Don't build tests. They require gmock
f2d911f2 95sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
96
97%build
98install -d build
99cd build
88ca6f4b
ER
100%cmake \
101 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
f2d911f2 102 -DBUNDLE_PROJECTM_PRESETS=OFF \
2c687024 103 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
104 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
105 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 106 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
88ca6f4b 107 ..
bf1e6952
ER
108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
112%{__make} -C build install \
113 DESTDIR=$RPM_BUILD_ROOT
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
726826ed
ER
118%post
119%update_desktop_database_post
120
121%postun
122%update_desktop_database_postun
123
bf1e6952
ER
124%files
125%defattr(644,root,root,755)
126%doc Changelog TODO
127%attr(755,root,root) %{_bindir}/clementine
128%{_desktopdir}/clementine.desktop
7279ad3f 129%{_pixmapsdir}/clementine.png
This page took 0.043502 seconds and 4 git commands to generate.