]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
- QtSingleApplication runtime dep as well
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - add missing BRs
3 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4 # -- Building engines: gst
5 # -- Skipping engines: vlc xine qt-phonon
6 #    The following engines are NOT supported by clementine developers:
7 #     vlc xine qt-phonon
8 # - apply patches to libprojectM.spec and use
9 # - make engines pluggable not statically linked, then could enable the bconds
10 #
11 # Conditional build:
12 %bcond_with             engine_xine             # without xine engine
13 %bcond_with             engine_vlc              # without vlc engine
14 %bcond_with             engine_qt_phonon        # without qt-phonon engine
15 %bcond_without  engine_gstreamer        # without gstreamer engine
16 %bcond_without  static_sqlite   # with static sqlite3
17 %bcond_with             static_projectm # with static projectM
18
19 Summary:        A music player and library organiser
20 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
21 Name:           clementine
22 Version:        0.5
23 Release:        0.1
24 License:        GPL v3 and GPL v2+
25 Group:          Applications/Multimedia
26 URL:            http://www.clementine-player.org/
27 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28 # Source0-md5:  59a94906394c7e22da567841770dab86
29 Patch0:         desktop-install.patch
30 Patch1:         no-private_header.patch
31 BuildRequires:  QtCore-devel
32 BuildRequires:  QtDBus-devel
33 BuildRequires:  QtGui-devel
34 BuildRequires:  QtIOCompressor-devel
35 BuildRequires:  QtNetwork-devel
36 BuildRequires:  QtOpenGL-devel
37 BuildRequires:  QtSingleApplication-devel >= 2.6-3
38 BuildRequires:  QtSql-devel
39 %{?with_tests:BuildRequires:    QtTest-devel}
40 BuildRequires:  boost-devel
41 BuildRequires:  cmake >= 2.6
42 #BuildRequires: desktop-file-utils
43 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
44 BuildRequires:  gettext-devel
45 %{?with_static_projectm:BuildRequires:  glew-devel}
46 %{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
47 %{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
48 BuildRequires:  gtest-devel
49 BuildRequires:  liblastfm-devel
50 BuildRequires:  libnotify-devel
51 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
52 BuildRequires:  libqxt-devel
53 #BuildRequires: libqxt-devel >= 0.6.0-0.2
54 BuildRequires:  notification-daemon
55 %{?with_engine_phonon:BuildRequires:    phonon-devel}
56 BuildRequires:  pkgconfig
57 BuildRequires:  qt4-build
58 BuildRequires:  qt4-linguist
59 BuildRequires:  qt4-qmake
60 BuildRequires:  rpmbuild(macros) >= 1.577
61 BuildRequires:  sed >= 4.0
62 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
63 BuildRequires:  taglib-devel >= 1.6
64 %{?with_engine_vlc:BuildRequires:       vlc-devel}
65 %{?with_engine_xine:BuildRequires:      xine-lib-devel}
66 Requires(post,postun):  desktop-file-utils
67 %{!?with_static_sqlite:Requires:        QtSql-sqlite3}
68 # while we do not link (yet), we use datafiles
69 Requires:       QtSingleApplication >= 2.6-3
70 Requires:       libprojectM
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 # see libprojectM.spec for explanation
74 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
75
76 %description
77 Clementine is a modern music player and library organiser. It is
78 largely a port of Amarok 1.4, with some features rewritten to take
79 advantage of Qt4.
80
81 %description -l hu.UTF-8
82 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
83 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
84 a Qt4 előnyeit.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90
91 # We already don't use these but just to make sure
92 rm -rf 3rdparty/gmock
93 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
94 rm -rf 3rdparty/qtsingleapplication
95 rm -rf 3rdparty/qxt
96 rm -rf 3rdparty/qtiocompressor
97 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
98
99 # Don't build tests. They require gmock
100 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
101
102 %build
103 install -d build
104 cd build
105 %cmake \
106         -DBUNDLE_PROJECTM_PRESETS=OFF \
107         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
108         -DUSE_SYSTEM_QXT=ON \
109         -DUSE_SYSTEM_PROJECTM=ON \
110         -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
111         -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
112         -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
113         -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
114         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
115         ..
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %{__make} -C build install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 %update_desktop_database_post
130
131 %postun
132 %update_desktop_database_postun
133
134 %files
135 %defattr(644,root,root,755)
136 %doc Changelog TODO
137 %attr(755,root,root) %{_bindir}/clementine
138 %{_desktopdir}/clementine.desktop
139 %{_pixmapsdir}/clementine.png
This page took 0.038913 seconds and 4 git commands to generate.