]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- fixed find_lang BR version
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2
ER
2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3# -- Building engines: gst
4# -- Skipping engines: vlc xine qt-phonon
5# The following engines are NOT supported by clementine developers:
6# vlc xine qt-phonon
7# - apply patches to libprojectM.spec and use
0b056df0 8# - make engines pluggable not statically linked, then could enable the bconds
2c687024 9#
10# Conditional build:
0b056df0
ER
11%bcond_with engine_xine # without xine engine
12%bcond_with engine_vlc # without vlc engine
13%bcond_with engine_qt_phonon # without qt-phonon engine
2c687024 14%bcond_without engine_gstreamer # without gstreamer engine
c6f8dd12 15%bcond_without static_sqlite # with static sqlite3
aca708d9 16%bcond_with static_projectm # with static projectM
0b056df0 17
d8982c6f 18%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 19Summary: A music player and library organiser
df3c0ac1 20Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 21Name: clementine
8b38c4df 22Version: 0.6
2eedc3b1 23Release: 2
bf1e6952
ER
24License: GPL v3 and GPL v2+
25Group: Applications/Multimedia
f823a794 26URL: http://www.clementine-player.org/
4c39f2e0 27Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28# Source0-md5: 7b7ee4c16f648a15eb2cff9ed2163e0e
f823a794 29Patch0: desktop-install.patch
10ecf727 30Patch1: unbundle-po.patch
64d9867e
ER
31BuildRequires: QtCore-devel >= %{qtver}
32BuildRequires: QtDBus-devel >= %{qtver}
33BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 34BuildRequires: QtIOCompressor-devel
64d9867e
ER
35BuildRequires: QtNetwork-devel >= %{qtver}
36BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 37BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
38BuildRequires: QtSql-devel >= %{qtver}
39%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
40BuildRequires: QtXml-devel >= %{qtver}
bf1e6952 41BuildRequires: boost-devel
7279ad3f 42BuildRequires: cmake >= 2.6
f823a794 43#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 44BuildRequires: gettext-devel
f823a794 45%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 46BuildRequires: glib2-devel
aca708d9 47%{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
bf1e6952 48BuildRequires: gtest-devel
8f83a8c0
ER
49BuildRequires: libgpod-devel >= 0.7.92
50BuildRequires: libimobiledevice-devel
2eedc3b1 51BuildRequires: libindicate-qt-devel
bf1e6952 52BuildRequires: liblastfm-devel
8f83a8c0 53BuildRequires: libmtp-devel
8f83a8c0 54BuildRequires: libplist-devel
f823a794 55%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 56BuildRequires: libqxt-devel
8f83a8c0 57BuildRequires: libxml2-devel
aca708d9 58%{?with_engine_phonon:BuildRequires: phonon-devel}
75ec0859 59BuildRequires: pkgconfig
2eedc3b1 60BuildRequires: pkgconfig
64d9867e 61BuildRequires: qt4-build >= %{qtver}
b6199a83 62BuildRequires: qt4-linguist
63BuildRequires: qt4-qmake
7aaa97de 64BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 65BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 66BuildRequires: sed >= 4.0
742e4e0a 67%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 68BuildRequires: taglib-devel >= 1.6
8f83a8c0 69BuildRequires: usbmuxd-devel
aca708d9
ER
70%{?with_engine_vlc:BuildRequires: vlc-devel}
71%{?with_engine_xine:BuildRequires: xine-lib-devel}
2eedc3b1 72Requires: hicolor-icon-theme
726826ed 73Requires(post,postun): desktop-file-utils
acb98f48 74Requires: QtSingleApplication >= 2.6-4
64d9867e 75%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
4282eb18 76Requires: gstreamer-audio-effects-base
f2d911f2
ER
77# while we do not link (yet), we use datafiles
78Requires: libprojectM
bf1e6952
ER
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
f2d911f2
ER
81# see libprojectM.spec for explanation
82%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
83
bf1e6952
ER
84%description
85Clementine is a modern music player and library organiser. It is
86largely a port of Amarok 1.4, with some features rewritten to take
87advantage of Qt4.
88
df3c0ac1
ZU
89%description -l hu.UTF-8
90Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
91az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
92a Qt4 előnyeit.
93
bf1e6952 94%prep
4c39f2e0 95%setup -q
f2d911f2 96%patch0 -p1
10ecf727 97%patch1 -p1
bf1e6952
ER
98
99# We already don't use these but just to make sure
f2d911f2 100rm -rf 3rdparty/gmock
742e4e0a 101%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
102rm -rf 3rdparty/qtsingleapplication
103rm -rf 3rdparty/qxt
104rm -rf 3rdparty/qtiocompressor
aca708d9 105%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 106
7279ad3f 107# Don't build tests. They require gmock
f2d911f2 108sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
109
110%build
111install -d build
7aaa97de 112install -d build/src/translations
bf1e6952 113cd build
88ca6f4b 114%cmake \
f2d911f2 115 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794
ER
116 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
117 -DUSE_SYSTEM_QXT=ON \
118 -DUSE_SYSTEM_PROJECTM=ON \
2c687024 119 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
120 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
121 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 122 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
742e4e0a 123 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 124 ..
bf1e6952
ER
125%{__make}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129%{__make} -C build install \
130 DESTDIR=$RPM_BUILD_ROOT
131
f823a794
ER
132rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
133
10ecf727
ER
134%find_lang %{name} --with-qm
135
2eedc3b1
ER
136install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
137cp -a $RPM_BUILD_ROOT{%{_datadir}/icons/ubuntu-mono-light/apps/24,%{_iconsdir}/hicolor/24x24/apps}/clementine-panel-grey.png
138cp -a $RPM_BUILD_ROOT{%{_datadir}/icons/ubuntu-mono-light/apps/24,%{_iconsdir}/hicolor/24x24/apps}/clementine-panel.png
139
140# don't want to depend on ubuntu themes
141rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/ubuntu-*
142
bf1e6952
ER
143%clean
144rm -rf $RPM_BUILD_ROOT
145
726826ed
ER
146%post
147%update_desktop_database_post
2eedc3b1 148%update_icon_cache hicolor
726826ed
ER
149
150%postun
151%update_desktop_database_postun
2eedc3b1 152%update_icon_cache hicolor
726826ed 153
10ecf727 154%files -f %{name}.lang
bf1e6952
ER
155%defattr(644,root,root,755)
156%doc Changelog TODO
157%attr(755,root,root) %{_bindir}/clementine
158%{_desktopdir}/clementine.desktop
7279ad3f 159%{_pixmapsdir}/clementine.png
2eedc3b1
ER
160%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
161%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.079821 seconds and 4 git commands to generate.