]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- strict qt deps:
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2
ER
2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3# -- Building engines: gst
4# -- Skipping engines: vlc xine qt-phonon
5# The following engines are NOT supported by clementine developers:
6# vlc xine qt-phonon
7# - apply patches to libprojectM.spec and use
0b056df0 8# - make engines pluggable not statically linked, then could enable the bconds
2c687024 9#
10# Conditional build:
0b056df0
ER
11%bcond_with engine_xine # without xine engine
12%bcond_with engine_vlc # without vlc engine
13%bcond_with engine_qt_phonon # without qt-phonon engine
2c687024 14%bcond_without engine_gstreamer # without gstreamer engine
c6f8dd12 15%bcond_without static_sqlite # with static sqlite3
aca708d9 16%bcond_with static_projectm # with static projectM
0b056df0 17
d8982c6f 18%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 19Summary: A music player and library organiser
df3c0ac1 20Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 21Name: clementine
8b38c4df 22Version: 0.6
d8982c6f 23Release: 1
bf1e6952
ER
24License: GPL v3 and GPL v2+
25Group: Applications/Multimedia
f823a794 26URL: http://www.clementine-player.org/
4c39f2e0 27Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28# Source0-md5: 7b7ee4c16f648a15eb2cff9ed2163e0e
f823a794 29Patch0: desktop-install.patch
10ecf727 30Patch1: unbundle-po.patch
64d9867e
ER
31BuildRequires: QtCore-devel >= %{qtver}
32BuildRequires: QtDBus-devel >= %{qtver}
d8982c6f 33BuildRequires: pkgconfig
64d9867e 34BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 35BuildRequires: QtIOCompressor-devel
64d9867e
ER
36BuildRequires: QtNetwork-devel >= %{qtver}
37BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 38BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
39BuildRequires: QtSql-devel >= %{qtver}
40%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
41BuildRequires: QtXml-devel >= %{qtver}
e809dfd9 42BuildRequires: QtXmlPatterns-devel >= %{qtver}
bf1e6952 43BuildRequires: boost-devel
7279ad3f 44BuildRequires: cmake >= 2.6
aca708d9 45#BuildRequires: desktop-file-utils
f823a794 46#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 47BuildRequires: gettext-devel
f823a794 48%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 49BuildRequires: glib2-devel
aca708d9
ER
50%{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
51%{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
bf1e6952 52BuildRequires: gtest-devel
8f83a8c0
ER
53BuildRequires: libgpod-devel >= 0.7.92
54BuildRequires: libimobiledevice-devel
bf1e6952 55BuildRequires: liblastfm-devel
8f83a8c0 56BuildRequires: libmtp-devel
bf1e6952 57BuildRequires: libnotify-devel
8f83a8c0 58BuildRequires: libplist-devel
f823a794 59%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 60BuildRequires: libqxt-devel
f2d911f2 61#BuildRequires: libqxt-devel >= 0.6.0-0.2
8f83a8c0 62BuildRequires: libxml2-devel
bf1e6952 63BuildRequires: notification-daemon
8f83a8c0 64BuildRequires: phonon
aca708d9 65%{?with_engine_phonon:BuildRequires: phonon-devel}
75ec0859 66BuildRequires: pkgconfig
64d9867e 67BuildRequires: qt4-build >= %{qtver}
b6199a83 68BuildRequires: qt4-linguist
69BuildRequires: qt4-qmake
10ecf727 70BuildRequires: rpmbuild(find_lang) = 1.33
f823a794 71BuildRequires: rpmbuild(macros) >= 1.577
bf1e6952 72BuildRequires: sed >= 4.0
742e4e0a 73%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 74BuildRequires: taglib-devel >= 1.6
8f83a8c0 75BuildRequires: usbmuxd-devel
aca708d9
ER
76%{?with_engine_vlc:BuildRequires: vlc-devel}
77%{?with_engine_xine:BuildRequires: xine-lib-devel}
726826ed 78Requires(post,postun): desktop-file-utils
acb98f48 79Requires: QtSingleApplication >= 2.6-4
64d9867e 80%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
4282eb18 81Requires: gstreamer-audio-effects-base
f2d911f2
ER
82# while we do not link (yet), we use datafiles
83Requires: libprojectM
bf1e6952
ER
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
f2d911f2
ER
86# see libprojectM.spec for explanation
87%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
88
bf1e6952
ER
89%description
90Clementine is a modern music player and library organiser. It is
91largely a port of Amarok 1.4, with some features rewritten to take
92advantage of Qt4.
93
df3c0ac1
ZU
94%description -l hu.UTF-8
95Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
96az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
97a Qt4 előnyeit.
98
bf1e6952 99%prep
4c39f2e0 100%setup -q
f2d911f2 101%patch0 -p1
10ecf727 102%patch1 -p1
bf1e6952
ER
103
104# We already don't use these but just to make sure
f2d911f2 105rm -rf 3rdparty/gmock
742e4e0a 106%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
107rm -rf 3rdparty/qtsingleapplication
108rm -rf 3rdparty/qxt
109rm -rf 3rdparty/qtiocompressor
aca708d9 110%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 111
7279ad3f 112# Don't build tests. They require gmock
f2d911f2 113sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
114
115%build
116install -d build
10ecf727 117install -d build/src/translations
bf1e6952 118cd build
88ca6f4b 119%cmake \
f2d911f2 120 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794
ER
121 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
122 -DUSE_SYSTEM_QXT=ON \
123 -DUSE_SYSTEM_PROJECTM=ON \
2c687024 124 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
125 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
126 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 127 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
742e4e0a 128 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 129 ..
bf1e6952
ER
130%{__make}
131
132%install
133rm -rf $RPM_BUILD_ROOT
134%{__make} -C build install \
135 DESTDIR=$RPM_BUILD_ROOT
136
f823a794
ER
137rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
138
10ecf727
ER
139%find_lang %{name} --with-qm
140
bf1e6952
ER
141%clean
142rm -rf $RPM_BUILD_ROOT
143
726826ed
ER
144%post
145%update_desktop_database_post
146
147%postun
148%update_desktop_database_postun
149
10ecf727 150%files -f %{name}.lang
bf1e6952
ER
151%defattr(644,root,root,755)
152%doc Changelog TODO
153%attr(755,root,root) %{_bindir}/clementine
154%{_desktopdir}/clementine.desktop
7279ad3f 155%{_pixmapsdir}/clementine.png
This page took 0.066158 seconds and 4 git commands to generate.