]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- up to 0.5.3
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
2c687024 2# - add missing BRs
f2d911f2
ER
3# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
4# -- Building engines: gst
5# -- Skipping engines: vlc xine qt-phonon
6# The following engines are NOT supported by clementine developers:
7# vlc xine qt-phonon
8# - apply patches to libprojectM.spec and use
0b056df0 9# - make engines pluggable not statically linked, then could enable the bconds
2c687024 10#
11# Conditional build:
0b056df0
ER
12%bcond_with engine_xine # without xine engine
13%bcond_with engine_vlc # without vlc engine
14%bcond_with engine_qt_phonon # without qt-phonon engine
2c687024 15%bcond_without engine_gstreamer # without gstreamer engine
c6f8dd12 16%bcond_without static_sqlite # with static sqlite3
aca708d9 17%bcond_with static_projectm # with static projectM
0b056df0 18
bf1e6952 19Summary: A music player and library organiser
df3c0ac1 20Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 21Name: clementine
b0f4dfa2 22Version: 0.5.3
acb98f48 23Release: 1
bf1e6952
ER
24License: GPL v3 and GPL v2+
25Group: Applications/Multimedia
f823a794 26URL: http://www.clementine-player.org/
2c687024 27Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
b0f4dfa2 28# Source0-md5: 3411a0e31bdab7a6693048e934996f40
f823a794 29Patch0: desktop-install.patch
b6199a83 30BuildRequires: QtCore-devel
31BuildRequires: QtDBus-devel
32BuildRequires: QtGui-devel
f2d911f2 33BuildRequires: QtIOCompressor-devel
b6199a83 34BuildRequires: QtNetwork-devel
35BuildRequires: QtOpenGL-devel
acb98f48 36BuildRequires: QtSingleApplication-devel >= 2.6-4
b6199a83 37BuildRequires: QtSql-devel
aca708d9 38%{?with_tests:BuildRequires: QtTest-devel}
bf1e6952 39BuildRequires: boost-devel
7279ad3f 40BuildRequires: cmake >= 2.6
aca708d9 41#BuildRequires: desktop-file-utils
f823a794 42#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 43BuildRequires: gettext-devel
f823a794 44%{?with_static_projectm:BuildRequires: glew-devel}
aca708d9
ER
45%{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
46%{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
bf1e6952
ER
47BuildRequires: gtest-devel
48BuildRequires: liblastfm-devel
49BuildRequires: libnotify-devel
f823a794 50%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 51BuildRequires: libqxt-devel
f2d911f2 52#BuildRequires: libqxt-devel >= 0.6.0-0.2
bf1e6952 53BuildRequires: notification-daemon
aca708d9 54%{?with_engine_phonon:BuildRequires: phonon-devel}
75ec0859 55BuildRequires: pkgconfig
bf1e6952 56BuildRequires: qt4-build
b6199a83 57BuildRequires: qt4-linguist
58BuildRequires: qt4-qmake
f823a794 59BuildRequires: rpmbuild(macros) >= 1.577
bf1e6952 60BuildRequires: sed >= 4.0
742e4e0a 61%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 62BuildRequires: taglib-devel >= 1.6
aca708d9
ER
63%{?with_engine_vlc:BuildRequires: vlc-devel}
64%{?with_engine_xine:BuildRequires: xine-lib-devel}
726826ed 65Requires(post,postun): desktop-file-utils
acb98f48 66Requires: QtSingleApplication >= 2.6-4
742e4e0a 67%{!?with_static_sqlite:Requires: QtSql-sqlite3}
f2d911f2
ER
68# while we do not link (yet), we use datafiles
69Requires: libprojectM
bf1e6952
ER
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
f2d911f2
ER
72# see libprojectM.spec for explanation
73%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
74
bf1e6952
ER
75%description
76Clementine is a modern music player and library organiser. It is
77largely a port of Amarok 1.4, with some features rewritten to take
78advantage of Qt4.
79
df3c0ac1
ZU
80%description -l hu.UTF-8
81Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
82az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
83a Qt4 előnyeit.
84
bf1e6952
ER
85%prep
86%setup -q
f2d911f2 87%patch0 -p1
bf1e6952
ER
88
89# We already don't use these but just to make sure
f2d911f2 90rm -rf 3rdparty/gmock
742e4e0a 91%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
92rm -rf 3rdparty/qtsingleapplication
93rm -rf 3rdparty/qxt
94rm -rf 3rdparty/qtiocompressor
aca708d9 95%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 96
7279ad3f 97# Don't build tests. They require gmock
f2d911f2 98sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
99
100%build
101install -d build
102cd build
88ca6f4b 103%cmake \
f2d911f2 104 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794
ER
105 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
106 -DUSE_SYSTEM_QXT=ON \
107 -DUSE_SYSTEM_PROJECTM=ON \
2c687024 108 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
109 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
110 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 111 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
742e4e0a 112 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 113 ..
bf1e6952
ER
114%{__make}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118%{__make} -C build install \
119 DESTDIR=$RPM_BUILD_ROOT
120
f823a794
ER
121rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
122
bf1e6952
ER
123%clean
124rm -rf $RPM_BUILD_ROOT
125
726826ed
ER
126%post
127%update_desktop_database_post
128
129%postun
130%update_desktop_database_postun
131
bf1e6952
ER
132%files
133%defattr(644,root,root,755)
134%doc Changelog TODO
135%attr(755,root,root) %{_bindir}/clementine
136%{_desktopdir}/clementine.desktop
7279ad3f 137%{_pixmapsdir}/clementine.png
This page took 0.074568 seconds and 4 git commands to generate.