]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- package panel icons; rel 2
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2
ER
2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3# -- Building engines: gst
4# -- Skipping engines: vlc xine qt-phonon
5# The following engines are NOT supported by clementine developers:
6# vlc xine qt-phonon
7# - apply patches to libprojectM.spec and use
0b056df0 8# - make engines pluggable not statically linked, then could enable the bconds
2c687024 9#
10# Conditional build:
0b056df0
ER
11%bcond_with engine_xine # without xine engine
12%bcond_with engine_vlc # without vlc engine
13%bcond_with engine_qt_phonon # without qt-phonon engine
2c687024 14%bcond_without engine_gstreamer # without gstreamer engine
c6f8dd12 15%bcond_without static_sqlite # with static sqlite3
aca708d9 16%bcond_with static_projectm # with static projectM
0b056df0 17
d8982c6f 18%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 19Summary: A music player and library organiser
df3c0ac1 20Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 21Name: clementine
8b38c4df 22Version: 0.6
2eedc3b1 23Release: 2
bf1e6952
ER
24License: GPL v3 and GPL v2+
25Group: Applications/Multimedia
f823a794 26URL: http://www.clementine-player.org/
4c39f2e0 27Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
28# Source0-md5: 7b7ee4c16f648a15eb2cff9ed2163e0e
f823a794 29Patch0: desktop-install.patch
10ecf727 30Patch1: unbundle-po.patch
64d9867e
ER
31BuildRequires: QtCore-devel >= %{qtver}
32BuildRequires: QtDBus-devel >= %{qtver}
33BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 34BuildRequires: QtIOCompressor-devel
64d9867e
ER
35BuildRequires: QtNetwork-devel >= %{qtver}
36BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 37BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
38BuildRequires: QtSql-devel >= %{qtver}
39%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
40BuildRequires: QtXml-devel >= %{qtver}
e809dfd9 41BuildRequires: QtXmlPatterns-devel >= %{qtver}
bf1e6952 42BuildRequires: boost-devel
7279ad3f 43BuildRequires: cmake >= 2.6
f823a794 44#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 45BuildRequires: gettext-devel
f823a794 46%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 47BuildRequires: glib2-devel
aca708d9
ER
48%{?with_engine_gstreamer:BuildRequires: gstreamer-devel >= 0.10}
49%{?with_engine_gstreamer:BuildRequires: gstreamer-plugins-base-devel >= 0.10}
bf1e6952 50BuildRequires: gtest-devel
8f83a8c0
ER
51BuildRequires: libgpod-devel >= 0.7.92
52BuildRequires: libimobiledevice-devel
2eedc3b1 53BuildRequires: libindicate-qt-devel
bf1e6952 54BuildRequires: liblastfm-devel
8f83a8c0 55BuildRequires: libmtp-devel
bf1e6952 56BuildRequires: libnotify-devel
8f83a8c0 57BuildRequires: libplist-devel
f823a794 58%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 59BuildRequires: libqxt-devel
f2d911f2 60#BuildRequires: libqxt-devel >= 0.6.0-0.2
8f83a8c0 61BuildRequires: libxml2-devel
bf1e6952 62BuildRequires: notification-daemon
8f83a8c0 63BuildRequires: phonon
aca708d9 64%{?with_engine_phonon:BuildRequires: phonon-devel}
75ec0859 65BuildRequires: pkgconfig
2eedc3b1 66BuildRequires: pkgconfig
64d9867e 67BuildRequires: qt4-build >= %{qtver}
b6199a83 68BuildRequires: qt4-linguist
69BuildRequires: qt4-qmake
10ecf727 70BuildRequires: rpmbuild(find_lang) = 1.33
2eedc3b1 71BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 72BuildRequires: sed >= 4.0
742e4e0a 73%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 74BuildRequires: taglib-devel >= 1.6
8f83a8c0 75BuildRequires: usbmuxd-devel
aca708d9
ER
76%{?with_engine_vlc:BuildRequires: vlc-devel}
77%{?with_engine_xine:BuildRequires: xine-lib-devel}
2eedc3b1 78Requires: hicolor-icon-theme
726826ed 79Requires(post,postun): desktop-file-utils
acb98f48 80Requires: QtSingleApplication >= 2.6-4
64d9867e 81%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
4282eb18 82Requires: gstreamer-audio-effects-base
f2d911f2
ER
83# while we do not link (yet), we use datafiles
84Requires: libprojectM
bf1e6952
ER
85BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
f2d911f2
ER
87# see libprojectM.spec for explanation
88%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
89
bf1e6952
ER
90%description
91Clementine is a modern music player and library organiser. It is
92largely a port of Amarok 1.4, with some features rewritten to take
93advantage of Qt4.
94
df3c0ac1
ZU
95%description -l hu.UTF-8
96Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
97az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
98a Qt4 előnyeit.
99
bf1e6952 100%prep
4c39f2e0 101%setup -q
f2d911f2 102%patch0 -p1
10ecf727 103%patch1 -p1
bf1e6952
ER
104
105# We already don't use these but just to make sure
f2d911f2 106rm -rf 3rdparty/gmock
742e4e0a 107%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
108rm -rf 3rdparty/qtsingleapplication
109rm -rf 3rdparty/qxt
110rm -rf 3rdparty/qtiocompressor
aca708d9 111%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 112
7279ad3f 113# Don't build tests. They require gmock
f2d911f2 114sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
bf1e6952
ER
115
116%build
117install -d build
118cd build
88ca6f4b 119%cmake \
f2d911f2 120 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794
ER
121 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
122 -DUSE_SYSTEM_QXT=ON \
123 -DUSE_SYSTEM_PROJECTM=ON \
2c687024 124 -DENGINE_GSTREAMER_ENABLED=%{?with_engine_gstreamer:ON}%{!?with_engine_gstreamer:OFF} \
125 -DENGINE_LIBVLC_ENABLED=%{?with_engine_vlc:ON}%{!?with_engine_vlc:OFF} \
126 -DENGINE_LIBXINE_ENABLED=%{?with_engine_xine:ON}%{!?with_engine_xine:OFF} \
75ec0859 127 -DENGINE_QT_PHONON_ENABLED=%{?with_engine_qt_phonon:ON}%{!?with_engine_qt_phonon:OFF} \
742e4e0a 128 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 129 ..
bf1e6952
ER
130%{__make}
131
132%install
133rm -rf $RPM_BUILD_ROOT
134%{__make} -C build install \
135 DESTDIR=$RPM_BUILD_ROOT
136
f823a794
ER
137rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
138
10ecf727
ER
139%find_lang %{name} --with-qm
140
2eedc3b1
ER
141install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
142cp -a $RPM_BUILD_ROOT{%{_datadir}/icons/ubuntu-mono-light/apps/24,%{_iconsdir}/hicolor/24x24/apps}/clementine-panel-grey.png
143cp -a $RPM_BUILD_ROOT{%{_datadir}/icons/ubuntu-mono-light/apps/24,%{_iconsdir}/hicolor/24x24/apps}/clementine-panel.png
144
145# don't want to depend on ubuntu themes
146rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/ubuntu-*
147
bf1e6952
ER
148%clean
149rm -rf $RPM_BUILD_ROOT
150
726826ed
ER
151%post
152%update_desktop_database_post
2eedc3b1 153%update_icon_cache hicolor
726826ed
ER
154
155%postun
156%update_desktop_database_postun
2eedc3b1 157%update_icon_cache hicolor
726826ed 158
10ecf727 159%files -f %{name}.lang
bf1e6952
ER
160%defattr(644,root,root,755)
161%doc Changelog TODO
162%attr(755,root,root) %{_bindir}/clementine
163%{_desktopdir}/clementine.desktop
7279ad3f 164%{_pixmapsdir}/clementine.png
2eedc3b1
ER
165%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
166%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.057763 seconds and 4 git commands to generate.