]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
use system libmygpo-qt
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2 2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
f2d911f2 3# - apply patches to libprojectM.spec and use
6b78beb2
ER
4# - package for kde4 stuff (or nuke them):
5# /usr/share/kde4/services/clementine-feed.protocol
6# /usr/share/kde4/services/clementine-itms.protocol
7# /usr/share/kde4/services/clementine-itpc.protocol
8# /usr/share/kde4/services/clementine-zune.protocol
2c687024 9#
10# Conditional build:
c6f8dd12 11%bcond_without static_sqlite # with static sqlite3
3834eb29 12%bcond_with static_projectm # with static projectM
aa506418 13%bcond_with libspotify # build with system libspotify instead of downloading blob
0b056df0 14
064e709c 15%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 16Summary: A music player and library organiser
df3c0ac1 17Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 18Name: clementine
dbbdd85a 19Version: 1.1.1
4a572e41 20Release: 6
bf1e6952
ER
21License: GPL v3 and GPL v2+
22Group: Applications/Multimedia
f823a794 23URL: http://www.clementine-player.org/
bf272879 24Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
dbbdd85a 25# Source0-md5: 28e4afb822388bd337a761db8f86febf
f823a794 26Patch0: desktop-install.patch
10ecf727 27Patch1: unbundle-po.patch
4a572e41 28Patch2: %{name}-1.1.1-libimobiledevice-fix.patch
68fe38b0 29Patch3: %{name}-dt_categories.patch
5fe14c9e 30Patch4: %{name}-mygpo.patch
64d9867e
ER
31BuildRequires: QtCore-devel >= %{qtver}
32BuildRequires: QtDBus-devel >= %{qtver}
33BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 34BuildRequires: QtIOCompressor-devel
64d9867e
ER
35BuildRequires: QtNetwork-devel >= %{qtver}
36BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 37BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
38BuildRequires: QtSql-devel >= %{qtver}
39%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
40BuildRequires: QtXml-devel >= %{qtver}
7dce7848 41BuildRequires: QtXmlPatterns-devel >= %{qtver}
bf1e6952 42BuildRequires: boost-devel
7279ad3f 43BuildRequires: cmake >= 2.6
f823a794 44#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 45BuildRequires: gettext-devel
f823a794 46%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 47BuildRequires: glib2-devel
dbbdd85a
JK
48BuildRequires: gstreamer0.10-devel
49BuildRequires: gstreamer0.10-plugins-base-devel
bf1e6952 50BuildRequires: gtest-devel
aa506418
ER
51BuildRequires: libcdio-devel
52BuildRequires: libchromaprint-devel
8f83a8c0 53BuildRequires: libgpod-devel >= 0.7.92
fbe6cce5 54BuildRequires: libimobiledevice-devel >= 1.1.5
2eedc3b1 55BuildRequires: libindicate-qt-devel
e0ba0da9 56BuildRequires: liblastfm-devel >= 0.3.3
8f83a8c0 57BuildRequires: libmtp-devel
5fe14c9e 58BuildRequires: libmygpo-qt-devel
8f83a8c0 59BuildRequires: libplist-devel
f823a794 60%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 61BuildRequires: libqxt-devel
aa506418 62%{?with_libspotify:BuildRequires: libspotify-devel >= 12.1.45}
8f83a8c0 63BuildRequires: libxml2-devel
75ec0859 64BuildRequires: pkgconfig
2eedc3b1 65BuildRequires: pkgconfig
e0ba0da9 66BuildRequires: protobuf-devel
49968d1b 67BuildRequires: qca-devel
e0ba0da9 68BuildRequires: qjson-devel
64d9867e 69BuildRequires: qt4-build >= %{qtver}
b6199a83 70BuildRequires: qt4-linguist
71BuildRequires: qt4-qmake
7aaa97de 72BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 73BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 74BuildRequires: sed >= 4.0
6f798db9 75BuildRequires: sparsehash-devel
742e4e0a 76%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 77BuildRequires: taglib-devel >= 1.6
8f83a8c0 78BuildRequires: usbmuxd-devel
726826ed 79Requires(post,postun): desktop-file-utils
23941661
AF
80Requires(post,postun): gtk-update-icon-cache
81Requires(post,postun): hicolor-icon-theme
acb98f48 82Requires: QtSingleApplication >= 2.6-4
64d9867e 83%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
dbbdd85a 84Requires: gstreamer0.10-audio-effects-base
862961b4 85Requires: gstreamer0.10-mad
cb052d79 86Suggests: gstreamer0.10-flac
5fe14c9e 87
f2d911f2
ER
88# while we do not link (yet), we use datafiles
89Requires: libprojectM
bf1e6952
ER
90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
f2d911f2
ER
92# see libprojectM.spec for explanation
93%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
94
bf1e6952
ER
95%description
96Clementine is a modern music player and library organiser. It is
97largely a port of Amarok 1.4, with some features rewritten to take
98advantage of Qt4.
99
df3c0ac1
ZU
100%description -l hu.UTF-8
101Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
102az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
103a Qt4 előnyeit.
104
bf1e6952 105%prep
862961b4 106%setup -q
f2d911f2 107%patch0 -p1
10ecf727 108%patch1 -p1
4a572e41 109%patch2 -p1
68fe38b0 110%patch3 -p1
5fe14c9e 111%patch4 -p1
bf1e6952 112
5fe14c9e
ER
113# Remove all 3rdparty libraries exceph universalchardet
114# as it is not available as a separate library.
115mv 3rdparty 3rdparty.keep
116install -d 3rdparty
117mv 3rdparty.keep/{universalchardet,sha2,libechonest,qocoa%{?with_static_sqlite:,qsqlite}%{?with_static_projectm:,libprojectM}} 3rdparty
bf1e6952 118
7279ad3f 119# Don't build tests. They require gmock
f2d911f2 120sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
ea86e9d9
BZ
121# remove -Wall
122sed -i -e 's/-Wall//' src/CMakeLists.txt
064e709c
JR
123# ...and -Werror
124sed -i -e 's/-Werror//' src/CMakeLists.txt
bf1e6952
ER
125
126%build
127install -d build
7aaa97de 128install -d build/src/translations
bf1e6952 129cd build
6b78beb2
ER
130# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
131CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
88ca6f4b 132%cmake \
f2d911f2 133 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794 134 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
862961b4 135 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
f823a794
ER
136 -DUSE_SYSTEM_QXT=ON \
137 -DUSE_SYSTEM_PROJECTM=ON \
742e4e0a 138 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 139 ..
bf1e6952
ER
140%{__make}
141
142%install
143rm -rf $RPM_BUILD_ROOT
144%{__make} -C build install \
145 DESTDIR=$RPM_BUILD_ROOT
146
f823a794
ER
147rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
148
dbbdd85a
JK
149# not in our glibc?
150rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
151
10ecf727
ER
152%find_lang %{name} --with-qm
153
23f69c7b
BZ
154install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
155cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
156cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
157
bf1e6952
ER
158%clean
159rm -rf $RPM_BUILD_ROOT
160
726826ed
ER
161%post
162%update_desktop_database_post
2eedc3b1 163%update_icon_cache hicolor
726826ed
ER
164
165%postun
166%update_desktop_database_postun
2eedc3b1 167%update_icon_cache hicolor
726826ed 168
10ecf727 169%files -f %{name}.lang
bf1e6952 170%defattr(644,root,root,755)
e0ba0da9 171%doc Changelog
bf1e6952 172%attr(755,root,root) %{_bindir}/clementine
dbbdd85a 173%attr(755,root,root) %{_bindir}/clementine-tagreader
bf1e6952 174%{_desktopdir}/clementine.desktop
7279ad3f 175%{_pixmapsdir}/clementine.png
23f69c7b
BZ
176%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
177%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.052393 seconds and 4 git commands to generate.