]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
fix .desktop categories (add Audio); patch from fedora
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2 2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
f2d911f2 3# - apply patches to libprojectM.spec and use
6b78beb2
ER
4# - checking for module 'libspotify>=12.1.45' - Spotify support: non-GPL binary helper (missing libspotify)
5# - checking for module 'libchromaprint'
6# - Google Drive support (missing Google sparsehash)
7# - package for kde4 stuff (or nuke them):
8# /usr/share/kde4/services/clementine-feed.protocol
9# /usr/share/kde4/services/clementine-itms.protocol
10# /usr/share/kde4/services/clementine-itpc.protocol
11# /usr/share/kde4/services/clementine-zune.protocol
2c687024 12#
13# Conditional build:
c6f8dd12 14%bcond_without static_sqlite # with static sqlite3
3834eb29 15%bcond_with static_projectm # with static projectM
0b056df0 16
064e709c 17%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 18Summary: A music player and library organiser
df3c0ac1 19Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 20Name: clementine
dbbdd85a 21Version: 1.1.1
4a572e41 22Release: 6
bf1e6952
ER
23License: GPL v3 and GPL v2+
24Group: Applications/Multimedia
f823a794 25URL: http://www.clementine-player.org/
bf272879 26Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
dbbdd85a 27# Source0-md5: 28e4afb822388bd337a761db8f86febf
f823a794 28Patch0: desktop-install.patch
10ecf727 29Patch1: unbundle-po.patch
4a572e41 30Patch2: %{name}-1.1.1-libimobiledevice-fix.patch
68fe38b0 31Patch3: %{name}-dt_categories.patch
64d9867e
ER
32BuildRequires: QtCore-devel >= %{qtver}
33BuildRequires: QtDBus-devel >= %{qtver}
34BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 35BuildRequires: QtIOCompressor-devel
64d9867e
ER
36BuildRequires: QtNetwork-devel >= %{qtver}
37BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 38BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
39BuildRequires: QtSql-devel >= %{qtver}
40%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
41BuildRequires: QtXml-devel >= %{qtver}
7dce7848 42BuildRequires: QtXmlPatterns-devel >= %{qtver}
bf1e6952 43BuildRequires: boost-devel
7279ad3f 44BuildRequires: cmake >= 2.6
f823a794 45#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 46BuildRequires: gettext-devel
f823a794 47%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 48BuildRequires: glib2-devel
dbbdd85a
JK
49BuildRequires: gstreamer0.10-devel
50BuildRequires: gstreamer0.10-plugins-base-devel
bf1e6952 51BuildRequires: gtest-devel
8f83a8c0
ER
52BuildRequires: libgpod-devel >= 0.7.92
53BuildRequires: libimobiledevice-devel
2eedc3b1 54BuildRequires: libindicate-qt-devel
e0ba0da9 55BuildRequires: liblastfm-devel >= 0.3.3
8f83a8c0 56BuildRequires: libmtp-devel
8f83a8c0 57BuildRequires: libplist-devel
f823a794 58%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 59BuildRequires: libqxt-devel
8f83a8c0 60BuildRequires: libxml2-devel
75ec0859 61BuildRequires: pkgconfig
2eedc3b1 62BuildRequires: pkgconfig
e0ba0da9 63BuildRequires: protobuf-devel
49968d1b 64BuildRequires: qca-devel
e0ba0da9 65BuildRequires: qjson-devel
64d9867e 66BuildRequires: qt4-build >= %{qtver}
b6199a83 67BuildRequires: qt4-linguist
68BuildRequires: qt4-qmake
7aaa97de 69BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 70BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 71BuildRequires: sed >= 4.0
742e4e0a 72%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 73BuildRequires: taglib-devel >= 1.6
8f83a8c0 74BuildRequires: usbmuxd-devel
726826ed 75Requires(post,postun): desktop-file-utils
23941661
AF
76Requires(post,postun): gtk-update-icon-cache
77Requires(post,postun): hicolor-icon-theme
acb98f48 78Requires: QtSingleApplication >= 2.6-4
64d9867e 79%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
dbbdd85a 80Requires: gstreamer0.10-audio-effects-base
862961b4 81Requires: gstreamer0.10-mad
f2d911f2
ER
82# while we do not link (yet), we use datafiles
83Requires: libprojectM
bf1e6952
ER
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
f2d911f2
ER
86# see libprojectM.spec for explanation
87%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
88
bf1e6952
ER
89%description
90Clementine is a modern music player and library organiser. It is
91largely a port of Amarok 1.4, with some features rewritten to take
92advantage of Qt4.
93
df3c0ac1
ZU
94%description -l hu.UTF-8
95Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
96az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
97a Qt4 előnyeit.
98
bf1e6952 99%prep
862961b4 100%setup -q
f2d911f2 101%patch0 -p1
10ecf727 102%patch1 -p1
4a572e41 103%patch2 -p1
68fe38b0 104%patch3 -p1
bf1e6952
ER
105
106# We already don't use these but just to make sure
f2d911f2 107rm -rf 3rdparty/gmock
742e4e0a 108%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
109rm -rf 3rdparty/qtsingleapplication
110rm -rf 3rdparty/qxt
111rm -rf 3rdparty/qtiocompressor
aca708d9 112%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 113
7279ad3f 114# Don't build tests. They require gmock
f2d911f2 115sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
ea86e9d9
BZ
116# remove -Wall
117sed -i -e 's/-Wall//' src/CMakeLists.txt
064e709c
JR
118# ...and -Werror
119sed -i -e 's/-Werror//' src/CMakeLists.txt
bf1e6952
ER
120
121%build
122install -d build
7aaa97de 123install -d build/src/translations
bf1e6952 124cd build
6b78beb2
ER
125# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
126CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
88ca6f4b 127%cmake \
f2d911f2 128 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794 129 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
862961b4 130 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
f823a794
ER
131 -DUSE_SYSTEM_QXT=ON \
132 -DUSE_SYSTEM_PROJECTM=ON \
742e4e0a 133 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 134 ..
bf1e6952
ER
135%{__make}
136
137%install
138rm -rf $RPM_BUILD_ROOT
139%{__make} -C build install \
140 DESTDIR=$RPM_BUILD_ROOT
141
f823a794
ER
142rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
143
dbbdd85a
JK
144# not in our glibc?
145rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
146
10ecf727
ER
147%find_lang %{name} --with-qm
148
23f69c7b
BZ
149install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
150cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
151cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
152
bf1e6952
ER
153%clean
154rm -rf $RPM_BUILD_ROOT
155
726826ed
ER
156%post
157%update_desktop_database_post
2eedc3b1 158%update_icon_cache hicolor
726826ed
ER
159
160%postun
161%update_desktop_database_postun
2eedc3b1 162%update_icon_cache hicolor
726826ed 163
10ecf727 164%files -f %{name}.lang
bf1e6952 165%defattr(644,root,root,755)
e0ba0da9 166%doc Changelog
bf1e6952 167%attr(755,root,root) %{_bindir}/clementine
dbbdd85a 168%attr(755,root,root) %{_bindir}/clementine-tagreader
bf1e6952 169%{_desktopdir}/clementine.desktop
7279ad3f 170%{_pixmapsdir}/clementine.png
23f69c7b
BZ
171%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
172%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.067805 seconds and 4 git commands to generate.