]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
- release 4
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2 2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
f2d911f2 3# - apply patches to libprojectM.spec and use
2c687024 4#
5# Conditional build:
c6f8dd12 6%bcond_without static_sqlite # with static sqlite3
3834eb29 7%bcond_with static_projectm # with static projectM
0b056df0 8
3834eb29 9%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 10Summary: A music player and library organiser
df3c0ac1 11Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 12Name: clementine
0ffedb94 13Version: 0.7.1
59fcb599 14Release: 4
bf1e6952
ER
15License: GPL v3 and GPL v2+
16Group: Applications/Multimedia
f823a794 17URL: http://www.clementine-player.org/
bf272879 18Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
0ffedb94 19# Source0-md5: 997f38d6bbd6b2fa9bf587eb89c5c2ec
f823a794 20Patch0: desktop-install.patch
10ecf727 21Patch1: unbundle-po.patch
64d9867e
ER
22BuildRequires: QtCore-devel >= %{qtver}
23BuildRequires: QtDBus-devel >= %{qtver}
24BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 25BuildRequires: QtIOCompressor-devel
64d9867e
ER
26BuildRequires: QtNetwork-devel >= %{qtver}
27BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 28BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
29BuildRequires: QtSql-devel >= %{qtver}
30%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
31BuildRequires: QtXml-devel >= %{qtver}
bf1e6952 32BuildRequires: boost-devel
7279ad3f 33BuildRequires: cmake >= 2.6
f823a794 34#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 35BuildRequires: gettext-devel
f823a794 36%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 37BuildRequires: glib2-devel
849a0dcb 38BuildRequires: gstreamer-devel >= 0.10
bf1e6952 39BuildRequires: gtest-devel
8f83a8c0
ER
40BuildRequires: libgpod-devel >= 0.7.92
41BuildRequires: libimobiledevice-devel
2eedc3b1 42BuildRequires: libindicate-qt-devel
bf1e6952 43BuildRequires: liblastfm-devel
8f83a8c0 44BuildRequires: libmtp-devel
8f83a8c0 45BuildRequires: libplist-devel
f823a794 46%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 47BuildRequires: libqxt-devel
8f83a8c0 48BuildRequires: libxml2-devel
75ec0859 49BuildRequires: pkgconfig
2eedc3b1 50BuildRequires: pkgconfig
64d9867e 51BuildRequires: qt4-build >= %{qtver}
b6199a83 52BuildRequires: qt4-linguist
53BuildRequires: qt4-qmake
7aaa97de 54BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 55BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 56BuildRequires: sed >= 4.0
742e4e0a 57%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 58BuildRequires: taglib-devel >= 1.6
8f83a8c0 59BuildRequires: usbmuxd-devel
726826ed 60Requires(post,postun): desktop-file-utils
23941661
AF
61Requires(post,postun): gtk-update-icon-cache
62Requires(post,postun): hicolor-icon-theme
acb98f48 63Requires: QtSingleApplication >= 2.6-4
64d9867e 64%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
4282eb18 65Requires: gstreamer-audio-effects-base
f2d911f2
ER
66# while we do not link (yet), we use datafiles
67Requires: libprojectM
bf1e6952
ER
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
f2d911f2
ER
70# see libprojectM.spec for explanation
71%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
72
bf1e6952
ER
73%description
74Clementine is a modern music player and library organiser. It is
75largely a port of Amarok 1.4, with some features rewritten to take
76advantage of Qt4.
77
df3c0ac1
ZU
78%description -l hu.UTF-8
79Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
80az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
81a Qt4 előnyeit.
82
bf1e6952 83%prep
bf272879 84%setup -q -n %{name}-%{version}
f2d911f2 85%patch0 -p1
10ecf727 86%patch1 -p1
bf1e6952
ER
87
88# We already don't use these but just to make sure
f2d911f2 89rm -rf 3rdparty/gmock
742e4e0a 90%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
91rm -rf 3rdparty/qtsingleapplication
92rm -rf 3rdparty/qxt
93rm -rf 3rdparty/qtiocompressor
aca708d9 94%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 95
7279ad3f 96# Don't build tests. They require gmock
f2d911f2 97sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
ea86e9d9
BZ
98# remove -Wall
99sed -i -e 's/-Wall//' src/CMakeLists.txt
bf1e6952
ER
100
101%build
102install -d build
7aaa97de 103install -d build/src/translations
bf1e6952 104cd build
88ca6f4b 105%cmake \
f2d911f2 106 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794 107 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
6bcbdfe8 108 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
f823a794
ER
109 -DUSE_SYSTEM_QXT=ON \
110 -DUSE_SYSTEM_PROJECTM=ON \
742e4e0a 111 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 112 ..
bf1e6952
ER
113%{__make}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117%{__make} -C build install \
118 DESTDIR=$RPM_BUILD_ROOT
119
f823a794
ER
120rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
121
10ecf727
ER
122%find_lang %{name} --with-qm
123
23f69c7b
BZ
124install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
125cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
126cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
127
bf1e6952
ER
128%clean
129rm -rf $RPM_BUILD_ROOT
130
726826ed
ER
131%post
132%update_desktop_database_post
2eedc3b1 133%update_icon_cache hicolor
726826ed
ER
134
135%postun
136%update_desktop_database_postun
2eedc3b1 137%update_icon_cache hicolor
726826ed 138
10ecf727 139%files -f %{name}.lang
bf1e6952
ER
140%defattr(644,root,root,755)
141%doc Changelog TODO
142%attr(755,root,root) %{_bindir}/clementine
143%{_desktopdir}/clementine.desktop
7279ad3f 144%{_pixmapsdir}/clementine.png
23f69c7b
BZ
145%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
146%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.063321 seconds and 4 git commands to generate.