]> git.pld-linux.org Git - packages/clementine.git/blame - clementine.spec
update BR, add libspotify bcond
[packages/clementine.git] / clementine.spec
CommitLineData
2c687024 1# TODO:
f2d911f2 2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
f2d911f2 3# - apply patches to libprojectM.spec and use
6b78beb2
ER
4# - Google Drive support (missing Google sparsehash)
5# - package for kde4 stuff (or nuke them):
6# /usr/share/kde4/services/clementine-feed.protocol
7# /usr/share/kde4/services/clementine-itms.protocol
8# /usr/share/kde4/services/clementine-itpc.protocol
9# /usr/share/kde4/services/clementine-zune.protocol
2c687024 10#
11# Conditional build:
c6f8dd12 12%bcond_without static_sqlite # with static sqlite3
3834eb29 13%bcond_with static_projectm # with static projectM
aa506418 14%bcond_with libspotify # build with system libspotify instead of downloading blob
0b056df0 15
064e709c 16%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
bf1e6952 17Summary: A music player and library organiser
df3c0ac1 18Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
bf1e6952 19Name: clementine
dbbdd85a 20Version: 1.1.1
4a572e41 21Release: 6
bf1e6952
ER
22License: GPL v3 and GPL v2+
23Group: Applications/Multimedia
f823a794 24URL: http://www.clementine-player.org/
bf272879 25Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
dbbdd85a 26# Source0-md5: 28e4afb822388bd337a761db8f86febf
f823a794 27Patch0: desktop-install.patch
10ecf727 28Patch1: unbundle-po.patch
4a572e41 29Patch2: %{name}-1.1.1-libimobiledevice-fix.patch
68fe38b0 30Patch3: %{name}-dt_categories.patch
64d9867e
ER
31BuildRequires: QtCore-devel >= %{qtver}
32BuildRequires: QtDBus-devel >= %{qtver}
33BuildRequires: QtGui-devel >= %{qtver}
f2d911f2 34BuildRequires: QtIOCompressor-devel
64d9867e
ER
35BuildRequires: QtNetwork-devel >= %{qtver}
36BuildRequires: QtOpenGL-devel >= %{qtver}
acb98f48 37BuildRequires: QtSingleApplication-devel >= 2.6-4
64d9867e
ER
38BuildRequires: QtSql-devel >= %{qtver}
39%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
40BuildRequires: QtXml-devel >= %{qtver}
7dce7848 41BuildRequires: QtXmlPatterns-devel >= %{qtver}
bf1e6952 42BuildRequires: boost-devel
7279ad3f 43BuildRequires: cmake >= 2.6
f823a794 44#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
75ec0859 45BuildRequires: gettext-devel
f823a794 46%{?with_static_projectm:BuildRequires: glew-devel}
8f83a8c0 47BuildRequires: glib2-devel
dbbdd85a
JK
48BuildRequires: gstreamer0.10-devel
49BuildRequires: gstreamer0.10-plugins-base-devel
bf1e6952 50BuildRequires: gtest-devel
aa506418
ER
51BuildRequires: libcdio-devel
52BuildRequires: libchromaprint-devel
8f83a8c0
ER
53BuildRequires: libgpod-devel >= 0.7.92
54BuildRequires: libimobiledevice-devel
2eedc3b1 55BuildRequires: libindicate-qt-devel
e0ba0da9 56BuildRequires: liblastfm-devel >= 0.3.3
8f83a8c0 57BuildRequires: libmtp-devel
8f83a8c0 58BuildRequires: libplist-devel
f823a794 59%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
bf1e6952 60BuildRequires: libqxt-devel
aa506418 61%{?with_libspotify:BuildRequires: libspotify-devel >= 12.1.45}
8f83a8c0 62BuildRequires: libxml2-devel
75ec0859 63BuildRequires: pkgconfig
2eedc3b1 64BuildRequires: pkgconfig
e0ba0da9 65BuildRequires: protobuf-devel
49968d1b 66BuildRequires: qca-devel
e0ba0da9 67BuildRequires: qjson-devel
64d9867e 68BuildRequires: qt4-build >= %{qtver}
b6199a83 69BuildRequires: qt4-linguist
70BuildRequires: qt4-qmake
7aaa97de 71BuildRequires: rpmbuild(find_lang) >= 1.33
2eedc3b1 72BuildRequires: rpmbuild(macros) >= 1.596
bf1e6952 73BuildRequires: sed >= 4.0
742e4e0a 74%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
f2d911f2 75BuildRequires: taglib-devel >= 1.6
8f83a8c0 76BuildRequires: usbmuxd-devel
726826ed 77Requires(post,postun): desktop-file-utils
23941661
AF
78Requires(post,postun): gtk-update-icon-cache
79Requires(post,postun): hicolor-icon-theme
acb98f48 80Requires: QtSingleApplication >= 2.6-4
64d9867e 81%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
dbbdd85a 82Requires: gstreamer0.10-audio-effects-base
862961b4 83Requires: gstreamer0.10-mad
f2d911f2
ER
84# while we do not link (yet), we use datafiles
85Requires: libprojectM
bf1e6952
ER
86BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
f2d911f2
ER
88# see libprojectM.spec for explanation
89%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
90
bf1e6952
ER
91%description
92Clementine is a modern music player and library organiser. It is
93largely a port of Amarok 1.4, with some features rewritten to take
94advantage of Qt4.
95
df3c0ac1
ZU
96%description -l hu.UTF-8
97Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
98az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
99a Qt4 előnyeit.
100
bf1e6952 101%prep
862961b4 102%setup -q
f2d911f2 103%patch0 -p1
10ecf727 104%patch1 -p1
4a572e41 105%patch2 -p1
68fe38b0 106%patch3 -p1
bf1e6952
ER
107
108# We already don't use these but just to make sure
f2d911f2 109rm -rf 3rdparty/gmock
742e4e0a 110%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
f2d911f2
ER
111rm -rf 3rdparty/qtsingleapplication
112rm -rf 3rdparty/qxt
113rm -rf 3rdparty/qtiocompressor
aca708d9 114%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
bf1e6952 115
7279ad3f 116# Don't build tests. They require gmock
f2d911f2 117sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
ea86e9d9
BZ
118# remove -Wall
119sed -i -e 's/-Wall//' src/CMakeLists.txt
064e709c
JR
120# ...and -Werror
121sed -i -e 's/-Werror//' src/CMakeLists.txt
bf1e6952
ER
122
123%build
124install -d build
7aaa97de 125install -d build/src/translations
bf1e6952 126cd build
6b78beb2
ER
127# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
128CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
88ca6f4b 129%cmake \
f2d911f2 130 -DBUNDLE_PROJECTM_PRESETS=OFF \
f823a794 131 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
862961b4 132 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
f823a794
ER
133 -DUSE_SYSTEM_QXT=ON \
134 -DUSE_SYSTEM_PROJECTM=ON \
742e4e0a 135 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
88ca6f4b 136 ..
bf1e6952
ER
137%{__make}
138
139%install
140rm -rf $RPM_BUILD_ROOT
141%{__make} -C build install \
142 DESTDIR=$RPM_BUILD_ROOT
143
f823a794
ER
144rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
145
dbbdd85a
JK
146# not in our glibc?
147rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
148
10ecf727
ER
149%find_lang %{name} --with-qm
150
23f69c7b
BZ
151install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
152cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
153cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
154
bf1e6952
ER
155%clean
156rm -rf $RPM_BUILD_ROOT
157
726826ed
ER
158%post
159%update_desktop_database_post
2eedc3b1 160%update_icon_cache hicolor
726826ed
ER
161
162%postun
163%update_desktop_database_postun
2eedc3b1 164%update_icon_cache hicolor
726826ed 165
10ecf727 166%files -f %{name}.lang
bf1e6952 167%defattr(644,root,root,755)
e0ba0da9 168%doc Changelog
bf1e6952 169%attr(755,root,root) %{_bindir}/clementine
dbbdd85a 170%attr(755,root,root) %{_bindir}/clementine-tagreader
bf1e6952 171%{_desktopdir}/clementine.desktop
7279ad3f 172%{_pixmapsdir}/clementine.png
23f69c7b
BZ
173%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
174%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.061918 seconds and 4 git commands to generate.