]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
- rel 3; ncursesw detection (wine checks for soname exactly instead of checking if...
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 7%bcond_without ldap # don't build LDAP DLL
16e36f25 8%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
7a30e9d7 9#
546bbb82 10# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
11# libcrypto,libssl (wininet.dll)
12# libcups (winspool.dll.so,wineps.dll.so)
13# libcurses/libncurses (wineconsole program)
14# libfontconfig (gdi32.dll.so)
15# libfreetype (wineps.dll.so,gdi32.dll.so)
16# libGL (x11drv.dll.so,ddraw.dll.so)
e7acaf22 17# libX11, libXext, libXi, libXrender (x11drv.dll.so)
db80a28e 18# libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
546bbb82 19# thus requires rebuild after change of any of the above.
db80a28e 20
4ce8abe1
ER
21# library qualifier in rpm generated deps
22%ifarch %{x8664} ia64 ppc64 s390x sparc64
23%define libqual ()(64bit)
24%else
25%define libqual %{nil}
26%endif
27
beafc810 28%define gecko_ver 1.4
698e86e7 29Summary: Program that lets you launch Win applications
93e41e44
ER
30Summary(es.UTF-8): Ejecuta programas Windows en Linux
31Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
32Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 33Name: wine
da5992aa 34Version: 1.4.1
7acebd3b 35Release: 3
46114a9a 36Epoch: 1
528c1138 37License: LGPL
5c4ec57b 38Group: Applications/Emulators
beafc810 39Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
da5992aa 40# Source0-md5: 0c28702ed478df7a1c097f3a9c4cabd6
beafc810
MM
41Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
42# Source1-md5: 700aaa08724be1992cffed7b87e79a44
43Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
44# Source2-md5: 7b4811f667fd01d300fdff68420a9c72
45Source3: %{name}-uninstaller.desktop
b68a79ec 46Patch0: %{name}-fontcache.patch
a0ff0658 47Patch1: %{name}-makedep.patch
a4a10255 48Patch2: %{name}-ncurses.patch
8b4bf701 49Patch4: %{name}-disable-valgrind.patch
5312a936 50Patch5: %{name}-ca_certificates.patch
84474518 51Patch6: %{name}-manpaths.patch
52Patch7: desktop.patch
62bd6e9a 53Patch8: wine-gnutls.patch
1b3d8891 54URL: http://www.winehq.org/
0aac4f59 55BuildRequires: OpenAL-devel >= 1.1
489ca66c 56BuildRequires: OpenGL-GLU-devel
6547534c
KK
57%{?with_alsa:BuildRequires: alsa-lib-devel}
58%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
59BuildRequires: autoconf
60BuildRequires: automake
d3c41437 61BuildRequires: bison
beafc810 62%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 63%{?with_cups:BuildRequires: cups-devel}
f88a3451 64BuildRequires: docbook-dtd31-sgml
65BuildRequires: docbook-utils
5fc34681 66BuildRequires: flex
16e36f25 67BuildRequires: fontconfig-devel
22432818 68BuildRequires: fontforge
5fc34681 69BuildRequires: freetype-devel >= 2.0.5
16b3dd87 70BuildRequires: fslint
beafc810 71BuildRequires: gettext-devel
734deeec 72BuildRequires: giflib-devel
c57a98fe 73BuildRequires: gnutls-devel
beafc810 74%{?with_gstreamer:BuildRequires: gstreamer-plugins-base-devel}
887fffcf 75BuildRequires: icoutils
beb8121e 76BuildRequires: lcms-devel
beb8121e 77BuildRequires: libgphoto2-devel
d0d61ce7 78BuildRequires: libgsm-devel
c504380e 79BuildRequires: libjpeg-devel
2341e633 80BuildRequires: libmpg123-devel >= 1.5.0
1e160e6e 81BuildRequires: libtool
0aac4f59 82BuildRequires: libv4l-devel
fbb1220c 83BuildRequires: libxslt-devel
8a1d358f 84BuildRequires: ncurses-devel
16e36f25 85# db2* failed previously - probably openjade or opensp bug
db80a28e 86BuildRequires: libpng-devel >= 1.5
16e36f25 87BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 88%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 89BuildRequires: opensp >= 1:1.5.1
2c81f5eb 90BuildRequires: openssl-devel >= 0.9.7d
beb8121e 91BuildRequires: pkgconfig
beafc810 92BuildRequires: prelink
5715e1d1 93%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 94BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 95#BuildRequires: valgrind
beb8121e 96BuildRequires: xorg-lib-libXcomposite-devel
97BuildRequires: xorg-lib-libXcursor-devel
c66c3406 98BuildRequires: xorg-lib-libXi-devel
beb8121e 99BuildRequires: xorg-lib-libXinerama-devel
c66c3406 100BuildRequires: xorg-lib-libXmu-devel
beb8121e 101BuildRequires: xorg-lib-libXrandr-devel
c66c3406 102BuildRequires: xorg-lib-libXrender-devel
103BuildRequires: xorg-lib-libXxf86dga-devel
104BuildRequires: xorg-lib-libXxf86vm-devel
4ce8abe1
ER
105Requires: libfreetype.so.6%{libqual}
106Requires: libpng15.so.15%{libqual}
8df63af6 107Requires(post): /sbin/ldconfig
ae42c99e 108Suggests: binfmt-detector
be70b824 109Suggests: ca-certificates
beafc810 110Suggests: cabextract
a2f68044 111Conflicts: ca-certificates < 20080809-4
b3d3861d 112# for printing needs lpr
113Suggests: cups-clients
f96e197b 114# for winelauncher
3bddfbf2 115Suggests: xorg-app-xmessage
f96e197b 116# for ntlm_auth
14e95129 117Suggests: samba-common >= 1:3.0.25
52b6007b
JB
118# link to wine/ntdll.dll.so, without any SONAME
119Provides: libntdll.dll.so
7212da21 120Obsoletes: wine-doc-pdf
93b34e12 121Obsoletes: wine-drv-arts
beafc810
MM
122Obsoletes: wine-drv-jack
123Obsoletes: wine-drv-nas
f829f028 124ExclusiveArch: %{ix86} %{x8664}
206eed29 125ExcludeArch: i386
0403821a 126BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 127
e8f81a0a 128%define _noautoreqdep libGL.so.1 libGLU.so.1
129%define no_install_post_strip 1
130
e8f81a0a 131%define _winedir %{_datadir}/%{name}
6731627f 132
5c4ec57b 133%description
6731627f 134Wine is a program which allows running Microsoft Windows programs
a519bc4f 135(including DOS, Windows 3.x and Win32 executables) on Unix. It
136consists of a program loader which loads and executes a Microsoft
137Windows binary, and a library that implements Windows API calls using
138their Unix or X11 equivalents. The library may also be used for
139porting Win32 code into native Unix executables.
5c4ec57b 140
c967e47d 141%description -l es.UTF-8
f33a1517 142Ejecuta programas Windows en Linux.
143
c967e47d
JR
144%description -l pl.UTF-8
145Wine jest programem dzięki któremu można uruchamiać programy napisane
146dla Microsoft Windows pod systemami uniksowymi. Składa się on z
147loadera, który pozwala wczytywać i uruchamiać programy w formacie
148Microsoft Windows, oraz z biblioteki, która implementuje API Windows
149przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
150także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 151
c967e47d
JR
152%description -l pt_BR.UTF-8
153O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 154Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 155binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 156chamadas da API para as equivalentes Unix/X11.
157
5c4ec57b 158%package devel
7a050f82 159Summary: Wine - header files
93e41e44
ER
160Summary(es.UTF-8): Biblioteca de desarrollo de wine
161Summary(pl.UTF-8): Wine - pliki nagłowkowe
162Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 163Group: Development/Libraries
46114a9a 164Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 165
5c4ec57b 166%description devel
167Wine - header files.
168
c967e47d 169%description devel -l es.UTF-8
f33a1517 170Biblioteca de desarrollo de wine.
171
c967e47d
JR
172%description devel -l pl.UTF-8
173Wine - pliki nagłówkowe.
5c4ec57b 174
c967e47d
JR
175%description devel -l pt_BR.UTF-8
176Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 177WINE.
178
e8f81a0a 179%package programs
180Summary: Wine - programs
93e41e44 181Summary(pl.UTF-8): Wine - programy
e8f81a0a 182Group: Applications
46114a9a 183Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 184
185%description programs
0a7c5d50 186Wine - programs.
e8f81a0a 187
c967e47d 188%description programs -l pl.UTF-8
0a7c5d50 189Wine - programy.
e8f81a0a 190
beafc810
MM
191%package dll-capi
192Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
193Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
194Group: Applications/Emulators
195Requires: %{name} = %{epoch}:%{version}-%{release}
196
197%description dll-capi
198CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
199
200%description dll-capi -l pl.UTF-8
201Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
202OpenGL).
203
16e36f25
JB
204%package dll-d3d
205Summary: Direct3D implementation DLLs for Wine
93e41e44 206Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 207Group: Applications/Emulators
46114a9a 208Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
209Requires: OpenGL
210
211%description dll-d3d
212Direct3D implementation DLLs for Wine (through OpenGL).
213
c967e47d
JR
214%description dll-d3d -l pl.UTF-8
215Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
216
217%package dll-gl
218Summary: OpenGL implementation DLLs for Wine
93e41e44 219Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 220Group: Applications/Emulators
46114a9a 221Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
222Requires: OpenGL
223
224%description dll-gl
225OpenGL implementation DLLs for Wine.
226
c967e47d
JR
227%description dll-gl -l pl.UTF-8
228Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
229
230%package dll-twain
231Summary: TWAIN implementation DLL for Wine
93e41e44 232Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 233Group: Applications/Emulators
46114a9a 234Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
235
236%description dll-twain
237TWAIN implementation DLL for Wine (through SANE).
238
c967e47d
JR
239%description dll-twain -l pl.UTF-8
240Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 241
9d6715c4 242%package dll-ldap
db80a28e 243Summary: Win32 LDAP API DLL for Wine
9d6715c4
ER
244Group: Applications/Emulators
245Requires: %{name} = %{epoch}:%{version}-%{release}
246
247%description dll-ldap
248Lightweight Directory Access Protocol Library.
249
16e36f25
JB
250%package drv-alsa
251Summary: ALSA driver for WINE mm.dll implementation
93e41e44 252Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 253Group: Applications/Emulators
46114a9a 254Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
255
256%description drv-alsa
257ALSA driver for WINE mm.dll (multimedia system) implementation.
258
c967e47d
JR
259%description drv-alsa -l pl.UTF-8
260Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 261
5c4ec57b 262%prep
db80a28e 263%setup -q
2fbbb535 264%patch0 -p1
265%patch1 -p1
ab25825d 266%patch2 -p1
8b4bf701 267%patch4 -p1
5312a936 268%patch5 -p1
3bfef0cd 269%patch6 -p1
aa3806d3 270%patch7 -p1
62bd6e9a 271%patch8 -p1
591d55ba 272
5c4ec57b 273%build
887fffcf
ER
274icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
275mv -f oic_winlogo_*.png %{name}.png
276
2fbbb535 277%{__autoconf}
103d8328 278%{__autoheader}
9d6a128d 279%configure \
f829f028
AM
280%ifarch %{x8664}
281 --enable-win64 \
282%endif
c504380e 283 --with%{!?with_alsa:out}-alsa \
beafc810 284 --with%{!?with_capi:out}-capi \
beb8121e 285 --with-cms \
d0d61ce7 286 --with-coreaudio \
c504380e 287 --with%{!?with_cups:out}-cups \
c504380e 288 --with-curses \
c504380e 289 --with-fontconfig \
290 --with-freetype \
291 --with-glu \
d0d61ce7 292 --with-gnutls \
beb8121e 293 --with-gphoto \
d0d61ce7 294 --with-gsm \
beafc810 295 --with%{!?with_gstreamer:out}-gstreamer \
c504380e 296 --with-jpeg \
9d6715c4 297 --with%{!?with_ldap:out}-ldap \
d0d61ce7 298 --with-mpg123 \
c504380e 299 --with-opengl \
300 --with-openssl \
301 --with-oss \
302 --with-png \
d0d61ce7 303 --with-pthread \
c504380e 304 --with%{!?with_sane:out}-sane \
beb8121e 305 --with-xcomposite \
306 --with-xcursor \
307 --with-xinerama \
308 --with-xinput \
c504380e 309 --with-xml \
beb8121e 310 --with-xrandr \
c504380e 311 --with-xrender \
312 --with-xshape \
313 --with-xshm \
314 --with-xslt \
beb8121e 315 --with-xxf86vm \
698e86e7 316 --with-x
05eb066b 317%{__make} depend
4aafdd81 318%{__make}
e8f81a0a 319
5c4ec57b 320%install
321rm -rf $RPM_BUILD_ROOT
ffb676e0 322install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
323%{__make} install \
324 DESTDIR=$RPM_BUILD_ROOT
325
16b3dd87
ER
326findup -m $RPM_BUILD_ROOT%{_winedir}/fakedlls
327
887fffcf
ER
328install -p tools/fnt2bdf $RPM_BUILD_ROOT%{_bindir}
329cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 330
2a437456 331install -d \
65c325f6 332 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
333 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 334 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
335 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
336 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
337
a91c2692 338touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
339touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
340touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
341
76055aa1 342cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 343[mci]
344cdaudio=mcicda.drv
345sequencer=mciseq.drv
346waveaudio=mciwave.drv
347avivideo=mciavi.drv
348videodisc=mcipionr.drv
349vcr=mciviscd.drv
350MPEGVideo=mciqtz.drv
5c4ec57b 351EOF
352
80496098 353# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 354
887fffcf
ER
355dir=$(pwd)
356> files.so
357> files.programs
55a96819 358cd $RPM_BUILD_ROOT%{_libdir}/wine
359for f in *.so; do
16e36f25 360 case $f in
beafc810 361 d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wldap32.dll.so)
887fffcf
ER
362 ;;
363 *)
364 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 365 esac
55a96819 366done
367cd -
887fffcf
ER
368
369programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 370for p in $programs; do
8d493411 371 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
372 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 373 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 374 grep -v "$p\.exe\.so$" files.so > files.so.
375 mv -f files.so. files.so
55a96819 376done
55a96819 377
f7357f09 378install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 379%ifnarch %{x8664}
db80a28e 380cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 381%else
db80a28e 382cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 383%endif
f7357f09 384
887fffcf 385install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
386cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
387cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 388
5c4ec57b 389%clean
390rm -rf $RPM_BUILD_ROOT
391
8df63af6 392%post
db80a28e 393/sbin/ldconfig
8df63af6
ER
394%update_desktop_database
395
f1f3af79
JB
396%postun -p /sbin/ldconfig
397
d142aa07 398%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 399rm -f /var/lock/subsys/wine
d142aa07
JB
400if [ -x /sbin/chkconfig ]; then
401 /sbin/chkconfig --del wine
402fi
403
55a96819 404%files -f files.so
5c4ec57b 405%defattr(644,root,root,755)
64ef6fe1 406%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
12b1296e 407%lang(de) %doc documentation/README.de
408%lang(es) %doc documentation/README.es
409%lang(fr) %doc documentation/README.fr
0aac4f59 410%lang(hu) %doc documentation/README.hu
12b1296e 411%lang(it) %doc documentation/README.it
7b9e958b 412%lang(ko) %doc documentation/README.ko
58a0e5f4 413%lang(nb) %doc documentation/README.no
12b1296e 414%lang(pt) %doc documentation/README.pt
74de5921 415%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
416%lang(ru) %doc documentation/README.ru
417%lang(sv) %doc documentation/README.sv
418%lang(tr) %doc documentation/README.tr
82432451 419%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
420%ifnarch %{x8664}
421%attr(755,root,root) %{_bindir}/wine
422%else
423%attr(755,root,root) %{_bindir}/wine64
424%endif
d479f953 425%attr(755,root,root) %{_bindir}/wineboot
55a96819 426%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 427%attr(755,root,root) %{_bindir}/winecfg
beafc810 428%ifnarch %{x8664}
f829f028 429%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
430%else
431%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 432%endif
beafc810 433%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 434%attr(755,root,root) %{_libdir}/*.so*
861238d3 435%dir %{_libdir}/wine
61e39970 436%dir %{_libdir}/wine/fakedlls
437%{_libdir}/wine/fakedlls/*.acm
438%{_libdir}/wine/fakedlls/*.cpl
439%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
440%ifarch %{ix86}
441%{_libdir}/wine/fakedlls/*.dll16
442%endif
61e39970 443%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
444%ifarch %{ix86}
445%{_libdir}/wine/fakedlls/*.drv16
446%endif
61e39970 447%{_libdir}/wine/fakedlls/*.ds
448%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
449%ifarch %{ix86}
450%{_libdir}/wine/fakedlls/*.exe16
451%{_libdir}/wine/fakedlls/*.mod16
452%endif
61e39970 453%{_libdir}/wine/fakedlls/*.ocx
454%{_libdir}/wine/fakedlls/*.sys
455%{_libdir}/wine/fakedlls/*.tlb
f829f028 456%ifarch %{ix86}
61e39970 457%{_libdir}/wine/fakedlls/*.vxd
f829f028 458%endif
b86f1c34 459%{_mandir}/man1/wine.1*
beafc810
MM
460%lang(de) %{_mandir}/de/man1/wine*.1*
461%lang(fr) %{_mandir}/fr/man1/wine*.1*
76656d4f 462#%lang(pl) %{_mandir}/pl/man1/wine*.1*
da274952
AG
463%{_mandir}/man1/msiexec.1*
464%{_mandir}/man1/wineboot.1*
465%{_mandir}/man1/winecfg.1*
72ede285 466%{_mandir}/man1/winedbg.1*
b86f1c34 467%{_mandir}/man1/wineserver.1*
a91c2692 468%{_winedir}
a6c536e0 469%{_desktopdir}/wine.desktop
76055aa1 470%{_desktopdir}/wine-uninstaller.desktop
887fffcf 471%{_pixmapsdir}/%{name}.png
5c4ec57b 472
55a96819 473%files programs -f files.programs
e8f81a0a 474%defattr(644,root,root,755)
e8f81a0a 475
5c4ec57b 476%files devel
477%defattr(644,root,root,755)
d479f953 478%attr(755,root,root) %{_bindir}/fnt2bdf
479%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 480%attr(755,root,root) %{_bindir}/widl
55a96819 481%attr(755,root,root) %{_bindir}/winebuild
55a96819 482%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 483%attr(755,root,root) %{_bindir}/wineg++
d479f953 484%attr(755,root,root) %{_bindir}/winegcc
485%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 486%attr(755,root,root) %{_bindir}/winecpp
55a96819 487%attr(755,root,root) %{_bindir}/wmc
d479f953 488%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
489%{_libdir}/wine/lib*.def
490# no shared variants, so not separated
491%{_libdir}/wine/lib*.def.a
b93e474e 492%{_libdir}/wine/libadsiid.a
7265d9f2 493%{_libdir}/wine/libdx*.a
beafc810 494%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
495%{_libdir}/wine/libstrmiids.a
496%{_libdir}/wine/libuuid.a
497%{_libdir}/wine/libwinecrt0.a
5c4ec57b 498%{_includedir}/wine
34f03014 499%{_mandir}/man1/widl.1*
0aac4f59 500%{_mandir}/man1/winebuild.1*
da274952 501%{_mandir}/man1/winecpp.1*
34f03014 502%{_mandir}/man1/winedump.1*
bff06719 503%{_mandir}/man1/winegcc.1*
5ec7e550 504%{_mandir}/man1/wineg++.1*
34f03014 505%{_mandir}/man1/winemaker.1*
0aac4f59 506%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 507%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
508%{_mandir}/man1/wmc.1*
509%{_mandir}/man1/wrc.1*
2b5050a8 510%{_aclocaldir}/*.m4
f18f723c 511
beafc810
MM
512%files dll-capi
513%defattr(644,root,root,755)
514%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
515
16e36f25
JB
516%files dll-d3d
517%defattr(644,root,root,755)
518%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
519%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
520%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
521
522%files dll-gl
523%defattr(644,root,root,755)
524%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
525%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
526
527%if %{with sane}
528%files dll-twain
529%defattr(644,root,root,755)
b08b16bf 530%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 531%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
532%endif
533
9d6715c4
ER
534%if %{with ldap}
535%files dll-ldap
536%defattr(644,root,root,755)
537%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
538%endif
539
16e36f25
JB
540%if %{with alsa}
541%files drv-alsa
542%defattr(644,root,root,755)
543%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
544%endif
545
16e36f25
JB
546# additional dependencies in *.so not separated (yet?) from main package
547# ddraw.dll.so,x11drv.dll.so depend on X11 libs
548# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
549# ttydrv.dll.so depends on ncurses
This page took 0.313522 seconds and 4 git commands to generate.