]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
compholio patches added for Silverlight / Pipelight
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 7%bcond_without ldap # don't build LDAP DLL
16e36f25 8%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 9%bcond_without netapi # don't use the Samba NetAPI library
6b84df53 10%bcond_without compholio # don't use the compholio patches for Silverlight
7a30e9d7 11#
546bbb82 12# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
13# libcrypto,libssl (wininet.dll)
14# libcups (winspool.dll.so,wineps.dll.so)
15# libcurses/libncurses (wineconsole program)
16# libfontconfig (gdi32.dll.so)
17# libfreetype (wineps.dll.so,gdi32.dll.so)
18# libGL (x11drv.dll.so,ddraw.dll.so)
e7acaf22 19# libX11, libXext, libXi, libXrender (x11drv.dll.so)
db80a28e 20# libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
546bbb82 21# thus requires rebuild after change of any of the above.
db80a28e 22
4ce8abe1
ER
23# library qualifier in rpm generated deps
24%ifarch %{x8664} ia64 ppc64 s390x sparc64
25%define libqual ()(64bit)
26%else
27%define libqual %{nil}
28%endif
29
c516c269 30%define gecko_ver 2.24
6b84df53 31%define compholio_ver %{version}
698e86e7 32Summary: Program that lets you launch Win applications
93e41e44
ER
33Summary(es.UTF-8): Ejecuta programas Windows en Linux
34Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
35Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 36Name: wine
c4aead27
JK
37# 1.6.x – stable
38# 1.7.x – development (DEVEL branch)
c516c269
JK
39Version: 1.7.18
40Release: 0.1
46114a9a 41Epoch: 1
528c1138 42License: LGPL
5c4ec57b 43Group: Applications/Emulators
beafc810 44Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
c516c269 45# Source0-md5: b13c19ef69a99f2aa6c0b3fd08ae8d90
beafc810 46Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
c516c269 47# Source1-md5: 766bb034172f7f0a97443951a02a0df8
beafc810 48Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
c516c269 49# Source2-md5: 1912fd191872c72d5f562283e44e8ab4
beafc810 50Source3: %{name}-uninstaller.desktop
6b84df53
JK
51Source4: https://github.com/compholio/wine-compholio-daily/archive/v%{compholio_ver}/wine-compholio-%{compholio_ver}.tar.gz
52# Source4-md5: 7e5b25b732415112f6d4b9418a2e5945
55061442 53Patch0: %{name}-gphoto2_bool.patch
a0ff0658 54Patch1: %{name}-makedep.patch
a4a10255 55Patch2: %{name}-ncurses.patch
8b4bf701 56Patch4: %{name}-disable-valgrind.patch
5312a936 57Patch5: %{name}-ca_certificates.patch
a26a3859
JK
58Patch6: desktop.patch
59Patch7: %{name}-wine64_man.patch
1b3d8891 60URL: http://www.winehq.org/
0aac4f59 61BuildRequires: OpenAL-devel >= 1.1
d7296a19 62BuildRequires: ocl-icd-libOpenCL-devel
489ca66c 63BuildRequires: OpenGL-GLU-devel
d7296a19 64BuildRequires: Mesa-libOSMesa-devel
6547534c
KK
65%{?with_alsa:BuildRequires: alsa-lib-devel}
66%{?with_arts:BuildRequires: artsc-devel}
6b84df53 67%{?with_compholio:BuildRequires: attr-devel}
c7af491d
JB
68BuildRequires: autoconf
69BuildRequires: automake
d3c41437 70BuildRequires: bison
beafc810 71%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 72%{?with_cups:BuildRequires: cups-devel}
d7296a19 73BuildRequires: dbus-devel
f88a3451 74BuildRequires: docbook-dtd31-sgml
75BuildRequires: docbook-utils
5fc34681 76BuildRequires: flex
16e36f25 77BuildRequires: fontconfig-devel
22432818 78BuildRequires: fontforge
5fc34681 79BuildRequires: freetype-devel >= 2.0.5
16b3dd87 80BuildRequires: fslint
beafc810 81BuildRequires: gettext-devel
734deeec 82BuildRequires: giflib-devel
c57a98fe 83BuildRequires: gnutls-devel
55061442 84%{?with_gstreamer:BuildRequires: gstreamer0.10-plugins-base-devel}
887fffcf 85BuildRequires: icoutils
55061442 86BuildRequires: lcms2-devel
beb8121e 87BuildRequires: libgphoto2-devel
d0d61ce7 88BuildRequires: libgsm-devel
c504380e 89BuildRequires: libjpeg-devel
2341e633 90BuildRequires: libmpg123-devel >= 1.5.0
1e160e6e 91BuildRequires: libtool
0aac4f59 92BuildRequires: libv4l-devel
fbb1220c 93BuildRequires: libxslt-devel
8a1d358f 94BuildRequires: ncurses-devel
16e36f25 95# db2* failed previously - probably openjade or opensp bug
db80a28e 96BuildRequires: libpng-devel >= 1.5
16e36f25 97BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 98%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 99BuildRequires: opensp >= 1:1.5.1
2c81f5eb 100BuildRequires: openssl-devel >= 0.9.7d
beb8121e 101BuildRequires: pkgconfig
beafc810 102BuildRequires: prelink
d7296a19 103BuildRequires: samba-devel
5715e1d1 104%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 105BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 106#BuildRequires: valgrind
beb8121e 107BuildRequires: xorg-lib-libXcomposite-devel
108BuildRequires: xorg-lib-libXcursor-devel
c66c3406 109BuildRequires: xorg-lib-libXi-devel
beb8121e 110BuildRequires: xorg-lib-libXinerama-devel
c66c3406 111BuildRequires: xorg-lib-libXmu-devel
beb8121e 112BuildRequires: xorg-lib-libXrandr-devel
c66c3406 113BuildRequires: xorg-lib-libXrender-devel
114BuildRequires: xorg-lib-libXxf86dga-devel
115BuildRequires: xorg-lib-libXxf86vm-devel
4ce8abe1 116Requires: libfreetype.so.6%{libqual}
a85c8746 117Requires: libpng16.so.16%{libqual}
8df63af6 118Requires(post): /sbin/ldconfig
ae42c99e 119Suggests: binfmt-detector
be70b824 120Suggests: ca-certificates
beafc810 121Suggests: cabextract
a2f68044 122Conflicts: ca-certificates < 20080809-4
b3d3861d 123# for printing needs lpr
124Suggests: cups-clients
f96e197b 125# for winelauncher
3bddfbf2 126Suggests: xorg-app-xmessage
f96e197b 127# for ntlm_auth
14e95129 128Suggests: samba-common >= 1:3.0.25
52b6007b
JB
129# link to wine/ntdll.dll.so, without any SONAME
130Provides: libntdll.dll.so
6b84df53
JK
131%if %{with compholio}
132Provides: wine(compholio) = %{compholio_ver}
133%ifarch %{ix86}
134# Pipelight dependency on x86_64
135Provides: wine(compholio)(32bit) = %{compholio_ver}
136%endif
137%endif
7212da21 138Obsoletes: wine-doc-pdf
93b34e12 139Obsoletes: wine-drv-arts
beafc810
MM
140Obsoletes: wine-drv-jack
141Obsoletes: wine-drv-nas
f829f028 142ExclusiveArch: %{ix86} %{x8664}
206eed29 143ExcludeArch: i386
0403821a 144BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 145
e8f81a0a 146%define _noautoreqdep libGL.so.1 libGLU.so.1
147%define no_install_post_strip 1
148
e8f81a0a 149%define _winedir %{_datadir}/%{name}
6731627f 150
5c4ec57b 151%description
6731627f 152Wine is a program which allows running Microsoft Windows programs
a519bc4f 153(including DOS, Windows 3.x and Win32 executables) on Unix. It
154consists of a program loader which loads and executes a Microsoft
155Windows binary, and a library that implements Windows API calls using
156their Unix or X11 equivalents. The library may also be used for
157porting Win32 code into native Unix executables.
5c4ec57b 158
c967e47d 159%description -l es.UTF-8
f33a1517 160Ejecuta programas Windows en Linux.
161
c967e47d
JR
162%description -l pl.UTF-8
163Wine jest programem dzięki któremu można uruchamiać programy napisane
164dla Microsoft Windows pod systemami uniksowymi. Składa się on z
165loadera, który pozwala wczytywać i uruchamiać programy w formacie
166Microsoft Windows, oraz z biblioteki, która implementuje API Windows
167przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
168także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 169
c967e47d
JR
170%description -l pt_BR.UTF-8
171O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 172Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 173binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 174chamadas da API para as equivalentes Unix/X11.
175
5c4ec57b 176%package devel
7a050f82 177Summary: Wine - header files
93e41e44
ER
178Summary(es.UTF-8): Biblioteca de desarrollo de wine
179Summary(pl.UTF-8): Wine - pliki nagłowkowe
180Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 181Group: Development/Libraries
46114a9a 182Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 183
5c4ec57b 184%description devel
185Wine - header files.
186
c967e47d 187%description devel -l es.UTF-8
f33a1517 188Biblioteca de desarrollo de wine.
189
c967e47d
JR
190%description devel -l pl.UTF-8
191Wine - pliki nagłówkowe.
5c4ec57b 192
c967e47d
JR
193%description devel -l pt_BR.UTF-8
194Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 195WINE.
196
e8f81a0a 197%package programs
198Summary: Wine - programs
93e41e44 199Summary(pl.UTF-8): Wine - programy
e8f81a0a 200Group: Applications
46114a9a 201Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 202
203%description programs
0a7c5d50 204Wine - programs.
e8f81a0a 205
c967e47d 206%description programs -l pl.UTF-8
0a7c5d50 207Wine - programy.
e8f81a0a 208
beafc810
MM
209%package dll-capi
210Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
211Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
212Group: Applications/Emulators
213Requires: %{name} = %{epoch}:%{version}-%{release}
214
215%description dll-capi
216CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
217
218%description dll-capi -l pl.UTF-8
219Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
220OpenGL).
221
16e36f25
JB
222%package dll-d3d
223Summary: Direct3D implementation DLLs for Wine
93e41e44 224Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 225Group: Applications/Emulators
46114a9a 226Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
227Requires: OpenGL
228
229%description dll-d3d
230Direct3D implementation DLLs for Wine (through OpenGL).
231
c967e47d
JR
232%description dll-d3d -l pl.UTF-8
233Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
234
235%package dll-gl
236Summary: OpenGL implementation DLLs for Wine
93e41e44 237Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 238Group: Applications/Emulators
46114a9a 239Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
240Requires: OpenGL
241
242%description dll-gl
243OpenGL implementation DLLs for Wine.
244
c967e47d
JR
245%description dll-gl -l pl.UTF-8
246Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
247
248%package dll-twain
249Summary: TWAIN implementation DLL for Wine
93e41e44 250Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 251Group: Applications/Emulators
46114a9a 252Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
253
254%description dll-twain
255TWAIN implementation DLL for Wine (through SANE).
256
c967e47d
JR
257%description dll-twain -l pl.UTF-8
258Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 259
9d6715c4 260%package dll-ldap
db80a28e 261Summary: Win32 LDAP API DLL for Wine
9d6715c4
ER
262Group: Applications/Emulators
263Requires: %{name} = %{epoch}:%{version}-%{release}
264
265%description dll-ldap
266Lightweight Directory Access Protocol Library.
267
16e36f25
JB
268%package drv-alsa
269Summary: ALSA driver for WINE mm.dll implementation
93e41e44 270Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 271Group: Applications/Emulators
46114a9a 272Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
273
274%description drv-alsa
275ALSA driver for WINE mm.dll (multimedia system) implementation.
276
c967e47d
JR
277%description drv-alsa -l pl.UTF-8
278Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 279
5c4ec57b 280%prep
6b84df53 281%setup -q -a4
2fbbb535 282%patch0 -p1
283%patch1 -p1
ab25825d 284%patch2 -p1
8b4bf701 285%patch4 -p1
5312a936 286%patch5 -p1
3bfef0cd 287%patch6 -p1
f6cf693b 288%ifarch %{x8664}
a26a3859 289%patch7 -p1
f6cf693b 290%endif
591d55ba 291
6b84df53
JK
292%if %{with compholio}
293# binary patch that doesn't apply
294# and real Arial may be installed through fonts-TTF-microsoft
295rm -r wine-compholio-*/patches/10-Missing_Fonts
296
297for patch in wine-compholio-*/patches/*/*.patch ; do
298 patch -N -p0 --strip=1 < "${patch}"
299# wine-compholio-*/debian/tools/gitapply.sh < "${patch}"
300done
301%endif
302
5c4ec57b 303%build
887fffcf
ER
304icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
305mv -f oic_winlogo_*.png %{name}.png
306
6b84df53
JK
307%if %{with compholio}
308tools/make_requests
309%endif
310
2fbbb535 311%{__autoconf}
103d8328 312%{__autoheader}
9d6a128d 313%configure \
f829f028
AM
314%ifarch %{x8664}
315 --enable-win64 \
316%endif
c504380e 317 --with%{!?with_alsa:out}-alsa \
beafc810 318 --with%{!?with_capi:out}-capi \
beb8121e 319 --with-cms \
d0d61ce7 320 --with-coreaudio \
c504380e 321 --with%{!?with_cups:out}-cups \
c504380e 322 --with-curses \
d7296a19 323 --with-dbus \
c504380e 324 --with-fontconfig \
325 --with-freetype \
d7296a19 326 --with-gphoto \
c504380e 327 --with-glu \
d0d61ce7 328 --with-gnutls \
d0d61ce7 329 --with-gsm \
beafc810 330 --with%{!?with_gstreamer:out}-gstreamer \
d7296a19 331 --without-hal \
c504380e 332 --with-jpeg \
9d6715c4 333 --with%{!?with_ldap:out}-ldap \
d0d61ce7 334 --with-mpg123 \
d7296a19
JK
335 --with%{!?with_netapi:out}-netapi \
336 --with-openal \
337 --with-opencl \
c504380e 338 --with-opengl \
339 --with-openssl \
d7296a19 340 --with-osmesa \
c504380e 341 --with-oss \
342 --with-png \
d0d61ce7 343 --with-pthread \
c504380e 344 --with%{!?with_sane:out}-sane \
d7296a19
JK
345 --with-tiff \
346 --with-v4l \
beb8121e 347 --with-xcomposite \
348 --with-xcursor \
349 --with-xinerama \
350 --with-xinput \
d7296a19 351 --with-xinput2 \
c504380e 352 --with-xml \
beb8121e 353 --with-xrandr \
c504380e 354 --with-xrender \
355 --with-xshape \
356 --with-xshm \
357 --with-xslt \
beb8121e 358 --with-xxf86vm \
d7296a19
JK
359 --with-x \
360 --with-zlib
05eb066b 361%{__make} depend
4aafdd81 362%{__make}
e8f81a0a 363
5c4ec57b 364%install
365rm -rf $RPM_BUILD_ROOT
ffb676e0 366install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
367%{__make} install \
368 DESTDIR=$RPM_BUILD_ROOT
369
a26a3859 370install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 371cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 372
2a437456 373install -d \
65c325f6 374 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
375 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 376 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
377 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
378 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
379
a91c2692 380touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
381touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
382touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
383
76055aa1 384cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 385[mci]
386cdaudio=mcicda.drv
387sequencer=mciseq.drv
388waveaudio=mciwave.drv
389avivideo=mciavi.drv
390videodisc=mcipionr.drv
391vcr=mciviscd.drv
392MPEGVideo=mciqtz.drv
5c4ec57b 393EOF
394
80496098 395# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 396
887fffcf
ER
397dir=$(pwd)
398> files.so
399> files.programs
55a96819 400cd $RPM_BUILD_ROOT%{_libdir}/wine
401for f in *.so; do
16e36f25 402 case $f in
ad4623a1 403 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
404 ;;
405 *)
406 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 407 esac
55a96819 408done
409cd -
887fffcf
ER
410
411programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 412for p in $programs; do
8d493411 413 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
414 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 415 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 416 grep -v "$p\.exe\.so$" files.so > files.so.
417 mv -f files.so. files.so
55a96819 418done
55a96819 419
a26a3859
JK
420for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
421 mv "$dir" "${dir%.UTF-8}"
422done
423
f6cf693b
JK
424%ifarch %{x8664}
425for langdir in "" de/ fr/ pl/ ; do
426mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
427done
428%endif
429
f7357f09 430install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 431%ifnarch %{x8664}
db80a28e 432cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 433%else
db80a28e 434cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 435%endif
f7357f09 436
887fffcf 437install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
438cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
439cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 440
5c4ec57b 441%clean
442rm -rf $RPM_BUILD_ROOT
443
8df63af6 444%post
db80a28e 445/sbin/ldconfig
8df63af6
ER
446%update_desktop_database
447
f1f3af79
JB
448%postun -p /sbin/ldconfig
449
d142aa07 450%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 451rm -f /var/lock/subsys/wine
d142aa07
JB
452if [ -x /sbin/chkconfig ]; then
453 /sbin/chkconfig --del wine
454fi
455
55a96819 456%files -f files.so
5c4ec57b 457%defattr(644,root,root,755)
47bd64d5 458%doc README AUTHORS ANNOUNCE
12b1296e 459%lang(de) %doc documentation/README.de
460%lang(es) %doc documentation/README.es
461%lang(fr) %doc documentation/README.fr
0aac4f59 462%lang(hu) %doc documentation/README.hu
12b1296e 463%lang(it) %doc documentation/README.it
7b9e958b 464%lang(ko) %doc documentation/README.ko
58a0e5f4 465%lang(nb) %doc documentation/README.no
12b1296e 466%lang(pt) %doc documentation/README.pt
74de5921 467%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
468%lang(ru) %doc documentation/README.ru
469%lang(sv) %doc documentation/README.sv
470%lang(tr) %doc documentation/README.tr
82432451 471%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
472%ifnarch %{x8664}
473%attr(755,root,root) %{_bindir}/wine
474%else
475%attr(755,root,root) %{_bindir}/wine64
476%endif
d479f953 477%attr(755,root,root) %{_bindir}/wineboot
55a96819 478%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 479%attr(755,root,root) %{_bindir}/winecfg
beafc810 480%ifnarch %{x8664}
f829f028 481%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
482%else
483%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 484%endif
beafc810 485%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 486%attr(755,root,root) %{_libdir}/*.so*
861238d3 487%dir %{_libdir}/wine
61e39970 488%dir %{_libdir}/wine/fakedlls
489%{_libdir}/wine/fakedlls/*.acm
490%{_libdir}/wine/fakedlls/*.cpl
491%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
492%ifarch %{ix86}
493%{_libdir}/wine/fakedlls/*.dll16
494%endif
61e39970 495%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
496%ifarch %{ix86}
497%{_libdir}/wine/fakedlls/*.drv16
498%endif
61e39970 499%{_libdir}/wine/fakedlls/*.ds
500%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
501%ifarch %{ix86}
502%{_libdir}/wine/fakedlls/*.exe16
503%{_libdir}/wine/fakedlls/*.mod16
504%endif
61e39970 505%{_libdir}/wine/fakedlls/*.ocx
506%{_libdir}/wine/fakedlls/*.sys
507%{_libdir}/wine/fakedlls/*.tlb
f829f028 508%ifarch %{ix86}
61e39970 509%{_libdir}/wine/fakedlls/*.vxd
f829f028 510%endif
f6cf693b 511%ifnarch %{x8664}
b86f1c34 512%{_mandir}/man1/wine.1*
47bd64d5
JK
513%lang(de) %{_mandir}/de/man1/wine.1*
514%lang(fr) %{_mandir}/fr/man1/wine.1*
515%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
516%else
517%{_mandir}/man1/wine64.1*
518%lang(de) %{_mandir}/de/man1/wine64.1*
519%lang(fr) %{_mandir}/fr/man1/wine64.1*
520%lang(pl) %{_mandir}/pl/man1/wine64.1*
521%endif
da274952
AG
522%{_mandir}/man1/msiexec.1*
523%{_mandir}/man1/wineboot.1*
524%{_mandir}/man1/winecfg.1*
72ede285 525%{_mandir}/man1/winedbg.1*
b86f1c34 526%{_mandir}/man1/wineserver.1*
ad4623a1
AM
527%lang(de) %{_mandir}/de/man1/wineserver.1*
528%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 529%{_winedir}
a6c536e0 530%{_desktopdir}/wine.desktop
76055aa1 531%{_desktopdir}/wine-uninstaller.desktop
887fffcf 532%{_pixmapsdir}/%{name}.png
5c4ec57b 533
55a96819 534%files programs -f files.programs
e8f81a0a 535%defattr(644,root,root,755)
e8f81a0a 536
5c4ec57b 537%files devel
538%defattr(644,root,root,755)
a26a3859 539%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 540%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 541%attr(755,root,root) %{_bindir}/widl
55a96819 542%attr(755,root,root) %{_bindir}/winebuild
55a96819 543%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 544%attr(755,root,root) %{_bindir}/wineg++
d479f953 545%attr(755,root,root) %{_bindir}/winegcc
546%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 547%attr(755,root,root) %{_bindir}/winecpp
55a96819 548%attr(755,root,root) %{_bindir}/wmc
d479f953 549%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
550%{_libdir}/wine/lib*.def
551# no shared variants, so not separated
552%{_libdir}/wine/lib*.def.a
b93e474e 553%{_libdir}/wine/libadsiid.a
7265d9f2 554%{_libdir}/wine/libdx*.a
beafc810 555%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
556%{_libdir}/wine/libstrmiids.a
557%{_libdir}/wine/libuuid.a
558%{_libdir}/wine/libwinecrt0.a
5c4ec57b 559%{_includedir}/wine
34f03014 560%{_mandir}/man1/widl.1*
0aac4f59 561%{_mandir}/man1/winebuild.1*
da274952 562%{_mandir}/man1/winecpp.1*
34f03014 563%{_mandir}/man1/winedump.1*
bff06719 564%{_mandir}/man1/winegcc.1*
5ec7e550 565%{_mandir}/man1/wineg++.1*
34f03014 566%{_mandir}/man1/winemaker.1*
0aac4f59 567%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 568%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
569%{_mandir}/man1/wmc.1*
570%{_mandir}/man1/wrc.1*
2b5050a8 571%{_aclocaldir}/*.m4
f18f723c 572
beafc810
MM
573%files dll-capi
574%defattr(644,root,root,755)
575%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
576
16e36f25
JB
577%files dll-d3d
578%defattr(644,root,root,755)
579%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
580%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
581%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
582
583%files dll-gl
584%defattr(644,root,root,755)
585%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
586%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
587
588%if %{with sane}
589%files dll-twain
590%defattr(644,root,root,755)
b08b16bf 591%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 592%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
593%endif
594
9d6715c4
ER
595%if %{with ldap}
596%files dll-ldap
597%defattr(644,root,root,755)
598%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
599%endif
600
16e36f25
JB
601%if %{with alsa}
602%files drv-alsa
603%defattr(644,root,root,755)
604%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
605%endif
606
16e36f25
JB
607# additional dependencies in *.so not separated (yet?) from main package
608# ddraw.dll.so,x11drv.dll.so depend on X11 libs
609# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
610# ttydrv.dll.so depends on ncurses
This page took 0.221227 seconds and 4 git commands to generate.