]> git.pld-linux.org Git - packages/wine.git/blame - wine.spec
builds now
[packages/wine.git] / wine.spec
CommitLineData
7a30e9d7 1#
2# Conditional build:
931f130b 3%bcond_without alsa # don't build ALSA mm driver
beafc810
MM
4%bcond_without capi # don't build CAPI 2.0 (ISDN) support
5%bcond_without gstreamer # don't build GStreamer filters support
16e36f25 6%bcond_without sane # don't build TWAIN DLL with scanning support (through SANE)
9d6715c4 7%bcond_without ldap # don't build LDAP DLL
16e36f25 8%bcond_without cups # without CUPS printing support in winspool,wineps DLLs
d7296a19 9%bcond_without netapi # don't use the Samba NetAPI library
7a30e9d7 10#
546bbb82 11# NOTE: wine detects the following SONAMES for dlopen at build time:
16e36f25
JB
12# libcrypto,libssl (wininet.dll)
13# libcups (winspool.dll.so,wineps.dll.so)
14# libcurses/libncurses (wineconsole program)
15# libfontconfig (gdi32.dll.so)
16# libfreetype (wineps.dll.so,gdi32.dll.so)
17# libGL (x11drv.dll.so,ddraw.dll.so)
e7acaf22 18# libX11, libXext, libXi, libXrender (x11drv.dll.so)
db80a28e 19# libpng (windowscodecs.dll: SONAME_LIBPNG in dlls/windowscodecs/pngformat.c)
546bbb82 20# thus requires rebuild after change of any of the above.
db80a28e 21
4ce8abe1
ER
22# library qualifier in rpm generated deps
23%ifarch %{x8664} ia64 ppc64 s390x sparc64
24%define libqual ()(64bit)
25%else
26%define libqual %{nil}
27%endif
28
c516c269 29%define gecko_ver 2.24
698e86e7 30Summary: Program that lets you launch Win applications
93e41e44
ER
31Summary(es.UTF-8): Ejecuta programas Windows en Linux
32Summary(pl.UTF-8): Program pozwalający uruchamiać aplikacje Windows
33Summary(pt_BR.UTF-8): Executa programas Windows no Linux
5c4ec57b 34Name: wine
c4aead27
JK
35# 1.6.x – stable
36# 1.7.x – development (DEVEL branch)
c516c269
JK
37Version: 1.7.18
38Release: 0.1
46114a9a 39Epoch: 1
528c1138 40License: LGPL
5c4ec57b 41Group: Applications/Emulators
beafc810 42Source0: http://downloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
c516c269 43# Source0-md5: b13c19ef69a99f2aa6c0b3fd08ae8d90
beafc810 44Source1: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86.msi
c516c269 45# Source1-md5: 766bb034172f7f0a97443951a02a0df8
beafc810 46Source2: http://downloads.sourceforge.net/wine/%{name}_gecko-%{gecko_ver}-x86_64.msi
c516c269 47# Source2-md5: 1912fd191872c72d5f562283e44e8ab4
beafc810 48Source3: %{name}-uninstaller.desktop
55061442 49Patch0: %{name}-gphoto2_bool.patch
a0ff0658 50Patch1: %{name}-makedep.patch
a4a10255 51Patch2: %{name}-ncurses.patch
8b4bf701 52Patch4: %{name}-disable-valgrind.patch
5312a936 53Patch5: %{name}-ca_certificates.patch
a26a3859
JK
54Patch6: desktop.patch
55Patch7: %{name}-wine64_man.patch
1b3d8891 56URL: http://www.winehq.org/
0aac4f59 57BuildRequires: OpenAL-devel >= 1.1
d7296a19 58BuildRequires: ocl-icd-libOpenCL-devel
489ca66c 59BuildRequires: OpenGL-GLU-devel
d7296a19 60BuildRequires: Mesa-libOSMesa-devel
6547534c
KK
61%{?with_alsa:BuildRequires: alsa-lib-devel}
62%{?with_arts:BuildRequires: artsc-devel}
c7af491d
JB
63BuildRequires: autoconf
64BuildRequires: automake
d3c41437 65BuildRequires: bison
beafc810 66%{?with_capi:BuildRequires: capi4k-utils-devel}
5715e1d1 67%{?with_cups:BuildRequires: cups-devel}
d7296a19 68BuildRequires: dbus-devel
f88a3451 69BuildRequires: docbook-dtd31-sgml
70BuildRequires: docbook-utils
5fc34681 71BuildRequires: flex
16e36f25 72BuildRequires: fontconfig-devel
22432818 73BuildRequires: fontforge
5fc34681 74BuildRequires: freetype-devel >= 2.0.5
16b3dd87 75BuildRequires: fslint
beafc810 76BuildRequires: gettext-devel
734deeec 77BuildRequires: giflib-devel
c57a98fe 78BuildRequires: gnutls-devel
55061442 79%{?with_gstreamer:BuildRequires: gstreamer0.10-plugins-base-devel}
887fffcf 80BuildRequires: icoutils
55061442 81BuildRequires: lcms2-devel
beb8121e 82BuildRequires: libgphoto2-devel
d0d61ce7 83BuildRequires: libgsm-devel
c504380e 84BuildRequires: libjpeg-devel
2341e633 85BuildRequires: libmpg123-devel >= 1.5.0
1e160e6e 86BuildRequires: libtool
0aac4f59 87BuildRequires: libv4l-devel
fbb1220c 88BuildRequires: libxslt-devel
8a1d358f 89BuildRequires: ncurses-devel
16e36f25 90# db2* failed previously - probably openjade or opensp bug
db80a28e 91BuildRequires: libpng-devel >= 1.5
16e36f25 92BuildRequires: openjade >= 1:1.3.3-0.pre1
9d6715c4 93%{?with_ldap:BuildRequires: openldap-devel}
16e36f25 94BuildRequires: opensp >= 1:1.5.1
2c81f5eb 95BuildRequires: openssl-devel >= 0.9.7d
beb8121e 96BuildRequires: pkgconfig
beafc810 97BuildRequires: prelink
d7296a19 98BuildRequires: samba-devel
5715e1d1 99%{?with_sane:BuildRequires: sane-backends-devel}
7057f2e9 100BuildRequires: unixODBC-devel >= 2.2.12-2
8b4bf701 101#BuildRequires: valgrind
beb8121e 102BuildRequires: xorg-lib-libXcomposite-devel
103BuildRequires: xorg-lib-libXcursor-devel
c66c3406 104BuildRequires: xorg-lib-libXi-devel
beb8121e 105BuildRequires: xorg-lib-libXinerama-devel
c66c3406 106BuildRequires: xorg-lib-libXmu-devel
beb8121e 107BuildRequires: xorg-lib-libXrandr-devel
c66c3406 108BuildRequires: xorg-lib-libXrender-devel
109BuildRequires: xorg-lib-libXxf86dga-devel
110BuildRequires: xorg-lib-libXxf86vm-devel
4ce8abe1 111Requires: libfreetype.so.6%{libqual}
a85c8746 112Requires: libpng16.so.16%{libqual}
8df63af6 113Requires(post): /sbin/ldconfig
ae42c99e 114Suggests: binfmt-detector
be70b824 115Suggests: ca-certificates
beafc810 116Suggests: cabextract
a2f68044 117Conflicts: ca-certificates < 20080809-4
b3d3861d 118# for printing needs lpr
119Suggests: cups-clients
f96e197b 120# for winelauncher
3bddfbf2 121Suggests: xorg-app-xmessage
f96e197b 122# for ntlm_auth
14e95129 123Suggests: samba-common >= 1:3.0.25
52b6007b
JB
124# link to wine/ntdll.dll.so, without any SONAME
125Provides: libntdll.dll.so
7212da21 126Obsoletes: wine-doc-pdf
93b34e12 127Obsoletes: wine-drv-arts
beafc810
MM
128Obsoletes: wine-drv-jack
129Obsoletes: wine-drv-nas
f829f028 130ExclusiveArch: %{ix86} %{x8664}
206eed29 131ExcludeArch: i386
0403821a 132BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
5c4ec57b 133
e8f81a0a 134%define _noautoreqdep libGL.so.1 libGLU.so.1
135%define no_install_post_strip 1
136
e8f81a0a 137%define _winedir %{_datadir}/%{name}
6731627f 138
5c4ec57b 139%description
6731627f 140Wine is a program which allows running Microsoft Windows programs
a519bc4f 141(including DOS, Windows 3.x and Win32 executables) on Unix. It
142consists of a program loader which loads and executes a Microsoft
143Windows binary, and a library that implements Windows API calls using
144their Unix or X11 equivalents. The library may also be used for
145porting Win32 code into native Unix executables.
5c4ec57b 146
c967e47d 147%description -l es.UTF-8
f33a1517 148Ejecuta programas Windows en Linux.
149
c967e47d
JR
150%description -l pl.UTF-8
151Wine jest programem dzięki któremu można uruchamiać programy napisane
152dla Microsoft Windows pod systemami uniksowymi. Składa się on z
153loadera, który pozwala wczytywać i uruchamiać programy w formacie
154Microsoft Windows, oraz z biblioteki, która implementuje API Windows
155przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
156także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
5c4ec57b 157
c967e47d
JR
158%description -l pt_BR.UTF-8
159O Wine é um programa que permite rodar programas MS-Windows no X11.
f33a1517 160Ele consiste de um carregador de programa, que carrega e executa um
c967e47d 161binário MS-Windows, e de uma biblioteca de emulação que traduz as
f33a1517 162chamadas da API para as equivalentes Unix/X11.
163
5c4ec57b 164%package devel
7a050f82 165Summary: Wine - header files
93e41e44
ER
166Summary(es.UTF-8): Biblioteca de desarrollo de wine
167Summary(pl.UTF-8): Wine - pliki nagłowkowe
168Summary(pt_BR.UTF-8): Biblioteca de desenvolvimento do wine
7a050f82 169Group: Development/Libraries
46114a9a 170Requires: %{name} = %{epoch}:%{version}-%{release}
6ab2e9fc 171
5c4ec57b 172%description devel
173Wine - header files.
174
c967e47d 175%description devel -l es.UTF-8
f33a1517 176Biblioteca de desarrollo de wine.
177
c967e47d
JR
178%description devel -l pl.UTF-8
179Wine - pliki nagłówkowe.
5c4ec57b 180
c967e47d
JR
181%description devel -l pt_BR.UTF-8
182Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
f33a1517 183WINE.
184
e8f81a0a 185%package programs
186Summary: Wine - programs
93e41e44 187Summary(pl.UTF-8): Wine - programy
e8f81a0a 188Group: Applications
46114a9a 189Requires: %{name} = %{epoch}:%{version}-%{release}
e8f81a0a 190
191%description programs
0a7c5d50 192Wine - programs.
e8f81a0a 193
c967e47d 194%description programs -l pl.UTF-8
0a7c5d50 195Wine - programy.
e8f81a0a 196
beafc810
MM
197%package dll-capi
198Summary: CAPI 2.0 (ISDN) implementation DLLs for Wine
199Summary(pl.UTF-8): Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine
200Group: Applications/Emulators
201Requires: %{name} = %{epoch}:%{version}-%{release}
202
203%description dll-capi
204CAPI 2.0 (ISDN) implementation DLLs for Wine (through OpenGL).
205
206%description dll-capi -l pl.UTF-8
207Biblioteki DLL z implementacją CAPI 2.0 (ISDN) dla Wine (poprzez
208OpenGL).
209
16e36f25
JB
210%package dll-d3d
211Summary: Direct3D implementation DLLs for Wine
93e41e44 212Summary(pl.UTF-8): Biblioteki DLL z implementacją Direct3D dla Wine
16e36f25 213Group: Applications/Emulators
46114a9a 214Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
215Requires: OpenGL
216
217%description dll-d3d
218Direct3D implementation DLLs for Wine (through OpenGL).
219
c967e47d
JR
220%description dll-d3d -l pl.UTF-8
221Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
16e36f25
JB
222
223%package dll-gl
224Summary: OpenGL implementation DLLs for Wine
93e41e44 225Summary(pl.UTF-8): Biblioteki DLL z implementacją OpenGL dla Wine
16e36f25 226Group: Applications/Emulators
46114a9a 227Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
228Requires: OpenGL
229
230%description dll-gl
231OpenGL implementation DLLs for Wine.
232
c967e47d
JR
233%description dll-gl -l pl.UTF-8
234Biblioteki DLL z implementacją OpenGL dla Wine.
16e36f25
JB
235
236%package dll-twain
237Summary: TWAIN implementation DLL for Wine
93e41e44 238Summary(pl.UTF-8): Biblioteka DLL z implementacją TWAIN dla Wine
16e36f25 239Group: Applications/Emulators
46114a9a 240Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
241
242%description dll-twain
243TWAIN implementation DLL for Wine (through SANE).
244
c967e47d
JR
245%description dll-twain -l pl.UTF-8
246Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
16e36f25 247
9d6715c4 248%package dll-ldap
db80a28e 249Summary: Win32 LDAP API DLL for Wine
9d6715c4
ER
250Group: Applications/Emulators
251Requires: %{name} = %{epoch}:%{version}-%{release}
252
253%description dll-ldap
254Lightweight Directory Access Protocol Library.
255
16e36f25
JB
256%package drv-alsa
257Summary: ALSA driver for WINE mm.dll implementation
93e41e44 258Summary(pl.UTF-8): Sterownik ALSA dla implementacji mm.dll w Wine
16e36f25 259Group: Applications/Emulators
46114a9a 260Requires: %{name} = %{epoch}:%{version}-%{release}
16e36f25
JB
261
262%description drv-alsa
263ALSA driver for WINE mm.dll (multimedia system) implementation.
264
c967e47d
JR
265%description drv-alsa -l pl.UTF-8
266Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
16e36f25 267
5c4ec57b 268%prep
db80a28e 269%setup -q
2fbbb535 270%patch0 -p1
271%patch1 -p1
ab25825d 272%patch2 -p1
8b4bf701 273%patch4 -p1
5312a936 274%patch5 -p1
3bfef0cd 275%patch6 -p1
f6cf693b 276%ifarch %{x8664}
a26a3859 277%patch7 -p1
f6cf693b 278%endif
591d55ba 279
5c4ec57b 280%build
887fffcf
ER
281icotool -x --width=32 --height=32 --bit-depth=32 -o . dlls/user32/resources/oic_winlogo.ico
282mv -f oic_winlogo_*.png %{name}.png
283
2fbbb535 284%{__autoconf}
103d8328 285%{__autoheader}
9d6a128d 286%configure \
f829f028
AM
287%ifarch %{x8664}
288 --enable-win64 \
289%endif
c504380e 290 --with%{!?with_alsa:out}-alsa \
beafc810 291 --with%{!?with_capi:out}-capi \
beb8121e 292 --with-cms \
d0d61ce7 293 --with-coreaudio \
c504380e 294 --with%{!?with_cups:out}-cups \
c504380e 295 --with-curses \
d7296a19 296 --with-dbus \
c504380e 297 --with-fontconfig \
298 --with-freetype \
d7296a19 299 --with-gphoto \
c504380e 300 --with-glu \
d0d61ce7 301 --with-gnutls \
d0d61ce7 302 --with-gsm \
beafc810 303 --with%{!?with_gstreamer:out}-gstreamer \
d7296a19 304 --without-hal \
c504380e 305 --with-jpeg \
9d6715c4 306 --with%{!?with_ldap:out}-ldap \
d0d61ce7 307 --with-mpg123 \
d7296a19
JK
308 --with%{!?with_netapi:out}-netapi \
309 --with-openal \
310 --with-opencl \
c504380e 311 --with-opengl \
312 --with-openssl \
d7296a19 313 --with-osmesa \
c504380e 314 --with-oss \
315 --with-png \
d0d61ce7 316 --with-pthread \
c504380e 317 --with%{!?with_sane:out}-sane \
d7296a19
JK
318 --with-tiff \
319 --with-v4l \
beb8121e 320 --with-xcomposite \
321 --with-xcursor \
322 --with-xinerama \
323 --with-xinput \
d7296a19 324 --with-xinput2 \
c504380e 325 --with-xml \
beb8121e 326 --with-xrandr \
c504380e 327 --with-xrender \
328 --with-xshape \
329 --with-xshm \
330 --with-xslt \
beb8121e 331 --with-xxf86vm \
d7296a19
JK
332 --with-x \
333 --with-zlib
05eb066b 334%{__make} depend
4aafdd81 335%{__make}
e8f81a0a 336
5c4ec57b 337%install
338rm -rf $RPM_BUILD_ROOT
ffb676e0 339install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
c7af491d
JB
340%{__make} install \
341 DESTDIR=$RPM_BUILD_ROOT
342
a26a3859 343install -p tools/sfnt2fon/sfnt2fon $RPM_BUILD_ROOT%{_bindir}
887fffcf 344cp -a aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
0b87866b 345
2a437456 346install -d \
65c325f6 347 $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
348 "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
a91c2692 349 $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
350 $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
351 $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
352
a91c2692 353touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
354touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
355touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
356
76055aa1 357cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
a91c2692 358[mci]
359cdaudio=mcicda.drv
360sequencer=mciseq.drv
361waveaudio=mciwave.drv
362avivideo=mciavi.drv
363videodisc=mcipionr.drv
364vcr=mciviscd.drv
365MPEGVideo=mciqtz.drv
5c4ec57b 366EOF
367
80496098 368# /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
5c4ec57b 369
887fffcf
ER
370dir=$(pwd)
371> files.so
372> files.programs
55a96819 373cd $RPM_BUILD_ROOT%{_libdir}/wine
374for f in *.so; do
16e36f25 375 case $f in
ad4623a1 376 capi2032.dll.so|d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|wined3d.dll.so|wldap32.dll.so)
887fffcf
ER
377 ;;
378 *)
379 echo "%attr(755,root,root) %{_libdir}/wine/$f" >> $dir/files.so
16e36f25 380 esac
55a96819 381done
382cd -
887fffcf
ER
383
384programs="notepad regedit regsvr32 wineconsole winefile winemine winepath"
2f6853f9 385for p in $programs; do
8d493411 386 echo "%attr(755,root,root) %{_bindir}/$p" >> files.programs
387 echo "%attr(755,root,root) %{_libdir}/wine/$p.exe.so" >> files.programs
da274952 388 echo "%{_mandir}/man1/$p.1*" >> files.programs
8d493411 389 grep -v "$p\.exe\.so$" files.so > files.so.
390 mv -f files.so. files.so
55a96819 391done
55a96819 392
a26a3859
JK
393for dir in $RPM_BUILD_ROOT%{_mandir}/*.UTF-8 ; do
394 mv "$dir" "${dir%.UTF-8}"
395done
396
f6cf693b
JK
397%ifarch %{x8664}
398for langdir in "" de/ fr/ pl/ ; do
399mv $RPM_BUILD_ROOT%{_mandir}/${langdir}man1/{wine,wine64}.1
400done
401%endif
402
f7357f09 403install -d $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 404%ifnarch %{x8664}
db80a28e 405cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 406%else
db80a28e 407cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_winedir}/gecko
beafc810 408%endif
f7357f09 409
887fffcf 410install -d $RPM_BUILD_ROOT%{_pixmapsdir}
db80a28e
ER
411cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
412cp -p %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
76055aa1 413
5c4ec57b 414%clean
415rm -rf $RPM_BUILD_ROOT
416
8df63af6 417%post
db80a28e 418/sbin/ldconfig
8df63af6
ER
419%update_desktop_database
420
f1f3af79
JB
421%postun -p /sbin/ldconfig
422
d142aa07 423%triggerpostun -- wine < 1:0.9.12-1.9
ccb219e0 424rm -f /var/lock/subsys/wine
d142aa07
JB
425if [ -x /sbin/chkconfig ]; then
426 /sbin/chkconfig --del wine
427fi
428
55a96819 429%files -f files.so
5c4ec57b 430%defattr(644,root,root,755)
47bd64d5 431%doc README AUTHORS ANNOUNCE
12b1296e 432%lang(de) %doc documentation/README.de
433%lang(es) %doc documentation/README.es
434%lang(fr) %doc documentation/README.fr
0aac4f59 435%lang(hu) %doc documentation/README.hu
12b1296e 436%lang(it) %doc documentation/README.it
7b9e958b 437%lang(ko) %doc documentation/README.ko
58a0e5f4 438%lang(nb) %doc documentation/README.no
12b1296e 439%lang(pt) %doc documentation/README.pt
74de5921 440%lang(pt_BR) %doc documentation/README.pt_br
0aac4f59
KK
441%lang(ru) %doc documentation/README.ru
442%lang(sv) %doc documentation/README.sv
443%lang(tr) %doc documentation/README.tr
82432451 444%attr(755,root,root) %{_bindir}/msiexec
beafc810
MM
445%ifnarch %{x8664}
446%attr(755,root,root) %{_bindir}/wine
447%else
448%attr(755,root,root) %{_bindir}/wine64
449%endif
d479f953 450%attr(755,root,root) %{_bindir}/wineboot
55a96819 451%attr(755,root,root) %{_bindir}/winedbg
0aac4f59 452%attr(755,root,root) %{_bindir}/winecfg
beafc810 453%ifnarch %{x8664}
f829f028 454%attr(755,root,root) %{_bindir}/wine-preloader
beafc810
MM
455%else
456%attr(755,root,root) %{_bindir}/wine64-preloader
f829f028 457%endif
beafc810 458%attr(755,root,root) %{_bindir}/wineserver
8a1d358f 459%attr(755,root,root) %{_libdir}/*.so*
861238d3 460%dir %{_libdir}/wine
61e39970 461%dir %{_libdir}/wine/fakedlls
462%{_libdir}/wine/fakedlls/*.acm
463%{_libdir}/wine/fakedlls/*.cpl
464%{_libdir}/wine/fakedlls/*.dll
beafc810
MM
465%ifarch %{ix86}
466%{_libdir}/wine/fakedlls/*.dll16
467%endif
61e39970 468%{_libdir}/wine/fakedlls/*.drv
beafc810
MM
469%ifarch %{ix86}
470%{_libdir}/wine/fakedlls/*.drv16
471%endif
61e39970 472%{_libdir}/wine/fakedlls/*.ds
473%{_libdir}/wine/fakedlls/*.exe
beafc810
MM
474%ifarch %{ix86}
475%{_libdir}/wine/fakedlls/*.exe16
476%{_libdir}/wine/fakedlls/*.mod16
477%endif
61e39970 478%{_libdir}/wine/fakedlls/*.ocx
479%{_libdir}/wine/fakedlls/*.sys
480%{_libdir}/wine/fakedlls/*.tlb
f829f028 481%ifarch %{ix86}
61e39970 482%{_libdir}/wine/fakedlls/*.vxd
f829f028 483%endif
f6cf693b 484%ifnarch %{x8664}
b86f1c34 485%{_mandir}/man1/wine.1*
47bd64d5
JK
486%lang(de) %{_mandir}/de/man1/wine.1*
487%lang(fr) %{_mandir}/fr/man1/wine.1*
488%lang(pl) %{_mandir}/pl/man1/wine.1*
f6cf693b
JK
489%else
490%{_mandir}/man1/wine64.1*
491%lang(de) %{_mandir}/de/man1/wine64.1*
492%lang(fr) %{_mandir}/fr/man1/wine64.1*
493%lang(pl) %{_mandir}/pl/man1/wine64.1*
494%endif
da274952
AG
495%{_mandir}/man1/msiexec.1*
496%{_mandir}/man1/wineboot.1*
497%{_mandir}/man1/winecfg.1*
72ede285 498%{_mandir}/man1/winedbg.1*
b86f1c34 499%{_mandir}/man1/wineserver.1*
ad4623a1
AM
500%lang(de) %{_mandir}/de/man1/wineserver.1*
501%lang(fr) %{_mandir}/fr/man1/wineserver.1*
a91c2692 502%{_winedir}
a6c536e0 503%{_desktopdir}/wine.desktop
76055aa1 504%{_desktopdir}/wine-uninstaller.desktop
887fffcf 505%{_pixmapsdir}/%{name}.png
5c4ec57b 506
55a96819 507%files programs -f files.programs
e8f81a0a 508%defattr(644,root,root,755)
e8f81a0a 509
5c4ec57b 510%files devel
511%defattr(644,root,root,755)
a26a3859 512%attr(755,root,root) %{_bindir}/sfnt2fon
d479f953 513%attr(755,root,root) %{_bindir}/function_grep.pl
d479f953 514%attr(755,root,root) %{_bindir}/widl
55a96819 515%attr(755,root,root) %{_bindir}/winebuild
55a96819 516%attr(755,root,root) %{_bindir}/winedump
1ae1bca2 517%attr(755,root,root) %{_bindir}/wineg++
d479f953 518%attr(755,root,root) %{_bindir}/winegcc
519%attr(755,root,root) %{_bindir}/winemaker
9a9c7643 520%attr(755,root,root) %{_bindir}/winecpp
55a96819 521%attr(755,root,root) %{_bindir}/wmc
d479f953 522%attr(755,root,root) %{_bindir}/wrc
7265d9f2
JB
523%{_libdir}/wine/lib*.def
524# no shared variants, so not separated
525%{_libdir}/wine/lib*.def.a
b93e474e 526%{_libdir}/wine/libadsiid.a
7265d9f2 527%{_libdir}/wine/libdx*.a
beafc810 528%{_libdir}/wine/libstrmbase.a
7265d9f2
JB
529%{_libdir}/wine/libstrmiids.a
530%{_libdir}/wine/libuuid.a
531%{_libdir}/wine/libwinecrt0.a
5c4ec57b 532%{_includedir}/wine
34f03014 533%{_mandir}/man1/widl.1*
0aac4f59 534%{_mandir}/man1/winebuild.1*
da274952 535%{_mandir}/man1/winecpp.1*
34f03014 536%{_mandir}/man1/winedump.1*
bff06719 537%{_mandir}/man1/winegcc.1*
5ec7e550 538%{_mandir}/man1/wineg++.1*
34f03014 539%{_mandir}/man1/winemaker.1*
0aac4f59 540%lang(de) %{_mandir}/de/man1/winemaker.1*
6ebf503e 541%lang(fr) %{_mandir}/fr/man1/winemaker.1*
34f03014
JB
542%{_mandir}/man1/wmc.1*
543%{_mandir}/man1/wrc.1*
2b5050a8 544%{_aclocaldir}/*.m4
f18f723c 545
beafc810
MM
546%files dll-capi
547%defattr(644,root,root,755)
548%attr(755,root,root) %{_libdir}/wine/capi2032.dll.so
549
16e36f25
JB
550%files dll-d3d
551%defattr(644,root,root,755)
552%attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
553%attr(755,root,root) %{_libdir}/wine/d3d9.dll.so
16e36f25
JB
554%attr(755,root,root) %{_libdir}/wine/wined3d.dll.so
555
556%files dll-gl
557%defattr(644,root,root,755)
558%attr(755,root,root) %{_libdir}/wine/glu32.dll.so
559%attr(755,root,root) %{_libdir}/wine/opengl32.dll.so
560
561%if %{with sane}
562%files dll-twain
563%defattr(644,root,root,755)
b08b16bf 564%attr(755,root,root) %{_libdir}/wine/sane.ds.so
72878a4c 565%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
16e36f25
JB
566%endif
567
9d6715c4
ER
568%if %{with ldap}
569%files dll-ldap
570%defattr(644,root,root,755)
571%attr(755,root,root) %{_libdir}/wine/wldap*.dll.so
572%endif
573
16e36f25
JB
574%if %{with alsa}
575%files drv-alsa
576%defattr(644,root,root,755)
577%attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
578%endif
579
16e36f25
JB
580# additional dependencies in *.so not separated (yet?) from main package
581# ddraw.dll.so,x11drv.dll.so depend on X11 libs
582# ole2disp.dll.so,oleaut32.dll.so,typelib.dll.so depend on lib(un)gif,libjpeg,libX11
583# ttydrv.dll.so depends on ncurses
This page took 0.17117 seconds and 4 git commands to generate.