]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
up to 1.69.0
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
fc3be51a 21# To bootstrap from scratch, set the channel and date from src/stage0.json
e361528e
ER
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
80e24d19 24%define bootstrap_rust 1.68.2
aea1d260 25%define bootstrap_cargo %{bootstrap_rust}
80e24d19 26%define bootstrap_date 2023-03-28
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
80e24d19 39Version: 1.69.0
4079dca2 40Release: 1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
80e24d19 45# Source0-md5: 2fac6c46422e743f5f05287e89e72f22
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
80e24d19 47# Source1-md5: b82ae74e630a849d6675b93ddf0ed6ca
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
80e24d19 49# Source2-md5: a2affbb1e831228c71f972a270717ce3
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
80e24d19 51# Source3-md5: 489073dd8a8380c28a570bf70c9fbd6e
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
80e24d19 53# Source4-md5: bb43d3fca2893f2de0b892e0f4a8fdb3
ad044650 54Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
80e24d19 55# Source5-md5: 5691b194302d66b40c3e4eee0eeb1813
a3e679e4 56Patch0: llvm-tools-install.patch
e361528e 57URL: https://www.rust-lang.org/
e8f16183
JB
58# for src/compiler-rt
59BuildRequires: cmake >= 3.4.3
e361528e 60BuildRequires: curl
dba8190b
JP
61%ifarch %{arm} %{mips32} %{ppc}
62BuildRequires: libatomic-devel
63%endif
2eb30149
JB
64# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
65BuildRequires: procps
e65d284f
JP
66BuildRequires: python3
67BuildRequires: python3-modules
fc3be51a 68BuildRequires: rpm-build >= 4.6
2eb30149
JB
69BuildRequires: rpmbuild(macros) >= 1.752
70%if %{without cross}
8f176645 71BuildRequires: curl-devel
8745efaa 72BuildRequires: libgit2-devel >= 1.4.0
d1b96fd8 73BuildRequires: libstdc++-devel
2cec66d3 74%if %{with system_llvm}
80e24d19
JP
75BuildRequires: llvm >= 14.0
76BuildRequires: llvm-devel >= 14.0
2cec66d3 77%endif
7da6653d 78BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
79BuildRequires: tar >= 1:1.22
80BuildRequires: xz
79a067de 81BuildRequires: xz-devel
e361528e 82BuildRequires: zlib-devel
2eb30149 83%endif
e361528e 84%if %{without bootstrap}
d6d4cb2b 85BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 86BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 87BuildConflicts: %{name} > %{version}
e361528e 88%endif
2eb30149 89%ifarch x32
cd0c1484
JR
90BuildRequires: glibc-devel(x86-64)
91BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
92%if "%{_host_cpu}" == "x86_64"
93# building on x86_64 host with --target x32-pld-linux
8f176645 94BuildRequires: curl-devel
2eb30149 95BuildRequires: gcc-multilib-x32
8745efaa 96BuildRequires: libgit2-devel >= 1.4.0
2eb30149 97BuildRequires: libstdc++-devel
80e24d19 98%{?with_system_llvm:BuildRequires: llvm-devel >= 14.0}
2eb30149 99BuildRequires: openssl-devel >= 1.0.1
79a067de 100BuildRequires: xz-devel
2eb30149
JB
101BuildRequires: zlib-devel
102%else
103# building x86_64-hosted crosscompiler on x32 host
56b25e8b 104BuildRequires: curl-devel(x86-64)
cd0c1484 105BuildRequires: curl-devel(x86-x32)
2eb30149 106BuildRequires: gcc-multilib-64
8745efaa
JP
107BuildRequires: libgit2-devel(x86-64) >= 1.4.0
108BuildRequires: libgit2-devel(x86-x32) >= 1.4.0
2eb30149 109BuildRequires: libstdc++-multilib-64-devel
cd0c1484 110%if %{with system_llvm}
80e24d19
JP
111BuildRequires: llvm-devel(x86-64) >= 14.0
112BuildRequires: llvm-devel(x86-x32) >= 14.0
cd0c1484 113%endif
56b25e8b 114BuildRequires: openssl-devel(x86-64)
cd0c1484 115BuildRequires: openssl-devel(x86-x32)
79a067de
JP
116BuildRequires: xz-devel(x86-64)
117BuildRequires: xz-devel(x86-x32)
56b25e8b 118BuildRequires: zlib-devel(x86-64)
cd0c1484 119BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
120%endif
121%endif
e361528e
ER
122# The C compiler is needed at runtime just for linking. Someday rustc might
123# invoke the linker directly, and then we'll only need binutils.
124# https://github.com/rust-lang/rust/issues/11937
125Requires: gcc
cd0c1484
JR
126Requires: %{name}-std%{?_isa} = %{version}-%{release}
127%ifarch x32
128Requires: %{name}-std(x86-64) = %{version}-%{release}
417178e1 129Requires: gcc-multilib-64
cd0c1484 130%endif
80e24d19 131Obsoletes: rust-analysis < 1.69.0
e361528e 132# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 133# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 134# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 135ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 136BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 137
e064fbd0 138%ifarch x32
badbe44d 139%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 140%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 141%define rust_bootstrap_triple x86_64-unknown-linux-gnu
a973dc7e
JR
142# libs in _libdir are x86_64 64bit
143%define _lib lib64
144%define _libdir %{_prefix}/lib64
e064fbd0 145%else
ad044650 146%ifarch armv6hl
1fe729c8
JP
147%define rust_triple arm-unknown-linux-gnueabihf
148%define rust_host_triple %{rust_triple}
149%define rust_bootstrap_triple %{rust_triple}
150%else
ad044650
JP
151%ifarch armv7hl armv7hnl
152%define rust_triple armv7-unknown-linux-gnueabihf
153%define rust_host_triple %{rust_triple}
154%define rust_bootstrap_triple %{rust_triple}
6c4856ce 155%define rust_suppl_targets thumbv7neon-unknown-linux-gnueabihf
ad044650 156%else
badbe44d 157%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
158%define rust_host_triple %{rust_triple}
159%define rust_bootstrap_triple %{rust_triple}
e064fbd0 160%endif
1fe729c8 161%endif
ad044650 162%endif
e361528e 163
62473c95
JP
164%define rust_targets %rust_triple %{?rust_suppl_targets}
165
e361528e 166%if %{without bootstrap}
8a073211 167%define local_rust_root %{_prefix}
e361528e 168%else
badbe44d 169%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 170%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
171%endif
172
18a1004b
JR
173# We're going to override --libdir when configuring to get rustlib into a
174# common path, but we'll fix the shared libraries during install.
5b9d67b0 175# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
176# for non-bootstrap build, lib64 is just too complicated for it.
177%define common_libdir %{_prefix}/lib
178%define rustlibdir %{common_libdir}/rustlib
179
19f98749 180# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 181%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 182
e361528e 183# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
184%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
185%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 186
37765656
JP
187%define x_py { \
188 x_py() { \
189 local cmd="$1"; \
190 shift; \
e65d284f 191 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
37765656
JP
192 }; x_py }
193
194
e361528e
ER
195%description
196Rust is a systems programming language that runs blazingly fast,
197prevents segfaults, and guarantees thread safety.
198
199This package includes the Rust compiler, standard library, and
200documentation generator.
201
e8f16183
JB
202%description -l pl.UTF-8
203Rust to systemowy język programowania działający bardzo szybko,
204zapobiegający naruszeniom ochrony pamięci i gwarantujący
205bezpieczną wielowątkowość.
206
cd0c1484
JR
207%package std
208Summary: Standard library for Rust
209Summary(pl.UTF-8): Standardowa biblioteka Rusta
210Group: Development/Tools
89a1e043 211Requires: %{name} = %{version}-%{release}
cd0c1484
JR
212
213%description std
214Standard library for Rust.
215
216%description std -l pl.UTF-8
217Standardowa biblioteka Rusta.
218
f397d93b 219%package analyzer
4079dca2
JP
220Summary: Implementation of Language Server Protocol for Rust
221Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
222Group: Development/Tools
223Requires: %{name} = %{version}-%{release}
224Obsoletes: rust-rls < 1.65.0
f397d93b
JP
225
226%description analyzer
227Implementation of Language Server Protocol for Rust.
228
229%description analyzer -l pl.UTF-8
230Implementacja Language Server Protocol dla Rusta.
231
d1b96fd8
JR
232%package debugger-common
233Summary: Common debugger pretty printers for Rust
e8f16183 234Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 235Group: Development/Debuggers
e67020b3 236BuildArch: noarch
d1b96fd8
JR
237
238%description debugger-common
e8f16183
JB
239This package includes the common functionality for rust-gdb and
240rust-lldb.
241
242%description debugger-common -l pl.UTF-8
243Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 244
e361528e
ER
245%package gdb
246Summary: GDB pretty printers for Rust
e8f16183 247Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
248Group: Development/Debuggers
249Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 250Requires: gdb
e67020b3 251BuildArch: noarch
e361528e
ER
252
253%description gdb
254This package includes the rust-gdb script, which allows easier
255debugging of Rust programs.
256
e8f16183
JB
257%description gdb -l pl.UTF-8
258Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
259odpluskwianie programów w języku Rust.
260
d1b96fd8
JR
261%package lldb
262Summary: LLDB pretty printers for Rust
e8f16183 263Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
264Group: Development/Debuggers
265Requires: %{name}-debugger-common = %{version}-%{release}
266Requires: lldb
e67020b3 267BuildArch: noarch
d1b96fd8
JR
268
269%description lldb
270This package includes the rust-lldb script, which allows easier
271debugging of Rust programs.
272
e8f16183
JB
273%description lldb -l pl.UTF-8
274Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
275odpluskwianie programów w języku Rust.
276
e361528e
ER
277%package doc
278Summary: Documentation for Rust
e8f16183 279Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 280Group: Documentation
e67020b3 281BuildArch: noarch
e361528e
ER
282
283%description doc
284This package includes HTML documentation for the Rust programming
285language and its standard library.
286
e8f16183
JB
287%description doc -l pl.UTF-8
288Ten pakiet zawiera dokumentację w formacie HTML do języka
289programowania Rust i jego biblioteki standardowej.
290
8a758d34
JP
291%package -n cargo
292Summary: Rust's package manager and build tool
293Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
294Group: Development/Tools
cd0c1484 295Requires: %{name}%{?_isa}
8a758d34
JP
296
297%description -n cargo
298Cargo is a tool that allows Rust projects to declare their various
299dependencies and ensure that you'll always get a repeatable build.
300
301%description -n cargo -l pl.UTF-8
302Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
303zależności i zapewniające powtarzalność procesu budowania.
304
6ed79af8
JB
305%package -n bash-completion-cargo
306Summary: Bash completion for cargo command
307Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
308Group: Applications/Shells
309Requires: %{name} = %{version}-%{release}
310Requires: bash-completion
449de7a9 311BuildArch: noarch
6ed79af8
JB
312
313%description -n bash-completion-cargo
314Bash completion for cargo command.
315
316%description -n bash-completion-cargo -l pl.UTF-8
317Bashowe dopełnianie parametrów polecenia cargo.
318
8a758d34
JP
319%package -n zsh-completion-cargo
320Summary: Zsh completion for cargo command
321Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
322Group: Applications/Shells
323Requires: %{name} = %{version}-%{release}
6ed79af8 324Requires: zsh
166962a5 325BuildArch: noarch
8a758d34
JP
326
327%description -n zsh-completion-cargo
328Zsh completion for cargo command.
329
330%description -n zsh-completion-cargo -l pl.UTF-8
331Dopełnianie parametrów polecenia cargo w powłoce Zsh.
332
e361528e
ER
333%prep
334%setup -q -n %{rustc_package}
80e24d19 335%patch0 -p1
b5eceb5e 336
e361528e 337%if %{with bootstrap}
a1735efb 338%ifarch %{x8664} x32
e361528e
ER
339tar xf %{SOURCE1}
340%endif
341%ifarch %{ix86}
342tar xf %{SOURCE2}
343%endif
c160f211 344%ifarch aarch64
9eb0511e 345tar xf %{SOURCE3}
c160f211 346%endif
ad044650 347%ifarch armv6hl
1fe729c8
JP
348tar xf %{SOURCE4}
349%endif
ad044650
JP
350%ifarch armv7hl armv7hnl
351tar xf %{SOURCE5}
352%endif
d6d4cb2b
JR
353%{__mv} %{bootstrap_root} %{bootstrap_root}-root
354%{bootstrap_root}-root/install.sh \
badbe44d 355 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
356 --prefix=%{local_rust_root} \
357 --disable-ldconfig
358test -f %{local_rust_root}/bin/cargo
e361528e
ER
359test -f %{local_rust_root}/bin/rustc
360%endif
361
362# unbundle
d4b51567 363# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 364#%{__rm} -r src/jemalloc
9e7854c5
JP
365%if %{with system_llvm}
366%{__rm} -r src/llvm-project
367mkdir -p src/llvm-project/libunwind
368%endif
e361528e 369
e361528e
ER
370# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
371sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
372 src/etc/rust-gdb
373
4b354bd7
JB
374# cargo has hardcoded libexec path - honour rpm _libexecdir
375%if "%{_libexecdir}" != "%{_prefix}/libexec"
376suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
377%{__sed} -i -e 's,"libexec","'${suffix}'",' \
378 src/bootstrap/dist.rs \
379 src/tools/cargo/src/cargo/ops/registry/auth.rs
380%{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
381%endif
382
5ee06aa0
JR
383# The configure macro will modify some autoconf-related files, which upsets
384# cargo when it tries to verify checksums in those files. If we just truncate
385# that file list, cargo won't have anything to complain about.
fe49e3fc 386find vendor -name .cargo-checksum.json \
5ee06aa0 387 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 388
e361528e 389%build
863a59ff
JP
390export CC="%{__cc}"
391export CXX="%{__cxx}"
392export AR="%{__ar}"
e361528e 393%configure \
2eb30149
JB
394 --build=%{rust_bootstrap_triple} \
395 --host=%{rust_host_triple} \
62473c95 396 --target="%(echo %rust_targets | tr ' ' ,)" \
18a1004b 397 --libdir=%{common_libdir} \
e8f16183 398 --disable-codegen-tests \
5ee06aa0 399 --disable-debuginfo-lines \
5b9d67b0 400%if %{with full_debuginfo}
5ee06aa0 401 --disable-debuginfo-only-std \
e361528e 402 --enable-debuginfo \
5b9d67b0
JB
403%else
404 --enable-debuginfo-only-std \
405 --disable-debuginfo \
406%endif
6ed79af8
JB
407 --disable-jemalloc \
408 --disable-option-checking \
409 --disable-rpath \
8a758d34 410 --enable-extended \
e8f16183 411 --enable-llvm-link-shared \
d6d4cb2b 412 --enable-vendor \
6ed79af8 413 --local-rust-root=%{local_rust_root} \
e8f16183 414 --llvm-root=%{_prefix} \
595dfba2
JP
415 --release-channel=%{channel} \
416 --set=llvm.static-libstdcpp=false
e361528e 417
37765656
JP
418export RUST_BACKTRACE=full
419%x_py dist --verbose
e361528e 420
37765656 421%{?with_tests:%x_py test}
8a073211 422
e361528e
ER
423%install
424rm -rf $RPM_BUILD_ROOT
e361528e 425
13ab0532
JP
426export CC="%{__cc}"
427export CXX="%{__cxx}"
428export AR="%{__ar}"
37765656
JP
429export DESTDIR=$RPM_BUILD_ROOT
430%x_py install
e361528e 431
18a1004b
JR
432# Make sure the shared libraries are in the proper libdir
433%if "%{_libdir}" != "%{common_libdir}"
434mkdir -p %{buildroot}%{_libdir}
435find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
436 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
437%endif
438
d1b96fd8 439# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
440find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
441
d1b96fd8
JR
442# The libdir libraries are identical to those under rustlib/. It's easier on
443# library loading if we keep them in libdir, but we do need them in rustlib/
444# to support dynamic linking for compiler plugins, so we'll symlink.
62473c95
JP
445for rust_target in %rust_targets; do
446 for l in libstd libtest ; do
447 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
448 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
449 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
450 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
451 fi
452 done
a973dc7e 453done
d1b96fd8
JR
454
455# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 456find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
457
458# FIXME: __os_install_post will strip the rlibs
459# -- should we find a way to preserve debuginfo?
460
461# Remove unwanted documentation files (we already package them)
e8f16183
JB
462%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
463%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
464%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
465%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
466
467# Sanitize the HTML documentation
468find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
469find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
470
471# Move rust-gdb's python scripts so they're noarch
472install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 473%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 474
4f353dba
JR
475# We don't need stdlib source
476%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
477
1dd26160
JP
478# Create the path for crate-devel packages
479install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
480
e361528e
ER
481%clean
482rm -rf $RPM_BUILD_ROOT
483
484%post -p /sbin/ldconfig
485%postun -p /sbin/ldconfig
486
487%files
488%defattr(644,root,root,755)
16ea23d8 489%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
1736a047 490%attr(755,root,root) %{_bindir}/rust-demangler
e361528e
ER
491%attr(755,root,root) %{_bindir}/rustc
492%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 493%attr(755,root,root) %{_bindir}/rustfmt
a973dc7e 494%attr(755,root,root) %{_libdir}/librustc_driver-*.so
e8f16183 495%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 496%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
497%{_mandir}/man1/rustc.1*
498%{_mandir}/man1/rustdoc.1*
18a1004b 499%dir %{rustlibdir}
cd0c1484 500
cd0c1484
JR
501%files std
502%defattr(644,root,root,755)
62473c95
JP
503%(for rust_target in %rust_targets; do
504cat <<EOF
505%dir %{rustlibdir}/$rust_target
506%dir %{rustlibdir}/$rust_target/lib
507%attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
508%{rustlibdir}/$rust_target/lib/*.rlib
509EOF
510done
511)
e361528e 512
f397d93b
JP
513%files analyzer
514%defattr(644,root,root,755)
515%attr(755,root,root) %{_bindir}/rust-analyzer
516%attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
517
d1b96fd8
JR
518%files debugger-common
519%defattr(644,root,root,755)
520%dir %{_datadir}/%{name}
521%dir %{_datadir}/%{name}/etc
5aae056c
JP
522%{_datadir}/%{name}/etc/lldb_commands
523%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
524
525%files lldb
526%defattr(644,root,root,755)
527%attr(755,root,root) %{_bindir}/rust-lldb
528%{_datadir}/%{name}/etc/lldb_*.py*
529
e361528e
ER
530%files gdb
531%defattr(644,root,root,755)
532%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 533%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 534%{_datadir}/%{name}/etc/gdb_*.py*
e361528e
ER
535
536%files doc
537%defattr(644,root,root,755)
538%dir %{_docdir}/%{name}
d1b96fd8 539%doc %{_docdir}/%{name}/html
8a758d34
JP
540
541%files -n cargo
542%defattr(644,root,root,755)
543%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
544%attr(755,root,root) %{_bindir}/cargo-clippy
545%attr(755,root,root) %{_bindir}/cargo-fmt
546%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 547%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
548%{_mandir}/man1/cargo*.1*
549%dir %{_datadir}/cargo
550%dir %{_datadir}/cargo/registry
551
552%files -n bash-completion-cargo
553%defattr(644,root,root,755)
554%{_sysconfdir}/bash_completion.d/cargo
555
556%files -n zsh-completion-cargo
557%defattr(644,root,root,755)
558%{zsh_compdir}/_cargo
This page took 0.497097 seconds and 4 git commands to generate.