]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
Revert "rpm4 noarch", PLD uses rpm5 since 2012, stop adding this cruft
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
e361528e
ER
4#
5# Conditional build:
8a073211 6%bcond_with bootstrap
cace5bf9 7%bcond_with tests # build without tests
e361528e 8
8a073211
JR
9# The channel can be stable, beta, or nightly
10%define channel stable
11
e361528e 12%if "%{channel}" == "stable"
8a073211 13%define rustc_package rustc-%{version}-src
e361528e 14%else
8a073211 15%define rustc_package rustc-%{channel}-src
e361528e
ER
16%endif
17
18# To bootstrap from scratch, set the channel and date from src/stage0.txt
19# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
20# or nightly wants some beta-YYYY-MM-DD
8a073211
JR
21%define bootstrap_rust 1.17.0
22%define bootstrap_cargo 0.18.0
23%define bootstrap_date 2017-04-27
e361528e
ER
24
25Summary: The Rust Programming Language
26Name: rust
d6d4cb2b 27Version: 1.18.0
c9b8e3ee 28Release: 2
d1b96fd8 29# Licenses: (rust itself) and (bundled libraries)
e361528e 30License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
e361528e 31Group: Development/Languages
d6d4cb2b
JR
32Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
33# Source0-md5: c37c0cd9d500f6a9d1f2f44401351f88
8a073211 34Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.gz
d6d4cb2b 35# Source1-md5: 98e8f479515969123b4c203191104a54
8a073211 36Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.gz
d6d4cb2b 37# Source2-md5: 2d5de850c32aa8d40c8c21abacf749f8
b5eceb5e 38Patch0: rust-1.16.0-configure-no-override.patch
e361528e
ER
39URL: https://www.rust-lang.org/
40BuildRequires: cmake
41BuildRequires: curl
42BuildRequires: gcc
43BuildRequires: libstdc++-devel
d1b96fd8 44BuildRequires: libstdc++-devel
e361528e 45BuildRequires: llvm-devel
d1b96fd8 46BuildRequires: ncurses-devel
e361528e
ER
47BuildRequires: python
48BuildRequires: zlib-devel
49%if %{without bootstrap}
d6d4cb2b 50BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 51BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 52BuildConflicts: %{name} > %{version}
e361528e
ER
53%endif
54# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
55BuildRequires: procps
e361528e
ER
56# The C compiler is needed at runtime just for linking. Someday rustc might
57# invoke the linker directly, and then we'll only need binutils.
58# https://github.com/rust-lang/rust/issues/11937
59Requires: gcc
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61# Only x86_64 and i686 are Tier 1 platforms at this time.
62# https://doc.rust-lang.org/stable/book/getting-started.html#tier-1
d36946a0 63ExclusiveArch: %{x8664} %{ix86}
e361528e 64
8a073211 65%define rust_triple %{_target_cpu}-unknown-linux-gnu
e361528e
ER
66
67%if %{without bootstrap}
8a073211 68%define local_rust_root %{_prefix}
e361528e 69%else
8a073211
JR
70%define bootstrap_root rust-%{bootstrap_rust}-%{rust_triple}
71%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
72%endif
73
18a1004b
JR
74# We're going to override --libdir when configuring to get rustlib into a
75# common path, but we'll fix the shared libraries during install.
76# Without this ugly hack, rust would not be able to buld itself
77# for non-bootstrap build, lib64 is just too complicated for it.
78%define common_libdir %{_prefix}/lib
79%define rustlibdir %{common_libdir}/rustlib
80
19f98749 81# once_call/once_callable non-function libstdc++ symbols
8a073211 82%define skip_post_check_so 'librustc_llvm-.*\.so.*'
19f98749 83
e361528e 84# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
85%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
86%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e
ER
87
88%description
89Rust is a systems programming language that runs blazingly fast,
90prevents segfaults, and guarantees thread safety.
91
92This package includes the Rust compiler, standard library, and
93documentation generator.
94
d1b96fd8
JR
95%package debugger-common
96Summary: Common debugger pretty printers for Rust
97Group: Development/Debuggers
98BuildArch: noarch
99
100%description debugger-common
101This package includes the common functionality for %{name}-gdb and
102%{name}-lldb.
103
e361528e
ER
104%package gdb
105Summary: GDB pretty printers for Rust
d1b96fd8
JR
106Group: Development/Debuggers
107Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 108Requires: gdb
e361528e 109BuildArch: noarch
e361528e
ER
110
111%description gdb
112This package includes the rust-gdb script, which allows easier
113debugging of Rust programs.
114
d1b96fd8
JR
115%package lldb
116Summary: LLDB pretty printers for Rust
117Group: Development/Debuggers
118Requires: %{name}-debugger-common = %{version}-%{release}
119Requires: lldb
d1b96fd8
JR
120BuildArch: noarch
121
122%description lldb
123This package includes the rust-lldb script, which allows easier
124debugging of Rust programs.
125
e361528e
ER
126%package doc
127Summary: Documentation for Rust
d1b96fd8
JR
128Group: Documentation
129BuildArch: noarch
e361528e
ER
130
131%description doc
132This package includes HTML documentation for the Rust programming
133language and its standard library.
134
135%prep
136%setup -q -n %{rustc_package}
b5eceb5e
JR
137%patch0 -p1
138
e361528e
ER
139%if %{with bootstrap}
140%ifarch %{x8664}
141tar xf %{SOURCE1}
142%endif
143%ifarch %{ix86}
144tar xf %{SOURCE2}
145%endif
d6d4cb2b
JR
146%{__mv} %{bootstrap_root} %{bootstrap_root}-root
147%{bootstrap_root}-root/install.sh \
148 --components=cargo,rustc,rust-std-%{rust_triple} \
149 --prefix=%{local_rust_root} \
150 --disable-ldconfig
151test -f %{local_rust_root}/bin/cargo
e361528e
ER
152test -f %{local_rust_root}/bin/rustc
153%endif
154
155# unbundle
156rm -r src/jemalloc/
157rm -r src/llvm/
158
159# extract bundled licenses for packaging
160cp -p src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
161sed -e '/*\//q' src/libbacktrace/backtrace.h \
162 >src/libbacktrace/LICENSE-libbacktrace
163
164# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
165sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
166 src/etc/rust-gdb
167
168# These tests assume that alloc_jemalloc is present
169sed -i -e '1i // ignore-test jemalloc is disabled' \
170 src/test/compile-fail/allocator-dylib-is-system.rs \
171 src/test/compile-fail/allocator-rust-dylib-is-jemalloc.rs \
172 src/test/run-pass/allocator-default.rs
173
e361528e
ER
174%build
175%configure \
18a1004b 176 --libdir=%{common_libdir} \
e361528e
ER
177 --disable-option-checking \
178 --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
179 --enable-local-rust --local-rust-root=%{local_rust_root} \
180 --llvm-root=%{_prefix} --disable-codegen-tests \
b5eceb5e 181 --enable-llvm-link-shared \
e361528e
ER
182 --disable-jemalloc \
183 --disable-rpath \
184 --enable-debuginfo \
d6d4cb2b 185 --enable-vendor \
e361528e
ER
186 --release-channel=%{channel}
187
d6d4cb2b 188./x.py dist
e361528e 189
8a073211
JR
190%{?with_tests:./x.py test}
191
e361528e
ER
192%install
193rm -rf $RPM_BUILD_ROOT
e361528e 194
d1b96fd8 195DESTDIR=$RPM_BUILD_ROOT ./x.py dist --install
e361528e 196
18a1004b
JR
197# Make sure the shared libraries are in the proper libdir
198%if "%{_libdir}" != "%{common_libdir}"
199mkdir -p %{buildroot}%{_libdir}
200find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
201 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
202%endif
203
d1b96fd8 204# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
205find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
206
d1b96fd8
JR
207# The libdir libraries are identical to those under rustlib/. It's easier on
208# library loading if we keep them in libdir, but we do need them in rustlib/
209# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 210(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
211 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
212 -exec ln -v -f -s -t . '{}' '+')
213
214# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 215find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
216
217# FIXME: __os_install_post will strip the rlibs
218# -- should we find a way to preserve debuginfo?
219
220# Remove unwanted documentation files (we already package them)
221rm $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
222rm $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
223rm $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
224rm $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
225
226# Sanitize the HTML documentation
227find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
228find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
229
230# Move rust-gdb's python scripts so they're noarch
231install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
18a1004b 232mv -v $RPM_BUILD_ROOT%{rustlibdir}/%{_sysconfdir} $RPM_BUILD_ROOT%{_datadir}/%{name}/
e361528e
ER
233
234%clean
235rm -rf $RPM_BUILD_ROOT
236
237%post -p /sbin/ldconfig
238%postun -p /sbin/ldconfig
239
240%files
241%defattr(644,root,root,755)
242%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT
243%doc src/libbacktrace/LICENSE-libbacktrace
244%doc src/rt/hoedown/LICENSE-hoedown
245%doc README.md
246%attr(755,root,root) %{_bindir}/rustc
247%attr(755,root,root) %{_bindir}/rustdoc
18a1004b 248%attr(755,root,root) %{_libdir}/lib*.so
e361528e
ER
249%{_mandir}/man1/rustc.1*
250%{_mandir}/man1/rustdoc.1*
18a1004b
JR
251%dir %{rustlibdir}
252%dir %{rustlibdir}/%{rust_triple}
253%dir %{rustlibdir}/%{rust_triple}/lib
254%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
255%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 256
d1b96fd8
JR
257%files debugger-common
258%defattr(644,root,root,755)
259%dir %{_datadir}/%{name}
260%dir %{_datadir}/%{name}/etc
261%{_datadir}/%{name}/etc/debugger_*.py*
262
263%files lldb
264%defattr(644,root,root,755)
265%attr(755,root,root) %{_bindir}/rust-lldb
266%{_datadir}/%{name}/etc/lldb_*.py*
267
e361528e
ER
268%files gdb
269%defattr(644,root,root,755)
270%attr(755,root,root) %{_bindir}/rust-gdb
d1b96fd8 271%{_datadir}/%{name}/etc/gdb_*.py*
e361528e
ER
272
273%files doc
274%defattr(644,root,root,755)
275%dir %{_docdir}/%{name}
d1b96fd8 276%doc %{_docdir}/%{name}/html
This page took 0.128701 seconds and 4 git commands to generate.