]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
disable debug packages when building without full_debuginfo
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
21# To bootstrap from scratch, set the channel and date from src/stage0.txt
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
8a54bb92
JP
24%define bootstrap_rust 1.51.0
25%define bootstrap_cargo 1.51.0
26%define bootstrap_date 2021-03-25
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
8a54bb92 39Version: 1.52.0
20b64456 40Release: 0.1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
8a54bb92 45# Source0-md5: f95ca614a531b3c1edd4918eaa329732
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
8a54bb92 47# Source1-md5: 7640d6538716c6492e56f361e3af0631
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
8a54bb92 49# Source2-md5: 64f117dc1ae1543c8910eaa9a971ddd4
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
8a54bb92 51# Source3-md5: 3ac79872671df7ea0215fd351f52ffcf
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
8a54bb92 53# Source4-md5: f624772d7c7ba2e83a51b4e9c1657f7b
5aae056c 54Patch0: %{name}-x32.patch
e361528e 55URL: https://www.rust-lang.org/
e8f16183
JB
56# for src/compiler-rt
57BuildRequires: cmake >= 3.4.3
e361528e 58BuildRequires: curl
2eb30149
JB
59# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
60BuildRequires: procps
61BuildRequires: python >= 1:2.7
62BuildRequires: rpmbuild(macros) >= 1.752
63%if %{without cross}
8f176645
JB
64BuildRequires: curl-devel
65BuildRequires: libgit2-devel
d1b96fd8 66BuildRequires: libstdc++-devel
8a54bb92 67%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
7da6653d 68BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
69BuildRequires: tar >= 1:1.22
70BuildRequires: xz
e361528e 71BuildRequires: zlib-devel
2eb30149 72%endif
e361528e 73%if %{without bootstrap}
d6d4cb2b 74BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 75BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 76BuildConflicts: %{name} > %{version}
e361528e 77%endif
2eb30149
JB
78%ifarch x32
79BuildRequires: glibc-devel(x32)
80BuildRequires: glibc-devel(x86_64)
81%if "%{_host_cpu}" == "x86_64"
82# building on x86_64 host with --target x32-pld-linux
8f176645 83BuildRequires: curl-devel
2eb30149 84BuildRequires: gcc-multilib-x32
8f176645 85BuildRequires: libgit2-devel
2eb30149 86BuildRequires: libstdc++-devel
8a54bb92 87%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
2eb30149
JB
88BuildRequires: openssl-devel >= 1.0.1
89BuildRequires: zlib-devel
90%else
91# building x86_64-hosted crosscompiler on x32 host
92BuildRequires: gcc-multilib-64
93BuildRequires: libstdc++-multilib-64-devel
3c25e53d
JR
94# how to specify? - rpm.org adds arch provides on packages (__isa), uncomment once we switch
95#BuildRequires: curl-devel(x86-64)
96#BuildRequires: libgit2-devel(x86-64)
97#BuildRequires: llvm-devel(x86-64)>= 7.0
98#BuildRequires: openssl-devel(x86-64)
99#BuildRequires: zlib-devel(x86-64)
2eb30149
JB
100%endif
101%endif
e361528e
ER
102# The C compiler is needed at runtime just for linking. Someday rustc might
103# invoke the linker directly, and then we'll only need binutils.
104# https://github.com/rust-lang/rust/issues/11937
105Requires: gcc
e361528e 106# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 107# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 108# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 109ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 110BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 111
e064fbd0 112%ifarch x32
badbe44d 113%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 114%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 115%define rust_bootstrap_triple x86_64-unknown-linux-gnu
e064fbd0 116%else
1fe729c8
JP
117%ifarch armv6hl armv7hl armv7hnl
118%define rust_triple arm-unknown-linux-gnueabihf
119%define rust_host_triple %{rust_triple}
120%define rust_bootstrap_triple %{rust_triple}
121%else
badbe44d 122%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
123%define rust_host_triple %{rust_triple}
124%define rust_bootstrap_triple %{rust_triple}
e064fbd0 125%endif
1fe729c8 126%endif
e361528e
ER
127
128%if %{without bootstrap}
8a073211 129%define local_rust_root %{_prefix}
e361528e 130%else
badbe44d 131%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 132%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
133%endif
134
18a1004b
JR
135# We're going to override --libdir when configuring to get rustlib into a
136# common path, but we'll fix the shared libraries during install.
5b9d67b0 137# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
138# for non-bootstrap build, lib64 is just too complicated for it.
139%define common_libdir %{_prefix}/lib
140%define rustlibdir %{common_libdir}/rustlib
141
19f98749 142# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 143%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 144
e361528e 145# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
146%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
147%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 148
37765656
JP
149%define x_py { \
150 x_py() { \
151 local cmd="$1"; \
152 shift; \
153 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
154 }; x_py }
155
156
e361528e
ER
157%description
158Rust is a systems programming language that runs blazingly fast,
159prevents segfaults, and guarantees thread safety.
160
161This package includes the Rust compiler, standard library, and
162documentation generator.
163
e8f16183
JB
164%description -l pl.UTF-8
165Rust to systemowy język programowania działający bardzo szybko,
166zapobiegający naruszeniom ochrony pamięci i gwarantujący
167bezpieczną wielowątkowość.
168
a7fda0f8
JP
169%package analyzer
170Summary: Implementation of Language Server Protocol for Rust
171Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
172Group: Development/Tools
173Requires: %{name} = %{version}-%{release}
174
175%description analyzer
176Implementation of Language Server Protocol for Rust.
177
178%description analyzer -l pl.UTF-8
179Implementacja Language Server Protocol dla Rusta.
180
d1b96fd8
JR
181%package debugger-common
182Summary: Common debugger pretty printers for Rust
e8f16183 183Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 184Group: Development/Debuggers
e67020b3 185BuildArch: noarch
d1b96fd8
JR
186
187%description debugger-common
e8f16183
JB
188This package includes the common functionality for rust-gdb and
189rust-lldb.
190
191%description debugger-common -l pl.UTF-8
192Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 193
e361528e
ER
194%package gdb
195Summary: GDB pretty printers for Rust
e8f16183 196Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
197Group: Development/Debuggers
198Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 199Requires: gdb
e67020b3 200BuildArch: noarch
e361528e
ER
201
202%description gdb
203This package includes the rust-gdb script, which allows easier
204debugging of Rust programs.
205
e8f16183
JB
206%description gdb -l pl.UTF-8
207Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
208odpluskwianie programów w języku Rust.
209
d1b96fd8
JR
210%package lldb
211Summary: LLDB pretty printers for Rust
e8f16183 212Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
213Group: Development/Debuggers
214Requires: %{name}-debugger-common = %{version}-%{release}
215Requires: lldb
e67020b3 216BuildArch: noarch
d1b96fd8
JR
217
218%description lldb
219This package includes the rust-lldb script, which allows easier
220debugging of Rust programs.
221
e8f16183
JB
222%description lldb -l pl.UTF-8
223Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
224odpluskwianie programów w języku Rust.
225
a7fda0f8
JP
226%package rls
227Summary: Rust Language Server for IDE integration
228Summary(pl.UTF-8): Rust Language Server do integracji z IDE
229Group: Development/Tools
230Requires: %{name} = %{version}-%{release}
231
232%description rls
233Rust Language Server for IDE integration.
234
235%description rls -l pl.UTF-8
236Rust Language Server do integracji z IDE.
237
e361528e
ER
238%package doc
239Summary: Documentation for Rust
e8f16183 240Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 241Group: Documentation
e67020b3 242BuildArch: noarch
e361528e
ER
243
244%description doc
245This package includes HTML documentation for the Rust programming
246language and its standard library.
247
e8f16183
JB
248%description doc -l pl.UTF-8
249Ten pakiet zawiera dokumentację w formacie HTML do języka
250programowania Rust i jego biblioteki standardowej.
251
8a758d34
JP
252%package -n cargo
253Summary: Rust's package manager and build tool
254Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
255Group: Development/Tools
256Requires: %{name}
257
258%description -n cargo
259Cargo is a tool that allows Rust projects to declare their various
260dependencies and ensure that you'll always get a repeatable build.
261
262%description -n cargo -l pl.UTF-8
263Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
264zależności i zapewniające powtarzalność procesu budowania.
265
6ed79af8
JB
266%package -n bash-completion-cargo
267Summary: Bash completion for cargo command
268Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
269Group: Applications/Shells
270Requires: %{name} = %{version}-%{release}
271Requires: bash-completion
272
273%description -n bash-completion-cargo
274Bash completion for cargo command.
275
276%description -n bash-completion-cargo -l pl.UTF-8
277Bashowe dopełnianie parametrów polecenia cargo.
278
8a758d34
JP
279%package -n zsh-completion-cargo
280Summary: Zsh completion for cargo command
281Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
282Group: Applications/Shells
283Requires: %{name} = %{version}-%{release}
6ed79af8 284Requires: zsh
8a758d34
JP
285
286%description -n zsh-completion-cargo
287Zsh completion for cargo command.
288
289%description -n zsh-completion-cargo -l pl.UTF-8
290Dopełnianie parametrów polecenia cargo w powłoce Zsh.
291
e361528e
ER
292%prep
293%setup -q -n %{rustc_package}
2eb30149 294# irrelevant when not building rustc for x32
8a54bb92 295#%%patch0 -p1
b5eceb5e 296
e361528e 297%if %{with bootstrap}
a1735efb 298%ifarch %{x8664} x32
e361528e
ER
299tar xf %{SOURCE1}
300%endif
301%ifarch %{ix86}
302tar xf %{SOURCE2}
303%endif
c160f211 304%ifarch aarch64
9eb0511e 305tar xf %{SOURCE3}
c160f211 306%endif
1fe729c8
JP
307%ifarch armv6hl armv7hl armv7hnl
308tar xf %{SOURCE4}
309%endif
d6d4cb2b
JR
310%{__mv} %{bootstrap_root} %{bootstrap_root}-root
311%{bootstrap_root}-root/install.sh \
badbe44d 312 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
313 --prefix=%{local_rust_root} \
314 --disable-ldconfig
315test -f %{local_rust_root}/bin/cargo
e361528e
ER
316test -f %{local_rust_root}/bin/rustc
317%endif
318
319# unbundle
d4b51567 320# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 321#%{__rm} -r src/jemalloc
9e7854c5
JP
322%if %{with system_llvm}
323%{__rm} -r src/llvm-project
324mkdir -p src/llvm-project/libunwind
325%endif
e361528e
ER
326
327# extract bundled licenses for packaging
5aae056c
JP
328sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
329 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
330
331# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
332sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
333 src/etc/rust-gdb
334
5ee06aa0
JR
335# The configure macro will modify some autoconf-related files, which upsets
336# cargo when it tries to verify checksums in those files. If we just truncate
337# that file list, cargo won't have anything to complain about.
fe49e3fc 338find vendor -name .cargo-checksum.json \
5ee06aa0 339 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 340
e361528e
ER
341%build
342%configure \
2eb30149
JB
343 --build=%{rust_bootstrap_triple} \
344 --host=%{rust_host_triple} \
e8f16183 345 --target=%{rust_triple} \
18a1004b 346 --libdir=%{common_libdir} \
e8f16183 347 --disable-codegen-tests \
5ee06aa0 348 --disable-debuginfo-lines \
5b9d67b0 349%if %{with full_debuginfo}
5ee06aa0 350 --disable-debuginfo-only-std \
e361528e 351 --enable-debuginfo \
5b9d67b0
JB
352%else
353 --enable-debuginfo-only-std \
354 --disable-debuginfo \
355%endif
6ed79af8
JB
356 --disable-jemalloc \
357 --disable-option-checking \
358 --disable-rpath \
8a758d34 359 --enable-extended \
e8f16183 360 --enable-llvm-link-shared \
d6d4cb2b 361 --enable-vendor \
6ed79af8 362 --local-rust-root=%{local_rust_root} \
e8f16183 363 --llvm-root=%{_prefix} \
e361528e
ER
364 --release-channel=%{channel}
365
37765656
JP
366export RUST_BACKTRACE=full
367%x_py dist --verbose
e361528e 368
37765656 369%{?with_tests:%x_py test}
8a073211 370
e361528e
ER
371%install
372rm -rf $RPM_BUILD_ROOT
e361528e 373
37765656
JP
374export DESTDIR=$RPM_BUILD_ROOT
375%x_py install
e361528e 376
18a1004b
JR
377# Make sure the shared libraries are in the proper libdir
378%if "%{_libdir}" != "%{common_libdir}"
379mkdir -p %{buildroot}%{_libdir}
380find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
381 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
382%endif
383
d1b96fd8 384# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
385find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
386
d1b96fd8
JR
387# The libdir libraries are identical to those under rustlib/. It's easier on
388# library loading if we keep them in libdir, but we do need them in rustlib/
389# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 390(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
391 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
392 -exec ln -v -f -s -t . '{}' '+')
393
394# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 395find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
396
397# FIXME: __os_install_post will strip the rlibs
398# -- should we find a way to preserve debuginfo?
399
400# Remove unwanted documentation files (we already package them)
e8f16183
JB
401%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
402%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
403%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
404%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
405
406# Sanitize the HTML documentation
407find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
408find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
409
410# Move rust-gdb's python scripts so they're noarch
411install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 412%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 413
4f353dba
JR
414# We don't need stdlib source
415%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
416
1dd26160
JP
417# Create the path for crate-devel packages
418install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
419
e361528e
ER
420%clean
421rm -rf $RPM_BUILD_ROOT
422
423%post -p /sbin/ldconfig
424%postun -p /sbin/ldconfig
425
426%files
427%defattr(644,root,root,755)
5aae056c 428%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
ca8b753f 429%attr(755,root,root) %{_bindir}/miri
e361528e
ER
430%attr(755,root,root) %{_bindir}/rustc
431%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 432%attr(755,root,root) %{_bindir}/rustfmt
e8f16183 433%attr(755,root,root) %{_libdir}/librustc*-*.so
e8f16183 434%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 435%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
436%{_mandir}/man1/rustc.1*
437%{_mandir}/man1/rustdoc.1*
18a1004b
JR
438%dir %{rustlibdir}
439%dir %{rustlibdir}/%{rust_triple}
6ed79af8 440%{rustlibdir}/%{rust_triple}/analysis
18a1004b
JR
441%dir %{rustlibdir}/%{rust_triple}/lib
442%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
443%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 444
a7fda0f8
JP
445%files analyzer
446%defattr(644,root,root,755)
447%attr(755,root,root) %{_bindir}/rust-analyzer
448
d1b96fd8
JR
449%files debugger-common
450%defattr(644,root,root,755)
451%dir %{_datadir}/%{name}
452%dir %{_datadir}/%{name}/etc
5aae056c
JP
453%{_datadir}/%{name}/etc/lldb_commands
454%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
455
456%files lldb
457%defattr(644,root,root,755)
458%attr(755,root,root) %{_bindir}/rust-lldb
459%{_datadir}/%{name}/etc/lldb_*.py*
460
e361528e
ER
461%files gdb
462%defattr(644,root,root,755)
463%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 464%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 465%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 466
a7fda0f8
JP
467%files rls
468%defattr(644,root,root,755)
469%attr(755,root,root) %{_bindir}/rls
470
e361528e
ER
471%files doc
472%defattr(644,root,root,755)
473%dir %{_docdir}/%{name}
d1b96fd8 474%doc %{_docdir}/%{name}/html
8a758d34
JP
475
476%files -n cargo
477%defattr(644,root,root,755)
478%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
479%attr(755,root,root) %{_bindir}/cargo-clippy
480%attr(755,root,root) %{_bindir}/cargo-fmt
ca8b753f 481%attr(755,root,root) %{_bindir}/cargo-miri
6ed79af8 482%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 483%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
484%{_mandir}/man1/cargo*.1*
485%dir %{_datadir}/cargo
486%dir %{_datadir}/cargo/registry
487
488%files -n bash-completion-cargo
489%defattr(644,root,root,755)
490%{_sysconfdir}/bash_completion.d/cargo
491
492%files -n zsh-completion-cargo
493%defattr(644,root,root,755)
494%{zsh_compdir}/_cargo
This page took 0.113714 seconds and 4 git commands to generate.