]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
up to 1.52.1
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
21# To bootstrap from scratch, set the channel and date from src/stage0.txt
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
8a54bb92
JP
24%define bootstrap_rust 1.51.0
25%define bootstrap_cargo 1.51.0
26%define bootstrap_date 2021-03-25
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
b263378f
JP
39Version: 1.52.1
40Release: 1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
b263378f 45# Source0-md5: 2df4835e3a15cc6f7e06fa4a986285d2
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
8a54bb92 47# Source1-md5: 7640d6538716c6492e56f361e3af0631
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
8a54bb92 49# Source2-md5: 64f117dc1ae1543c8910eaa9a971ddd4
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
8a54bb92 51# Source3-md5: 3ac79872671df7ea0215fd351f52ffcf
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
8a54bb92 53# Source4-md5: f624772d7c7ba2e83a51b4e9c1657f7b
5aae056c 54Patch0: %{name}-x32.patch
e361528e 55URL: https://www.rust-lang.org/
e8f16183
JB
56# for src/compiler-rt
57BuildRequires: cmake >= 3.4.3
e361528e 58BuildRequires: curl
2eb30149
JB
59# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
60BuildRequires: procps
61BuildRequires: python >= 1:2.7
62BuildRequires: rpmbuild(macros) >= 1.752
63%if %{without cross}
8f176645 64BuildRequires: curl-devel
1f9b8560 65BuildRequires: libgit2-devel >= 1.1.0
d1b96fd8 66BuildRequires: libstdc++-devel
8a54bb92 67%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
7da6653d 68BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
69BuildRequires: tar >= 1:1.22
70BuildRequires: xz
e361528e 71BuildRequires: zlib-devel
2eb30149 72%endif
e361528e 73%if %{without bootstrap}
d6d4cb2b 74BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 75BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 76BuildConflicts: %{name} > %{version}
e361528e 77%endif
2eb30149
JB
78%ifarch x32
79BuildRequires: glibc-devel(x32)
80BuildRequires: glibc-devel(x86_64)
81%if "%{_host_cpu}" == "x86_64"
82# building on x86_64 host with --target x32-pld-linux
8f176645 83BuildRequires: curl-devel
2eb30149 84BuildRequires: gcc-multilib-x32
1f9b8560 85BuildRequires: libgit2-devel >= 1.1.0
2eb30149 86BuildRequires: libstdc++-devel
8a54bb92 87%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
2eb30149
JB
88BuildRequires: openssl-devel >= 1.0.1
89BuildRequires: zlib-devel
90%else
91# building x86_64-hosted crosscompiler on x32 host
56b25e8b 92BuildRequires: curl-devel(x86-64)
2eb30149 93BuildRequires: gcc-multilib-64
1f9b8560 94BuildRequires: libgit2-devel(x86-64) >= 1.1.0
2eb30149 95BuildRequires: libstdc++-multilib-64-devel
56b25e8b
JP
96%{?with_system_llvm:BuildRequires: llvm-devel(x86-64) >= 9.0}
97BuildRequires: openssl-devel(x86-64)
98BuildRequires: zlib-devel(x86-64)
2eb30149
JB
99%endif
100%endif
e361528e
ER
101# The C compiler is needed at runtime just for linking. Someday rustc might
102# invoke the linker directly, and then we'll only need binutils.
103# https://github.com/rust-lang/rust/issues/11937
104Requires: gcc
e361528e 105# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 106# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 107# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 108ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 109BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 110
e064fbd0 111%ifarch x32
badbe44d 112%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 113%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 114%define rust_bootstrap_triple x86_64-unknown-linux-gnu
e064fbd0 115%else
1fe729c8
JP
116%ifarch armv6hl armv7hl armv7hnl
117%define rust_triple arm-unknown-linux-gnueabihf
118%define rust_host_triple %{rust_triple}
119%define rust_bootstrap_triple %{rust_triple}
120%else
badbe44d 121%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
122%define rust_host_triple %{rust_triple}
123%define rust_bootstrap_triple %{rust_triple}
e064fbd0 124%endif
1fe729c8 125%endif
e361528e
ER
126
127%if %{without bootstrap}
8a073211 128%define local_rust_root %{_prefix}
e361528e 129%else
badbe44d 130%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 131%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
132%endif
133
18a1004b
JR
134# We're going to override --libdir when configuring to get rustlib into a
135# common path, but we'll fix the shared libraries during install.
5b9d67b0 136# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
137# for non-bootstrap build, lib64 is just too complicated for it.
138%define common_libdir %{_prefix}/lib
139%define rustlibdir %{common_libdir}/rustlib
140
19f98749 141# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 142%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 143
e361528e 144# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
145%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
146%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 147
37765656
JP
148%define x_py { \
149 x_py() { \
150 local cmd="$1"; \
151 shift; \
152 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
153 }; x_py }
154
155
e361528e
ER
156%description
157Rust is a systems programming language that runs blazingly fast,
158prevents segfaults, and guarantees thread safety.
159
160This package includes the Rust compiler, standard library, and
161documentation generator.
162
e8f16183
JB
163%description -l pl.UTF-8
164Rust to systemowy język programowania działający bardzo szybko,
165zapobiegający naruszeniom ochrony pamięci i gwarantujący
166bezpieczną wielowątkowość.
167
a7fda0f8
JP
168%package analyzer
169Summary: Implementation of Language Server Protocol for Rust
170Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
171Group: Development/Tools
172Requires: %{name} = %{version}-%{release}
173
174%description analyzer
175Implementation of Language Server Protocol for Rust.
176
177%description analyzer -l pl.UTF-8
178Implementacja Language Server Protocol dla Rusta.
179
d1b96fd8
JR
180%package debugger-common
181Summary: Common debugger pretty printers for Rust
e8f16183 182Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 183Group: Development/Debuggers
e67020b3 184BuildArch: noarch
d1b96fd8
JR
185
186%description debugger-common
e8f16183
JB
187This package includes the common functionality for rust-gdb and
188rust-lldb.
189
190%description debugger-common -l pl.UTF-8
191Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 192
e361528e
ER
193%package gdb
194Summary: GDB pretty printers for Rust
e8f16183 195Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
196Group: Development/Debuggers
197Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 198Requires: gdb
e67020b3 199BuildArch: noarch
e361528e
ER
200
201%description gdb
202This package includes the rust-gdb script, which allows easier
203debugging of Rust programs.
204
e8f16183
JB
205%description gdb -l pl.UTF-8
206Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
207odpluskwianie programów w języku Rust.
208
d1b96fd8
JR
209%package lldb
210Summary: LLDB pretty printers for Rust
e8f16183 211Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
212Group: Development/Debuggers
213Requires: %{name}-debugger-common = %{version}-%{release}
214Requires: lldb
e67020b3 215BuildArch: noarch
d1b96fd8
JR
216
217%description lldb
218This package includes the rust-lldb script, which allows easier
219debugging of Rust programs.
220
e8f16183
JB
221%description lldb -l pl.UTF-8
222Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
223odpluskwianie programów w języku Rust.
224
a7fda0f8
JP
225%package rls
226Summary: Rust Language Server for IDE integration
227Summary(pl.UTF-8): Rust Language Server do integracji z IDE
228Group: Development/Tools
229Requires: %{name} = %{version}-%{release}
230
231%description rls
232Rust Language Server for IDE integration.
233
234%description rls -l pl.UTF-8
235Rust Language Server do integracji z IDE.
236
e361528e
ER
237%package doc
238Summary: Documentation for Rust
e8f16183 239Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 240Group: Documentation
e67020b3 241BuildArch: noarch
e361528e
ER
242
243%description doc
244This package includes HTML documentation for the Rust programming
245language and its standard library.
246
e8f16183
JB
247%description doc -l pl.UTF-8
248Ten pakiet zawiera dokumentację w formacie HTML do języka
249programowania Rust i jego biblioteki standardowej.
250
8a758d34
JP
251%package -n cargo
252Summary: Rust's package manager and build tool
253Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
254Group: Development/Tools
255Requires: %{name}
256
257%description -n cargo
258Cargo is a tool that allows Rust projects to declare their various
259dependencies and ensure that you'll always get a repeatable build.
260
261%description -n cargo -l pl.UTF-8
262Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
263zależności i zapewniające powtarzalność procesu budowania.
264
6ed79af8
JB
265%package -n bash-completion-cargo
266Summary: Bash completion for cargo command
267Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
268Group: Applications/Shells
269Requires: %{name} = %{version}-%{release}
270Requires: bash-completion
271
272%description -n bash-completion-cargo
273Bash completion for cargo command.
274
275%description -n bash-completion-cargo -l pl.UTF-8
276Bashowe dopełnianie parametrów polecenia cargo.
277
8a758d34
JP
278%package -n zsh-completion-cargo
279Summary: Zsh completion for cargo command
280Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
281Group: Applications/Shells
282Requires: %{name} = %{version}-%{release}
6ed79af8 283Requires: zsh
8a758d34
JP
284
285%description -n zsh-completion-cargo
286Zsh completion for cargo command.
287
288%description -n zsh-completion-cargo -l pl.UTF-8
289Dopełnianie parametrów polecenia cargo w powłoce Zsh.
290
e361528e
ER
291%prep
292%setup -q -n %{rustc_package}
2eb30149 293# irrelevant when not building rustc for x32
8a54bb92 294#%%patch0 -p1
b5eceb5e 295
e361528e 296%if %{with bootstrap}
a1735efb 297%ifarch %{x8664} x32
e361528e
ER
298tar xf %{SOURCE1}
299%endif
300%ifarch %{ix86}
301tar xf %{SOURCE2}
302%endif
c160f211 303%ifarch aarch64
9eb0511e 304tar xf %{SOURCE3}
c160f211 305%endif
1fe729c8
JP
306%ifarch armv6hl armv7hl armv7hnl
307tar xf %{SOURCE4}
308%endif
d6d4cb2b
JR
309%{__mv} %{bootstrap_root} %{bootstrap_root}-root
310%{bootstrap_root}-root/install.sh \
badbe44d 311 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
312 --prefix=%{local_rust_root} \
313 --disable-ldconfig
314test -f %{local_rust_root}/bin/cargo
e361528e
ER
315test -f %{local_rust_root}/bin/rustc
316%endif
317
318# unbundle
d4b51567 319# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 320#%{__rm} -r src/jemalloc
9e7854c5
JP
321%if %{with system_llvm}
322%{__rm} -r src/llvm-project
323mkdir -p src/llvm-project/libunwind
324%endif
e361528e
ER
325
326# extract bundled licenses for packaging
5aae056c
JP
327sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
328 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
329
330# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
331sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
332 src/etc/rust-gdb
333
5ee06aa0
JR
334# The configure macro will modify some autoconf-related files, which upsets
335# cargo when it tries to verify checksums in those files. If we just truncate
336# that file list, cargo won't have anything to complain about.
fe49e3fc 337find vendor -name .cargo-checksum.json \
5ee06aa0 338 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 339
e361528e
ER
340%build
341%configure \
2eb30149
JB
342 --build=%{rust_bootstrap_triple} \
343 --host=%{rust_host_triple} \
e8f16183 344 --target=%{rust_triple} \
18a1004b 345 --libdir=%{common_libdir} \
e8f16183 346 --disable-codegen-tests \
5ee06aa0 347 --disable-debuginfo-lines \
5b9d67b0 348%if %{with full_debuginfo}
5ee06aa0 349 --disable-debuginfo-only-std \
e361528e 350 --enable-debuginfo \
5b9d67b0
JB
351%else
352 --enable-debuginfo-only-std \
353 --disable-debuginfo \
354%endif
6ed79af8
JB
355 --disable-jemalloc \
356 --disable-option-checking \
357 --disable-rpath \
8a758d34 358 --enable-extended \
e8f16183 359 --enable-llvm-link-shared \
d6d4cb2b 360 --enable-vendor \
6ed79af8 361 --local-rust-root=%{local_rust_root} \
e8f16183 362 --llvm-root=%{_prefix} \
e361528e
ER
363 --release-channel=%{channel}
364
37765656
JP
365export RUST_BACKTRACE=full
366%x_py dist --verbose
e361528e 367
37765656 368%{?with_tests:%x_py test}
8a073211 369
e361528e
ER
370%install
371rm -rf $RPM_BUILD_ROOT
e361528e 372
37765656
JP
373export DESTDIR=$RPM_BUILD_ROOT
374%x_py install
e361528e 375
18a1004b
JR
376# Make sure the shared libraries are in the proper libdir
377%if "%{_libdir}" != "%{common_libdir}"
378mkdir -p %{buildroot}%{_libdir}
379find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
380 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
381%endif
382
d1b96fd8 383# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
384find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
385
d1b96fd8
JR
386# The libdir libraries are identical to those under rustlib/. It's easier on
387# library loading if we keep them in libdir, but we do need them in rustlib/
388# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 389(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
390 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
391 -exec ln -v -f -s -t . '{}' '+')
392
393# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 394find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
395
396# FIXME: __os_install_post will strip the rlibs
397# -- should we find a way to preserve debuginfo?
398
399# Remove unwanted documentation files (we already package them)
e8f16183
JB
400%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
401%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
402%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
403%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
404
405# Sanitize the HTML documentation
406find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
407find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
408
409# Move rust-gdb's python scripts so they're noarch
410install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 411%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 412
4f353dba
JR
413# We don't need stdlib source
414%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
415
1dd26160
JP
416# Create the path for crate-devel packages
417install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
418
e361528e
ER
419%clean
420rm -rf $RPM_BUILD_ROOT
421
422%post -p /sbin/ldconfig
423%postun -p /sbin/ldconfig
424
425%files
426%defattr(644,root,root,755)
5aae056c 427%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
ca8b753f 428%attr(755,root,root) %{_bindir}/miri
e361528e
ER
429%attr(755,root,root) %{_bindir}/rustc
430%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 431%attr(755,root,root) %{_bindir}/rustfmt
e8f16183 432%attr(755,root,root) %{_libdir}/librustc*-*.so
e8f16183 433%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 434%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
435%{_mandir}/man1/rustc.1*
436%{_mandir}/man1/rustdoc.1*
18a1004b
JR
437%dir %{rustlibdir}
438%dir %{rustlibdir}/%{rust_triple}
6ed79af8 439%{rustlibdir}/%{rust_triple}/analysis
18a1004b
JR
440%dir %{rustlibdir}/%{rust_triple}/lib
441%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
442%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 443
a7fda0f8
JP
444%files analyzer
445%defattr(644,root,root,755)
446%attr(755,root,root) %{_bindir}/rust-analyzer
447
d1b96fd8
JR
448%files debugger-common
449%defattr(644,root,root,755)
450%dir %{_datadir}/%{name}
451%dir %{_datadir}/%{name}/etc
5aae056c
JP
452%{_datadir}/%{name}/etc/lldb_commands
453%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
454
455%files lldb
456%defattr(644,root,root,755)
457%attr(755,root,root) %{_bindir}/rust-lldb
458%{_datadir}/%{name}/etc/lldb_*.py*
459
e361528e
ER
460%files gdb
461%defattr(644,root,root,755)
462%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 463%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 464%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 465
a7fda0f8
JP
466%files rls
467%defattr(644,root,root,755)
468%attr(755,root,root) %{_bindir}/rls
469
e361528e
ER
470%files doc
471%defattr(644,root,root,755)
472%dir %{_docdir}/%{name}
d1b96fd8 473%doc %{_docdir}/%{name}/html
8a758d34
JP
474
475%files -n cargo
476%defattr(644,root,root,755)
477%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
478%attr(755,root,root) %{_bindir}/cargo-clippy
479%attr(755,root,root) %{_bindir}/cargo-fmt
ca8b753f 480%attr(755,root,root) %{_bindir}/cargo-miri
6ed79af8 481%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 482%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
483%{_mandir}/man1/cargo*.1*
484%dir %{_datadir}/cargo
485%dir %{_datadir}/cargo/registry
486
487%files -n bash-completion-cargo
488%defattr(644,root,root,755)
489%{_sysconfdir}/bash_completion.d/cargo
490
491%files -n zsh-completion-cargo
492%defattr(644,root,root,755)
493%{zsh_compdir}/_cargo
This page took 0.136143 seconds and 4 git commands to generate.