]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
- updated libexecdir adjustment
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
fc3be51a 21# To bootstrap from scratch, set the channel and date from src/stage0.json
e361528e
ER
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
33a4a51f 24%define bootstrap_rust 1.76.0
aea1d260 25%define bootstrap_cargo %{bootstrap_rust}
33a4a51f 26%define bootstrap_date 2024-02-08
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
33a4a51f 39Version: 1.77.0
98f3eec9 40Release: 1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
33a4a51f 45# Source0-md5: 7df442945fb2e32cbccd45a7faa3a5e1
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
33a4a51f 47# Source1-md5: 5f9b4a89f2123e044cc46c7659dfc4fb
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
33a4a51f 49# Source2-md5: fe76aea1be1894a9b48e1bea614038c6
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
33a4a51f 51# Source3-md5: b4741f9574bd432e2370c91d56d17ae0
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
33a4a51f 53# Source4-md5: de71c41731df9187d4cca2f61359be28
ad044650 54Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
33a4a51f 55# Source5-md5: 80c933da93013752d852f6f1280d7e12
e361528e 56URL: https://www.rust-lang.org/
e8f16183
JB
57# for src/compiler-rt
58BuildRequires: cmake >= 3.4.3
e361528e 59BuildRequires: curl
dba8190b
JP
60%ifarch %{arm} %{mips32} %{ppc}
61BuildRequires: libatomic-devel
62%endif
2eb30149
JB
63# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
64BuildRequires: procps
e65d284f
JP
65BuildRequires: python3
66BuildRequires: python3-modules
fc3be51a 67BuildRequires: rpm-build >= 4.6
2eb30149
JB
68BuildRequires: rpmbuild(macros) >= 1.752
69%if %{without cross}
8f176645 70BuildRequires: curl-devel
33a4a51f 71BuildRequires: libgit2-devel >= 1.7.2
d1b96fd8 72BuildRequires: libstdc++-devel
2cec66d3 73%if %{with system_llvm}
13554c8c
JP
74BuildRequires: llvm >= 16.0
75BuildRequires: llvm-devel >= 16.0
2cec66d3 76%endif
7da6653d 77BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
78BuildRequires: tar >= 1:1.22
79BuildRequires: xz
79a067de 80BuildRequires: xz-devel
e361528e 81BuildRequires: zlib-devel
2eb30149 82%endif
e361528e 83%if %{without bootstrap}
d6d4cb2b 84BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 85BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 86BuildConflicts: %{name} > %{version}
e361528e 87%endif
2eb30149 88%ifarch x32
cd0c1484
JR
89BuildRequires: glibc-devel(x86-64)
90BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
91%if "%{_host_cpu}" == "x86_64"
92# building on x86_64 host with --target x32-pld-linux
8f176645 93BuildRequires: curl-devel
2eb30149 94BuildRequires: gcc-multilib-x32
33a4a51f 95BuildRequires: libgit2-devel >= 1.7.2
2eb30149 96BuildRequires: libstdc++-devel
13554c8c 97%{?with_system_llvm:BuildRequires: llvm-devel >= 16.0}
2eb30149 98BuildRequires: openssl-devel >= 1.0.1
79a067de 99BuildRequires: xz-devel
2eb30149
JB
100BuildRequires: zlib-devel
101%else
102# building x86_64-hosted crosscompiler on x32 host
56b25e8b 103BuildRequires: curl-devel(x86-64)
cd0c1484 104BuildRequires: curl-devel(x86-x32)
2eb30149 105BuildRequires: gcc-multilib-64
33a4a51f
JP
106BuildRequires: libgit2-devel(x86-64) >= 1.7.2
107BuildRequires: libgit2-devel(x86-x32) >= 1.7.2
2eb30149 108BuildRequires: libstdc++-multilib-64-devel
cd0c1484 109%if %{with system_llvm}
13554c8c
JP
110BuildRequires: llvm-devel(x86-64) >= 16.0
111BuildRequires: llvm-devel(x86-x32) >= 16.0
cd0c1484 112%endif
56b25e8b 113BuildRequires: openssl-devel(x86-64)
cd0c1484 114BuildRequires: openssl-devel(x86-x32)
79a067de
JP
115BuildRequires: xz-devel(x86-64)
116BuildRequires: xz-devel(x86-x32)
56b25e8b 117BuildRequires: zlib-devel(x86-64)
cd0c1484 118BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
119%endif
120%endif
e361528e
ER
121# The C compiler is needed at runtime just for linking. Someday rustc might
122# invoke the linker directly, and then we'll only need binutils.
123# https://github.com/rust-lang/rust/issues/11937
124Requires: gcc
cd0c1484
JR
125Requires: %{name}-std%{?_isa} = %{version}-%{release}
126%ifarch x32
127Requires: %{name}-std(x86-64) = %{version}-%{release}
417178e1 128Requires: gcc-multilib-64
cd0c1484 129%endif
80e24d19 130Obsoletes: rust-analysis < 1.69.0
e361528e 131# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 132# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 133# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 134ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 135BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 136
e064fbd0 137%ifarch x32
badbe44d 138%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 139%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 140%define rust_bootstrap_triple x86_64-unknown-linux-gnu
a973dc7e
JR
141# libs in _libdir are x86_64 64bit
142%define _lib lib64
143%define _libdir %{_prefix}/lib64
e064fbd0 144%else
ad044650 145%ifarch armv6hl
1fe729c8
JP
146%define rust_triple arm-unknown-linux-gnueabihf
147%define rust_host_triple %{rust_triple}
148%define rust_bootstrap_triple %{rust_triple}
149%else
ad044650
JP
150%ifarch armv7hl armv7hnl
151%define rust_triple armv7-unknown-linux-gnueabihf
152%define rust_host_triple %{rust_triple}
153%define rust_bootstrap_triple %{rust_triple}
6c4856ce 154%define rust_suppl_targets thumbv7neon-unknown-linux-gnueabihf
ad044650 155%else
badbe44d 156%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
157%define rust_host_triple %{rust_triple}
158%define rust_bootstrap_triple %{rust_triple}
e064fbd0 159%endif
1fe729c8 160%endif
ad044650 161%endif
e361528e 162
62473c95
JP
163%define rust_targets %rust_triple %{?rust_suppl_targets}
164
e361528e 165%if %{without bootstrap}
8a073211 166%define local_rust_root %{_prefix}
e361528e 167%else
badbe44d 168%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 169%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
170%endif
171
18a1004b
JR
172# We're going to override --libdir when configuring to get rustlib into a
173# common path, but we'll fix the shared libraries during install.
5b9d67b0 174# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
175# for non-bootstrap build, lib64 is just too complicated for it.
176%define common_libdir %{_prefix}/lib
177%define rustlibdir %{common_libdir}/rustlib
178
19f98749 179# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 180%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 181
e361528e 182# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
183%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
184%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 185
37765656
JP
186%define x_py { \
187 x_py() { \
188 local cmd="$1"; \
189 shift; \
e65d284f 190 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
37765656
JP
191 }; x_py }
192
193
e361528e
ER
194%description
195Rust is a systems programming language that runs blazingly fast,
196prevents segfaults, and guarantees thread safety.
197
198This package includes the Rust compiler, standard library, and
199documentation generator.
200
e8f16183
JB
201%description -l pl.UTF-8
202Rust to systemowy język programowania działający bardzo szybko,
203zapobiegający naruszeniom ochrony pamięci i gwarantujący
204bezpieczną wielowątkowość.
205
cd0c1484
JR
206%package std
207Summary: Standard library for Rust
208Summary(pl.UTF-8): Standardowa biblioteka Rusta
209Group: Development/Tools
89a1e043 210Requires: %{name} = %{version}-%{release}
cd0c1484
JR
211
212%description std
213Standard library for Rust.
214
215%description std -l pl.UTF-8
216Standardowa biblioteka Rusta.
217
f397d93b 218%package analyzer
4079dca2
JP
219Summary: Implementation of Language Server Protocol for Rust
220Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
221Group: Development/Tools
222Requires: %{name} = %{version}-%{release}
223Obsoletes: rust-rls < 1.65.0
f397d93b
JP
224
225%description analyzer
226Implementation of Language Server Protocol for Rust.
227
228%description analyzer -l pl.UTF-8
229Implementacja Language Server Protocol dla Rusta.
230
d1b96fd8
JR
231%package debugger-common
232Summary: Common debugger pretty printers for Rust
e8f16183 233Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 234Group: Development/Debuggers
e67020b3 235BuildArch: noarch
d1b96fd8
JR
236
237%description debugger-common
e8f16183
JB
238This package includes the common functionality for rust-gdb and
239rust-lldb.
240
241%description debugger-common -l pl.UTF-8
242Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 243
e361528e
ER
244%package gdb
245Summary: GDB pretty printers for Rust
e8f16183 246Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
247Group: Development/Debuggers
248Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 249Requires: gdb
e67020b3 250BuildArch: noarch
e361528e
ER
251
252%description gdb
253This package includes the rust-gdb script, which allows easier
254debugging of Rust programs.
255
e8f16183
JB
256%description gdb -l pl.UTF-8
257Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
258odpluskwianie programów w języku Rust.
259
d1b96fd8
JR
260%package lldb
261Summary: LLDB pretty printers for Rust
e8f16183 262Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
263Group: Development/Debuggers
264Requires: %{name}-debugger-common = %{version}-%{release}
265Requires: lldb
e67020b3 266BuildArch: noarch
d1b96fd8
JR
267
268%description lldb
269This package includes the rust-lldb script, which allows easier
270debugging of Rust programs.
271
e8f16183
JB
272%description lldb -l pl.UTF-8
273Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
274odpluskwianie programów w języku Rust.
275
e361528e
ER
276%package doc
277Summary: Documentation for Rust
e8f16183 278Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 279Group: Documentation
e67020b3 280BuildArch: noarch
e361528e
ER
281
282%description doc
283This package includes HTML documentation for the Rust programming
284language and its standard library.
285
e8f16183
JB
286%description doc -l pl.UTF-8
287Ten pakiet zawiera dokumentację w formacie HTML do języka
288programowania Rust i jego biblioteki standardowej.
289
8a758d34
JP
290%package -n cargo
291Summary: Rust's package manager and build tool
292Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
293Group: Development/Tools
cd0c1484 294Requires: %{name}%{?_isa}
8a758d34
JP
295
296%description -n cargo
297Cargo is a tool that allows Rust projects to declare their various
298dependencies and ensure that you'll always get a repeatable build.
299
300%description -n cargo -l pl.UTF-8
301Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
302zależności i zapewniające powtarzalność procesu budowania.
303
6ed79af8
JB
304%package -n bash-completion-cargo
305Summary: Bash completion for cargo command
306Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
307Group: Applications/Shells
308Requires: %{name} = %{version}-%{release}
309Requires: bash-completion
449de7a9 310BuildArch: noarch
6ed79af8
JB
311
312%description -n bash-completion-cargo
313Bash completion for cargo command.
314
315%description -n bash-completion-cargo -l pl.UTF-8
316Bashowe dopełnianie parametrów polecenia cargo.
317
8a758d34
JP
318%package -n zsh-completion-cargo
319Summary: Zsh completion for cargo command
320Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
321Group: Applications/Shells
322Requires: %{name} = %{version}-%{release}
6ed79af8 323Requires: zsh
166962a5 324BuildArch: noarch
8a758d34
JP
325
326%description -n zsh-completion-cargo
327Zsh completion for cargo command.
328
329%description -n zsh-completion-cargo -l pl.UTF-8
330Dopełnianie parametrów polecenia cargo w powłoce Zsh.
331
e361528e
ER
332%prep
333%setup -q -n %{rustc_package}
b5eceb5e 334
e361528e 335%if %{with bootstrap}
a1735efb 336%ifarch %{x8664} x32
e361528e
ER
337tar xf %{SOURCE1}
338%endif
339%ifarch %{ix86}
340tar xf %{SOURCE2}
341%endif
c160f211 342%ifarch aarch64
9eb0511e 343tar xf %{SOURCE3}
c160f211 344%endif
ad044650 345%ifarch armv6hl
1fe729c8
JP
346tar xf %{SOURCE4}
347%endif
ad044650
JP
348%ifarch armv7hl armv7hnl
349tar xf %{SOURCE5}
350%endif
d6d4cb2b
JR
351%{__mv} %{bootstrap_root} %{bootstrap_root}-root
352%{bootstrap_root}-root/install.sh \
badbe44d 353 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
354 --prefix=%{local_rust_root} \
355 --disable-ldconfig
356test -f %{local_rust_root}/bin/cargo
e361528e
ER
357test -f %{local_rust_root}/bin/rustc
358%endif
359
360# unbundle
d4b51567 361# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 362#%{__rm} -r src/jemalloc
9e7854c5
JP
363%if %{with system_llvm}
364%{__rm} -r src/llvm-project
365mkdir -p src/llvm-project/libunwind
366%endif
e361528e 367
e361528e
ER
368# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
369sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
370 src/etc/rust-gdb
371
4b354bd7
JB
372# cargo has hardcoded libexec path - honour rpm _libexecdir
373%if "%{_libexecdir}" != "%{_prefix}/libexec"
374suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
375%{__sed} -i -e 's,"libexec","'${suffix}'",' \
8a21aeee
JB
376 src/bootstrap/src/core/download.rs \
377 src/bootstrap/src/core/build_steps/dist.rs \
378 src/bootstrap/src/core/build_steps/tool.rs
379%{__sed} -i -e "s,/libexec/,/${suffix}/," src/bootstrap/bootstrap.py
4b354bd7
JB
380%endif
381
5ee06aa0
JR
382# The configure macro will modify some autoconf-related files, which upsets
383# cargo when it tries to verify checksums in those files. If we just truncate
384# that file list, cargo won't have anything to complain about.
fe49e3fc 385find vendor -name .cargo-checksum.json \
5ee06aa0 386 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 387
e361528e 388%build
863a59ff
JP
389export CC="%{__cc}"
390export CXX="%{__cxx}"
391export AR="%{__ar}"
e361528e 392%configure \
2eb30149
JB
393 --build=%{rust_bootstrap_triple} \
394 --host=%{rust_host_triple} \
62473c95 395 --target="%(echo %rust_targets | tr ' ' ,)" \
18a1004b 396 --libdir=%{common_libdir} \
e8f16183 397 --disable-codegen-tests \
5ee06aa0 398 --disable-debuginfo-lines \
5b9d67b0 399%if %{with full_debuginfo}
5ee06aa0 400 --disable-debuginfo-only-std \
e361528e 401 --enable-debuginfo \
5b9d67b0
JB
402%else
403 --enable-debuginfo-only-std \
404 --disable-debuginfo \
405%endif
6ed79af8
JB
406 --disable-jemalloc \
407 --disable-option-checking \
408 --disable-rpath \
8a758d34 409 --enable-extended \
e8f16183 410 --enable-llvm-link-shared \
d6d4cb2b 411 --enable-vendor \
6ed79af8 412 --local-rust-root=%{local_rust_root} \
e8f16183 413 --llvm-root=%{_prefix} \
595dfba2 414 --release-channel=%{channel} \
33a4a51f
JP
415 --set=llvm.static-libstdcpp=false \
416 --set=build.optimized-compiler-builtins=false
e361528e 417
37765656
JP
418export RUST_BACKTRACE=full
419%x_py dist --verbose
e361528e 420
37765656 421%{?with_tests:%x_py test}
8a073211 422
e361528e
ER
423%install
424rm -rf $RPM_BUILD_ROOT
e361528e 425
13ab0532
JP
426export CC="%{__cc}"
427export CXX="%{__cxx}"
428export AR="%{__ar}"
37765656
JP
429export DESTDIR=$RPM_BUILD_ROOT
430%x_py install
e361528e 431
18a1004b
JR
432# Make sure the shared libraries are in the proper libdir
433%if "%{_libdir}" != "%{common_libdir}"
434mkdir -p %{buildroot}%{_libdir}
435find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
436 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
437%endif
438
d1b96fd8 439# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
440find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
441
d1b96fd8
JR
442# The libdir libraries are identical to those under rustlib/. It's easier on
443# library loading if we keep them in libdir, but we do need them in rustlib/
444# to support dynamic linking for compiler plugins, so we'll symlink.
62473c95
JP
445for rust_target in %rust_targets; do
446 for l in libstd libtest ; do
447 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
448 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
449 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
450 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
451 fi
452 done
a973dc7e 453done
d1b96fd8
JR
454
455# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 456find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
457
458# FIXME: __os_install_post will strip the rlibs
459# -- should we find a way to preserve debuginfo?
460
461# Remove unwanted documentation files (we already package them)
e8f16183
JB
462%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
463%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
464%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
465%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
466
467# Sanitize the HTML documentation
468find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
469find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
470
471# Move rust-gdb's python scripts so they're noarch
472install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 473%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 474
4f353dba
JR
475# We don't need stdlib source
476%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
477
1dd26160
JP
478# Create the path for crate-devel packages
479install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
480
e361528e
ER
481%clean
482rm -rf $RPM_BUILD_ROOT
483
484%post -p /sbin/ldconfig
485%postun -p /sbin/ldconfig
486
487%files
488%defattr(644,root,root,755)
16ea23d8 489%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
1736a047 490%attr(755,root,root) %{_bindir}/rust-demangler
e361528e
ER
491%attr(755,root,root) %{_bindir}/rustc
492%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 493%attr(755,root,root) %{_bindir}/rustfmt
a973dc7e 494%attr(755,root,root) %{_libdir}/librustc_driver-*.so
e8f16183 495%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 496%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
497%{_mandir}/man1/rustc.1*
498%{_mandir}/man1/rustdoc.1*
18a1004b 499%dir %{rustlibdir}
cd0c1484 500
cd0c1484
JR
501%files std
502%defattr(644,root,root,755)
62473c95
JP
503%(for rust_target in %rust_targets; do
504cat <<EOF
505%dir %{rustlibdir}/$rust_target
506%dir %{rustlibdir}/$rust_target/lib
507%attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
508%{rustlibdir}/$rust_target/lib/*.rlib
509EOF
510done
511)
e361528e 512
f397d93b
JP
513%files analyzer
514%defattr(644,root,root,755)
515%attr(755,root,root) %{_bindir}/rust-analyzer
516%attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
517
d1b96fd8
JR
518%files debugger-common
519%defattr(644,root,root,755)
520%dir %{_datadir}/%{name}
521%dir %{_datadir}/%{name}/etc
5aae056c
JP
522%{_datadir}/%{name}/etc/lldb_commands
523%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
524
525%files lldb
526%defattr(644,root,root,755)
527%attr(755,root,root) %{_bindir}/rust-lldb
528%{_datadir}/%{name}/etc/lldb_*.py*
529
e361528e
ER
530%files gdb
531%defattr(644,root,root,755)
532%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 533%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 534%{_datadir}/%{name}/etc/gdb_*.py*
e361528e
ER
535
536%files doc
537%defattr(644,root,root,755)
538%dir %{_docdir}/%{name}
d1b96fd8 539%doc %{_docdir}/%{name}/html
8a758d34
JP
540
541%files -n cargo
542%defattr(644,root,root,755)
543%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
544%attr(755,root,root) %{_bindir}/cargo-clippy
545%attr(755,root,root) %{_bindir}/cargo-fmt
546%attr(755,root,root) %{_bindir}/clippy-driver
8a758d34
JP
547%{_mandir}/man1/cargo*.1*
548%dir %{_datadir}/cargo
549%dir %{_datadir}/cargo/registry
550
551%files -n bash-completion-cargo
552%defattr(644,root,root,755)
553%{_sysconfdir}/bash_completion.d/cargo
554
555%files -n zsh-completion-cargo
556%defattr(644,root,root,755)
557%{zsh_compdir}/_cargo
This page took 0.799962 seconds and 5 git commands to generate.