]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
x32 patch does not seem to be required anymore
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
21# To bootstrap from scratch, set the channel and date from src/stage0.txt
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
8a54bb92
JP
24%define bootstrap_rust 1.51.0
25%define bootstrap_cargo 1.51.0
26%define bootstrap_date 2021-03-25
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
b263378f
JP
39Version: 1.52.1
40Release: 1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
b263378f 45# Source0-md5: 2df4835e3a15cc6f7e06fa4a986285d2
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
8a54bb92 47# Source1-md5: 7640d6538716c6492e56f361e3af0631
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
8a54bb92 49# Source2-md5: 64f117dc1ae1543c8910eaa9a971ddd4
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
8a54bb92 51# Source3-md5: 3ac79872671df7ea0215fd351f52ffcf
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
8a54bb92 53# Source4-md5: f624772d7c7ba2e83a51b4e9c1657f7b
e361528e 54URL: https://www.rust-lang.org/
e8f16183
JB
55# for src/compiler-rt
56BuildRequires: cmake >= 3.4.3
e361528e 57BuildRequires: curl
2eb30149
JB
58# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
59BuildRequires: procps
60BuildRequires: python >= 1:2.7
61BuildRequires: rpmbuild(macros) >= 1.752
62%if %{without cross}
8f176645 63BuildRequires: curl-devel
1f9b8560 64BuildRequires: libgit2-devel >= 1.1.0
d1b96fd8 65BuildRequires: libstdc++-devel
8a54bb92 66%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
7da6653d 67BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
68BuildRequires: tar >= 1:1.22
69BuildRequires: xz
e361528e 70BuildRequires: zlib-devel
2eb30149 71%endif
e361528e 72%if %{without bootstrap}
d6d4cb2b 73BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 74BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 75BuildConflicts: %{name} > %{version}
e361528e 76%endif
2eb30149 77%ifarch x32
cd0c1484
JR
78BuildRequires: glibc-devel(x86-64)
79BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
80%if "%{_host_cpu}" == "x86_64"
81# building on x86_64 host with --target x32-pld-linux
8f176645 82BuildRequires: curl-devel
2eb30149 83BuildRequires: gcc-multilib-x32
1f9b8560 84BuildRequires: libgit2-devel >= 1.1.0
2eb30149 85BuildRequires: libstdc++-devel
8a54bb92 86%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
2eb30149
JB
87BuildRequires: openssl-devel >= 1.0.1
88BuildRequires: zlib-devel
89%else
90# building x86_64-hosted crosscompiler on x32 host
56b25e8b 91BuildRequires: curl-devel(x86-64)
cd0c1484 92BuildRequires: curl-devel(x86-x32)
2eb30149 93BuildRequires: gcc-multilib-64
1f9b8560 94BuildRequires: libgit2-devel(x86-64) >= 1.1.0
cd0c1484 95BuildRequires: libgit2-devel(x86-x32) >= 1.1.0
2eb30149 96BuildRequires: libstdc++-multilib-64-devel
cd0c1484
JR
97%if %{with system_llvm}
98BuildRequires: llvm-devel(x86-64) >= 9.0
99BuildRequires: llvm-devel(x86-x32) >= 9.0
100%endif
56b25e8b 101BuildRequires: openssl-devel(x86-64)
cd0c1484 102BuildRequires: openssl-devel(x86-x32)
56b25e8b 103BuildRequires: zlib-devel(x86-64)
cd0c1484 104BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
105%endif
106%endif
e361528e
ER
107# The C compiler is needed at runtime just for linking. Someday rustc might
108# invoke the linker directly, and then we'll only need binutils.
109# https://github.com/rust-lang/rust/issues/11937
110Requires: gcc
cd0c1484
JR
111Requires: %{name}-std%{?_isa} = %{version}-%{release}
112%ifarch x32
113Requires: %{name}-std(x86-64) = %{version}-%{release}
114%endif
e361528e 115# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 116# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 117# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 118ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 119BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 120
e064fbd0 121%ifarch x32
badbe44d 122%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 123%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 124%define rust_bootstrap_triple x86_64-unknown-linux-gnu
e064fbd0 125%else
1fe729c8
JP
126%ifarch armv6hl armv7hl armv7hnl
127%define rust_triple arm-unknown-linux-gnueabihf
128%define rust_host_triple %{rust_triple}
129%define rust_bootstrap_triple %{rust_triple}
130%else
badbe44d 131%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
132%define rust_host_triple %{rust_triple}
133%define rust_bootstrap_triple %{rust_triple}
e064fbd0 134%endif
1fe729c8 135%endif
e361528e
ER
136
137%if %{without bootstrap}
8a073211 138%define local_rust_root %{_prefix}
e361528e 139%else
badbe44d 140%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 141%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
142%endif
143
18a1004b
JR
144# We're going to override --libdir when configuring to get rustlib into a
145# common path, but we'll fix the shared libraries during install.
5b9d67b0 146# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
147# for non-bootstrap build, lib64 is just too complicated for it.
148%define common_libdir %{_prefix}/lib
149%define rustlibdir %{common_libdir}/rustlib
150
19f98749 151# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 152%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 153
e361528e 154# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
155%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
156%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 157
37765656
JP
158%define x_py { \
159 x_py() { \
160 local cmd="$1"; \
161 shift; \
162 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
163 }; x_py }
164
165
e361528e
ER
166%description
167Rust is a systems programming language that runs blazingly fast,
168prevents segfaults, and guarantees thread safety.
169
170This package includes the Rust compiler, standard library, and
171documentation generator.
172
e8f16183
JB
173%description -l pl.UTF-8
174Rust to systemowy język programowania działający bardzo szybko,
175zapobiegający naruszeniom ochrony pamięci i gwarantujący
176bezpieczną wielowątkowość.
177
cd0c1484
JR
178%package analysis
179Summary: Metadata about the standard library
180Summary(pl.UTF-8): Metadane o standardowej bibliotece
181Group: Development/Tools
89a1e043 182Requires: %{name} = %{version}-%{release}
cd0c1484
JR
183
184%description analysis
185Metadata about the standard library.
186
187%description analysis -l pl.UTF-8
188Metadane o standardowej bibliotece.
189
190%package std
191Summary: Standard library for Rust
192Summary(pl.UTF-8): Standardowa biblioteka Rusta
193Group: Development/Tools
89a1e043 194Requires: %{name} = %{version}-%{release}
cd0c1484
JR
195
196%description std
197Standard library for Rust.
198
199%description std -l pl.UTF-8
200Standardowa biblioteka Rusta.
201
a7fda0f8
JP
202%package analyzer
203Summary: Implementation of Language Server Protocol for Rust
204Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
205Group: Development/Tools
89a1e043 206Requires: %{name} = %{version}-%{release}
a7fda0f8
JP
207
208%description analyzer
209Implementation of Language Server Protocol for Rust.
210
211%description analyzer -l pl.UTF-8
212Implementacja Language Server Protocol dla Rusta.
213
d1b96fd8
JR
214%package debugger-common
215Summary: Common debugger pretty printers for Rust
e8f16183 216Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 217Group: Development/Debuggers
e67020b3 218BuildArch: noarch
d1b96fd8
JR
219
220%description debugger-common
e8f16183
JB
221This package includes the common functionality for rust-gdb and
222rust-lldb.
223
224%description debugger-common -l pl.UTF-8
225Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 226
e361528e
ER
227%package gdb
228Summary: GDB pretty printers for Rust
e8f16183 229Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
230Group: Development/Debuggers
231Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 232Requires: gdb
e67020b3 233BuildArch: noarch
e361528e
ER
234
235%description gdb
236This package includes the rust-gdb script, which allows easier
237debugging of Rust programs.
238
e8f16183
JB
239%description gdb -l pl.UTF-8
240Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
241odpluskwianie programów w języku Rust.
242
d1b96fd8
JR
243%package lldb
244Summary: LLDB pretty printers for Rust
e8f16183 245Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
246Group: Development/Debuggers
247Requires: %{name}-debugger-common = %{version}-%{release}
248Requires: lldb
e67020b3 249BuildArch: noarch
d1b96fd8
JR
250
251%description lldb
252This package includes the rust-lldb script, which allows easier
253debugging of Rust programs.
254
e8f16183
JB
255%description lldb -l pl.UTF-8
256Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
257odpluskwianie programów w języku Rust.
258
a7fda0f8
JP
259%package rls
260Summary: Rust Language Server for IDE integration
261Summary(pl.UTF-8): Rust Language Server do integracji z IDE
262Group: Development/Tools
89a1e043
JR
263Requires: %{name} = %{version}-%{release}
264Requires: %{name}-analysis = %{version}-%{release}
a7fda0f8
JP
265
266%description rls
267Rust Language Server for IDE integration.
268
269%description rls -l pl.UTF-8
270Rust Language Server do integracji z IDE.
271
e361528e
ER
272%package doc
273Summary: Documentation for Rust
e8f16183 274Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 275Group: Documentation
e67020b3 276BuildArch: noarch
e361528e
ER
277
278%description doc
279This package includes HTML documentation for the Rust programming
280language and its standard library.
281
e8f16183
JB
282%description doc -l pl.UTF-8
283Ten pakiet zawiera dokumentację w formacie HTML do języka
284programowania Rust i jego biblioteki standardowej.
285
8a758d34
JP
286%package -n cargo
287Summary: Rust's package manager and build tool
288Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
289Group: Development/Tools
cd0c1484 290Requires: %{name}%{?_isa}
8a758d34
JP
291
292%description -n cargo
293Cargo is a tool that allows Rust projects to declare their various
294dependencies and ensure that you'll always get a repeatable build.
295
296%description -n cargo -l pl.UTF-8
297Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
298zależności i zapewniające powtarzalność procesu budowania.
299
6ed79af8
JB
300%package -n bash-completion-cargo
301Summary: Bash completion for cargo command
302Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
303Group: Applications/Shells
304Requires: %{name} = %{version}-%{release}
305Requires: bash-completion
306
307%description -n bash-completion-cargo
308Bash completion for cargo command.
309
310%description -n bash-completion-cargo -l pl.UTF-8
311Bashowe dopełnianie parametrów polecenia cargo.
312
8a758d34
JP
313%package -n zsh-completion-cargo
314Summary: Zsh completion for cargo command
315Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
316Group: Applications/Shells
317Requires: %{name} = %{version}-%{release}
6ed79af8 318Requires: zsh
8a758d34
JP
319
320%description -n zsh-completion-cargo
321Zsh completion for cargo command.
322
323%description -n zsh-completion-cargo -l pl.UTF-8
324Dopełnianie parametrów polecenia cargo w powłoce Zsh.
325
e361528e
ER
326%prep
327%setup -q -n %{rustc_package}
b5eceb5e 328
e361528e 329%if %{with bootstrap}
a1735efb 330%ifarch %{x8664} x32
e361528e
ER
331tar xf %{SOURCE1}
332%endif
333%ifarch %{ix86}
334tar xf %{SOURCE2}
335%endif
c160f211 336%ifarch aarch64
9eb0511e 337tar xf %{SOURCE3}
c160f211 338%endif
1fe729c8
JP
339%ifarch armv6hl armv7hl armv7hnl
340tar xf %{SOURCE4}
341%endif
d6d4cb2b
JR
342%{__mv} %{bootstrap_root} %{bootstrap_root}-root
343%{bootstrap_root}-root/install.sh \
badbe44d 344 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
345 --prefix=%{local_rust_root} \
346 --disable-ldconfig
347test -f %{local_rust_root}/bin/cargo
e361528e
ER
348test -f %{local_rust_root}/bin/rustc
349%endif
350
351# unbundle
d4b51567 352# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 353#%{__rm} -r src/jemalloc
9e7854c5
JP
354%if %{with system_llvm}
355%{__rm} -r src/llvm-project
356mkdir -p src/llvm-project/libunwind
357%endif
e361528e
ER
358
359# extract bundled licenses for packaging
5aae056c
JP
360sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
361 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
362
363# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
364sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
365 src/etc/rust-gdb
366
5ee06aa0
JR
367# The configure macro will modify some autoconf-related files, which upsets
368# cargo when it tries to verify checksums in those files. If we just truncate
369# that file list, cargo won't have anything to complain about.
fe49e3fc 370find vendor -name .cargo-checksum.json \
5ee06aa0 371 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 372
e361528e
ER
373%build
374%configure \
2eb30149
JB
375 --build=%{rust_bootstrap_triple} \
376 --host=%{rust_host_triple} \
e8f16183 377 --target=%{rust_triple} \
18a1004b 378 --libdir=%{common_libdir} \
e8f16183 379 --disable-codegen-tests \
5ee06aa0 380 --disable-debuginfo-lines \
5b9d67b0 381%if %{with full_debuginfo}
5ee06aa0 382 --disable-debuginfo-only-std \
e361528e 383 --enable-debuginfo \
5b9d67b0
JB
384%else
385 --enable-debuginfo-only-std \
386 --disable-debuginfo \
387%endif
6ed79af8
JB
388 --disable-jemalloc \
389 --disable-option-checking \
390 --disable-rpath \
8a758d34 391 --enable-extended \
e8f16183 392 --enable-llvm-link-shared \
d6d4cb2b 393 --enable-vendor \
6ed79af8 394 --local-rust-root=%{local_rust_root} \
e8f16183 395 --llvm-root=%{_prefix} \
e361528e
ER
396 --release-channel=%{channel}
397
37765656
JP
398export RUST_BACKTRACE=full
399%x_py dist --verbose
e361528e 400
37765656 401%{?with_tests:%x_py test}
8a073211 402
e361528e
ER
403%install
404rm -rf $RPM_BUILD_ROOT
e361528e 405
37765656
JP
406export DESTDIR=$RPM_BUILD_ROOT
407%x_py install
e361528e 408
18a1004b
JR
409# Make sure the shared libraries are in the proper libdir
410%if "%{_libdir}" != "%{common_libdir}"
411mkdir -p %{buildroot}%{_libdir}
412find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
413 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
414%endif
415
d1b96fd8 416# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
417find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
418
d1b96fd8
JR
419# The libdir libraries are identical to those under rustlib/. It's easier on
420# library loading if we keep them in libdir, but we do need them in rustlib/
421# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 422(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
423 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
424 -exec ln -v -f -s -t . '{}' '+')
425
426# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 427find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
428
429# FIXME: __os_install_post will strip the rlibs
430# -- should we find a way to preserve debuginfo?
431
432# Remove unwanted documentation files (we already package them)
e8f16183
JB
433%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
434%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
435%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
436%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
437
438# Sanitize the HTML documentation
439find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
440find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
441
442# Move rust-gdb's python scripts so they're noarch
443install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 444%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 445
4f353dba
JR
446# We don't need stdlib source
447%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
448
1dd26160
JP
449# Create the path for crate-devel packages
450install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
451
e361528e
ER
452%clean
453rm -rf $RPM_BUILD_ROOT
454
455%post -p /sbin/ldconfig
456%postun -p /sbin/ldconfig
457
458%files
459%defattr(644,root,root,755)
5aae056c 460%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
ca8b753f 461%attr(755,root,root) %{_bindir}/miri
e361528e
ER
462%attr(755,root,root) %{_bindir}/rustc
463%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 464%attr(755,root,root) %{_bindir}/rustfmt
e8f16183 465%attr(755,root,root) %{_libdir}/librustc*-*.so
e8f16183 466%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 467%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
468%{_mandir}/man1/rustc.1*
469%{_mandir}/man1/rustdoc.1*
18a1004b 470%dir %{rustlibdir}
cd0c1484
JR
471
472%files analysis
473%defattr(644,root,root,755)
6ed79af8 474%{rustlibdir}/%{rust_triple}/analysis
cd0c1484
JR
475
476%files std
477%defattr(644,root,root,755)
478%dir %{rustlibdir}/%{rust_triple}
18a1004b
JR
479%dir %{rustlibdir}/%{rust_triple}/lib
480%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
481%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 482
a7fda0f8
JP
483%files analyzer
484%defattr(644,root,root,755)
485%attr(755,root,root) %{_bindir}/rust-analyzer
486
d1b96fd8
JR
487%files debugger-common
488%defattr(644,root,root,755)
489%dir %{_datadir}/%{name}
490%dir %{_datadir}/%{name}/etc
5aae056c
JP
491%{_datadir}/%{name}/etc/lldb_commands
492%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
493
494%files lldb
495%defattr(644,root,root,755)
496%attr(755,root,root) %{_bindir}/rust-lldb
497%{_datadir}/%{name}/etc/lldb_*.py*
498
e361528e
ER
499%files gdb
500%defattr(644,root,root,755)
501%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 502%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 503%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 504
a7fda0f8
JP
505%files rls
506%defattr(644,root,root,755)
507%attr(755,root,root) %{_bindir}/rls
508
e361528e
ER
509%files doc
510%defattr(644,root,root,755)
511%dir %{_docdir}/%{name}
d1b96fd8 512%doc %{_docdir}/%{name}/html
8a758d34
JP
513
514%files -n cargo
515%defattr(644,root,root,755)
516%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
517%attr(755,root,root) %{_bindir}/cargo-clippy
518%attr(755,root,root) %{_bindir}/cargo-fmt
ca8b753f 519%attr(755,root,root) %{_bindir}/cargo-miri
6ed79af8 520%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 521%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
522%{_mandir}/man1/cargo*.1*
523%dir %{_datadir}/cargo
524%dir %{_datadir}/cargo/registry
525
526%files -n bash-completion-cargo
527%defattr(644,root,root,755)
528%{_sysconfdir}/bash_completion.d/cargo
529
530%files -n zsh-completion-cargo
531%defattr(644,root,root,755)
532%{zsh_compdir}/_cargo
This page took 0.189079 seconds and 4 git commands to generate.