]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
- rel 1, no need for release bump
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
e361528e
ER
4#
5# Conditional build:
e8f16183 6%bcond_with bootstrap # bootstrap using precompiled binaries
cace5bf9 7%bcond_with tests # build without tests
e361528e 8
8a073211
JR
9# The channel can be stable, beta, or nightly
10%define channel stable
11
e361528e 12%if "%{channel}" == "stable"
8a073211 13%define rustc_package rustc-%{version}-src
e361528e 14%else
8a073211 15%define rustc_package rustc-%{channel}-src
e361528e
ER
16%endif
17
18# To bootstrap from scratch, set the channel and date from src/stage0.txt
19# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
20# or nightly wants some beta-YYYY-MM-DD
9ee62e7d
JP
21%define bootstrap_rust 1.24.0
22%define bootstrap_cargo 0.25.0
23%define bootstrap_date 2018-02-15
e361528e
ER
24
25Summary: The Rust Programming Language
e8f16183 26Summary(pl.UTF-8): Język programowania Rust
e361528e 27Name: rust
9ee62e7d 28Version: 1.25.0
47e3f987 29Release: 1
d1b96fd8 30# Licenses: (rust itself) and (bundled libraries)
e8f16183 31License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 32Group: Development/Languages
d6d4cb2b 33Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
9ee62e7d 34# Source0-md5: d8d4d30c8d0b905f978bee3fdd618db5
8a073211 35Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.gz
9ee62e7d 36# Source1-md5: 61be17f80e1811211450e5b733624232
8a073211 37Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.gz
9ee62e7d 38# Source2-md5: 5568788cd5d96173a89bd0e82a2aa356
e361528e 39URL: https://www.rust-lang.org/
e8f16183
JB
40# for src/compiler-rt
41BuildRequires: cmake >= 3.4.3
e361528e 42BuildRequires: curl
d1b96fd8 43BuildRequires: libstdc++-devel
e361528e 44BuildRequires: llvm-devel
d1b96fd8 45BuildRequires: ncurses-devel
e8f16183 46BuildRequires: python >= 1:2.7
e361528e
ER
47BuildRequires: zlib-devel
48%if %{without bootstrap}
d6d4cb2b 49BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 50BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 51BuildConflicts: %{name} > %{version}
e361528e
ER
52%endif
53# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
54BuildRequires: procps
e361528e
ER
55# The C compiler is needed at runtime just for linking. Someday rustc might
56# invoke the linker directly, and then we'll only need binutils.
57# https://github.com/rust-lang/rust/issues/11937
58Requires: gcc
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60# Only x86_64 and i686 are Tier 1 platforms at this time.
61# https://doc.rust-lang.org/stable/book/getting-started.html#tier-1
d36946a0 62ExclusiveArch: %{x8664} %{ix86}
e361528e 63
8a073211 64%define rust_triple %{_target_cpu}-unknown-linux-gnu
e361528e
ER
65
66%if %{without bootstrap}
8a073211 67%define local_rust_root %{_prefix}
e361528e 68%else
8a073211
JR
69%define bootstrap_root rust-%{bootstrap_rust}-%{rust_triple}
70%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
71%endif
72
18a1004b
JR
73# We're going to override --libdir when configuring to get rustlib into a
74# common path, but we'll fix the shared libraries during install.
75# Without this ugly hack, rust would not be able to buld itself
76# for non-bootstrap build, lib64 is just too complicated for it.
77%define common_libdir %{_prefix}/lib
78%define rustlibdir %{common_libdir}/rustlib
79
19f98749 80# once_call/once_callable non-function libstdc++ symbols
f1c81849 81%define skip_post_check_so 'librustc_.*llvm-.*\.so.*'
19f98749 82
e361528e 83# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
84%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
85%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e
ER
86
87%description
88Rust is a systems programming language that runs blazingly fast,
89prevents segfaults, and guarantees thread safety.
90
91This package includes the Rust compiler, standard library, and
92documentation generator.
93
e8f16183
JB
94%description -l pl.UTF-8
95Rust to systemowy język programowania działający bardzo szybko,
96zapobiegający naruszeniom ochrony pamięci i gwarantujący
97bezpieczną wielowątkowość.
98
d1b96fd8
JR
99%package debugger-common
100Summary: Common debugger pretty printers for Rust
e8f16183 101Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8
JR
102Group: Development/Debuggers
103BuildArch: noarch
104
105%description debugger-common
e8f16183
JB
106This package includes the common functionality for rust-gdb and
107rust-lldb.
108
109%description debugger-common -l pl.UTF-8
110Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 111
e361528e
ER
112%package gdb
113Summary: GDB pretty printers for Rust
e8f16183 114Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
115Group: Development/Debuggers
116Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 117Requires: gdb
e361528e 118BuildArch: noarch
e361528e
ER
119
120%description gdb
121This package includes the rust-gdb script, which allows easier
122debugging of Rust programs.
123
e8f16183
JB
124%description gdb -l pl.UTF-8
125Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
126odpluskwianie programów w języku Rust.
127
d1b96fd8
JR
128%package lldb
129Summary: LLDB pretty printers for Rust
e8f16183 130Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
131Group: Development/Debuggers
132Requires: %{name}-debugger-common = %{version}-%{release}
133Requires: lldb
d1b96fd8
JR
134BuildArch: noarch
135
136%description lldb
137This package includes the rust-lldb script, which allows easier
138debugging of Rust programs.
139
e8f16183
JB
140%description lldb -l pl.UTF-8
141Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
142odpluskwianie programów w języku Rust.
143
e361528e
ER
144%package doc
145Summary: Documentation for Rust
e8f16183 146Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8
JR
147Group: Documentation
148BuildArch: noarch
e361528e
ER
149
150%description doc
151This package includes HTML documentation for the Rust programming
152language and its standard library.
153
e8f16183
JB
154%description doc -l pl.UTF-8
155Ten pakiet zawiera dokumentację w formacie HTML do języka
156programowania Rust i jego biblioteki standardowej.
157
e361528e
ER
158%prep
159%setup -q -n %{rustc_package}
b5eceb5e 160
e361528e
ER
161%if %{with bootstrap}
162%ifarch %{x8664}
163tar xf %{SOURCE1}
164%endif
165%ifarch %{ix86}
166tar xf %{SOURCE2}
167%endif
d6d4cb2b
JR
168%{__mv} %{bootstrap_root} %{bootstrap_root}-root
169%{bootstrap_root}-root/install.sh \
170 --components=cargo,rustc,rust-std-%{rust_triple} \
171 --prefix=%{local_rust_root} \
172 --disable-ldconfig
173test -f %{local_rust_root}/bin/cargo
e361528e
ER
174test -f %{local_rust_root}/bin/rustc
175%endif
176
177# unbundle
d4b51567
JR
178# We're disabling jemalloc, but rust-src still wants it.
179#%{__rm} -r src/jemalloc/
e8f16183 180%{__rm} -r src/llvm/
e361528e
ER
181
182# extract bundled licenses for packaging
183cp -p src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
184sed -e '/*\//q' src/libbacktrace/backtrace.h \
185 >src/libbacktrace/LICENSE-libbacktrace
186
187# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
188sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
189 src/etc/rust-gdb
190
5ee06aa0
JR
191# The configure macro will modify some autoconf-related files, which upsets
192# cargo when it tries to verify checksums in those files. If we just truncate
193# that file list, cargo won't have anything to complain about.
194find src/vendor -name .cargo-checksum.json \
195 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 196
e361528e
ER
197%build
198%configure \
e8f16183
JB
199 --build=%{rust_triple} \
200 --host=%{rust_triple} \
201 --target=%{rust_triple} \
18a1004b 202 --libdir=%{common_libdir} \
e8f16183 203 --disable-codegen-tests \
e361528e 204 --disable-jemalloc \
e8f16183 205 --disable-option-checking \
e361528e 206 --disable-rpath \
5ee06aa0
JR
207 --disable-debuginfo-lines \
208 --disable-debuginfo-only-std \
e361528e 209 --enable-debuginfo \
e8f16183 210 --enable-llvm-link-shared \
830375b8 211 --local-rust-root=%{local_rust_root} \
d6d4cb2b 212 --enable-vendor \
e8f16183 213 --llvm-root=%{_prefix} \
e361528e
ER
214 --release-channel=%{channel}
215
d6d4cb2b 216./x.py dist
e361528e 217
8a073211
JR
218%{?with_tests:./x.py test}
219
e361528e
ER
220%install
221rm -rf $RPM_BUILD_ROOT
e361528e 222
4f353dba
JR
223DESTDIR=$RPM_BUILD_ROOT ./x.py install
224DESTDIR=$RPM_BUILD_ROOT ./x.py install src
e361528e 225
18a1004b
JR
226# Make sure the shared libraries are in the proper libdir
227%if "%{_libdir}" != "%{common_libdir}"
228mkdir -p %{buildroot}%{_libdir}
229find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
230 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
231%endif
232
d1b96fd8 233# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
234find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
235
d1b96fd8
JR
236# The libdir libraries are identical to those under rustlib/. It's easier on
237# library loading if we keep them in libdir, but we do need them in rustlib/
238# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 239(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
240 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
241 -exec ln -v -f -s -t . '{}' '+')
242
243# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 244find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
245
246# FIXME: __os_install_post will strip the rlibs
247# -- should we find a way to preserve debuginfo?
248
249# Remove unwanted documentation files (we already package them)
e8f16183
JB
250%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
251%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
252%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
253%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
254
255# Sanitize the HTML documentation
256find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
257find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
258
259# Move rust-gdb's python scripts so they're noarch
260install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 261%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 262
4f353dba
JR
263# We don't need stdlib source
264%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
265
e361528e
ER
266%clean
267rm -rf $RPM_BUILD_ROOT
268
269%post -p /sbin/ldconfig
270%postun -p /sbin/ldconfig
271
272%files
273%defattr(644,root,root,755)
e8f16183 274%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md src/libbacktrace/LICENSE-libbacktrace src/rt/hoedown/LICENSE-hoedown
e361528e
ER
275%attr(755,root,root) %{_bindir}/rustc
276%attr(755,root,root) %{_bindir}/rustdoc
e8f16183 277%attr(755,root,root) %{_libdir}/libarena-*.so
e8f16183 278%attr(755,root,root) %{_libdir}/libfmt_macros-*.so
e8f16183
JB
279%attr(755,root,root) %{_libdir}/libgraphviz-*.so
280%attr(755,root,root) %{_libdir}/libproc_macro-*.so
e8f16183 281%attr(755,root,root) %{_libdir}/librustc*-*.so
e8f16183
JB
282%attr(755,root,root) %{_libdir}/libserialize-*.so
283%attr(755,root,root) %{_libdir}/libstd-*.so
284%attr(755,root,root) %{_libdir}/libsyntax-*.so
285%attr(755,root,root) %{_libdir}/libsyntax_ext-*.so
286%attr(755,root,root) %{_libdir}/libsyntax_pos-*.so
287%attr(755,root,root) %{_libdir}/libterm-*.so
288%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
289%{_mandir}/man1/rustc.1*
290%{_mandir}/man1/rustdoc.1*
18a1004b
JR
291%dir %{rustlibdir}
292%dir %{rustlibdir}/%{rust_triple}
9ee62e7d
JP
293%dir %{rustlibdir}/%{rust_triple}/codegen-backends
294%attr(755,root,root) %{rustlibdir}/%{rust_triple}/codegen-backends/*.so
18a1004b
JR
295%dir %{rustlibdir}/%{rust_triple}/lib
296%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
297%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 298
d1b96fd8
JR
299%files debugger-common
300%defattr(644,root,root,755)
301%dir %{_datadir}/%{name}
302%dir %{_datadir}/%{name}/etc
303%{_datadir}/%{name}/etc/debugger_*.py*
304
305%files lldb
306%defattr(644,root,root,755)
307%attr(755,root,root) %{_bindir}/rust-lldb
308%{_datadir}/%{name}/etc/lldb_*.py*
309
e361528e
ER
310%files gdb
311%defattr(644,root,root,755)
312%attr(755,root,root) %{_bindir}/rust-gdb
d1b96fd8 313%{_datadir}/%{name}/etc/gdb_*.py*
e361528e
ER
314
315%files doc
316%defattr(644,root,root,755)
317%dir %{_docdir}/%{name}
d1b96fd8 318%doc %{_docdir}/%{name}/html
This page took 0.152683 seconds and 4 git commands to generate.