]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
bin dir also not available on x32; rel 3
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
fc3be51a 21# To bootstrap from scratch, set the channel and date from src/stage0.json
e361528e
ER
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
aea1d260
JP
24%define bootstrap_rust 1.57.0
25%define bootstrap_cargo %{bootstrap_rust}
26%define bootstrap_date 2021-12-02
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
5c688b54 39Version: 1.58.1
f78840a2 40Release: 3
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
5c688b54 45# Source0-md5: 835e82d659ea4fc19fd1f0888de01ad8
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
aea1d260 47# Source1-md5: 0f58dba84eba1a5ab8ec51f52d95f453
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
aea1d260 49# Source2-md5: d75c7b995614c6ffa8df4409e64a13d6
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
aea1d260 51# Source3-md5: 7ba95696643b96b765b7ef5179cba8a4
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
aea1d260 53# Source4-md5: 50ab0a0c6f4dc386e09616778e92a934
ad044650 54Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
aea1d260 55# Source5-md5: d79e80ff8677da71154b326f51ea39ee
e361528e 56URL: https://www.rust-lang.org/
e8f16183
JB
57# for src/compiler-rt
58BuildRequires: cmake >= 3.4.3
e361528e 59BuildRequires: curl
2eb30149
JB
60# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61BuildRequires: procps
e65d284f
JP
62BuildRequires: python3
63BuildRequires: python3-modules
fc3be51a 64BuildRequires: rpm-build >= 4.6
2eb30149
JB
65BuildRequires: rpmbuild(macros) >= 1.752
66%if %{without cross}
8f176645 67BuildRequires: curl-devel
2983f519 68BuildRequires: libgit2-devel >= 1.3.0
d1b96fd8 69BuildRequires: libstdc++-devel
2cec66d3 70%if %{with system_llvm}
aea1d260
JP
71BuildRequires: llvm >= 12.0
72BuildRequires: llvm-devel >= 12.0
2cec66d3 73%endif
7da6653d 74BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
75BuildRequires: tar >= 1:1.22
76BuildRequires: xz
e361528e 77BuildRequires: zlib-devel
2eb30149 78%endif
e361528e 79%if %{without bootstrap}
d6d4cb2b 80BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 81BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 82BuildConflicts: %{name} > %{version}
e361528e 83%endif
2eb30149 84%ifarch x32
cd0c1484
JR
85BuildRequires: glibc-devel(x86-64)
86BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
87%if "%{_host_cpu}" == "x86_64"
88# building on x86_64 host with --target x32-pld-linux
8f176645 89BuildRequires: curl-devel
2eb30149 90BuildRequires: gcc-multilib-x32
2983f519 91BuildRequires: libgit2-devel >= 1.3.0
2eb30149 92BuildRequires: libstdc++-devel
aea1d260 93%{?with_system_llvm:BuildRequires: llvm-devel >= 12.0}
2eb30149
JB
94BuildRequires: openssl-devel >= 1.0.1
95BuildRequires: zlib-devel
96%else
97# building x86_64-hosted crosscompiler on x32 host
56b25e8b 98BuildRequires: curl-devel(x86-64)
cd0c1484 99BuildRequires: curl-devel(x86-x32)
2eb30149 100BuildRequires: gcc-multilib-64
2983f519
JR
101BuildRequires: libgit2-devel(x86-64) >= 1.3.0
102BuildRequires: libgit2-devel(x86-x32) >= 1.3.0
2eb30149 103BuildRequires: libstdc++-multilib-64-devel
cd0c1484 104%if %{with system_llvm}
aea1d260
JP
105BuildRequires: llvm-devel(x86-64) >= 12.0
106BuildRequires: llvm-devel(x86-x32) >= 12.0
cd0c1484 107%endif
56b25e8b 108BuildRequires: openssl-devel(x86-64)
cd0c1484 109BuildRequires: openssl-devel(x86-x32)
56b25e8b 110BuildRequires: zlib-devel(x86-64)
cd0c1484 111BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
112%endif
113%endif
e361528e
ER
114# The C compiler is needed at runtime just for linking. Someday rustc might
115# invoke the linker directly, and then we'll only need binutils.
116# https://github.com/rust-lang/rust/issues/11937
117Requires: gcc
cd0c1484
JR
118Requires: %{name}-std%{?_isa} = %{version}-%{release}
119%ifarch x32
120Requires: %{name}-std(x86-64) = %{version}-%{release}
121%endif
b8711561 122Obsoletes: rust-analyzer < 1.53.0
e361528e 123# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 124# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 125# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 126ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 127BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 128
e064fbd0 129%ifarch x32
badbe44d 130%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 131%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 132%define rust_bootstrap_triple x86_64-unknown-linux-gnu
a973dc7e
JR
133# libs in _libdir are x86_64 64bit
134%define _lib lib64
135%define _libdir %{_prefix}/lib64
e064fbd0 136%else
ad044650 137%ifarch armv6hl
1fe729c8
JP
138%define rust_triple arm-unknown-linux-gnueabihf
139%define rust_host_triple %{rust_triple}
140%define rust_bootstrap_triple %{rust_triple}
141%else
ad044650
JP
142%ifarch armv7hl armv7hnl
143%define rust_triple armv7-unknown-linux-gnueabihf
144%define rust_host_triple %{rust_triple}
145%define rust_bootstrap_triple %{rust_triple}
6c4856ce 146%define rust_suppl_targets thumbv7neon-unknown-linux-gnueabihf
ad044650 147%else
badbe44d 148%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
149%define rust_host_triple %{rust_triple}
150%define rust_bootstrap_triple %{rust_triple}
e064fbd0 151%endif
1fe729c8 152%endif
ad044650 153%endif
e361528e 154
62473c95
JP
155%define rust_targets %rust_triple %{?rust_suppl_targets}
156
e361528e 157%if %{without bootstrap}
8a073211 158%define local_rust_root %{_prefix}
e361528e 159%else
badbe44d 160%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 161%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
162%endif
163
18a1004b
JR
164# We're going to override --libdir when configuring to get rustlib into a
165# common path, but we'll fix the shared libraries during install.
5b9d67b0 166# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
167# for non-bootstrap build, lib64 is just too complicated for it.
168%define common_libdir %{_prefix}/lib
169%define rustlibdir %{common_libdir}/rustlib
170
19f98749 171# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 172%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 173
e361528e 174# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
175%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
176%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 177
37765656
JP
178%define x_py { \
179 x_py() { \
180 local cmd="$1"; \
181 shift; \
e65d284f 182 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
37765656
JP
183 }; x_py }
184
185
e361528e
ER
186%description
187Rust is a systems programming language that runs blazingly fast,
188prevents segfaults, and guarantees thread safety.
189
190This package includes the Rust compiler, standard library, and
191documentation generator.
192
e8f16183
JB
193%description -l pl.UTF-8
194Rust to systemowy język programowania działający bardzo szybko,
195zapobiegający naruszeniom ochrony pamięci i gwarantujący
196bezpieczną wielowątkowość.
197
cd0c1484
JR
198%package analysis
199Summary: Metadata about the standard library
200Summary(pl.UTF-8): Metadane o standardowej bibliotece
201Group: Development/Tools
89a1e043 202Requires: %{name} = %{version}-%{release}
cd0c1484
JR
203
204%description analysis
205Metadata about the standard library.
206
207%description analysis -l pl.UTF-8
208Metadane o standardowej bibliotece.
209
210%package std
211Summary: Standard library for Rust
212Summary(pl.UTF-8): Standardowa biblioteka Rusta
213Group: Development/Tools
89a1e043 214Requires: %{name} = %{version}-%{release}
cd0c1484
JR
215
216%description std
217Standard library for Rust.
218
219%description std -l pl.UTF-8
220Standardowa biblioteka Rusta.
221
d1b96fd8
JR
222%package debugger-common
223Summary: Common debugger pretty printers for Rust
e8f16183 224Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 225Group: Development/Debuggers
e67020b3 226BuildArch: noarch
d1b96fd8
JR
227
228%description debugger-common
e8f16183
JB
229This package includes the common functionality for rust-gdb and
230rust-lldb.
231
232%description debugger-common -l pl.UTF-8
233Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 234
e361528e
ER
235%package gdb
236Summary: GDB pretty printers for Rust
e8f16183 237Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
238Group: Development/Debuggers
239Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 240Requires: gdb
e67020b3 241BuildArch: noarch
e361528e
ER
242
243%description gdb
244This package includes the rust-gdb script, which allows easier
245debugging of Rust programs.
246
e8f16183
JB
247%description gdb -l pl.UTF-8
248Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
249odpluskwianie programów w języku Rust.
250
d1b96fd8
JR
251%package lldb
252Summary: LLDB pretty printers for Rust
e8f16183 253Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
254Group: Development/Debuggers
255Requires: %{name}-debugger-common = %{version}-%{release}
256Requires: lldb
e67020b3 257BuildArch: noarch
d1b96fd8
JR
258
259%description lldb
260This package includes the rust-lldb script, which allows easier
261debugging of Rust programs.
262
e8f16183
JB
263%description lldb -l pl.UTF-8
264Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
265odpluskwianie programów w języku Rust.
266
a7fda0f8
JP
267%package rls
268Summary: Rust Language Server for IDE integration
269Summary(pl.UTF-8): Rust Language Server do integracji z IDE
270Group: Development/Tools
89a1e043
JR
271Requires: %{name} = %{version}-%{release}
272Requires: %{name}-analysis = %{version}-%{release}
a7fda0f8
JP
273
274%description rls
275Rust Language Server for IDE integration.
276
277%description rls -l pl.UTF-8
278Rust Language Server do integracji z IDE.
279
e361528e
ER
280%package doc
281Summary: Documentation for Rust
e8f16183 282Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 283Group: Documentation
e67020b3 284BuildArch: noarch
e361528e
ER
285
286%description doc
287This package includes HTML documentation for the Rust programming
288language and its standard library.
289
e8f16183
JB
290%description doc -l pl.UTF-8
291Ten pakiet zawiera dokumentację w formacie HTML do języka
292programowania Rust i jego biblioteki standardowej.
293
8a758d34
JP
294%package -n cargo
295Summary: Rust's package manager and build tool
296Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
297Group: Development/Tools
cd0c1484 298Requires: %{name}%{?_isa}
8a758d34
JP
299
300%description -n cargo
301Cargo is a tool that allows Rust projects to declare their various
302dependencies and ensure that you'll always get a repeatable build.
303
304%description -n cargo -l pl.UTF-8
305Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
306zależności i zapewniające powtarzalność procesu budowania.
307
6ed79af8
JB
308%package -n bash-completion-cargo
309Summary: Bash completion for cargo command
310Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
311Group: Applications/Shells
312Requires: %{name} = %{version}-%{release}
313Requires: bash-completion
314
315%description -n bash-completion-cargo
316Bash completion for cargo command.
317
318%description -n bash-completion-cargo -l pl.UTF-8
319Bashowe dopełnianie parametrów polecenia cargo.
320
8a758d34
JP
321%package -n zsh-completion-cargo
322Summary: Zsh completion for cargo command
323Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
324Group: Applications/Shells
325Requires: %{name} = %{version}-%{release}
6ed79af8 326Requires: zsh
8a758d34
JP
327
328%description -n zsh-completion-cargo
329Zsh completion for cargo command.
330
331%description -n zsh-completion-cargo -l pl.UTF-8
332Dopełnianie parametrów polecenia cargo w powłoce Zsh.
333
e361528e
ER
334%prep
335%setup -q -n %{rustc_package}
b5eceb5e 336
e361528e 337%if %{with bootstrap}
a1735efb 338%ifarch %{x8664} x32
e361528e
ER
339tar xf %{SOURCE1}
340%endif
341%ifarch %{ix86}
342tar xf %{SOURCE2}
343%endif
c160f211 344%ifarch aarch64
9eb0511e 345tar xf %{SOURCE3}
c160f211 346%endif
ad044650 347%ifarch armv6hl
1fe729c8
JP
348tar xf %{SOURCE4}
349%endif
ad044650
JP
350%ifarch armv7hl armv7hnl
351tar xf %{SOURCE5}
352%endif
d6d4cb2b
JR
353%{__mv} %{bootstrap_root} %{bootstrap_root}-root
354%{bootstrap_root}-root/install.sh \
badbe44d 355 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
356 --prefix=%{local_rust_root} \
357 --disable-ldconfig
358test -f %{local_rust_root}/bin/cargo
e361528e
ER
359test -f %{local_rust_root}/bin/rustc
360%endif
361
362# unbundle
d4b51567 363# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 364#%{__rm} -r src/jemalloc
9e7854c5
JP
365%if %{with system_llvm}
366%{__rm} -r src/llvm-project
367mkdir -p src/llvm-project/libunwind
368%endif
e361528e 369
e361528e
ER
370# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
371sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
372 src/etc/rust-gdb
373
4b354bd7
JB
374# cargo has hardcoded libexec path - honour rpm _libexecdir
375%if "%{_libexecdir}" != "%{_prefix}/libexec"
376suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
377%{__sed} -i -e 's,"libexec","'${suffix}'",' \
378 src/bootstrap/dist.rs \
379 src/tools/cargo/src/cargo/ops/registry/auth.rs
380%{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
381%endif
382
5ee06aa0
JR
383# The configure macro will modify some autoconf-related files, which upsets
384# cargo when it tries to verify checksums in those files. If we just truncate
385# that file list, cargo won't have anything to complain about.
fe49e3fc 386find vendor -name .cargo-checksum.json \
5ee06aa0 387 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 388
e361528e 389%build
863a59ff
JP
390export CC="%{__cc}"
391export CXX="%{__cxx}"
392export AR="%{__ar}"
e361528e 393%configure \
2eb30149
JB
394 --build=%{rust_bootstrap_triple} \
395 --host=%{rust_host_triple} \
62473c95 396 --target="%(echo %rust_targets | tr ' ' ,)" \
18a1004b 397 --libdir=%{common_libdir} \
e8f16183 398 --disable-codegen-tests \
5ee06aa0 399 --disable-debuginfo-lines \
5b9d67b0 400%if %{with full_debuginfo}
5ee06aa0 401 --disable-debuginfo-only-std \
e361528e 402 --enable-debuginfo \
5b9d67b0
JB
403%else
404 --enable-debuginfo-only-std \
405 --disable-debuginfo \
406%endif
6ed79af8
JB
407 --disable-jemalloc \
408 --disable-option-checking \
409 --disable-rpath \
8a758d34 410 --enable-extended \
e8f16183 411 --enable-llvm-link-shared \
d6d4cb2b 412 --enable-vendor \
6ed79af8 413 --local-rust-root=%{local_rust_root} \
e8f16183 414 --llvm-root=%{_prefix} \
e361528e
ER
415 --release-channel=%{channel}
416
37765656
JP
417export RUST_BACKTRACE=full
418%x_py dist --verbose
e361528e 419
37765656 420%{?with_tests:%x_py test}
8a073211 421
e361528e
ER
422%install
423rm -rf $RPM_BUILD_ROOT
e361528e 424
37765656
JP
425export DESTDIR=$RPM_BUILD_ROOT
426%x_py install
e361528e 427
18a1004b
JR
428# Make sure the shared libraries are in the proper libdir
429%if "%{_libdir}" != "%{common_libdir}"
430mkdir -p %{buildroot}%{_libdir}
431find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
432 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
433%endif
434
d1b96fd8 435# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
436find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
437
d1b96fd8
JR
438# The libdir libraries are identical to those under rustlib/. It's easier on
439# library loading if we keep them in libdir, but we do need them in rustlib/
440# to support dynamic linking for compiler plugins, so we'll symlink.
62473c95
JP
441for rust_target in %rust_targets; do
442 for l in libstd libtest ; do
443 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
444 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
445 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
446 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
447 fi
448 done
a973dc7e 449done
d1b96fd8
JR
450
451# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 452find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
453
454# FIXME: __os_install_post will strip the rlibs
455# -- should we find a way to preserve debuginfo?
456
457# Remove unwanted documentation files (we already package them)
e8f16183
JB
458%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
459%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
460%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
461%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
462
463# Sanitize the HTML documentation
464find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
465find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
466
467# Move rust-gdb's python scripts so they're noarch
468install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 469%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 470
4f353dba
JR
471# We don't need stdlib source
472%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
473
1dd26160
JP
474# Create the path for crate-devel packages
475install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
476
e361528e
ER
477%clean
478rm -rf $RPM_BUILD_ROOT
479
480%post -p /sbin/ldconfig
481%postun -p /sbin/ldconfig
482
483%files
484%defattr(644,root,root,755)
16ea23d8 485%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
1736a047 486%attr(755,root,root) %{_bindir}/rust-demangler
e361528e
ER
487%attr(755,root,root) %{_bindir}/rustc
488%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 489%attr(755,root,root) %{_bindir}/rustfmt
a973dc7e 490%attr(755,root,root) %{_libdir}/librustc_driver-*.so
e8f16183 491%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 492%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
493%{_mandir}/man1/rustc.1*
494%{_mandir}/man1/rustdoc.1*
18a1004b 495%dir %{rustlibdir}
cd0c1484
JR
496
497%files analysis
498%defattr(644,root,root,755)
62473c95
JP
499%(for rust_target in %rust_targets; do
500echo "%{rustlibdir}/$rust_target/analysis"
501done
502)
cd0c1484
JR
503
504%files std
505%defattr(644,root,root,755)
62473c95
JP
506%(for rust_target in %rust_targets; do
507cat <<EOF
508%dir %{rustlibdir}/$rust_target
509%dir %{rustlibdir}/$rust_target/lib
510%attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
511%{rustlibdir}/$rust_target/lib/*.rlib
512EOF
513done
514)
df90c046 515%ifnarch x32
f78840a2 516%dir %{rustlibdir}/%{rust_triple}/bin
1736a047 517%attr(755,root,root) %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
df90c046 518%endif
e361528e 519
d1b96fd8
JR
520%files debugger-common
521%defattr(644,root,root,755)
522%dir %{_datadir}/%{name}
523%dir %{_datadir}/%{name}/etc
5aae056c
JP
524%{_datadir}/%{name}/etc/lldb_commands
525%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
526
527%files lldb
528%defattr(644,root,root,755)
529%attr(755,root,root) %{_bindir}/rust-lldb
530%{_datadir}/%{name}/etc/lldb_*.py*
531
e361528e
ER
532%files gdb
533%defattr(644,root,root,755)
534%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 535%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 536%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 537
a7fda0f8
JP
538%files rls
539%defattr(644,root,root,755)
540%attr(755,root,root) %{_bindir}/rls
541
e361528e
ER
542%files doc
543%defattr(644,root,root,755)
544%dir %{_docdir}/%{name}
d1b96fd8 545%doc %{_docdir}/%{name}/html
8a758d34
JP
546
547%files -n cargo
548%defattr(644,root,root,755)
549%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
550%attr(755,root,root) %{_bindir}/cargo-clippy
551%attr(755,root,root) %{_bindir}/cargo-fmt
552%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 553%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
554%{_mandir}/man1/cargo*.1*
555%dir %{_datadir}/cargo
556%dir %{_datadir}/cargo/registry
557
558%files -n bash-completion-cargo
559%defattr(644,root,root,755)
560%{_sysconfdir}/bash_completion.d/cargo
561
562%files -n zsh-completion-cargo
563%defattr(644,root,root,755)
564%{zsh_compdir}/_cargo
This page took 0.187381 seconds and 4 git commands to generate.