]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
up to 1.52.0
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
21# To bootstrap from scratch, set the channel and date from src/stage0.txt
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
8a54bb92
JP
24%define bootstrap_rust 1.51.0
25%define bootstrap_cargo 1.51.0
26%define bootstrap_date 2021-03-25
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
e361528e 31Summary: The Rust Programming Language
e8f16183 32Summary(pl.UTF-8): Język programowania Rust
e361528e 33Name: rust
8a54bb92 34Version: 1.52.0
20b64456 35Release: 0.1
d1b96fd8 36# Licenses: (rust itself) and (bundled libraries)
e8f16183 37License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 38Group: Development/Languages
be28e1f1 39Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
8a54bb92 40# Source0-md5: f95ca614a531b3c1edd4918eaa329732
be28e1f1 41Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
8a54bb92 42# Source1-md5: 7640d6538716c6492e56f361e3af0631
be28e1f1 43Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
8a54bb92 44# Source2-md5: 64f117dc1ae1543c8910eaa9a971ddd4
9eb0511e 45Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
8a54bb92 46# Source3-md5: 3ac79872671df7ea0215fd351f52ffcf
1fe729c8 47Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
8a54bb92 48# Source4-md5: f624772d7c7ba2e83a51b4e9c1657f7b
5aae056c 49Patch0: %{name}-x32.patch
e361528e 50URL: https://www.rust-lang.org/
e8f16183
JB
51# for src/compiler-rt
52BuildRequires: cmake >= 3.4.3
e361528e 53BuildRequires: curl
2eb30149
JB
54# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
55BuildRequires: procps
56BuildRequires: python >= 1:2.7
57BuildRequires: rpmbuild(macros) >= 1.752
58%if %{without cross}
8f176645
JB
59BuildRequires: curl-devel
60BuildRequires: libgit2-devel
d1b96fd8 61BuildRequires: libstdc++-devel
8a54bb92 62%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
7da6653d 63BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
64BuildRequires: tar >= 1:1.22
65BuildRequires: xz
e361528e 66BuildRequires: zlib-devel
2eb30149 67%endif
e361528e 68%if %{without bootstrap}
d6d4cb2b 69BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 70BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 71BuildConflicts: %{name} > %{version}
e361528e 72%endif
2eb30149
JB
73%ifarch x32
74BuildRequires: glibc-devel(x32)
75BuildRequires: glibc-devel(x86_64)
76%if "%{_host_cpu}" == "x86_64"
77# building on x86_64 host with --target x32-pld-linux
8f176645 78BuildRequires: curl-devel
2eb30149 79BuildRequires: gcc-multilib-x32
8f176645 80BuildRequires: libgit2-devel
2eb30149 81BuildRequires: libstdc++-devel
8a54bb92 82%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
2eb30149
JB
83BuildRequires: openssl-devel >= 1.0.1
84BuildRequires: zlib-devel
85%else
86# building x86_64-hosted crosscompiler on x32 host
87BuildRequires: gcc-multilib-64
88BuildRequires: libstdc++-multilib-64-devel
3c25e53d
JR
89# how to specify? - rpm.org adds arch provides on packages (__isa), uncomment once we switch
90#BuildRequires: curl-devel(x86-64)
91#BuildRequires: libgit2-devel(x86-64)
92#BuildRequires: llvm-devel(x86-64)>= 7.0
93#BuildRequires: openssl-devel(x86-64)
94#BuildRequires: zlib-devel(x86-64)
2eb30149
JB
95%endif
96%endif
e361528e
ER
97# The C compiler is needed at runtime just for linking. Someday rustc might
98# invoke the linker directly, and then we'll only need binutils.
99# https://github.com/rust-lang/rust/issues/11937
100Requires: gcc
e361528e 101# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 102# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 103# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 104ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 105BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 106
e064fbd0 107%ifarch x32
badbe44d 108%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 109%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 110%define rust_bootstrap_triple x86_64-unknown-linux-gnu
e064fbd0 111%else
1fe729c8
JP
112%ifarch armv6hl armv7hl armv7hnl
113%define rust_triple arm-unknown-linux-gnueabihf
114%define rust_host_triple %{rust_triple}
115%define rust_bootstrap_triple %{rust_triple}
116%else
badbe44d 117%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
118%define rust_host_triple %{rust_triple}
119%define rust_bootstrap_triple %{rust_triple}
e064fbd0 120%endif
1fe729c8 121%endif
e361528e
ER
122
123%if %{without bootstrap}
8a073211 124%define local_rust_root %{_prefix}
e361528e 125%else
badbe44d 126%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 127%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
128%endif
129
18a1004b
JR
130# We're going to override --libdir when configuring to get rustlib into a
131# common path, but we'll fix the shared libraries during install.
5b9d67b0 132# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
133# for non-bootstrap build, lib64 is just too complicated for it.
134%define common_libdir %{_prefix}/lib
135%define rustlibdir %{common_libdir}/rustlib
136
19f98749 137# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 138%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 139
e361528e 140# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
141%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
142%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 143
37765656
JP
144%define x_py { \
145 x_py() { \
146 local cmd="$1"; \
147 shift; \
148 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
149 }; x_py }
150
151
e361528e
ER
152%description
153Rust is a systems programming language that runs blazingly fast,
154prevents segfaults, and guarantees thread safety.
155
156This package includes the Rust compiler, standard library, and
157documentation generator.
158
e8f16183
JB
159%description -l pl.UTF-8
160Rust to systemowy język programowania działający bardzo szybko,
161zapobiegający naruszeniom ochrony pamięci i gwarantujący
162bezpieczną wielowątkowość.
163
a7fda0f8
JP
164%package analyzer
165Summary: Implementation of Language Server Protocol for Rust
166Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
167Group: Development/Tools
168Requires: %{name} = %{version}-%{release}
169
170%description analyzer
171Implementation of Language Server Protocol for Rust.
172
173%description analyzer -l pl.UTF-8
174Implementacja Language Server Protocol dla Rusta.
175
d1b96fd8
JR
176%package debugger-common
177Summary: Common debugger pretty printers for Rust
e8f16183 178Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 179Group: Development/Debuggers
e67020b3 180BuildArch: noarch
d1b96fd8
JR
181
182%description debugger-common
e8f16183
JB
183This package includes the common functionality for rust-gdb and
184rust-lldb.
185
186%description debugger-common -l pl.UTF-8
187Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 188
e361528e
ER
189%package gdb
190Summary: GDB pretty printers for Rust
e8f16183 191Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
192Group: Development/Debuggers
193Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 194Requires: gdb
e67020b3 195BuildArch: noarch
e361528e
ER
196
197%description gdb
198This package includes the rust-gdb script, which allows easier
199debugging of Rust programs.
200
e8f16183
JB
201%description gdb -l pl.UTF-8
202Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
203odpluskwianie programów w języku Rust.
204
d1b96fd8
JR
205%package lldb
206Summary: LLDB pretty printers for Rust
e8f16183 207Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
208Group: Development/Debuggers
209Requires: %{name}-debugger-common = %{version}-%{release}
210Requires: lldb
e67020b3 211BuildArch: noarch
d1b96fd8
JR
212
213%description lldb
214This package includes the rust-lldb script, which allows easier
215debugging of Rust programs.
216
e8f16183
JB
217%description lldb -l pl.UTF-8
218Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
219odpluskwianie programów w języku Rust.
220
a7fda0f8
JP
221%package rls
222Summary: Rust Language Server for IDE integration
223Summary(pl.UTF-8): Rust Language Server do integracji z IDE
224Group: Development/Tools
225Requires: %{name} = %{version}-%{release}
226
227%description rls
228Rust Language Server for IDE integration.
229
230%description rls -l pl.UTF-8
231Rust Language Server do integracji z IDE.
232
e361528e
ER
233%package doc
234Summary: Documentation for Rust
e8f16183 235Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 236Group: Documentation
e67020b3 237BuildArch: noarch
e361528e
ER
238
239%description doc
240This package includes HTML documentation for the Rust programming
241language and its standard library.
242
e8f16183
JB
243%description doc -l pl.UTF-8
244Ten pakiet zawiera dokumentację w formacie HTML do języka
245programowania Rust i jego biblioteki standardowej.
246
8a758d34
JP
247%package -n cargo
248Summary: Rust's package manager and build tool
249Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
250Group: Development/Tools
251Requires: %{name}
252
253%description -n cargo
254Cargo is a tool that allows Rust projects to declare their various
255dependencies and ensure that you'll always get a repeatable build.
256
257%description -n cargo -l pl.UTF-8
258Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
259zależności i zapewniające powtarzalność procesu budowania.
260
6ed79af8
JB
261%package -n bash-completion-cargo
262Summary: Bash completion for cargo command
263Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
264Group: Applications/Shells
265Requires: %{name} = %{version}-%{release}
266Requires: bash-completion
267
268%description -n bash-completion-cargo
269Bash completion for cargo command.
270
271%description -n bash-completion-cargo -l pl.UTF-8
272Bashowe dopełnianie parametrów polecenia cargo.
273
8a758d34
JP
274%package -n zsh-completion-cargo
275Summary: Zsh completion for cargo command
276Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
277Group: Applications/Shells
278Requires: %{name} = %{version}-%{release}
6ed79af8 279Requires: zsh
8a758d34
JP
280
281%description -n zsh-completion-cargo
282Zsh completion for cargo command.
283
284%description -n zsh-completion-cargo -l pl.UTF-8
285Dopełnianie parametrów polecenia cargo w powłoce Zsh.
286
e361528e
ER
287%prep
288%setup -q -n %{rustc_package}
2eb30149 289# irrelevant when not building rustc for x32
8a54bb92 290#%%patch0 -p1
b5eceb5e 291
e361528e 292%if %{with bootstrap}
a1735efb 293%ifarch %{x8664} x32
e361528e
ER
294tar xf %{SOURCE1}
295%endif
296%ifarch %{ix86}
297tar xf %{SOURCE2}
298%endif
c160f211 299%ifarch aarch64
9eb0511e 300tar xf %{SOURCE3}
c160f211 301%endif
1fe729c8
JP
302%ifarch armv6hl armv7hl armv7hnl
303tar xf %{SOURCE4}
304%endif
d6d4cb2b
JR
305%{__mv} %{bootstrap_root} %{bootstrap_root}-root
306%{bootstrap_root}-root/install.sh \
badbe44d 307 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
308 --prefix=%{local_rust_root} \
309 --disable-ldconfig
310test -f %{local_rust_root}/bin/cargo
e361528e
ER
311test -f %{local_rust_root}/bin/rustc
312%endif
313
314# unbundle
d4b51567 315# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 316#%{__rm} -r src/jemalloc
9e7854c5
JP
317%if %{with system_llvm}
318%{__rm} -r src/llvm-project
319mkdir -p src/llvm-project/libunwind
320%endif
e361528e
ER
321
322# extract bundled licenses for packaging
5aae056c
JP
323sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
324 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
325
326# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
327sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
328 src/etc/rust-gdb
329
5ee06aa0
JR
330# The configure macro will modify some autoconf-related files, which upsets
331# cargo when it tries to verify checksums in those files. If we just truncate
332# that file list, cargo won't have anything to complain about.
fe49e3fc 333find vendor -name .cargo-checksum.json \
5ee06aa0 334 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 335
e361528e
ER
336%build
337%configure \
2eb30149
JB
338 --build=%{rust_bootstrap_triple} \
339 --host=%{rust_host_triple} \
e8f16183 340 --target=%{rust_triple} \
18a1004b 341 --libdir=%{common_libdir} \
e8f16183 342 --disable-codegen-tests \
5ee06aa0 343 --disable-debuginfo-lines \
5b9d67b0 344%if %{with full_debuginfo}
5ee06aa0 345 --disable-debuginfo-only-std \
e361528e 346 --enable-debuginfo \
5b9d67b0
JB
347%else
348 --enable-debuginfo-only-std \
349 --disable-debuginfo \
350%endif
6ed79af8
JB
351 --disable-jemalloc \
352 --disable-option-checking \
353 --disable-rpath \
8a758d34 354 --enable-extended \
e8f16183 355 --enable-llvm-link-shared \
d6d4cb2b 356 --enable-vendor \
6ed79af8 357 --local-rust-root=%{local_rust_root} \
e8f16183 358 --llvm-root=%{_prefix} \
e361528e
ER
359 --release-channel=%{channel}
360
37765656
JP
361export RUST_BACKTRACE=full
362%x_py dist --verbose
e361528e 363
37765656 364%{?with_tests:%x_py test}
8a073211 365
e361528e
ER
366%install
367rm -rf $RPM_BUILD_ROOT
e361528e 368
37765656
JP
369export DESTDIR=$RPM_BUILD_ROOT
370%x_py install
e361528e 371
18a1004b
JR
372# Make sure the shared libraries are in the proper libdir
373%if "%{_libdir}" != "%{common_libdir}"
374mkdir -p %{buildroot}%{_libdir}
375find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
376 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
377%endif
378
d1b96fd8 379# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
380find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
381
d1b96fd8
JR
382# The libdir libraries are identical to those under rustlib/. It's easier on
383# library loading if we keep them in libdir, but we do need them in rustlib/
384# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 385(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
386 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
387 -exec ln -v -f -s -t . '{}' '+')
388
389# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 390find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
391
392# FIXME: __os_install_post will strip the rlibs
393# -- should we find a way to preserve debuginfo?
394
395# Remove unwanted documentation files (we already package them)
e8f16183
JB
396%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
397%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
398%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
399%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
400
401# Sanitize the HTML documentation
402find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
403find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
404
405# Move rust-gdb's python scripts so they're noarch
406install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 407%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 408
4f353dba
JR
409# We don't need stdlib source
410%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
411
1dd26160
JP
412# Create the path for crate-devel packages
413install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
414
e361528e
ER
415%clean
416rm -rf $RPM_BUILD_ROOT
417
418%post -p /sbin/ldconfig
419%postun -p /sbin/ldconfig
420
421%files
422%defattr(644,root,root,755)
5aae056c 423%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
ca8b753f 424%attr(755,root,root) %{_bindir}/miri
e361528e
ER
425%attr(755,root,root) %{_bindir}/rustc
426%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 427%attr(755,root,root) %{_bindir}/rustfmt
e8f16183 428%attr(755,root,root) %{_libdir}/librustc*-*.so
e8f16183 429%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 430%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
431%{_mandir}/man1/rustc.1*
432%{_mandir}/man1/rustdoc.1*
18a1004b
JR
433%dir %{rustlibdir}
434%dir %{rustlibdir}/%{rust_triple}
6ed79af8 435%{rustlibdir}/%{rust_triple}/analysis
18a1004b
JR
436%dir %{rustlibdir}/%{rust_triple}/lib
437%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
438%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 439
a7fda0f8
JP
440%files analyzer
441%defattr(644,root,root,755)
442%attr(755,root,root) %{_bindir}/rust-analyzer
443
d1b96fd8
JR
444%files debugger-common
445%defattr(644,root,root,755)
446%dir %{_datadir}/%{name}
447%dir %{_datadir}/%{name}/etc
5aae056c
JP
448%{_datadir}/%{name}/etc/lldb_commands
449%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
450
451%files lldb
452%defattr(644,root,root,755)
453%attr(755,root,root) %{_bindir}/rust-lldb
454%{_datadir}/%{name}/etc/lldb_*.py*
455
e361528e
ER
456%files gdb
457%defattr(644,root,root,755)
458%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 459%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 460%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 461
a7fda0f8
JP
462%files rls
463%defattr(644,root,root,755)
464%attr(755,root,root) %{_bindir}/rls
465
e361528e
ER
466%files doc
467%defattr(644,root,root,755)
468%dir %{_docdir}/%{name}
d1b96fd8 469%doc %{_docdir}/%{name}/html
8a758d34
JP
470
471%files -n cargo
472%defattr(644,root,root,755)
473%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
474%attr(755,root,root) %{_bindir}/cargo-clippy
475%attr(755,root,root) %{_bindir}/cargo-fmt
ca8b753f 476%attr(755,root,root) %{_bindir}/cargo-miri
6ed79af8 477%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 478%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
479%{_mandir}/man1/cargo*.1*
480%dir %{_datadir}/cargo
481%dir %{_datadir}/cargo/registry
482
483%files -n bash-completion-cargo
484%defattr(644,root,root,755)
485%{_sysconfdir}/bash_completion.d/cargo
486
487%files -n zsh-completion-cargo
488%defattr(644,root,root,755)
489%{zsh_compdir}/_cargo
This page took 0.110597 seconds and 4 git commands to generate.