]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
use python3 for invoking build scripts
[packages/rust.git] / rust.spec
CommitLineData
e361528e 1# TODO
d3346bb0 2# - unpackaged %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
e361528e
ER
3# - consider a rust-std package containing .../rustlib/$target
4# This might allow multilib cross-compilation to work naturally.
8a758d34 5# - package additional tools
e361528e
ER
6#
7# Conditional build:
e8f16183 8%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 9%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 10%bcond_without system_llvm # system LLVM
cace5bf9 11%bcond_with tests # build without tests
e361528e 12
8a073211
JR
13# The channel can be stable, beta, or nightly
14%define channel stable
15
e361528e 16%if "%{channel}" == "stable"
8a073211 17%define rustc_package rustc-%{version}-src
e361528e 18%else
8a073211 19%define rustc_package rustc-%{channel}-src
e361528e
ER
20%endif
21
fc3be51a 22# To bootstrap from scratch, set the channel and date from src/stage0.json
e361528e
ER
23# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
24# or nightly wants some beta-YYYY-MM-DD
fc3be51a
JP
25%define bootstrap_rust 1.56.1
26%define bootstrap_cargo 1.56.1
27%define bootstrap_date 2021-11-01
e361528e 28
badbe44d 29%ifarch x32
2eb30149 30%define with_cross 1
badbe44d 31%endif
c19e7faa
JP
32
33%if %{without full_debuginfo}
34%define _enable_debug_packages 0
35%endif
36
e361528e 37Summary: The Rust Programming Language
e8f16183 38Summary(pl.UTF-8): Język programowania Rust
e361528e 39Name: rust
fc3be51a 40Version: 1.57.0
d586bd33 41Release: 1
d1b96fd8 42# Licenses: (rust itself) and (bundled libraries)
e8f16183 43License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 44Group: Development/Languages
be28e1f1 45Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
fc3be51a 46# Source0-md5: 0c7d63d9c456c4ec0f95bb6bb729c13e
be28e1f1 47Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
fc3be51a 48# Source1-md5: 9c12561dff9debea38e4b93f881ae2bb
be28e1f1 49Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
fc3be51a 50# Source2-md5: 947bd95b9c8a9943d43af1bbabf1a8e1
9eb0511e 51Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
fc3be51a 52# Source3-md5: 64d78bc0747c975fe0451e4fd5b8ac4b
1fe729c8 53Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
fc3be51a 54# Source4-md5: a13652efd627b5e5f8bd278f378acea4
ad044650 55Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
fc3be51a 56# Source5-md5: 3fb69008b1b0141d464a4a48317709b3
e361528e 57URL: https://www.rust-lang.org/
e8f16183
JB
58# for src/compiler-rt
59BuildRequires: cmake >= 3.4.3
e361528e 60BuildRequires: curl
2eb30149
JB
61# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
62BuildRequires: procps
e65d284f
JP
63BuildRequires: python3
64BuildRequires: python3-modules
fc3be51a 65BuildRequires: rpm-build >= 4.6
2eb30149
JB
66BuildRequires: rpmbuild(macros) >= 1.752
67%if %{without cross}
8f176645 68BuildRequires: curl-devel
2983f519 69BuildRequires: libgit2-devel >= 1.3.0
d1b96fd8 70BuildRequires: libstdc++-devel
2cec66d3
JP
71%if %{with system_llvm}
72BuildRequires: llvm >= 10.0
73BuildRequires: llvm-devel >= 10.0
74%endif
7da6653d 75BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
76BuildRequires: tar >= 1:1.22
77BuildRequires: xz
e361528e 78BuildRequires: zlib-devel
2eb30149 79%endif
e361528e 80%if %{without bootstrap}
d6d4cb2b 81BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 82BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 83BuildConflicts: %{name} > %{version}
e361528e 84%endif
2eb30149 85%ifarch x32
cd0c1484
JR
86BuildRequires: glibc-devel(x86-64)
87BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
88%if "%{_host_cpu}" == "x86_64"
89# building on x86_64 host with --target x32-pld-linux
8f176645 90BuildRequires: curl-devel
2eb30149 91BuildRequires: gcc-multilib-x32
2983f519 92BuildRequires: libgit2-devel >= 1.3.0
2eb30149 93BuildRequires: libstdc++-devel
cdc531fa 94%{?with_system_llvm:BuildRequires: llvm-devel >= 10.0}
2eb30149
JB
95BuildRequires: openssl-devel >= 1.0.1
96BuildRequires: zlib-devel
97%else
98# building x86_64-hosted crosscompiler on x32 host
56b25e8b 99BuildRequires: curl-devel(x86-64)
cd0c1484 100BuildRequires: curl-devel(x86-x32)
2eb30149 101BuildRequires: gcc-multilib-64
2983f519
JR
102BuildRequires: libgit2-devel(x86-64) >= 1.3.0
103BuildRequires: libgit2-devel(x86-x32) >= 1.3.0
2eb30149 104BuildRequires: libstdc++-multilib-64-devel
cd0c1484 105%if %{with system_llvm}
cdc531fa
JP
106BuildRequires: llvm-devel(x86-64) >= 10.0
107BuildRequires: llvm-devel(x86-x32) >= 10.0
cd0c1484 108%endif
56b25e8b 109BuildRequires: openssl-devel(x86-64)
cd0c1484 110BuildRequires: openssl-devel(x86-x32)
56b25e8b 111BuildRequires: zlib-devel(x86-64)
cd0c1484 112BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
113%endif
114%endif
e361528e
ER
115# The C compiler is needed at runtime just for linking. Someday rustc might
116# invoke the linker directly, and then we'll only need binutils.
117# https://github.com/rust-lang/rust/issues/11937
118Requires: gcc
cd0c1484
JR
119Requires: %{name}-std%{?_isa} = %{version}-%{release}
120%ifarch x32
121Requires: %{name}-std(x86-64) = %{version}-%{release}
122%endif
b8711561 123Obsoletes: rust-analyzer < 1.53.0
e361528e 124# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 125# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 126# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 127ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 128BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 129
e064fbd0 130%ifarch x32
badbe44d 131%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 132%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 133%define rust_bootstrap_triple x86_64-unknown-linux-gnu
a973dc7e
JR
134# libs in _libdir are x86_64 64bit
135%define _lib lib64
136%define _libdir %{_prefix}/lib64
e064fbd0 137%else
ad044650 138%ifarch armv6hl
1fe729c8
JP
139%define rust_triple arm-unknown-linux-gnueabihf
140%define rust_host_triple %{rust_triple}
141%define rust_bootstrap_triple %{rust_triple}
142%else
ad044650
JP
143%ifarch armv7hl armv7hnl
144%define rust_triple armv7-unknown-linux-gnueabihf
145%define rust_host_triple %{rust_triple}
146%define rust_bootstrap_triple %{rust_triple}
147%else
badbe44d 148%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
149%define rust_host_triple %{rust_triple}
150%define rust_bootstrap_triple %{rust_triple}
e064fbd0 151%endif
1fe729c8 152%endif
ad044650 153%endif
e361528e
ER
154
155%if %{without bootstrap}
8a073211 156%define local_rust_root %{_prefix}
e361528e 157%else
badbe44d 158%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 159%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
160%endif
161
18a1004b
JR
162# We're going to override --libdir when configuring to get rustlib into a
163# common path, but we'll fix the shared libraries during install.
5b9d67b0 164# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
165# for non-bootstrap build, lib64 is just too complicated for it.
166%define common_libdir %{_prefix}/lib
167%define rustlibdir %{common_libdir}/rustlib
168
19f98749 169# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 170%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 171
e361528e 172# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
173%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
174%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 175
37765656
JP
176%define x_py { \
177 x_py() { \
178 local cmd="$1"; \
179 shift; \
e65d284f 180 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
37765656
JP
181 }; x_py }
182
183
e361528e
ER
184%description
185Rust is a systems programming language that runs blazingly fast,
186prevents segfaults, and guarantees thread safety.
187
188This package includes the Rust compiler, standard library, and
189documentation generator.
190
e8f16183
JB
191%description -l pl.UTF-8
192Rust to systemowy język programowania działający bardzo szybko,
193zapobiegający naruszeniom ochrony pamięci i gwarantujący
194bezpieczną wielowątkowość.
195
cd0c1484
JR
196%package analysis
197Summary: Metadata about the standard library
198Summary(pl.UTF-8): Metadane o standardowej bibliotece
199Group: Development/Tools
89a1e043 200Requires: %{name} = %{version}-%{release}
cd0c1484
JR
201
202%description analysis
203Metadata about the standard library.
204
205%description analysis -l pl.UTF-8
206Metadane o standardowej bibliotece.
207
208%package std
209Summary: Standard library for Rust
210Summary(pl.UTF-8): Standardowa biblioteka Rusta
211Group: Development/Tools
89a1e043 212Requires: %{name} = %{version}-%{release}
cd0c1484
JR
213
214%description std
215Standard library for Rust.
216
217%description std -l pl.UTF-8
218Standardowa biblioteka Rusta.
219
d1b96fd8
JR
220%package debugger-common
221Summary: Common debugger pretty printers for Rust
e8f16183 222Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 223Group: Development/Debuggers
e67020b3 224BuildArch: noarch
d1b96fd8
JR
225
226%description debugger-common
e8f16183
JB
227This package includes the common functionality for rust-gdb and
228rust-lldb.
229
230%description debugger-common -l pl.UTF-8
231Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 232
e361528e
ER
233%package gdb
234Summary: GDB pretty printers for Rust
e8f16183 235Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
236Group: Development/Debuggers
237Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 238Requires: gdb
e67020b3 239BuildArch: noarch
e361528e
ER
240
241%description gdb
242This package includes the rust-gdb script, which allows easier
243debugging of Rust programs.
244
e8f16183
JB
245%description gdb -l pl.UTF-8
246Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
247odpluskwianie programów w języku Rust.
248
d1b96fd8
JR
249%package lldb
250Summary: LLDB pretty printers for Rust
e8f16183 251Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
252Group: Development/Debuggers
253Requires: %{name}-debugger-common = %{version}-%{release}
254Requires: lldb
e67020b3 255BuildArch: noarch
d1b96fd8
JR
256
257%description lldb
258This package includes the rust-lldb script, which allows easier
259debugging of Rust programs.
260
e8f16183
JB
261%description lldb -l pl.UTF-8
262Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
263odpluskwianie programów w języku Rust.
264
a7fda0f8
JP
265%package rls
266Summary: Rust Language Server for IDE integration
267Summary(pl.UTF-8): Rust Language Server do integracji z IDE
268Group: Development/Tools
89a1e043
JR
269Requires: %{name} = %{version}-%{release}
270Requires: %{name}-analysis = %{version}-%{release}
a7fda0f8
JP
271
272%description rls
273Rust Language Server for IDE integration.
274
275%description rls -l pl.UTF-8
276Rust Language Server do integracji z IDE.
277
e361528e
ER
278%package doc
279Summary: Documentation for Rust
e8f16183 280Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 281Group: Documentation
e67020b3 282BuildArch: noarch
e361528e
ER
283
284%description doc
285This package includes HTML documentation for the Rust programming
286language and its standard library.
287
e8f16183
JB
288%description doc -l pl.UTF-8
289Ten pakiet zawiera dokumentację w formacie HTML do języka
290programowania Rust i jego biblioteki standardowej.
291
8a758d34
JP
292%package -n cargo
293Summary: Rust's package manager and build tool
294Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
295Group: Development/Tools
cd0c1484 296Requires: %{name}%{?_isa}
8a758d34
JP
297
298%description -n cargo
299Cargo is a tool that allows Rust projects to declare their various
300dependencies and ensure that you'll always get a repeatable build.
301
302%description -n cargo -l pl.UTF-8
303Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
304zależności i zapewniające powtarzalność procesu budowania.
305
6ed79af8
JB
306%package -n bash-completion-cargo
307Summary: Bash completion for cargo command
308Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
309Group: Applications/Shells
310Requires: %{name} = %{version}-%{release}
311Requires: bash-completion
312
313%description -n bash-completion-cargo
314Bash completion for cargo command.
315
316%description -n bash-completion-cargo -l pl.UTF-8
317Bashowe dopełnianie parametrów polecenia cargo.
318
8a758d34
JP
319%package -n zsh-completion-cargo
320Summary: Zsh completion for cargo command
321Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
322Group: Applications/Shells
323Requires: %{name} = %{version}-%{release}
6ed79af8 324Requires: zsh
8a758d34
JP
325
326%description -n zsh-completion-cargo
327Zsh completion for cargo command.
328
329%description -n zsh-completion-cargo -l pl.UTF-8
330Dopełnianie parametrów polecenia cargo w powłoce Zsh.
331
e361528e
ER
332%prep
333%setup -q -n %{rustc_package}
b5eceb5e 334
e361528e 335%if %{with bootstrap}
a1735efb 336%ifarch %{x8664} x32
e361528e
ER
337tar xf %{SOURCE1}
338%endif
339%ifarch %{ix86}
340tar xf %{SOURCE2}
341%endif
c160f211 342%ifarch aarch64
9eb0511e 343tar xf %{SOURCE3}
c160f211 344%endif
ad044650 345%ifarch armv6hl
1fe729c8
JP
346tar xf %{SOURCE4}
347%endif
ad044650
JP
348%ifarch armv7hl armv7hnl
349tar xf %{SOURCE5}
350%endif
d6d4cb2b
JR
351%{__mv} %{bootstrap_root} %{bootstrap_root}-root
352%{bootstrap_root}-root/install.sh \
badbe44d 353 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
354 --prefix=%{local_rust_root} \
355 --disable-ldconfig
356test -f %{local_rust_root}/bin/cargo
e361528e
ER
357test -f %{local_rust_root}/bin/rustc
358%endif
359
360# unbundle
d4b51567 361# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 362#%{__rm} -r src/jemalloc
9e7854c5
JP
363%if %{with system_llvm}
364%{__rm} -r src/llvm-project
365mkdir -p src/llvm-project/libunwind
366%endif
e361528e 367
e361528e
ER
368# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
369sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
370 src/etc/rust-gdb
371
4b354bd7
JB
372# cargo has hardcoded libexec path - honour rpm _libexecdir
373%if "%{_libexecdir}" != "%{_prefix}/libexec"
374suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
375%{__sed} -i -e 's,"libexec","'${suffix}'",' \
376 src/bootstrap/dist.rs \
377 src/tools/cargo/src/cargo/ops/registry/auth.rs
378%{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
379%endif
380
5ee06aa0
JR
381# The configure macro will modify some autoconf-related files, which upsets
382# cargo when it tries to verify checksums in those files. If we just truncate
383# that file list, cargo won't have anything to complain about.
fe49e3fc 384find vendor -name .cargo-checksum.json \
5ee06aa0 385 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 386
e361528e
ER
387%build
388%configure \
2eb30149
JB
389 --build=%{rust_bootstrap_triple} \
390 --host=%{rust_host_triple} \
e8f16183 391 --target=%{rust_triple} \
18a1004b 392 --libdir=%{common_libdir} \
e8f16183 393 --disable-codegen-tests \
5ee06aa0 394 --disable-debuginfo-lines \
5b9d67b0 395%if %{with full_debuginfo}
5ee06aa0 396 --disable-debuginfo-only-std \
e361528e 397 --enable-debuginfo \
5b9d67b0
JB
398%else
399 --enable-debuginfo-only-std \
400 --disable-debuginfo \
401%endif
6ed79af8
JB
402 --disable-jemalloc \
403 --disable-option-checking \
404 --disable-rpath \
8a758d34 405 --enable-extended \
e8f16183 406 --enable-llvm-link-shared \
d6d4cb2b 407 --enable-vendor \
6ed79af8 408 --local-rust-root=%{local_rust_root} \
e8f16183 409 --llvm-root=%{_prefix} \
e361528e
ER
410 --release-channel=%{channel}
411
37765656
JP
412export RUST_BACKTRACE=full
413%x_py dist --verbose
e361528e 414
37765656 415%{?with_tests:%x_py test}
8a073211 416
e361528e
ER
417%install
418rm -rf $RPM_BUILD_ROOT
e361528e 419
37765656
JP
420export DESTDIR=$RPM_BUILD_ROOT
421%x_py install
e361528e 422
18a1004b
JR
423# Make sure the shared libraries are in the proper libdir
424%if "%{_libdir}" != "%{common_libdir}"
425mkdir -p %{buildroot}%{_libdir}
426find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
427 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
428%endif
429
d1b96fd8 430# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
431find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
432
d1b96fd8
JR
433# The libdir libraries are identical to those under rustlib/. It's easier on
434# library loading if we keep them in libdir, but we do need them in rustlib/
435# to support dynamic linking for compiler plugins, so we'll symlink.
a973dc7e
JR
436for l in libstd libtest ; do
437 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
438 libstd=$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib/${l}-*.so
439 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
440 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
441 fi
442done
d1b96fd8
JR
443
444# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 445find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
446
447# FIXME: __os_install_post will strip the rlibs
448# -- should we find a way to preserve debuginfo?
449
450# Remove unwanted documentation files (we already package them)
e8f16183
JB
451%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
452%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
453%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
454%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
455
456# Sanitize the HTML documentation
457find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
458find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
459
460# Move rust-gdb's python scripts so they're noarch
461install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 462%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 463
4f353dba
JR
464# We don't need stdlib source
465%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
466
1dd26160
JP
467# Create the path for crate-devel packages
468install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
469
e361528e
ER
470%clean
471rm -rf $RPM_BUILD_ROOT
472
473%post -p /sbin/ldconfig
474%postun -p /sbin/ldconfig
475
476%files
477%defattr(644,root,root,755)
16ea23d8 478%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
e361528e
ER
479%attr(755,root,root) %{_bindir}/rustc
480%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 481%attr(755,root,root) %{_bindir}/rustfmt
a973dc7e 482%attr(755,root,root) %{_libdir}/librustc_driver-*.so
e8f16183 483%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 484%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
485%{_mandir}/man1/rustc.1*
486%{_mandir}/man1/rustdoc.1*
18a1004b 487%dir %{rustlibdir}
cd0c1484
JR
488
489%files analysis
490%defattr(644,root,root,755)
6ed79af8 491%{rustlibdir}/%{rust_triple}/analysis
cd0c1484
JR
492
493%files std
494%defattr(644,root,root,755)
495%dir %{rustlibdir}/%{rust_triple}
18a1004b
JR
496%dir %{rustlibdir}/%{rust_triple}/lib
497%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
498%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 499
d1b96fd8
JR
500%files debugger-common
501%defattr(644,root,root,755)
502%dir %{_datadir}/%{name}
503%dir %{_datadir}/%{name}/etc
5aae056c
JP
504%{_datadir}/%{name}/etc/lldb_commands
505%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
506
507%files lldb
508%defattr(644,root,root,755)
509%attr(755,root,root) %{_bindir}/rust-lldb
510%{_datadir}/%{name}/etc/lldb_*.py*
511
e361528e
ER
512%files gdb
513%defattr(644,root,root,755)
514%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 515%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 516%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 517
a7fda0f8
JP
518%files rls
519%defattr(644,root,root,755)
520%attr(755,root,root) %{_bindir}/rls
521
e361528e
ER
522%files doc
523%defattr(644,root,root,755)
524%dir %{_docdir}/%{name}
d1b96fd8 525%doc %{_docdir}/%{name}/html
8a758d34
JP
526
527%files -n cargo
528%defattr(644,root,root,755)
529%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
530%attr(755,root,root) %{_bindir}/cargo-clippy
531%attr(755,root,root) %{_bindir}/cargo-fmt
532%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 533%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
534%{_mandir}/man1/cargo*.1*
535%dir %{_datadir}/cargo
536%dir %{_datadir}/cargo/registry
537
538%files -n bash-completion-cargo
539%defattr(644,root,root,755)
540%{_sysconfdir}/bash_completion.d/cargo
541
542%files -n zsh-completion-cargo
543%defattr(644,root,root,755)
544%{zsh_compdir}/_cargo
This page took 0.165738 seconds and 4 git commands to generate.