]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- rel 2
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
f56b6dce 1# TODO: libzmq ?
197f4211 2#
5663f846
JB
3# How to deal with ffmpeg/opencv checken-egg problem:
4# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 5# 2. make-request -r opencv.spec
6# 3. bump release of ffmpeg.spec
7# 4. make-request -r ffmpeg.spec
8#
2b3b2117 9# Conditional build:
38cefaee 10%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 11%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
004e5628 12%bcond_with fdk_aac # AAC encoding via libfdk_aac (requires nonfree)
1c1d1368 13%bcond_without caca # textual display using libcaca
a584ded4
JB
14%bcond_without flite # flite voice synthesis support
15%bcond_without frei0r # frei0r video filtering
22745365 16%bcond_without gme # Game Music Emu support
cbeed0a5 17%bcond_without ilbc # iLBC de/encoding via WebRTC libilbc
a584ded4 18%bcond_without openal # OpenAL 1.1 capture support
f56b6dce 19%bcond_with opencl # OpenCL code [OpenCL 1.2, but Mesa 9.1.x headers don't suffice]
a584ded4
JB
20%bcond_without opencv # OpenCV video filtering
21%bcond_without pulseaudio # PulseAudio input support
22745365 22%bcond_without quvi # quvi input support
f56b6dce 23%bcond_without shine # shine fixed-point MP3 encoder
05408820 24%bcond_without soxr # SoX Resampler support
a584ded4
JB
25%bcond_without x264 # x264 encoder
26%bcond_without utvideo # Ut Video decoder
1ef27ea1 27%bcond_without va # VAAPI (Video Acceleration API)
f56b6dce 28%bcond_without vidstab # vid.stab video stabilization support
1ef27ea1 29%bcond_without vpx # VP8, a high-quality video codec
22745365 30%bcond_without wavpack # wavpack encoding support
6a6b11be 31%bcond_without zmq # 0MQ message passing
1ef27ea1 32%bcond_without doc # don't build docs
314ef0df 33
cbdd2688
JB
34Summary: FFmpeg - a very fast video and audio converter
35Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 36Name: ffmpeg
d97a793a 37Version: 2.1
af6193d3 38Release: 2
9cf4d8a4 39# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
40# (postprocessing, some filters, x264, xavs, xvid, x11grab)
41# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 42License: GPL v3+ with LGPL v3+ parts
fde29260 43Group: Applications/Multimedia
1ef27ea1 44Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
d97a793a 45# Source0-md5: 4ec1cedd4c7753512462f70b347c338a
fde29260
ER
46Source1: ffserver.init
47Source2: ffserver.sysconfig
38cf6de3 48Source3: ffserver.conf
a7e0e69a 49Patch0: %{name}-opencv24.patch
85f7cea1 50URL: http://www.ffmpeg.org/
28673856 51%{?with_openal:BuildRequires: OpenAL-devel >= 1.1}
6a6b11be 52%{?with_opencl:BuildRequires: OpenCL-devel >= 1.2}
3dcb8642 53BuildRequires: SDL-devel >= 1.2.1
cbdd2688 54BuildRequires: alsa-lib-devel
38cefaee 55BuildRequires: bzip2-devel
9f9ba8ac 56BuildRequires: celt-devel >= 0.11.0
38cefaee 57%{?with_nonfree:BuildRequires: faac-devel}
004e5628 58%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
a584ded4 59%{?with_flite:BuildRequires: flite-devel >= 1.4}
3dcb8642 60BuildRequires: fontconfig-devel
2a60eebe 61BuildRequires: freetype-devel
d7a39558 62%{?with_frei0r:BuildRequires: frei0r-devel}
22745365 63%{?with_gme:BuildRequires: game-music-emu-devel}
4bee03f0
JB
64%ifarch ppc
65# require version with altivec support fixed
66BuildRequires: gcc >= 5:3.3.2-3
67%endif
d5aef92e 68BuildRequires: gnutls-devel
cbdd2688
JB
69BuildRequires: jack-audio-connection-kit-devel
70BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 71%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 72BuildRequires: libass-devel
1c1d1368 73BuildRequires: libavc1394-devel
3dcb8642 74BuildRequires: libbluray-devel
1c1d1368 75%{?with_caca:BuildRequires: libcaca-devel}
a09e741c 76BuildRequires: libcdio-paranoia-devel >= 0.90-2
9c4296c2 77BuildRequires: libdc1394-devel >= 2
f1669449 78BuildRequires: libgsm-devel
1c1d1368 79BuildRequires: libiec61883-devel
d5aef92e 80BuildRequires: libmodplug-devel
4a927f9d 81BuildRequires: libnut-devel
22745365 82%{?with_quvi:BuildRequires: libquvi-devel}
7571bfa0 83BuildRequires: libraw1394-devel >= 2
cbdd2688 84BuildRequires: librtmp-devel
9042663c 85BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 86BuildRequires: libtool >= 2:1.4d-3
daf9a670 87BuildRequires: libv4l-devel
64f8f109 88%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 89BuildRequires: libvdpau-devel >= 0.2
e380e18a 90BuildRequires: libvorbis-devel
28673856 91%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.7}
4b05ede1 92%{?with_shine:BuildRequires: shine-devel}
660918c5
AM
93# X264_BUILD >= 118
94%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
e1fe03f7 95%ifarch %{ix86}
96%ifnarch i386 i486
76243dbd
JB
97BuildRequires: nasm
98%endif
e1fe03f7 99%endif
1c1d1368
JB
100BuildRequires: opencore-amr-devel
101%{?with_opencv:BuildRequires: opencv-devel}
102BuildRequires: openjpeg-devel >= 1.5
103BuildRequires: opus-devel
136f0f45 104BuildRequires: perl-Encode
1463656a 105BuildRequires: perl-tools-pod
ef3c0513 106BuildRequires: pkgconfig
1c1d1368 107%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 108BuildRequires: rpmbuild(macros) >= 1.470
126fb805 109BuildRequires: schroedinger-devel
d97a793a 110BuildRequires: shine-devel >= 3.0.0
05408820 111%{?with_soxr:BuildRequires: soxr-devel}
1c1d1368 112BuildRequires: speex-devel >= 1:1.2-rc1
64f8f109
ER
113%{?with_doc:BuildRequires: tetex}
114%{?with_doc:BuildRequires: texi2html}
115%{?with_doc:BuildRequires: texinfo}
1c1d1368 116BuildRequires: twolame-devel
05408820 117%{?with_utvideo:BuildRequires: utvideo-devel >= 12}
f56b6dce 118%{?with_vidstab:BuildRequires: vid.stab-devel}
5dc039cb
JB
119BuildRequires: vo-aacenc-devel
120BuildRequires: vo-amrwbenc-devel
22745365 121%{?with_wavpack:BuildRequires: wavpack-devel}
cbeed0a5 122%{?with_ilbc:BuildRequires: webrtc-libilbc-devel}
5dc039cb 123BuildRequires: xavs-devel
28673856 124BuildRequires: xorg-lib-libX11-devel
cbdd2688
JB
125BuildRequires: xorg-lib-libXext-devel
126BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 127BuildRequires: xvid-devel >= 1:1.1.0
cbeed0a5 128BuildRequires: yasm
6a6b11be 129%{?with_zmq:BuildRequires: zeromq-devel}
33a1c0f3 130BuildRequires: zlib-devel
57ebb8ad 131%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
132# overflows maximum hash table size
133BuildConflicts: pdksh < 5.2.14-57
54ec280e 134Requires: %{name}-libs = %{version}-%{release}
05408820 135%{?with_utvideo:Requires: utvideo >= 12}
92a3edff 136%{?with_ilbc:Requires: webrtc-libilbc}
839e806f 137Requires: xvid >= 1:1.1.0
af49d6ab 138Obsoletes: libpostproc
539b540f 139BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 140
2a60eebe
JB
141%define _noautoreqdep libGL.so.1 libGLU.so.1
142
c01d7857
PS
143%define specflags -fno-strict-aliasing
144
145# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
146%define specflags_ia32 -fomit-frame-pointer
147# -mmmx is needed to enable <mmintrin.h> code.
148%define specflags_i586 -mmmx
149%define specflags_i686 -mmmx
1162803a 150%define specflags_ppc -fPIC
c01d7857 151
9fc4ad22 152%description
85f7cea1
ER
153FFmpeg is a complete solution to record, convert and stream audio and
154video. It is a command line tool to convert one video file format to
155another. It also supports grabbing and encoding in real time from a TV
156card.
9fc4ad22 157
cdb7b42e 158%description -l pl.UTF-8
cbdd2688
JB
159FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
160strumieni dźwięku i obrazu. Jest to działające z linii poleceń
161narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
162także przechwytywanie i kodowanie w czasie rzeczywistym z karty
163telewizyjnej.
9fc4ad22 164
54ec280e
PG
165%package libs
166Summary: ffmpeg libraries
adcc0f76 167Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
168Group: Libraries
169
170%description libs
cbdd2688
JB
171This package contains the ffmpeg shared libraries:
172- the codec library (libavcodec). It supports most existing encoding
173 formats (MPEG, DivX, MPEG4, AC3, DV...),
174- demuxer library (libavformat). It supports most existing file
175 formats (AVI, MPEG, OGG, Matroska, ASF...),
176- video postprocessing library (libpostproc).
54ec280e 177
cdb7b42e 178%description libs -l pl.UTF-8
cbdd2688
JB
179Ten pakiet zawiera biblioteki współdzielone ffmpeg:
180- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
181 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
182- bibliotekę demuksera (libavformat); obsługuje większość istniejących
183 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
184- bibliotekę postprocessingu (libpostproc).
54ec280e 185
af49d6ab
JB
186%package devel
187Summary: ffmpeg header files
adcc0f76 188Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 189Group: Development/Libraries
54ec280e 190Requires: %{name}-libs = %{version}-%{release}
38cefaee 191# Libs.private from *.pc (unreasonably they are all the same)
6a6b11be 192%{?with_opencl:Requires: OpenCL-devel >= 1.2}
3dcb8642 193Requires: SDL-devel >= 1.2.1
38cefaee
JB
194Requires: alsa-lib-devel
195Requires: bzip2-devel
9c4296c2 196Requires: celt-devel >= 0.11.0
38cefaee 197%{?with_nonfree:Requires: faac-devel}
004e5628 198%{?with_fdk_aac:Requires: fdk-aac-devel}
4b05ede1 199%{?with_flite:Requires: flite-devel >= 1.4}
3dcb8642
JB
200Requires: fontconfig-devel
201Requires: freetype-devel
22745365 202%{?with_gme:Requires: game-music-emu-devel}
38cefaee
JB
203Requires: jack-audio-connection-kit-devel
204Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
205%{?with_aacplus:Requires: libaacplus-devel >= 2.0.0}
206Requires: libass-devel
207Requires: libavc1394-devel
3dcb8642 208Requires: libbluray-devel
28673856 209%{?with_caca:Requires: libcaca-devel}
a09e741c 210Requires: libcdio-paranoia-devel >= 0.90-2
9c4296c2 211Requires: libdc1394-devel >= 2
bf479bc6 212Requires: libgsm-devel
1c1d1368
JB
213Requires: libiec61883-devel
214Requires: libmodplug-devel
4a927f9d 215Requires: libnut-devel
22745365 216%{?with_quvi:Requires: libquvi-devel}
7571bfa0 217Requires: libraw1394-devel >= 2
38cefaee
JB
218Requires: librtmp-devel
219Requires: libtheora-devel >= 1.0-0.beta3
220%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 221Requires: libvorbis-devel
28673856 222%{?with_vpx:Requires: libvpx-devel >= 0.9.7}
ea09f25d 223%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee 224Requires: opencore-amr-devel
fc1d9619 225%{?with_opencv:Requires: opencv-devel}
ae5be86b 226Requires: openjpeg-devel >= 1.5
38cefaee 227Requires: schroedinger-devel
f56b6dce 228%{?with_shine:Requires: shine-devel}
05408820 229%{?with_soxr:Requires: soxr-devel}
38cefaee 230Requires: speex-devel >= 1:1.2-rc1
1c1d1368 231Requires: twolame-devel
05408820 232%{?with_utvideo:Requires: utvideo-devel >= 12}
f56b6dce 233%{?with_vidstab:Requires: vid.stab-devel}
38cefaee
JB
234Requires: vo-aacenc-devel
235Requires: vo-amrwbenc-devel
22745365 236%{?with_wavpack:Requires: wavpack-devel}
cbeed0a5 237%{?with_ilbc:Requires: webrtc-libilbc-devel}
38cefaee
JB
238Requires: xavs-devel
239Requires: xorg-lib-libXext-devel
240Requires: xorg-lib-libXfixes-devel
46f2a56b 241Requires: xvid-devel >= 1:1.1.0
6a6b11be 242%{?with_zmq:Requires: zeromq-devel}
33a1c0f3 243Requires: zlib-devel
8152d6a2 244Obsoletes: libpostproc-devel
af49d6ab
JB
245
246%description devel
247ffmpeg header files.
248
cdb7b42e
JR
249%description devel -l pl.UTF-8
250Pliki nagłówkowe ffmpeg.
af49d6ab
JB
251
252%package static
253Summary: ffmpeg static libraries
adcc0f76 254Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
255Group: Development/Libraries
256Requires: %{name}-devel = %{version}-%{release}
257
258%description static
259ffmpeg static libraries (libavcodec and libavformat).
260
cdb7b42e 261%description static -l pl.UTF-8
af49d6ab
JB
262Statyczne biblioteki ffmpeg (libavcodec i libavformat).
263
2a60eebe
JB
264%package ffplay
265Summary: FFplay - SDL-based media player
adcc0f76 266Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 267Group: Applications/Multimedia
54ec280e 268Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
269
270%description ffplay
271FFplay is a very simple and portable media player using the FFmpeg
272libraries and the SDL library. It is mostly used as a test bench for
273the various APIs of FFmpeg.
274
cdb7b42e
JR
275%description ffplay -l pl.UTF-8
276FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
277bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
278testowania różnych API FFmpeg.
2a60eebe 279
fde29260
ER
280%package ffserver
281Summary: FFserver video server
adcc0f76 282Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 283Group: Daemons
593d3a64 284Requires(post,preun): /sbin/chkconfig
67103923 285Requires: %{name}-libs = %{version}-%{release}
2305d791 286Requires: rc-scripts >= 0.4.0.10
fde29260
ER
287
288%description ffserver
289FFserver is a streaming server for both audio and video. It supports
290several live feeds, streaming from files and time shifting on live
291feeds (you can seek to positions in the past on each live feed,
292provided you specify a big enough feed storage in ffserver.conf).
293
cdb7b42e
JR
294%description ffserver -l pl.UTF-8
295FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
296źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
297czasie dla źródeł na żywo (można przeskakiwać na położenia w
298przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
299dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 300
4b05ede1
ER
301%package doc
302Summary: Manual for ffmpeg
303Summary(fr.UTF-8): Documentation pour ffmpeg
304Summary(it.UTF-8): Documentazione di ffmpeg
305Summary(pl.UTF-8): Podręcznik dla ffmpeg
306Group: Documentation
307%if "%{_rpmversion}" >= "5"
308BuildArch: noarch
309%endif
310
311%description doc
312Documentation for ffmpeg.
313
314%description doc -l fr.UTF-8
315Documentation pour ffmpeg.
316
317%description doc -l it.UTF-8
318Documentazione di ffmpeg.
319
320%description doc -l pl.UTF-8
321Dokumentacja do ffmpeg.
322
9fc4ad22 323%prep
aed8e8c9 324%setup -q
f1669449 325%patch0 -p1
9fc4ad22 326
9d4f8977
ER
327# package the grep result for mplayer, the result formatted as ./mplayer/configure
328cat <<EOF > ffmpeg-avconfig
2b2445b7 329#! /bin/sh
16803cdb
ER
330libavdecoders_all="$(sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
331libavencoders_all="$(sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
332libavparsers_all="$(sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
333libavbsfs_all="$(sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
334libavdemuxers_all="$(sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
335libavmuxers_all="$(sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
336libavprotocols_all="$(sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]')"
337libavhwaccels_all="$(sed -n 's/^[^#]*HWACCEL.*(.*, *\(.*\)).*/\1_hwaccel/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]')"
338libavfilters_all="$(sed -n 's/^[^#]*FILTER.*(.*, *\(.*\),.*).*/\1_filter/p' libavfilter/allfilters.c | tr '[a-z]' '[A-Z]')"
2b2445b7 339EOF
9d4f8977 340cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
341
342case "$1" in
343--decoders)
16803cdb 344 echo $libavdecoders_all
2b2445b7
ER
345 ;;
346--encoders)
16803cdb 347 echo $libavencoders_all
2b2445b7
ER
348 ;;
349--parsers)
16803cdb 350 echo $libavparsers_all
2b2445b7
ER
351 ;;
352--bsfs)
16803cdb 353 echo $libavbsfs_all
2b2445b7
ER
354 ;;
355--demuxers)
16803cdb 356 echo $libavdemuxers_all
2b2445b7
ER
357 ;;
358--muxers)
16803cdb 359 echo $libavmuxers_all
2b2445b7
ER
360 ;;
361--protocols)
16803cdb
ER
362 echo $libavprotocols_all
363 ;;
364--hwaccels)
365 echo $libavhwaccels_all
366 ;;
367--filters)
368 echo $libavfilters_all
2b2445b7
ER
369 ;;
370*)
371 cat <<USAGE
372Usage: $0 [OPTION]
373Options:
374 --decoders
375 --encoders
376 --parsers
377 --bsfs
378 --demuxers
379 --muxers
380 --protocols
16803cdb
ER
381 --hwaccels
382 --filters
2b2445b7
ER
383USAGE
384 exit 1;;
385esac
386
387exit 0
388EOF
389
9fc4ad22 390%build
05e1eb2f
JB
391# notes:
392# - it's not autoconf configure
d0a0ec26 393# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 394./configure \
b4680d0b 395 --arch=%{_target_base_arch} \
539b540f 396 --prefix=%{_prefix} \
9cf4d8a4 397 --libdir=%{_libdir} \
d81dfa95 398 --shlibdir=%{_libdir} \
2a60eebe 399 --mandir=%{_mandir} \
314ef0df 400 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 401 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 402 --cc="%{__cc}" \
126fb805
JB
403 --disable-debug \
404 --disable-optimizations \
6382c99d 405 --disable-stripping \
314ef0df 406 --enable-avfilter \
0797daec 407 --enable-avresample \
d5aef92e 408 --enable-gnutls \
126fb805 409 --enable-gpl \
0b43f655 410 --enable-version3 \
3dcb8642 411 --enable-fontconfig \
d7a39558 412 %{?with_frei0r:--enable-frei0r} \
2e585b44 413 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 414 --enable-libass \
3dcb8642 415 --enable-libbluray \
2362253d 416 %{?with_caca:--enable-libcaca} \
cbdd2688 417 --enable-libcelt \
d5aef92e
JB
418 --enable-libcdio \
419 --enable-libdc1394 \
004e5628 420 %{?with_fdk_aac:--enable-libfdk-aac} \
1c1d1368 421 %{?with_flite:--enable-libflite} \
3dcb8642 422 --enable-libfreetype \
22745365 423 %{?with_gme:--enable-libgme} \
f3692243 424 --enable-libgsm \
1c1d1368 425 --enable-libiec61883 \
004e5628 426 %{?with_ilbc:--enable-libilbc} \
d5aef92e 427 --enable-libmodplug \
15c15700 428 --enable-libmp3lame \
4a927f9d 429 --enable-libnut \
cbdd2688
JB
430 --enable-libopencore-amrnb \
431 --enable-libopencore-amrwb \
192f9f57 432 %{?with_opencv:--enable-libopencv} \
cbdd2688 433 --enable-libopenjpeg \
1c1d1368 434 --enable-libopus \
d5aef92e 435 %{?with_pulseaudio:--enable-libpulse} \
22745365 436 %{?with_quvi:--enable-libquvi} \
cbdd2688 437 --enable-librtmp \
126fb805 438 --enable-libschroedinger \
f56b6dce 439 %{?with_shine:--enable-libshine} \
05408820 440 %{?with_soxr:--enable-libsoxr} \
da99dcf2 441 --enable-libspeex \
126fb805 442 --enable-libtheora \
1c1d1368 443 --enable-libtwolame \
daf9a670 444 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 445 --enable-libv4l2 \
f56b6dce 446 %{?with_vidstab:--enable-libvidstab} \
5dc039cb
JB
447 --enable-libvo-aacenc \
448 --enable-libvo-amrwbenc \
126fb805 449 --enable-libvorbis \
64f8f109 450 %{?with_vpx:--enable-libvpx} \
22745365 451 %{?with_wavpack:--enable-libwavpack} \
ea09f25d 452 %{?with_x264:--enable-libx264} \
5dc039cb 453 --enable-libxavs \
126fb805 454 --enable-libxvid \
6a6b11be 455 %{?with_zmq:--enable-libzmq} \
d5aef92e 456 %{?with_openal:--enable-openal} \
f56b6dce 457 %{?with_opencl:--enable-opencl} \
6382c99d 458 --enable-postproc \
d7493de8 459 --enable-pthreads \
9cf4d8a4 460 --enable-shared \
6382c99d 461 --enable-swscale \
22745365 462 %{!?with_va:--disable-vaapi} \
75231f25 463 --enable-x11grab \
7a286645 464%ifnarch %{ix86} %{x8664}
e1fe03f7 465 --disable-mmx \
466%endif
467%ifarch i386 i486
05e1eb2f 468 --disable-mmx \
b524cd99 469%endif
0b43f655 470%if %{with nonfree}
48610c64 471 --enable-nonfree \
0b43f655 472 --enable-libfaac \
76243dbd 473%endif
75231f25 474 --enable-runtime-cpudetect
2305d791 475
1ef27ea1
JB
476%{__make} \
477 V=1
9fc4ad22 478
b8c60172
ER
479# CC_O to add -c to commandline. makefile should be patched
480%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
481
9fc4ad22
AM
482%install
483rm -rf $RPM_BUILD_ROOT
38cf6de3 484install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 485 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 486 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 487
a831ce58 488%{__make} install install-headers \
1ef27ea1
JB
489 DESTDIR=$RPM_BUILD_ROOT \
490 V=1
539b540f 491
a831ce58 492# install nonstandard, non-public headers manually
544421b2 493cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
544421b2 494for a in libavutil/*/bswap.h; do
a831ce58 495 install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
544421b2 496done
9d4f8977 497cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
498# for lim-omx ffmpeg components
499cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 500
b8c60172
ER
501install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
502cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
503cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 504mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 505install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 506
2b2445b7
ER
507# install as ffmpeg-avconfig to avoid with possible programs looking for
508# ffmpeg-config and expecting --libs output from it which is not implemented
509# simple to do (by querying pkgconfig), but why?
b8c60172 510install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 511
9fc4ad22
AM
512%clean
513rm -rf $RPM_BUILD_ROOT
514
1ef27ea1
JB
515%post libs -p /sbin/ldconfig
516%postun libs -p /sbin/ldconfig
539b540f 517
38cf6de3
ER
518%pre ffserver
519%groupadd -g 167 ffserver
520%useradd -g ffserver -u 167 ffserver
521
593d3a64
ER
522%post ffserver
523/sbin/chkconfig --add ffserver
524%service ffserver restart
525
38cf6de3 526%preun ffserver
593d3a64
ER
527if [ "$1" = 0 ]; then
528 %service ffserver stop
529 /sbin/chkconfig --del ffserver
530fi
531
38cf6de3
ER
532%postun ffserver
533if [ "$1" = 0 ]; then
534 %userremove ffserver
535 %groupremove ffserver
536fi
537
9fc4ad22
AM
538%files
539%defattr(644,root,root,755)
4b05ede1 540%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES}
2a60eebe 541%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 542%attr(755,root,root) %{_bindir}/ffprobe
b7313442 543%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
544%dir %{_datadir}/ffmpeg
545%{_datadir}/ffmpeg/*.ffpreset
714dcf83 546%{_datadir}/ffmpeg/ffprobe.xsd
28673856
JB
547%if %{with doc}
548%{_mandir}/man1/ffmpeg.1*
22745365 549%{_mandir}/man1/ffmpeg-all.1*
28673856
JB
550%{_mandir}/man1/ffmpeg-bitstream-filters.1*
551%{_mandir}/man1/ffmpeg-codecs.1*
552%{_mandir}/man1/ffmpeg-devices.1*
553%{_mandir}/man1/ffmpeg-filters.1*
554%{_mandir}/man1/ffmpeg-formats.1*
555%{_mandir}/man1/ffmpeg-protocols.1*
556%{_mandir}/man1/ffmpeg-resampler.1*
557%{_mandir}/man1/ffmpeg-scaler.1*
558%{_mandir}/man1/ffmpeg-utils.1*
559%{_mandir}/man1/ffprobe.1*
22745365 560%{_mandir}/man1/ffprobe-all.1*
28673856 561%endif
54ec280e
PG
562
563%files libs
564%defattr(644,root,root,755)
f50f7d7c 565%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
22745365 566%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.55
d0a0ec26 567%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
22745365 568%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.55
314ef0df 569%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
1c1d1368 570%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
f50f7d7c 571%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
22745365 572%attr(755,root,root) %ghost %{_libdir}/libavformat.so.55
5663f846 573%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
28673856 574%attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
f50f7d7c 575%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
28673856 576%attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
d7493de8 577%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 578%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
579%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
580%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 581%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 582%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 583
539b540f
JB
584%files devel
585%defattr(644,root,root,755)
54ec280e 586%doc doc/optimization.txt
1ef27ea1 587%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 588%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 589%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 590%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 591%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 592%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 593%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 594%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 595%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 596%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 597%{_includedir}/ffmpeg
6382c99d
AM
598%{_includedir}/libavcodec
599%{_includedir}/libavdevice
314ef0df 600%{_includedir}/libavfilter
6382c99d 601%{_includedir}/libavformat
5663f846 602%{_includedir}/libavresample
6382c99d
AM
603%{_includedir}/libavutil
604%{_includedir}/libpostproc
660918c5 605%{_includedir}/libswresample
6382c99d 606%{_includedir}/libswscale
1ef27ea1
JB
607%{_pkgconfigdir}/libavcodec.pc
608%{_pkgconfigdir}/libavdevice.pc
609%{_pkgconfigdir}/libavfilter.pc
610%{_pkgconfigdir}/libavformat.pc
5663f846 611%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
612%{_pkgconfigdir}/libavutil.pc
613%{_pkgconfigdir}/libpostproc.pc
660918c5 614%{_pkgconfigdir}/libswresample.pc
1ef27ea1 615%{_pkgconfigdir}/libswscale.pc
28673856
JB
616%if %{with doc}
617%{_mandir}/man3/libavcodec.3*
618%{_mandir}/man3/libavdevice.3*
619%{_mandir}/man3/libavfilter.3*
620%{_mandir}/man3/libavformat.3*
621%{_mandir}/man3/libavutil.3*
622%{_mandir}/man3/libswresample.3*
623%{_mandir}/man3/libswscale.3*
624%endif
539b540f 625
9cf4d8a4
JB
626%files static
627%defattr(644,root,root,755)
1ef27ea1
JB
628%{_libdir}/libavcodec.a
629%{_libdir}/libavdevice.a
630%{_libdir}/libavfilter.a
631%{_libdir}/libavformat.a
5663f846 632%{_libdir}/libavresample.a
1ef27ea1
JB
633%{_libdir}/libavutil.a
634%{_libdir}/libpostproc.a
660918c5 635%{_libdir}/libswresample.a
1ef27ea1 636%{_libdir}/libswscale.a
af49d6ab
JB
637
638%files ffplay
639%defattr(644,root,root,755)
640%attr(755,root,root) %{_bindir}/ffplay
22745365
JB
641%if %{with doc}
642%{_mandir}/man1/ffplay.1*
643%{_mandir}/man1/ffplay-all.1*
644%endif
af49d6ab 645
fde29260
ER
646%files ffserver
647%defattr(644,root,root,755)
648%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
649%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
650%attr(755,root,root) %{_sbindir}/ffserver
651%attr(754,root,root) /etc/rc.d/init.d/ffserver
22745365
JB
652%if %{with doc}
653%{_mandir}/man1/ffserver.1*
654%{_mandir}/man1/ffserver-all.1*
655%endif
38cf6de3
ER
656%dir %attr(770,root,ffserver) /var/cache/ffserver
657%dir %attr(770,root,ffserver) /var/log/ffserver
4b05ede1
ER
658
659%if %{with doc}
660%files doc
661%defattr(644,root,root,755)
662%doc doc/*.html
663%endif
This page took 0.198748 seconds and 4 git commands to generate.