]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- updated to 1.0 (note: new libavfilter soname); 0.11.x left on FFMPEG_0_11 branch
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
1c1d1368 1# TODO: libilbc, libfdk-aac, flite
197f4211 2#
5663f846
JB
3# How to deal with ffmpeg/opencv checken-egg problem:
4# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 5# 2. make-request -r opencv.spec
6# 3. bump release of ffmpeg.spec
7# 4. make-request -r ffmpeg.spec
8#
2b3b2117 9# Conditional build:
38cefaee 10%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 11%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
294c9b1e 12%bcond_without autoreqdep # don't care about package name deps generated by rpm
1c1d1368
JB
13%bcond_without caca # textual display using libcaca
14%bcond_with flite # flite voice synthesis support [ffmpeg expects more voices]
d7a39558 15%bcond_without frei0r # build without frei0r video filtering
d5aef92e 16%bcond_without openal # build without OpenAL 1.1 capture support
192f9f57 17%bcond_without opencv # build without opencv video filtering
d5aef92e 18%bcond_without pulseaudio # build without PulseAudio input support
ea09f25d 19%bcond_without x264 # build without x264 encoder
daf9a670 20%bcond_without utvideo # build without Ut Video decoder
1ef27ea1
JB
21%bcond_without va # VAAPI (Video Acceleration API)
22%bcond_without vpx # VP8, a high-quality video codec
23%bcond_without doc # don't build docs
314ef0df 24
cbdd2688
JB
25Summary: FFmpeg - a very fast video and audio converter
26Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 27Name: ffmpeg
1c1d1368 28Version: 1.0
ae5be86b 29Release: 1
9cf4d8a4 30# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
31# (postprocessing, some filters, x264, xavs, xvid, x11grab)
32# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 33License: GPL v3+ with LGPL v3+ parts
fde29260 34Group: Applications/Multimedia
1ef27ea1 35Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
1c1d1368 36# Source0-md5: 3ed526cea20c1bffb5a37f7730f710bd
fde29260
ER
37Source1: ffserver.init
38Source2: ffserver.sysconfig
38cf6de3 39Source3: ffserver.conf
5663f846 40Patch0: %{name}-gsm.patch
3eef5ddf 41Patch1: %{name}-opencv24.patch
ae5be86b 42Patch2: %{name}-openjpeg.patch
85f7cea1 43URL: http://www.ffmpeg.org/
d5aef92e 44%{?with_openal:BuildRequires: OpenAL-devel}
3dcb8642 45BuildRequires: SDL-devel >= 1.2.1
cbdd2688 46BuildRequires: alsa-lib-devel
38cefaee 47BuildRequires: bzip2-devel
9f9ba8ac 48BuildRequires: celt-devel >= 0.11.0
38cefaee 49%{?with_nonfree:BuildRequires: faac-devel}
1c1d1368 50%{?with_flite:BuildRequires: flite-devel}
3dcb8642 51BuildRequires: fontconfig-devel
2a60eebe 52BuildRequires: freetype-devel
d7a39558 53%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
54%ifarch ppc
55# require version with altivec support fixed
56BuildRequires: gcc >= 5:3.3.2-3
57%endif
d5aef92e 58BuildRequires: gnutls-devel
cbdd2688
JB
59BuildRequires: jack-audio-connection-kit-devel
60BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 61%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 62BuildRequires: libass-devel
1c1d1368 63BuildRequires: libavc1394-devel
3dcb8642 64BuildRequires: libbluray-devel
1c1d1368 65%{?with_caca:BuildRequires: libcaca-devel}
d5aef92e 66BuildRequires: libcdio-devel
9c4296c2 67BuildRequires: libdc1394-devel >= 2
f1669449 68BuildRequires: libgsm-devel
1c1d1368 69BuildRequires: libiec61883-devel
d5aef92e 70BuildRequires: libmodplug-devel
4a927f9d 71BuildRequires: libnut-devel
7571bfa0 72BuildRequires: libraw1394-devel >= 2
cbdd2688 73BuildRequires: librtmp-devel
9042663c 74BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 75BuildRequires: libtool >= 2:1.4d-3
daf9a670 76BuildRequires: libv4l-devel
64f8f109 77%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 78BuildRequires: libvdpau-devel >= 0.2
e380e18a 79BuildRequires: libvorbis-devel
065be88e 80%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.6}
660918c5
AM
81# X264_BUILD >= 118
82%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
e1fe03f7 83%ifarch %{ix86}
84%ifnarch i386 i486
76243dbd
JB
85BuildRequires: nasm
86%endif
e1fe03f7 87%endif
1c1d1368
JB
88BuildRequires: opencore-amr-devel
89%{?with_opencv:BuildRequires: opencv-devel}
90BuildRequires: openjpeg-devel >= 1.5
91BuildRequires: opus-devel
136f0f45 92BuildRequires: perl-Encode
1463656a 93BuildRequires: perl-tools-pod
ef3c0513 94BuildRequires: pkgconfig
1c1d1368 95%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 96BuildRequires: rpmbuild(macros) >= 1.470
126fb805 97BuildRequires: schroedinger-devel
1c1d1368 98BuildRequires: speex-devel >= 1:1.2-rc1
64f8f109
ER
99%{?with_doc:BuildRequires: tetex}
100%{?with_doc:BuildRequires: texi2html}
101%{?with_doc:BuildRequires: texinfo}
1c1d1368 102BuildRequires: twolame-devel
daf9a670 103%{?with_utvideo:BuildRequires: utvideo-devel}
986e22a5 104BuildRequires: yasm
5dc039cb
JB
105BuildRequires: vo-aacenc-devel
106BuildRequires: vo-amrwbenc-devel
107BuildRequires: xavs-devel
cbdd2688
JB
108BuildRequires: xorg-lib-libXext-devel
109BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 110BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 111BuildRequires: zlib-devel
57ebb8ad 112%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
113# overflows maximum hash table size
114BuildConflicts: pdksh < 5.2.14-57
54ec280e 115Requires: %{name}-libs = %{version}-%{release}
839e806f 116Requires: xvid >= 1:1.1.0
af49d6ab 117Obsoletes: libpostproc
539b540f 118BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 119
2a60eebe
JB
120%define _noautoreqdep libGL.so.1 libGLU.so.1
121
c01d7857
PS
122%define specflags -fno-strict-aliasing
123
124# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
125%define specflags_ia32 -fomit-frame-pointer
126# -mmmx is needed to enable <mmintrin.h> code.
127%define specflags_i586 -mmmx
128%define specflags_i686 -mmmx
1162803a 129%define specflags_ppc -fPIC
c01d7857 130
9fc4ad22 131%description
85f7cea1
ER
132FFmpeg is a complete solution to record, convert and stream audio and
133video. It is a command line tool to convert one video file format to
134another. It also supports grabbing and encoding in real time from a TV
135card.
9fc4ad22 136
cdb7b42e 137%description -l pl.UTF-8
cbdd2688
JB
138FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
139strumieni dźwięku i obrazu. Jest to działające z linii poleceń
140narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
141także przechwytywanie i kodowanie w czasie rzeczywistym z karty
142telewizyjnej.
9fc4ad22 143
54ec280e
PG
144%package libs
145Summary: ffmpeg libraries
adcc0f76 146Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
147Group: Libraries
148
149%description libs
cbdd2688
JB
150This package contains the ffmpeg shared libraries:
151- the codec library (libavcodec). It supports most existing encoding
152 formats (MPEG, DivX, MPEG4, AC3, DV...),
153- demuxer library (libavformat). It supports most existing file
154 formats (AVI, MPEG, OGG, Matroska, ASF...),
155- video postprocessing library (libpostproc).
54ec280e 156
cdb7b42e 157%description libs -l pl.UTF-8
cbdd2688
JB
158Ten pakiet zawiera biblioteki współdzielone ffmpeg:
159- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
160 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
161- bibliotekę demuksera (libavformat); obsługuje większość istniejących
162 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
163- bibliotekę postprocessingu (libpostproc).
54ec280e 164
af49d6ab
JB
165%package devel
166Summary: ffmpeg header files
adcc0f76 167Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 168Group: Development/Libraries
54ec280e 169Requires: %{name}-libs = %{version}-%{release}
38cefaee 170# Libs.private from *.pc (unreasonably they are all the same)
3dcb8642 171Requires: SDL-devel >= 1.2.1
38cefaee
JB
172Requires: alsa-lib-devel
173Requires: bzip2-devel
9c4296c2 174Requires: celt-devel >= 0.11.0
38cefaee 175%{?with_nonfree:Requires: faac-devel}
3dcb8642
JB
176Requires: fontconfig-devel
177Requires: freetype-devel
38cefaee 178Requires: jack-audio-connection-kit-devel
1c1d1368 179%{?with_flite:Requires: flite-devel}
38cefaee 180Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
181%{?with_aacplus:Requires: libaacplus-devel >= 2.0.0}
182Requires: libass-devel
183Requires: libavc1394-devel
3dcb8642 184Requires: libbluray-devel
1c1d1368 185Requires: libcdio-devel
9c4296c2 186Requires: libdc1394-devel >= 2
bf479bc6 187Requires: libgsm-devel
1c1d1368
JB
188Requires: libiec61883-devel
189Requires: libmodplug-devel
4a927f9d 190Requires: libnut-devel
7571bfa0 191Requires: libraw1394-devel >= 2
38cefaee
JB
192Requires: librtmp-devel
193Requires: libtheora-devel >= 1.0-0.beta3
194%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 195Requires: libvorbis-devel
38cefaee 196%{?with_vpx:Requires: libvpx-devel >= 0.9.6}
ea09f25d 197%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee 198Requires: opencore-amr-devel
ae5be86b 199Requires: openjpeg-devel >= 1.5
38cefaee
JB
200Requires: schroedinger-devel
201Requires: speex-devel >= 1:1.2-rc1
1c1d1368 202Requires: twolame-devel
38cefaee
JB
203Requires: vo-aacenc-devel
204Requires: vo-amrwbenc-devel
205Requires: xavs-devel
206Requires: xorg-lib-libXext-devel
207Requires: xorg-lib-libXfixes-devel
46f2a56b 208Requires: xvid-devel >= 1:1.1.0
33a1c0f3 209Requires: zlib-devel
8152d6a2 210Obsoletes: libpostproc-devel
af49d6ab
JB
211
212%description devel
213ffmpeg header files.
214
cdb7b42e
JR
215%description devel -l pl.UTF-8
216Pliki nagłówkowe ffmpeg.
af49d6ab
JB
217
218%package static
219Summary: ffmpeg static libraries
adcc0f76 220Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
221Group: Development/Libraries
222Requires: %{name}-devel = %{version}-%{release}
223
224%description static
225ffmpeg static libraries (libavcodec and libavformat).
226
cdb7b42e 227%description static -l pl.UTF-8
af49d6ab
JB
228Statyczne biblioteki ffmpeg (libavcodec i libavformat).
229
2a60eebe
JB
230%package ffplay
231Summary: FFplay - SDL-based media player
adcc0f76 232Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 233Group: Applications/Multimedia
54ec280e 234Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
235
236%description ffplay
237FFplay is a very simple and portable media player using the FFmpeg
238libraries and the SDL library. It is mostly used as a test bench for
239the various APIs of FFmpeg.
240
cdb7b42e
JR
241%description ffplay -l pl.UTF-8
242FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
243bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
244testowania różnych API FFmpeg.
2a60eebe 245
fde29260
ER
246%package ffserver
247Summary: FFserver video server
adcc0f76 248Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 249Group: Daemons
593d3a64 250Requires(post,preun): /sbin/chkconfig
67103923 251Requires: %{name}-libs = %{version}-%{release}
2305d791 252Requires: rc-scripts >= 0.4.0.10
fde29260
ER
253
254%description ffserver
255FFserver is a streaming server for both audio and video. It supports
256several live feeds, streaming from files and time shifting on live
257feeds (you can seek to positions in the past on each live feed,
258provided you specify a big enough feed storage in ffserver.conf).
259
cdb7b42e
JR
260%description ffserver -l pl.UTF-8
261FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
262źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
263czasie dla źródeł na żywo (można przeskakiwać na położenia w
264przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
265dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 266
9fc4ad22 267%prep
aed8e8c9 268%setup -q
f1669449 269%patch0 -p1
3eef5ddf 270%patch1 -p0
ae5be86b 271%patch2 -p1
9fc4ad22 272
9d4f8977
ER
273# package the grep result for mplayer, the result formatted as ./mplayer/configure
274cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
275#! /bin/sh
276_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
277_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
278_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
279_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
280_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
281_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
282_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
283EOF
9d4f8977 284cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
285
286case "$1" in
287--decoders)
288 echo $_libavdecoders_all
289 ;;
290--encoders)
291 echo $_libavencoders_all
292 ;;
293--parsers)
294 echo $_libavparsers_all
295 ;;
296--bsfs)
297 echo $_libavbsfs_all
298 ;;
299--demuxers)
300 echo $_libavdemuxers_all
301 ;;
302--muxers)
303 echo $_libavmuxers_all
304 ;;
305--protocols)
306 echo $_libavprotocols_all
307 ;;
308*)
309 cat <<USAGE
310Usage: $0 [OPTION]
311Options:
312 --decoders
313 --encoders
314 --parsers
315 --bsfs
316 --demuxers
317 --muxers
318 --protocols
319USAGE
320 exit 1;;
321esac
322
323exit 0
324EOF
325
9fc4ad22 326%build
05e1eb2f
JB
327# notes:
328# - it's not autoconf configure
d0a0ec26 329# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 330./configure \
b4680d0b 331 --arch=%{_target_base_arch} \
539b540f 332 --prefix=%{_prefix} \
9cf4d8a4 333 --libdir=%{_libdir} \
d81dfa95 334 --shlibdir=%{_libdir} \
2a60eebe 335 --mandir=%{_mandir} \
314ef0df 336 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 337 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 338 --cc="%{__cc}" \
126fb805
JB
339 --disable-debug \
340 --disable-optimizations \
6382c99d 341 --disable-stripping \
314ef0df 342 --enable-avfilter \
0797daec 343 --enable-avresample \
d5aef92e 344 --enable-gnutls \
126fb805 345 --enable-gpl \
0b43f655 346 --enable-version3 \
3dcb8642 347 --enable-fontconfig \
d7a39558 348 %{?with_frei0r:--enable-frei0r} \
2e585b44 349 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 350 --enable-libass \
3dcb8642 351 --enable-libbluray \
1c1d1368 352 %{?with_libcaca:--enable-libcaca} \
cbdd2688 353 --enable-libcelt \
d5aef92e
JB
354 --enable-libcdio \
355 --enable-libdc1394 \
1c1d1368 356 %{?with_flite:--enable-libflite} \
3dcb8642 357 --enable-libfreetype \
f3692243 358 --enable-libgsm \
1c1d1368 359 --enable-libiec61883 \
d5aef92e 360 --enable-libmodplug \
15c15700 361 --enable-libmp3lame \
4a927f9d 362 --enable-libnut \
cbdd2688
JB
363 --enable-libopencore-amrnb \
364 --enable-libopencore-amrwb \
192f9f57 365 %{?with_opencv:--enable-libopencv} \
cbdd2688 366 --enable-libopenjpeg \
1c1d1368 367 --enable-libopus \
d5aef92e 368 %{?with_pulseaudio:--enable-libpulse} \
cbdd2688 369 --enable-librtmp \
126fb805 370 --enable-libschroedinger \
da99dcf2 371 --enable-libspeex \
126fb805 372 --enable-libtheora \
1c1d1368 373 --enable-libtwolame \
daf9a670 374 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 375 --enable-libv4l2 \
5dc039cb
JB
376 --enable-libvo-aacenc \
377 --enable-libvo-amrwbenc \
126fb805 378 --enable-libvorbis \
64f8f109 379 %{?with_vpx:--enable-libvpx} \
ea09f25d 380 %{?with_x264:--enable-libx264} \
5dc039cb 381 --enable-libxavs \
126fb805 382 --enable-libxvid \
d5aef92e 383 %{?with_openal:--enable-openal} \
6382c99d 384 --enable-postproc \
d7493de8 385 --enable-pthreads \
9cf4d8a4 386 --enable-shared \
6382c99d 387 --enable-swscale \
1c1d1368 388 %{?with_va:--enable-vaapi} \
0b43f655 389 --enable-vdpau \
75231f25 390 --enable-x11grab \
7a286645 391%ifnarch %{ix86} %{x8664}
e1fe03f7 392 --disable-mmx \
393%endif
394%ifarch i386 i486
05e1eb2f 395 --disable-mmx \
b524cd99 396%endif
0b43f655 397%if %{with nonfree}
48610c64 398 --enable-nonfree \
0b43f655 399 --enable-libfaac \
76243dbd 400%endif
75231f25 401 --enable-runtime-cpudetect
2305d791 402
da99dcf2 403# force oldscaler build
b8c60172 404%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 405
1ef27ea1
JB
406%{__make} \
407 V=1
9fc4ad22 408
b8c60172
ER
409# CC_O to add -c to commandline. makefile should be patched
410%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
411
9fc4ad22
AM
412%install
413rm -rf $RPM_BUILD_ROOT
38cf6de3 414install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 415 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 416 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 417
539b540f 418%{__make} install \
1ef27ea1
JB
419 DESTDIR=$RPM_BUILD_ROOT \
420 V=1
539b540f 421
544421b2
ER
422cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
423cp -a libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
424cp -a libavutil/bswap.h $RPM_BUILD_ROOT%{_includedir}/libavutil
425cp -a libavutil/common.h $RPM_BUILD_ROOT%{_includedir}/libavutil
426cp -a libavutil/mem.h $RPM_BUILD_ROOT%{_includedir}/libavutil
427for a in libavutil/*/bswap.h; do
428 install -D $a $RPM_BUILD_ROOT%{_includedir}/$a
429done
9d4f8977
ER
430cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
431cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
432# for lim-omx ffmpeg components
433cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 434
b8c60172
ER
435install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
436cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
437cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 438mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 439install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 440
2b2445b7
ER
441# install as ffmpeg-avconfig to avoid with possible programs looking for
442# ffmpeg-config and expecting --libs output from it which is not implemented
443# simple to do (by querying pkgconfig), but why?
b8c60172 444install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 445
9fc4ad22
AM
446%clean
447rm -rf $RPM_BUILD_ROOT
448
1ef27ea1
JB
449%post libs -p /sbin/ldconfig
450%postun libs -p /sbin/ldconfig
539b540f 451
38cf6de3
ER
452%pre ffserver
453%groupadd -g 167 ffserver
454%useradd -g ffserver -u 167 ffserver
455
593d3a64
ER
456%post ffserver
457/sbin/chkconfig --add ffserver
458%service ffserver restart
459
38cf6de3 460%preun ffserver
593d3a64
ER
461if [ "$1" = 0 ]; then
462 %service ffserver stop
463 /sbin/chkconfig --del ffserver
464fi
465
38cf6de3
ER
466%postun ffserver
467if [ "$1" = 0 ]; then
468 %userremove ffserver
469 %groupremove ffserver
470fi
471
9fc4ad22
AM
472%files
473%defattr(644,root,root,755)
660918c5 474%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
2a60eebe 475%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 476%attr(755,root,root) %{_bindir}/ffprobe
b7313442 477%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
478%dir %{_datadir}/ffmpeg
479%{_datadir}/ffmpeg/*.ffpreset
714dcf83 480%{_datadir}/ffmpeg/ffprobe.xsd
64f8f109
ER
481%{?with_doc:%{_mandir}/man1/ffmpeg.1*}
482%{?with_doc:%{_mandir}/man1/ffprobe.1*}
54ec280e
PG
483
484%files libs
485%defattr(644,root,root,755)
f50f7d7c 486%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
5663f846 487%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
d0a0ec26 488%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
5663f846 489%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
314ef0df 490%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
1c1d1368 491%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
f50f7d7c 492%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
5663f846
JB
493%attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
494%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
495%attr(755,root,root) %ghost %{_libdir}/libavresample.so.0
f50f7d7c 496%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
cbdd2688 497%attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
d7493de8 498%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 499%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
500%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
501%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 502%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 503%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 504
539b540f
JB
505%files devel
506%defattr(644,root,root,755)
54ec280e 507%doc doc/optimization.txt
1ef27ea1 508%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 509%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 510%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 511%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 512%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 513%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 514%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 515%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 516%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 517%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 518%{_includedir}/ffmpeg
6382c99d
AM
519%{_includedir}/libavcodec
520%{_includedir}/libavdevice
314ef0df 521%{_includedir}/libavfilter
6382c99d 522%{_includedir}/libavformat
5663f846 523%{_includedir}/libavresample
6382c99d
AM
524%{_includedir}/libavutil
525%{_includedir}/libpostproc
660918c5 526%{_includedir}/libswresample
6382c99d 527%{_includedir}/libswscale
1ef27ea1
JB
528%{_pkgconfigdir}/libavcodec.pc
529%{_pkgconfigdir}/libavdevice.pc
530%{_pkgconfigdir}/libavfilter.pc
531%{_pkgconfigdir}/libavformat.pc
5663f846 532%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
533%{_pkgconfigdir}/libavutil.pc
534%{_pkgconfigdir}/libpostproc.pc
660918c5 535%{_pkgconfigdir}/libswresample.pc
1ef27ea1 536%{_pkgconfigdir}/libswscale.pc
539b540f 537
9cf4d8a4
JB
538%files static
539%defattr(644,root,root,755)
1ef27ea1
JB
540%{_libdir}/libavcodec.a
541%{_libdir}/libavdevice.a
542%{_libdir}/libavfilter.a
543%{_libdir}/libavformat.a
5663f846 544%{_libdir}/libavresample.a
1ef27ea1
JB
545%{_libdir}/libavutil.a
546%{_libdir}/libpostproc.a
660918c5 547%{_libdir}/libswresample.a
1ef27ea1 548%{_libdir}/libswscale.a
af49d6ab
JB
549
550%files ffplay
551%defattr(644,root,root,755)
552%attr(755,root,root) %{_bindir}/ffplay
64f8f109 553%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 554
fde29260
ER
555%files ffserver
556%defattr(644,root,root,755)
557%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
558%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
559%attr(755,root,root) %{_sbindir}/ffserver
560%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 561%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
562%dir %attr(770,root,ffserver) /var/cache/ffserver
563%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.527777 seconds and 4 git commands to generate.