]> git.pld-linux.org Git - packages/ffmpeg.git/commitdiff
- updated to 1.0 (note: new libavfilter soname); 0.11.x left on FFMPEG_0_11 branch
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 6 Oct 2012 09:14:52 +0000 (11:14 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 6 Oct 2012 09:15:24 +0000 (11:15 +0200)
- updated gsm,openjpeg patches
- enabled new features: libcaca,libiec61883,opus,twolame; few more to go

ffmpeg-gsm.patch
ffmpeg-openjpeg.patch
ffmpeg.spec

index c62b28710b450bc9a2740ee9cbcd99abc9df84b4..ca85652c14b4870e01da325483884d1b91ea14d6 100644 (file)
@@ -1,14 +1,14 @@
---- ffmpeg-0.10/configure.orig 2011-06-21 21:29:25.000000000 +0200
-+++ ffmpeg-0.10/configure      2011-06-26 20:07:17.579181375 +0200
-@@ -3071,7 +3071,7 @@
    "dirac_decoder_init dirac_encoder_init"
- enabled libfaac    && require2 libfaac "stdint.h faac.h" faacEncGetVersion -lfaac
+--- ffmpeg-1.0/configure.orig  2012-10-05 22:11:11.888434415 +0200
++++ ffmpeg-1.0/configure       2012-10-05 22:12:56.018432244 +0200
+@@ -3646,7 +3646,7 @@
flite_libs="-lflite_cmu_time_awb -lflite_cmu_us_awb -lflite_cmu_us_kal -lflite_cmu_us_kal16 -lflite_cmu_us_rms -lflite_cmu_us_slt -lflite_usenglish -lflite_cmulex -lflite"
+ enabled libflite   && require2 libflite "flite/flite.h" flite_init $flite_libs
  enabled libfreetype && require_pkg_config freetype2 "ft2build.h freetype/freetype.h" FT_Init_FreeType
 -enabled libgsm     && require  libgsm gsm/gsm.h gsm_create -lgsm
 +enabled libgsm     && require  libgsm gsm.h gsm_create -lgsm
+ enabled libilbc    && require  libilbc ilbc.h WebRtcIlbcfix_InitDecode -lilbc
  enabled libmodplug && require  libmodplug libmodplug/modplug.h ModPlug_Load -lmodplug
  enabled libmp3lame && require  "libmp3lame >= 3.98.3" lame/lame.h lame_set_VBR_quality -lmp3lame
- enabled libnut     && require  libnut libnut.h nut_demuxer_init -lnut
 --- ffmpeg-0.10/libavcodec/libgsm.c.orig       2012-01-26 23:15:59.000000000 +0100
 +++ ffmpeg-0.10/libavcodec/libgsm.c    2012-01-27 17:58:28.495275196 +0100
 @@ -27,7 +27,7 @@
index 51badf773c11627bcf5ff78a163a31665418d431..67158e2f96d24ce53c99f3c2d9c83f32e1bce56e 100644 (file)
@@ -1,11 +1,11 @@
---- ffmpeg-0.11.2/configure.orig       2012-10-05 21:04:40.855184264 +0200
-+++ ffmpeg-0.11.2/configure    2012-10-05 21:23:33.891827315 +0200
-@@ -3225,7 +3225,7 @@
+--- ffmpeg-1.0/configure.orig  2012-10-05 22:13:45.328431216 +0200
++++ ffmpeg-1.0/configure       2012-10-05 22:15:06.931762850 +0200
+@@ -3654,7 +3654,7 @@
  enabled libopencore_amrnb  && require libopencore_amrnb opencore-amrnb/interf_dec.h Decoder_Interface_init -lopencore-amrnb
  enabled libopencore_amrwb  && require libopencore_amrwb opencore-amrwb/dec_if.h D_IF_init -lopencore-amrwb
  enabled libopencv  && add_extralibs -lopencv_core -lopencv_features2d -lopencv_imgproc -lopencv_objdetect -lgcrypt
 -enabled libopenjpeg && require libopenjpeg openjpeg.h opj_version -lopenjpeg
 +enabled libopenjpeg && require_pkg_config libopenjpeg openjpeg.h opj_version
+ enabled libopus    && require_pkg_config opus opus_multistream.h opus_multistream_decoder_create
  enabled libpulse && require_pkg_config libpulse-simple pulse/simple.h pa_simple_new
  enabled librtmp    && require_pkg_config librtmp librtmp/rtmp.h RTMP_Socket
- enabled libschroedinger && require_pkg_config schroedinger-1.0 schroedinger/schro.h schro_init
index dd855ce83e97d2ea69bc8f94644af1cef7ce79c5..aa9a4060339d204f7a833de998493c6c36a08bbf 100644 (file)
@@ -1,3 +1,4 @@
+# TODO: libilbc, libfdk-aac, flite
 #
 # How to deal with ffmpeg/opencv checken-egg problem:
 #      1. make-request -r --without opencv ffmpeg.spec
@@ -9,6 +10,8 @@
 %bcond_with    nonfree         # non free options of package (currently: faac)
 %bcond_with    aacplus         # AAC+ encoding via libaacplus (requires nonfree)
 %bcond_without autoreqdep      # don't care about package name deps generated by rpm
+%bcond_without caca            # textual display using libcaca
+%bcond_with    flite           # flite voice synthesis support [ffmpeg expects more voices]
 %bcond_without frei0r          # build without frei0r video filtering
 %bcond_without openal          # build without OpenAL 1.1 capture support
 %bcond_without opencv          # build without opencv video filtering
@@ -22,7 +25,7 @@
 Summary:       FFmpeg - a very fast video and audio converter
 Summary(pl.UTF-8):     FFmpeg - szybki konwerter audio/wideo
 Name:          ffmpeg
-Version:       0.11.2
+Version:       1.0
 Release:       1
 # LGPL or GPL, chosen at configure time (GPL version is more featured)
 # (postprocessing, some filters, x264, xavs, xvid, x11grab)
@@ -30,7 +33,7 @@ Release:      1
 License:       GPL v3+ with LGPL v3+ parts
 Group:         Applications/Multimedia
 Source0:       http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
-# Source0-md5: 93c1908022567b321df74db7214da6ac
+# Source0-md5: 3ed526cea20c1bffb5a37f7730f710bd
 Source1:       ffserver.init
 Source2:       ffserver.sysconfig
 Source3:       ffserver.conf
@@ -44,6 +47,7 @@ BuildRequires:        alsa-lib-devel
 BuildRequires: bzip2-devel
 BuildRequires: celt-devel >= 0.11.0
 %{?with_nonfree:BuildRequires: faac-devel}
+%{?with_flite:BuildRequires:   flite-devel}
 BuildRequires: fontconfig-devel
 BuildRequires: freetype-devel
 %{?with_frei0r:BuildRequires:  frei0r-devel}
@@ -56,10 +60,13 @@ BuildRequires:      jack-audio-connection-kit-devel
 BuildRequires: lame-libs-devel >= 3.98.3
 %{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
 BuildRequires: libass-devel
+BuildRequires: libavc1394-devel
 BuildRequires: libbluray-devel
+%{?with_caca:BuildRequires:    libcaca-devel}
 BuildRequires: libcdio-devel
 BuildRequires: libdc1394-devel >= 2
 BuildRequires: libgsm-devel
+BuildRequires: libiec61883-devel
 BuildRequires: libmodplug-devel
 BuildRequires: libnut-devel
 BuildRequires: libraw1394-devel >= 2
@@ -73,24 +80,26 @@ BuildRequires:      libvorbis-devel
 %{?with_vpx:BuildRequires:     libvpx-devel >= 0.9.6}
 # X264_BUILD >= 118
 %{?with_x264:BuildRequires:    libx264-devel >= 0.1.3-1.20111212_2245}
-BuildRequires: opencore-amr-devel
-%{?with_opencv:BuildRequires:  opencv-devel}
-BuildRequires: openjpeg-devel >= 1.5
-%{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
-BuildRequires: speex-devel >= 1:1.2-rc1
 %ifarch %{ix86}
 %ifnarch i386 i486
 BuildRequires: nasm
 %endif
 %endif
+BuildRequires: opencore-amr-devel
+%{?with_opencv:BuildRequires:  opencv-devel}
+BuildRequires: openjpeg-devel >= 1.5
+BuildRequires: opus-devel
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
 BuildRequires: pkgconfig
+%{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: schroedinger-devel
+BuildRequires: speex-devel >= 1:1.2-rc1
 %{?with_doc:BuildRequires:     tetex}
 %{?with_doc:BuildRequires:     texi2html}
 %{?with_doc:BuildRequires:     texinfo}
+BuildRequires: twolame-devel
 %{?with_utvideo:BuildRequires: utvideo-devel}
 BuildRequires: yasm
 BuildRequires: vo-aacenc-devel
@@ -167,10 +176,17 @@ Requires: celt-devel >= 0.11.0
 Requires:      fontconfig-devel
 Requires:      freetype-devel
 Requires:      jack-audio-connection-kit-devel
+%{?with_flite:Requires:        flite-devel}
 Requires:      lame-libs-devel >= 3.98.3
+%{?with_aacplus:Requires:      libaacplus-devel >= 2.0.0}
+Requires:      libass-devel
+Requires:      libavc1394-devel
 Requires:      libbluray-devel
+Requires:      libcdio-devel
 Requires:      libdc1394-devel >= 2
 Requires:      libgsm-devel
+Requires:      libiec61883-devel
+Requires:      libmodplug-devel
 Requires:      libnut-devel
 Requires:      libraw1394-devel >= 2
 Requires:      librtmp-devel
@@ -183,6 +199,7 @@ Requires:   opencore-amr-devel
 Requires:      openjpeg-devel >= 1.5
 Requires:      schroedinger-devel
 Requires:      speex-devel >= 1:1.2-rc1
+Requires:      twolame-devel
 Requires:      vo-aacenc-devel
 Requires:      vo-amrwbenc-devel
 Requires:      xavs-devel
@@ -332,11 +349,14 @@ EOF
        %{?with_aacplus:--enable-libaacplus} \
        --enable-libass \
        --enable-libbluray \
+       %{?with_libcaca:--enable-libcaca} \
        --enable-libcelt \
        --enable-libcdio \
        --enable-libdc1394 \
+       %{?with_flite:--enable-libflite} \
        --enable-libfreetype \
        --enable-libgsm \
+       --enable-libiec61883 \
        --enable-libmodplug \
        --enable-libmp3lame \
        --enable-libnut \
@@ -344,11 +364,13 @@ EOF
        --enable-libopencore-amrwb \
        %{?with_opencv:--enable-libopencv} \
        --enable-libopenjpeg \
+       --enable-libopus \
        %{?with_pulseaudio:--enable-libpulse} \
        --enable-librtmp \
        --enable-libschroedinger \
        --enable-libspeex \
        --enable-libtheora \
+       --enable-libtwolame \
        %{?with_utvideo:--enable-libutvideo} \
        --enable-libv4l2 \
        --enable-libvo-aacenc \
@@ -363,6 +385,7 @@ EOF
        --enable-pthreads \
        --enable-shared \
        --enable-swscale \
+       %{?with_va:--enable-vaapi} \
        --enable-vdpau \
        --enable-x11grab \
 %ifnarch %{ix86} %{x8664}
@@ -465,7 +488,7 @@ fi
 %attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
 %attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.2
+%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
 %attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
 %attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
This page took 0.040198 seconds and 4 git commands to generate.