]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- enabled: libfreetype and fontconfig (for drawtext filter), libbluray (for BluRay...
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
197f4211 1#
5663f846
JB
2# How to deal with ffmpeg/opencv checken-egg problem:
3# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 4# 2. make-request -r opencv.spec
5# 3. bump release of ffmpeg.spec
6# 4. make-request -r ffmpeg.spec
7#
2b3b2117 8# Conditional build:
38cefaee 9%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 10%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
294c9b1e 11%bcond_without autoreqdep # don't care about package name deps generated by rpm
d7a39558 12%bcond_without frei0r # build without frei0r video filtering
d5aef92e 13%bcond_without openal # build without OpenAL 1.1 capture support
192f9f57 14%bcond_without opencv # build without opencv video filtering
d5aef92e 15%bcond_without pulseaudio # build without PulseAudio input support
ea09f25d 16%bcond_without x264 # build without x264 encoder
daf9a670 17%bcond_without utvideo # build without Ut Video decoder
1ef27ea1
JB
18%bcond_without va # VAAPI (Video Acceleration API)
19%bcond_without vpx # VP8, a high-quality video codec
20%bcond_without doc # don't build docs
314ef0df 21
cbdd2688
JB
22Summary: FFmpeg - a very fast video and audio converter
23Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 24Name: ffmpeg
5663f846
JB
25Version: 0.11
26Release: 0.1
9cf4d8a4 27# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
28# (postprocessing, some filters, x264, xavs, xvid, x11grab)
29# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 30License: GPL v3+ with LGPL v3+ parts
fde29260 31Group: Applications/Multimedia
1ef27ea1 32Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
5663f846 33# Source0-md5: 101e1092582bbfca8f2a204cbcecb8fc
fde29260
ER
34Source1: ffserver.init
35Source2: ffserver.sysconfig
38cf6de3 36Source3: ffserver.conf
5663f846 37Patch0: %{name}-gsm.patch
85f7cea1 38URL: http://www.ffmpeg.org/
d5aef92e 39%{?with_openal:BuildRequires: OpenAL-devel}
3dcb8642 40BuildRequires: SDL-devel >= 1.2.1
cbdd2688 41BuildRequires: alsa-lib-devel
38cefaee 42BuildRequires: bzip2-devel
9f9ba8ac 43BuildRequires: celt-devel >= 0.11.0
38cefaee 44%{?with_nonfree:BuildRequires: faac-devel}
3dcb8642 45BuildRequires: fontconfig-devel
2a60eebe 46BuildRequires: freetype-devel
d7a39558 47%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
48%ifarch ppc
49# require version with altivec support fixed
50BuildRequires: gcc >= 5:3.3.2-3
51%endif
d5aef92e 52BuildRequires: gnutls-devel
cbdd2688
JB
53BuildRequires: jack-audio-connection-kit-devel
54BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 55%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 56BuildRequires: libass-devel
3dcb8642 57BuildRequires: libbluray-devel
d5aef92e 58BuildRequires: libcdio-devel
9c4296c2 59BuildRequires: libdc1394-devel >= 2
f1669449 60BuildRequires: libgsm-devel
d5aef92e 61BuildRequires: libmodplug-devel
4a927f9d 62BuildRequires: libnut-devel
7571bfa0 63BuildRequires: libraw1394-devel >= 2
cbdd2688 64BuildRequires: librtmp-devel
9042663c 65BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 66BuildRequires: libtool >= 2:1.4d-3
daf9a670 67BuildRequires: libv4l-devel
64f8f109 68%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 69BuildRequires: libvdpau-devel >= 0.2
e380e18a 70BuildRequires: libvorbis-devel
065be88e 71%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.6}
660918c5
AM
72# X264_BUILD >= 118
73%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
0b43f655 74BuildRequires: opencore-amr-devel
192f9f57 75%{?with_opencv:BuildRequires: opencv-devel}
0b43f655 76BuildRequires: openjpeg-devel >= 1.3-2
d5aef92e 77%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
17a2d1a8 78BuildRequires: speex-devel >= 1:1.2-rc1
e1fe03f7 79%ifarch %{ix86}
80%ifnarch i386 i486
76243dbd
JB
81BuildRequires: nasm
82%endif
e1fe03f7 83%endif
136f0f45 84BuildRequires: perl-Encode
1463656a 85BuildRequires: perl-tools-pod
ef3c0513 86BuildRequires: pkgconfig
db8052c8 87BuildRequires: rpmbuild(macros) >= 1.470
126fb805 88BuildRequires: schroedinger-devel
64f8f109
ER
89%{?with_doc:BuildRequires: tetex}
90%{?with_doc:BuildRequires: texi2html}
91%{?with_doc:BuildRequires: texinfo}
daf9a670 92%{?with_utvideo:BuildRequires: utvideo-devel}
986e22a5 93BuildRequires: yasm
5dc039cb
JB
94BuildRequires: vo-aacenc-devel
95BuildRequires: vo-amrwbenc-devel
96BuildRequires: xavs-devel
cbdd2688
JB
97BuildRequires: xorg-lib-libXext-devel
98BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 99BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 100BuildRequires: zlib-devel
57ebb8ad 101%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
102# overflows maximum hash table size
103BuildConflicts: pdksh < 5.2.14-57
54ec280e 104Requires: %{name}-libs = %{version}-%{release}
839e806f 105Requires: xvid >= 1:1.1.0
af49d6ab 106Obsoletes: libpostproc
539b540f 107BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 108
2a60eebe
JB
109%define _noautoreqdep libGL.so.1 libGLU.so.1
110
c01d7857
PS
111%define specflags -fno-strict-aliasing
112
113# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
114%define specflags_ia32 -fomit-frame-pointer
115# -mmmx is needed to enable <mmintrin.h> code.
116%define specflags_i586 -mmmx
117%define specflags_i686 -mmmx
1162803a 118%define specflags_ppc -fPIC
c01d7857 119
9fc4ad22 120%description
85f7cea1
ER
121FFmpeg is a complete solution to record, convert and stream audio and
122video. It is a command line tool to convert one video file format to
123another. It also supports grabbing and encoding in real time from a TV
124card.
9fc4ad22 125
cdb7b42e 126%description -l pl.UTF-8
cbdd2688
JB
127FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
128strumieni dźwięku i obrazu. Jest to działające z linii poleceń
129narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
130także przechwytywanie i kodowanie w czasie rzeczywistym z karty
131telewizyjnej.
9fc4ad22 132
54ec280e
PG
133%package libs
134Summary: ffmpeg libraries
adcc0f76 135Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
136Group: Libraries
137
138%description libs
cbdd2688
JB
139This package contains the ffmpeg shared libraries:
140- the codec library (libavcodec). It supports most existing encoding
141 formats (MPEG, DivX, MPEG4, AC3, DV...),
142- demuxer library (libavformat). It supports most existing file
143 formats (AVI, MPEG, OGG, Matroska, ASF...),
144- video postprocessing library (libpostproc).
54ec280e 145
cdb7b42e 146%description libs -l pl.UTF-8
cbdd2688
JB
147Ten pakiet zawiera biblioteki współdzielone ffmpeg:
148- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
149 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
150- bibliotekę demuksera (libavformat); obsługuje większość istniejących
151 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
152- bibliotekę postprocessingu (libpostproc).
54ec280e 153
af49d6ab
JB
154%package devel
155Summary: ffmpeg header files
adcc0f76 156Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 157Group: Development/Libraries
54ec280e 158Requires: %{name}-libs = %{version}-%{release}
38cefaee 159# Libs.private from *.pc (unreasonably they are all the same)
3dcb8642 160Requires: SDL-devel >= 1.2.1
38cefaee
JB
161Requires: alsa-lib-devel
162Requires: bzip2-devel
9c4296c2 163Requires: celt-devel >= 0.11.0
38cefaee 164%{?with_nonfree:Requires: faac-devel}
3dcb8642
JB
165Requires: fontconfig-devel
166Requires: freetype-devel
38cefaee
JB
167Requires: jack-audio-connection-kit-devel
168Requires: lame-libs-devel >= 3.98.3
3dcb8642 169Requires: libbluray-devel
9c4296c2 170Requires: libdc1394-devel >= 2
bf479bc6 171Requires: libgsm-devel
4a927f9d 172Requires: libnut-devel
7571bfa0 173Requires: libraw1394-devel >= 2
38cefaee
JB
174Requires: librtmp-devel
175Requires: libtheora-devel >= 1.0-0.beta3
176%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 177Requires: libvorbis-devel
38cefaee 178%{?with_vpx:Requires: libvpx-devel >= 0.9.6}
ea09f25d 179%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee
JB
180Requires: opencore-amr-devel
181Requires: openjpeg-devel >= 1.3-2
182Requires: schroedinger-devel
183Requires: speex-devel >= 1:1.2-rc1
184Requires: vo-aacenc-devel
185Requires: vo-amrwbenc-devel
186Requires: xavs-devel
187Requires: xorg-lib-libXext-devel
188Requires: xorg-lib-libXfixes-devel
46f2a56b 189Requires: xvid-devel >= 1:1.1.0
33a1c0f3 190Requires: zlib-devel
8152d6a2 191Obsoletes: libpostproc-devel
af49d6ab
JB
192
193%description devel
194ffmpeg header files.
195
cdb7b42e
JR
196%description devel -l pl.UTF-8
197Pliki nagłówkowe ffmpeg.
af49d6ab
JB
198
199%package static
200Summary: ffmpeg static libraries
adcc0f76 201Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
202Group: Development/Libraries
203Requires: %{name}-devel = %{version}-%{release}
204
205%description static
206ffmpeg static libraries (libavcodec and libavformat).
207
cdb7b42e 208%description static -l pl.UTF-8
af49d6ab
JB
209Statyczne biblioteki ffmpeg (libavcodec i libavformat).
210
2a60eebe
JB
211%package ffplay
212Summary: FFplay - SDL-based media player
adcc0f76 213Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 214Group: Applications/Multimedia
54ec280e 215Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
216
217%description ffplay
218FFplay is a very simple and portable media player using the FFmpeg
219libraries and the SDL library. It is mostly used as a test bench for
220the various APIs of FFmpeg.
221
cdb7b42e
JR
222%description ffplay -l pl.UTF-8
223FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
224bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
225testowania różnych API FFmpeg.
2a60eebe 226
fde29260
ER
227%package ffserver
228Summary: FFserver video server
adcc0f76 229Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 230Group: Daemons
593d3a64 231Requires(post,preun): /sbin/chkconfig
67103923 232Requires: %{name}-libs = %{version}-%{release}
2305d791 233Requires: rc-scripts >= 0.4.0.10
fde29260
ER
234
235%description ffserver
236FFserver is a streaming server for both audio and video. It supports
237several live feeds, streaming from files and time shifting on live
238feeds (you can seek to positions in the past on each live feed,
239provided you specify a big enough feed storage in ffserver.conf).
240
cdb7b42e
JR
241%description ffserver -l pl.UTF-8
242FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
243źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
244czasie dla źródeł na żywo (można przeskakiwać na położenia w
245przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
246dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 247
9fc4ad22 248%prep
aed8e8c9 249%setup -q
f1669449 250%patch0 -p1
9fc4ad22 251
9d4f8977
ER
252# package the grep result for mplayer, the result formatted as ./mplayer/configure
253cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
254#! /bin/sh
255_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
256_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
257_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
258_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
259_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
260_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
261_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
262EOF
9d4f8977 263cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
264
265case "$1" in
266--decoders)
267 echo $_libavdecoders_all
268 ;;
269--encoders)
270 echo $_libavencoders_all
271 ;;
272--parsers)
273 echo $_libavparsers_all
274 ;;
275--bsfs)
276 echo $_libavbsfs_all
277 ;;
278--demuxers)
279 echo $_libavdemuxers_all
280 ;;
281--muxers)
282 echo $_libavmuxers_all
283 ;;
284--protocols)
285 echo $_libavprotocols_all
286 ;;
287*)
288 cat <<USAGE
289Usage: $0 [OPTION]
290Options:
291 --decoders
292 --encoders
293 --parsers
294 --bsfs
295 --demuxers
296 --muxers
297 --protocols
298USAGE
299 exit 1;;
300esac
301
302exit 0
303EOF
304
9fc4ad22 305%build
05e1eb2f
JB
306# notes:
307# - it's not autoconf configure
d0a0ec26 308# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 309./configure \
b4680d0b 310 --arch=%{_target_base_arch} \
539b540f 311 --prefix=%{_prefix} \
9cf4d8a4 312 --libdir=%{_libdir} \
d81dfa95 313 --shlibdir=%{_libdir} \
2a60eebe 314 --mandir=%{_mandir} \
126fb805 315 --cc="%{__cc}" \
314ef0df 316 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 317 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
126fb805
JB
318 --disable-debug \
319 --disable-optimizations \
6382c99d 320 --disable-stripping \
314ef0df 321 --enable-avfilter \
d5aef92e 322 --enable-gnutls \
126fb805 323 --enable-gpl \
0b43f655 324 --enable-version3 \
3dcb8642 325 --enable-fontconfig \
d7a39558 326 %{?with_frei0r:--enable-frei0r} \
2e585b44 327 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 328 --enable-libass \
3dcb8642 329 --enable-libbluray \
cbdd2688 330 --enable-libcelt \
d5aef92e
JB
331 --enable-libcdio \
332 --enable-libdc1394 \
3dcb8642 333 --enable-libfreetype \
f3692243 334 --enable-libgsm \
d5aef92e 335 --enable-libmodplug \
15c15700 336 --enable-libmp3lame \
4a927f9d 337 --enable-libnut \
cbdd2688
JB
338 --enable-libopencore-amrnb \
339 --enable-libopencore-amrwb \
192f9f57 340 %{?with_opencv:--enable-libopencv} \
cbdd2688 341 --enable-libopenjpeg \
d5aef92e 342 %{?with_pulseaudio:--enable-libpulse} \
cbdd2688 343 --enable-librtmp \
126fb805 344 --enable-libschroedinger \
da99dcf2 345 --enable-libspeex \
126fb805 346 --enable-libtheora \
daf9a670 347 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 348 --enable-libv4l2 \
5dc039cb
JB
349 --enable-libvo-aacenc \
350 --enable-libvo-amrwbenc \
126fb805 351 --enable-libvorbis \
64f8f109 352 %{?with_vpx:--enable-libvpx} \
ea09f25d 353 %{?with_x264:--enable-libx264} \
5dc039cb 354 --enable-libxavs \
126fb805 355 --enable-libxvid \
d5aef92e 356 %{?with_openal:--enable-openal} \
6382c99d 357 --enable-postproc \
d7493de8 358 --enable-pthreads \
9cf4d8a4 359 --enable-shared \
6382c99d 360 --enable-swscale \
0b43f655 361 --enable-vdpau \
75231f25 362 --enable-x11grab \
7a286645 363%ifnarch %{ix86} %{x8664}
e1fe03f7 364 --disable-mmx \
365%endif
366%ifarch i386 i486
05e1eb2f 367 --disable-mmx \
b524cd99 368%endif
0b43f655 369%if %{with nonfree}
48610c64 370 --enable-nonfree \
0b43f655 371 --enable-libfaac \
76243dbd 372%endif
75231f25 373 --enable-runtime-cpudetect
2305d791 374
da99dcf2 375# force oldscaler build
b8c60172 376%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 377
1ef27ea1
JB
378%{__make} \
379 V=1
9fc4ad22 380
b8c60172
ER
381# CC_O to add -c to commandline. makefile should be patched
382%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
383
9fc4ad22
AM
384%install
385rm -rf $RPM_BUILD_ROOT
38cf6de3 386install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 387 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 388 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 389
539b540f 390%{__make} install \
1ef27ea1
JB
391 DESTDIR=$RPM_BUILD_ROOT \
392 V=1
539b540f 393
544421b2
ER
394cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
395cp -a libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
396cp -a libavutil/bswap.h $RPM_BUILD_ROOT%{_includedir}/libavutil
397cp -a libavutil/common.h $RPM_BUILD_ROOT%{_includedir}/libavutil
398cp -a libavutil/mem.h $RPM_BUILD_ROOT%{_includedir}/libavutil
399for a in libavutil/*/bswap.h; do
400 install -D $a $RPM_BUILD_ROOT%{_includedir}/$a
401done
9d4f8977
ER
402cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
403cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
404# for lim-omx ffmpeg components
405cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 406
b8c60172
ER
407install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
408cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
409cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 410mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 411install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 412
2b2445b7
ER
413# install as ffmpeg-avconfig to avoid with possible programs looking for
414# ffmpeg-config and expecting --libs output from it which is not implemented
415# simple to do (by querying pkgconfig), but why?
b8c60172 416install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 417
9fc4ad22
AM
418%clean
419rm -rf $RPM_BUILD_ROOT
420
1ef27ea1
JB
421%post libs -p /sbin/ldconfig
422%postun libs -p /sbin/ldconfig
539b540f 423
38cf6de3
ER
424%pre ffserver
425%groupadd -g 167 ffserver
426%useradd -g ffserver -u 167 ffserver
427
593d3a64
ER
428%post ffserver
429/sbin/chkconfig --add ffserver
430%service ffserver restart
431
38cf6de3 432%preun ffserver
593d3a64
ER
433if [ "$1" = 0 ]; then
434 %service ffserver stop
435 /sbin/chkconfig --del ffserver
436fi
437
38cf6de3
ER
438%postun ffserver
439if [ "$1" = 0 ]; then
440 %userremove ffserver
441 %groupremove ffserver
442fi
443
9fc4ad22
AM
444%files
445%defattr(644,root,root,755)
660918c5 446%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
2a60eebe 447%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 448%attr(755,root,root) %{_bindir}/ffprobe
b7313442 449%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
450%dir %{_datadir}/ffmpeg
451%{_datadir}/ffmpeg/*.ffpreset
714dcf83 452%{_datadir}/ffmpeg/ffprobe.xsd
64f8f109
ER
453%{?with_doc:%{_mandir}/man1/ffmpeg.1*}
454%{?with_doc:%{_mandir}/man1/ffprobe.1*}
54ec280e
PG
455
456%files libs
457%defattr(644,root,root,755)
f50f7d7c 458%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
5663f846 459%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
d0a0ec26 460%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
5663f846 461%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
314ef0df 462%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
cbdd2688 463%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.2
f50f7d7c 464%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
5663f846
JB
465%attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
466%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
467%attr(755,root,root) %ghost %{_libdir}/libavresample.so.0
f50f7d7c 468%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
cbdd2688 469%attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
d7493de8 470%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 471%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
472%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
473%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 474%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 475%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 476
539b540f
JB
477%files devel
478%defattr(644,root,root,755)
54ec280e 479%doc doc/optimization.txt
1ef27ea1 480%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 481%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 482%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 483%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 484%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 485%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 486%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 487%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 488%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 489%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 490%{_includedir}/ffmpeg
6382c99d
AM
491%{_includedir}/libavcodec
492%{_includedir}/libavdevice
314ef0df 493%{_includedir}/libavfilter
6382c99d 494%{_includedir}/libavformat
5663f846 495%{_includedir}/libavresample
6382c99d
AM
496%{_includedir}/libavutil
497%{_includedir}/libpostproc
660918c5 498%{_includedir}/libswresample
6382c99d 499%{_includedir}/libswscale
1ef27ea1
JB
500%{_pkgconfigdir}/libavcodec.pc
501%{_pkgconfigdir}/libavdevice.pc
502%{_pkgconfigdir}/libavfilter.pc
503%{_pkgconfigdir}/libavformat.pc
5663f846 504%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
505%{_pkgconfigdir}/libavutil.pc
506%{_pkgconfigdir}/libpostproc.pc
660918c5 507%{_pkgconfigdir}/libswresample.pc
1ef27ea1 508%{_pkgconfigdir}/libswscale.pc
539b540f 509
9cf4d8a4
JB
510%files static
511%defattr(644,root,root,755)
1ef27ea1
JB
512%{_libdir}/libavcodec.a
513%{_libdir}/libavdevice.a
514%{_libdir}/libavfilter.a
515%{_libdir}/libavformat.a
5663f846 516%{_libdir}/libavresample.a
1ef27ea1
JB
517%{_libdir}/libavutil.a
518%{_libdir}/libpostproc.a
660918c5 519%{_libdir}/libswresample.a
1ef27ea1 520%{_libdir}/libswscale.a
af49d6ab
JB
521
522%files ffplay
523%defattr(644,root,root,755)
524%attr(755,root,root) %{_bindir}/ffplay
64f8f109 525%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 526
fde29260
ER
527%files ffserver
528%defattr(644,root,root,755)
529%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
530%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
531%attr(755,root,root) %{_sbindir}/ffserver
532%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 533%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
534%dir %attr(770,root,ffserver) /var/cache/ffserver
535%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.145193 seconds and 4 git commands to generate.