]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- added x264 bcond
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
94447fde 1# TODO
cbdd2688 2# - is bug803 patch still needed? the code changed somehow
197f4211 3#
2b3b2117 4# Conditional build:
38cefaee 5%bcond_with nonfree # non free options of package (currently: faac)
294c9b1e 6%bcond_without autoreqdep # don't care about package name deps generated by rpm
d7a39558 7%bcond_without frei0r # build without frei0r video filtering
ea09f25d 8%bcond_without x264 # build without x264 encoder
1ef27ea1
JB
9%bcond_without va # VAAPI (Video Acceleration API)
10%bcond_without vpx # VP8, a high-quality video codec
11%bcond_without doc # don't build docs
314ef0df 12
cbdd2688
JB
13Summary: FFmpeg - a very fast video and audio converter
14Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 15Name: ffmpeg
66f9c0d7 16Version: 0.8.3
8fa30871 17Release: 1
9cf4d8a4 18# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
19# (postprocessing, some filters, x264, xavs, xvid, x11grab)
20# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 21License: GPL v3+ with LGPL v3+ parts
fde29260 22Group: Applications/Multimedia
1ef27ea1 23Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
66f9c0d7 24# Source0-md5: 556870ccfd6c9c0426c7dd86dd5beb62
fde29260
ER
25Source1: ffserver.init
26Source2: ffserver.sysconfig
38cf6de3 27Source3: ffserver.conf
0b43f655 28Patch0: %{name}-bug-803.patch
3a7b84be 29Patch1: %{name}-gsm.patch
85f7cea1 30URL: http://www.ffmpeg.org/
2a60eebe 31BuildRequires: SDL-devel
cbdd2688 32BuildRequires: alsa-lib-devel
38cefaee 33BuildRequires: bzip2-devel
cbdd2688 34BuildRequires: celt-devel
7ca51e4c 35BuildRequires: dirac-devel >= 1.0.0
38cefaee 36%{?with_nonfree:BuildRequires: faac-devel}
2a60eebe 37BuildRequires: freetype-devel
d7a39558 38%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
39%ifarch ppc
40# require version with altivec support fixed
41BuildRequires: gcc >= 5:3.3.2-3
42%endif
cbdd2688
JB
43BuildRequires: jack-audio-connection-kit-devel
44BuildRequires: lame-libs-devel >= 3.98.3
6382c99d 45BuildRequires: libdc1394-devel
f1669449 46BuildRequires: libgsm-devel
4a927f9d 47BuildRequires: libnut-devel
94447fde 48BuildRequires: libraw1394-devel
cbdd2688 49BuildRequires: librtmp-devel
9042663c 50BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 51BuildRequires: libtool >= 2:1.4d-3
64f8f109 52%{?with_va:BuildRequires: libva-devel >= 1.0.3}
0b43f655 53BuildRequires: libvdpau-devel
e380e18a 54BuildRequires: libvorbis-devel
065be88e 55%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.6}
d1ecc96e 56# X264_BUILD >= 83
ea09f25d 57%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20110625_2245}
0b43f655
AM
58BuildRequires: opencore-amr-devel
59BuildRequires: openjpeg-devel >= 1.3-2
17a2d1a8 60BuildRequires: speex-devel >= 1:1.2-rc1
e1fe03f7 61%ifarch %{ix86}
62%ifnarch i386 i486
76243dbd
JB
63BuildRequires: nasm
64%endif
e1fe03f7 65%endif
136f0f45 66BuildRequires: perl-Encode
1463656a 67BuildRequires: perl-tools-pod
ef3c0513 68BuildRequires: pkgconfig
db8052c8 69BuildRequires: rpmbuild(macros) >= 1.470
126fb805 70BuildRequires: schroedinger-devel
64f8f109
ER
71%{?with_doc:BuildRequires: tetex}
72%{?with_doc:BuildRequires: texi2html}
73%{?with_doc:BuildRequires: texinfo}
5dc039cb
JB
74BuildRequires: vo-aacenc-devel
75BuildRequires: vo-amrwbenc-devel
76BuildRequires: xavs-devel
cbdd2688
JB
77BuildRequires: xorg-lib-libXext-devel
78BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 79BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 80BuildRequires: zlib-devel
57ebb8ad 81%{?with_autoreqdep:BuildConflicts: libpostproc}
54ec280e 82Requires: %{name}-libs = %{version}-%{release}
839e806f 83Requires: xvid >= 1:1.1.0
af49d6ab 84Obsoletes: libpostproc
539b540f 85BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 86
2a60eebe
JB
87%define _noautoreqdep libGL.so.1 libGLU.so.1
88
c01d7857
PS
89%define specflags -fno-strict-aliasing
90
91# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
92%define specflags_ia32 -fomit-frame-pointer
93# -mmmx is needed to enable <mmintrin.h> code.
94%define specflags_i586 -mmmx
95%define specflags_i686 -mmmx
1162803a 96%define specflags_ppc -fPIC
c01d7857 97
9fc4ad22 98%description
85f7cea1
ER
99FFmpeg is a complete solution to record, convert and stream audio and
100video. It is a command line tool to convert one video file format to
101another. It also supports grabbing and encoding in real time from a TV
102card.
9fc4ad22 103
cdb7b42e 104%description -l pl.UTF-8
cbdd2688
JB
105FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
106strumieni dźwięku i obrazu. Jest to działające z linii poleceń
107narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
108także przechwytywanie i kodowanie w czasie rzeczywistym z karty
109telewizyjnej.
9fc4ad22 110
54ec280e
PG
111%package libs
112Summary: ffmpeg libraries
adcc0f76 113Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
114Group: Libraries
115
116%description libs
cbdd2688
JB
117This package contains the ffmpeg shared libraries:
118- the codec library (libavcodec). It supports most existing encoding
119 formats (MPEG, DivX, MPEG4, AC3, DV...),
120- demuxer library (libavformat). It supports most existing file
121 formats (AVI, MPEG, OGG, Matroska, ASF...),
122- video postprocessing library (libpostproc).
54ec280e 123
cdb7b42e 124%description libs -l pl.UTF-8
cbdd2688
JB
125Ten pakiet zawiera biblioteki współdzielone ffmpeg:
126- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
127 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
128- bibliotekę demuksera (libavformat); obsługuje większość istniejących
129 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
130- bibliotekę postprocessingu (libpostproc).
54ec280e 131
af49d6ab
JB
132%package devel
133Summary: ffmpeg header files
adcc0f76 134Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 135Group: Development/Libraries
54ec280e 136Requires: %{name}-libs = %{version}-%{release}
38cefaee
JB
137# Libs.private from *.pc (unreasonably they are all the same)
138Requires: SDL-devel
139Requires: alsa-lib-devel
140Requires: bzip2-devel
141Requires: celt-devel
142Requires: dirac-devel >= 1.0.0
143%{?with_nonfree:Requires: faac-devel}
144Requires: jack-audio-connection-kit-devel
145Requires: lame-libs-devel >= 3.98.3
146Requires: libdc1394-devel
bf479bc6 147Requires: libgsm-devel
4a927f9d 148Requires: libnut-devel
95e2cf29 149Requires: libraw1394-devel
38cefaee
JB
150Requires: librtmp-devel
151Requires: libtheora-devel >= 1.0-0.beta3
152%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 153Requires: libvorbis-devel
38cefaee 154%{?with_vpx:Requires: libvpx-devel >= 0.9.6}
ea09f25d 155%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee
JB
156Requires: opencore-amr-devel
157Requires: openjpeg-devel >= 1.3-2
158Requires: schroedinger-devel
159Requires: speex-devel >= 1:1.2-rc1
160Requires: vo-aacenc-devel
161Requires: vo-amrwbenc-devel
162Requires: xavs-devel
163Requires: xorg-lib-libXext-devel
164Requires: xorg-lib-libXfixes-devel
46f2a56b 165Requires: xvid-devel >= 1:1.1.0
33a1c0f3 166Requires: zlib-devel
8152d6a2 167Obsoletes: libpostproc-devel
af49d6ab
JB
168
169%description devel
170ffmpeg header files.
171
cdb7b42e
JR
172%description devel -l pl.UTF-8
173Pliki nagłówkowe ffmpeg.
af49d6ab
JB
174
175%package static
176Summary: ffmpeg static libraries
adcc0f76 177Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
178Group: Development/Libraries
179Requires: %{name}-devel = %{version}-%{release}
180
181%description static
182ffmpeg static libraries (libavcodec and libavformat).
183
cdb7b42e 184%description static -l pl.UTF-8
af49d6ab
JB
185Statyczne biblioteki ffmpeg (libavcodec i libavformat).
186
2a60eebe
JB
187%package ffplay
188Summary: FFplay - SDL-based media player
adcc0f76 189Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 190Group: Applications/Multimedia
54ec280e 191Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
192
193%description ffplay
194FFplay is a very simple and portable media player using the FFmpeg
195libraries and the SDL library. It is mostly used as a test bench for
196the various APIs of FFmpeg.
197
cdb7b42e
JR
198%description ffplay -l pl.UTF-8
199FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
200bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
201testowania różnych API FFmpeg.
2a60eebe 202
fde29260
ER
203%package ffserver
204Summary: FFserver video server
adcc0f76 205Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 206Group: Daemons
593d3a64 207Requires(post,preun): /sbin/chkconfig
67103923 208Requires: %{name}-libs = %{version}-%{release}
2305d791 209Requires: rc-scripts >= 0.4.0.10
fde29260
ER
210
211%description ffserver
212FFserver is a streaming server for both audio and video. It supports
213several live feeds, streaming from files and time shifting on live
214feeds (you can seek to positions in the past on each live feed,
215provided you specify a big enough feed storage in ffserver.conf).
216
cdb7b42e
JR
217%description ffserver -l pl.UTF-8
218FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
219źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
220czasie dla źródeł na żywo (można przeskakiwać na położenia w
221przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
222dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 223
9fc4ad22 224%prep
aed8e8c9 225%setup -q
f1669449 226%patch0 -p1
3a7b84be 227%patch1 -p0
9fc4ad22 228
9d4f8977
ER
229# package the grep result for mplayer, the result formatted as ./mplayer/configure
230cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
231#! /bin/sh
232_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
233_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
234_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
235_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
236_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
237_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
238_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
239EOF
9d4f8977 240cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
241
242case "$1" in
243--decoders)
244 echo $_libavdecoders_all
245 ;;
246--encoders)
247 echo $_libavencoders_all
248 ;;
249--parsers)
250 echo $_libavparsers_all
251 ;;
252--bsfs)
253 echo $_libavbsfs_all
254 ;;
255--demuxers)
256 echo $_libavdemuxers_all
257 ;;
258--muxers)
259 echo $_libavmuxers_all
260 ;;
261--protocols)
262 echo $_libavprotocols_all
263 ;;
264*)
265 cat <<USAGE
266Usage: $0 [OPTION]
267Options:
268 --decoders
269 --encoders
270 --parsers
271 --bsfs
272 --demuxers
273 --muxers
274 --protocols
275USAGE
276 exit 1;;
277esac
278
279exit 0
280EOF
281
9fc4ad22 282%build
05e1eb2f
JB
283# notes:
284# - it's not autoconf configure
d0a0ec26 285# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 286./configure \
b4680d0b 287 --arch=%{_target_base_arch} \
539b540f 288 --prefix=%{_prefix} \
9cf4d8a4 289 --libdir=%{_libdir} \
d81dfa95 290 --shlibdir=%{_libdir} \
2a60eebe 291 --mandir=%{_mandir} \
126fb805 292 --cc="%{__cc}" \
314ef0df 293 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 294 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
126fb805
JB
295 --disable-debug \
296 --disable-optimizations \
6382c99d 297 --disable-stripping \
314ef0df 298 --enable-avfilter \
126fb805 299 --enable-gpl \
0b43f655 300 --enable-version3 \
d7a39558 301 %{?with_frei0r:--enable-frei0r} \
32243b76 302 --enable-libdc1394 \
cbdd2688 303 --enable-libcelt \
32243b76 304 --enable-libdirac \
f3692243 305 --enable-libgsm \
15c15700 306 --enable-libmp3lame \
4a927f9d 307 --enable-libnut \
cbdd2688
JB
308 --enable-libopencore-amrnb \
309 --enable-libopencore-amrwb \
310 --enable-libopenjpeg \
311 --enable-librtmp \
126fb805 312 --enable-libschroedinger \
da99dcf2 313 --enable-libspeex \
126fb805 314 --enable-libtheora \
5dc039cb
JB
315 --enable-libvo-aacenc \
316 --enable-libvo-amrwbenc \
126fb805 317 --enable-libvorbis \
64f8f109 318 %{?with_vpx:--enable-libvpx} \
ea09f25d 319 %{?with_x264:--enable-libx264} \
5dc039cb 320 --enable-libxavs \
126fb805 321 --enable-libxvid \
6382c99d 322 --enable-postproc \
d7493de8 323 --enable-pthreads \
9cf4d8a4 324 --enable-shared \
6382c99d 325 --enable-swscale \
0b43f655 326 --enable-vdpau \
75231f25 327 --enable-x11grab \
7a286645 328%ifnarch %{ix86} %{x8664}
e1fe03f7 329 --disable-mmx \
330%endif
331%ifarch i386 i486
05e1eb2f 332 --disable-mmx \
b524cd99 333%endif
0b43f655 334%if %{with nonfree}
48610c64 335 --enable-nonfree \
0b43f655 336 --enable-libfaac \
76243dbd 337%endif
75231f25 338 --enable-runtime-cpudetect
2305d791 339
cbdd2688
JB
340# --enable-libopencv would cause dependency loop
341
da99dcf2 342# force oldscaler build
b8c60172 343%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 344
1ef27ea1
JB
345%{__make} \
346 V=1
9fc4ad22 347
b8c60172
ER
348# CC_O to add -c to commandline. makefile should be patched
349%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
350
9fc4ad22
AM
351%install
352rm -rf $RPM_BUILD_ROOT
38cf6de3 353install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 354 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 355 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 356
539b540f 357%{__make} install \
1ef27ea1
JB
358 DESTDIR=$RPM_BUILD_ROOT \
359 V=1
539b540f 360
544421b2
ER
361cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
362cp -a libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
363cp -a libavutil/bswap.h $RPM_BUILD_ROOT%{_includedir}/libavutil
364cp -a libavutil/common.h $RPM_BUILD_ROOT%{_includedir}/libavutil
365cp -a libavutil/mem.h $RPM_BUILD_ROOT%{_includedir}/libavutil
366for a in libavutil/*/bswap.h; do
367 install -D $a $RPM_BUILD_ROOT%{_includedir}/$a
368done
9d4f8977
ER
369cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
370cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
544421b2 371
b8c60172
ER
372install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
373cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
374cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 375mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 376install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 377
2b2445b7
ER
378# install as ffmpeg-avconfig to avoid with possible programs looking for
379# ffmpeg-config and expecting --libs output from it which is not implemented
380# simple to do (by querying pkgconfig), but why?
b8c60172 381install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 382
9fc4ad22
AM
383%clean
384rm -rf $RPM_BUILD_ROOT
385
1ef27ea1
JB
386%post libs -p /sbin/ldconfig
387%postun libs -p /sbin/ldconfig
539b540f 388
38cf6de3
ER
389%pre ffserver
390%groupadd -g 167 ffserver
391%useradd -g ffserver -u 167 ffserver
392
593d3a64
ER
393%post ffserver
394/sbin/chkconfig --add ffserver
395%service ffserver restart
396
38cf6de3 397%preun ffserver
593d3a64
ER
398if [ "$1" = 0 ]; then
399 %service ffserver stop
400 /sbin/chkconfig --del ffserver
401fi
402
38cf6de3
ER
403%postun ffserver
404if [ "$1" = 0 ]; then
405 %userremove ffserver
406 %groupremove ffserver
407fi
408
9fc4ad22
AM
409%files
410%defattr(644,root,root,755)
cbdd2688 411%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES,TODO} %{?with_doc:doc/*.html}
2a60eebe 412%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 413%attr(755,root,root) %{_bindir}/ffprobe
b7313442 414%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
415%dir %{_datadir}/ffmpeg
416%{_datadir}/ffmpeg/*.ffpreset
64f8f109
ER
417%{?with_doc:%{_mandir}/man1/ffmpeg.1*}
418%{?with_doc:%{_mandir}/man1/ffprobe.1*}
54ec280e
PG
419
420%files libs
421%defattr(644,root,root,755)
f50f7d7c 422%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
cbdd2688 423%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.53
d0a0ec26 424%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
cbdd2688 425%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.53
314ef0df 426%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
cbdd2688 427%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.2
f50f7d7c 428%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
cbdd2688 429%attr(755,root,root) %ghost %{_libdir}/libavformat.so.53
f50f7d7c 430%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
cbdd2688 431%attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
d7493de8 432%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
314ef0df 433%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.51
ee032235 434%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 435%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 436
539b540f
JB
437%files devel
438%defattr(644,root,root,755)
54ec280e 439%doc doc/optimization.txt
1ef27ea1 440%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 441%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 442%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 443%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 444%attr(755,root,root) %{_libdir}/libavformat.so
d7493de8 445%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 446%attr(755,root,root) %{_libdir}/libpostproc.so
ee032235 447%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 448%{_includedir}/ffmpeg
6382c99d
AM
449%{_includedir}/libavcodec
450%{_includedir}/libavdevice
314ef0df 451%{_includedir}/libavfilter
6382c99d
AM
452%{_includedir}/libavformat
453%{_includedir}/libavutil
454%{_includedir}/libpostproc
455%{_includedir}/libswscale
1ef27ea1
JB
456%{_pkgconfigdir}/libavcodec.pc
457%{_pkgconfigdir}/libavdevice.pc
458%{_pkgconfigdir}/libavfilter.pc
459%{_pkgconfigdir}/libavformat.pc
460%{_pkgconfigdir}/libavutil.pc
461%{_pkgconfigdir}/libpostproc.pc
462%{_pkgconfigdir}/libswscale.pc
539b540f 463
9cf4d8a4
JB
464%files static
465%defattr(644,root,root,755)
1ef27ea1
JB
466%{_libdir}/libavcodec.a
467%{_libdir}/libavdevice.a
468%{_libdir}/libavfilter.a
469%{_libdir}/libavformat.a
470%{_libdir}/libavutil.a
471%{_libdir}/libpostproc.a
472%{_libdir}/libswscale.a
af49d6ab
JB
473
474%files ffplay
475%defattr(644,root,root,755)
476%attr(755,root,root) %{_bindir}/ffplay
64f8f109 477%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 478
fde29260
ER
479%files ffserver
480%defattr(644,root,root,755)
481%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
482%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
483%attr(755,root,root) %{_sbindir}/ffserver
484%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 485%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
486%dir %attr(770,root,ffserver) /var/cache/ffserver
487%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.141195 seconds and 4 git commands to generate.