]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- -devel R: libx264-devel now
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
8152d6a2
JB
1#
2# TODO: only lzo 1.x is supported
3f3f0ec8 3# - make (ffmpeg code inside) mplayer play .3gp mobile phone movies
f68a4dcc 4# (ffplay and vlc plays them fine
8152d6a2 5#
2b3b2117 6# Conditional build:
8152d6a2 7%bcond_without imlib2 # don't build imlib2 vhook module
c2a62dca 8%bcond_without autoreqdep # don't care about package name deps generated by rpm
3534e1ea 9%bcond_without amr # don't build 3GPP Adaptive Multi Rate (AMR) speech codec
874f67c9 10#
76243dbd
JB
11Summary: Realtime audio/video encoder and streaming server
12Summary(pl): Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
9fc4ad22 13Name: ffmpeg
c32b589f 14Version: 0.4.9
3534e1ea
PS
15%define snap 20060129
16%define _rel 9
839e806f 17Release: 3.%{snap}.%{_rel}
9cf4d8a4 18# LGPL or GPL, chosen at configure time (GPL version is more featured)
f68a4dcc 19#
20# (BTW. what are the 'more' features mentioned above?)
21#
22# Some parts of the code *is* LGPL (for example libavformat amr.c) so
23# it is possible to include /and distribute/ external 3GPP AMR codecs
24# (some kind of public domain with patent restrictions) to the
25# GPL-licensed stuff /and keep GPL license/.
26%if %{with amr}
27License: GPL with LGPL/Public Domain parts
28%else
29License: GPL with LGPL parts
30%endif
fde29260 31Group: Applications/Multimedia
d7493de8 32#Source0: http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
f50f7d7c
JB
33#Source0: ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
34Source0: %{name}-%{snap}.tar.bz2
35# Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
fde29260
ER
36Source1: ffserver.init
37Source2: ffserver.sysconfig
38cf6de3 38Source3: ffserver.conf
b524cd99 39%if %{with amr}
40# AMR WB FLOAT
41#Source4: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26204-600.zip
b524cd99 42Source4: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26204-530.zip
43# Source4-md5: 988060bdb18b5d64b8bd82c3507d2420
b524cd99 44# AMR NB FLOAT
45#Source6: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26104-610.zip
46Source6: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26104-540.zip
47# Source6-md5: 4dcbeb2bc28bf86e7131fe4cae3e0dec
48%endif
49
d7493de8
JB
50Patch0: %{name}-libtool.patch
51Patch1: %{name}-libdir.patch
7a286645 52Patch2: %{name}-gcc4.patch
bb062d35 53URL: http://ffmpeg.sourceforge.net/
2a60eebe 54BuildRequires: SDL-devel
e380e18a 55BuildRequires: faac-devel
b959c224 56BuildRequires: faad2-devel
2a60eebe 57BuildRequires: freetype-devel
4bee03f0
JB
58%ifarch ppc
59# require version with altivec support fixed
60BuildRequires: gcc >= 5:3.3.2-3
61%endif
8a764e4b 62%{?with_imlib2:BuildRequires: imlib2-devel >= 1.1.0-2}
e380e18a 63BuildRequires: lame-libs-devel
b959c224 64BuildRequires: libdts-devel
f3692243 65BuildRequires: libgsm-devel
d7493de8 66BuildRequires: libtheora-devel
4814ac84 67BuildRequires: libtool >= 2:1.4d-3
e380e18a 68BuildRequires: libvorbis-devel
8b2a8e66 69BuildRequires: libx264-devel >= 0.1.2-1.20060430_2245.1
3f3f0ec8 70BuildRequires: lzo-devel < 2.0
e1fe03f7 71%ifarch %{ix86}
72%ifnarch i386 i486
76243dbd
JB
73BuildRequires: nasm
74%endif
e1fe03f7 75%endif
1463656a 76BuildRequires: perl-tools-pod
593d3a64 77BuildRequires: rpmbuild(macros) >= 1.268
1463656a 78BuildRequires: tetex
9cf4d8a4 79BuildRequires: texinfo
872de59d 80%{?with_amr:BuildRequires: unzip}
46f2a56b 81BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 82BuildRequires: zlib-devel
57ebb8ad 83%{?with_autoreqdep:BuildConflicts: libpostproc}
54ec280e 84Requires: %{name}-libs = %{version}-%{release}
839e806f 85Requires: xvid >= 1:1.1.0
af49d6ab 86Obsoletes: libpostproc
539b540f 87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 88
2a60eebe
JB
89%define _noautoreqdep libGL.so.1 libGLU.so.1
90
c01d7857
PS
91%define specflags -fno-strict-aliasing
92
93# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
94%define specflags_ia32 -fomit-frame-pointer
95# -mmmx is needed to enable <mmintrin.h> code.
96%define specflags_i586 -mmmx
97%define specflags_i686 -mmmx
98
9fc4ad22
AM
99%description
100ffmpeg is a hyper fast realtime audio/video encoder and streaming
101server. It can grab from a standard Video4Linux video source and
102convert it into several file formats based on DCT/motion compensation
103encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
fda3e16d 104compatible stream.
9fc4ad22
AM
105
106%description -l pl
fda3e16d 107ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
108