]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- src files cleanup (amr stuff)
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
8152d6a2
JB
1#
2# TODO: only lzo 1.x is supported
f68a4dcc 3# - make (ffmpeg code inside) mplayer play .3gp mobile phone movies
4# (ffplay and vlc plays them fine
b524cd99 5# - revert amr bcond when done
8152d6a2 6#
2b3b2117 7# Conditional build:
8152d6a2 8%bcond_without imlib2 # don't build imlib2 vhook module
c2a62dca 9%bcond_without autoreqdep # don't care about package name deps generated by rpm
b524cd99 10%bcond_with amr # build with 3GPP Adaptive Multi Rate (AMR) speech codec
874f67c9 11#
839e806f 12%define snap 20060129
f68a4dcc 13%define _rel 8.8
76243dbd
JB
14Summary: Realtime audio/video encoder and streaming server
15Summary(pl): Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
9fc4ad22 16Name: ffmpeg
c32b589f 17Version: 0.4.9
839e806f 18Release: 3.%{snap}.%{_rel}
9cf4d8a4 19# LGPL or GPL, chosen at configure time (GPL version is more featured)
f68a4dcc 20#
21# (BTW. what are the 'more' features mentioned above?)
22#
23# Some parts of the code *is* LGPL (for example libavformat amr.c) so
24# it is possible to include /and distribute/ external 3GPP AMR codecs
25# (some kind of public domain with patent restrictions) to the
26# GPL-licensed stuff /and keep GPL license/.
27%if %{with amr}
28License: GPL with LGPL/Public Domain parts
29%else
30License: GPL with LGPL parts
31%endif
fde29260 32Group: Applications/Multimedia
d7493de8 33#Source0: http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
f50f7d7c
JB
34#Source0: ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
35Source0: %{name}-%{snap}.tar.bz2
36# Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
fde29260
ER
37Source1: ffserver.init
38Source2: ffserver.sysconfig
38cf6de3 39Source3: ffserver.conf
b524cd99 40%if %{with amr}
41# AMR WB FLOAT
42#Source4: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26204-600.zip
b524cd99 43Source4: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26204-530.zip
44# Source4-md5: 988060bdb18b5d64b8bd82c3507d2420
b524cd99 45# AMR NB FLOAT
46#Source6: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26104-610.zip
47Source6: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26104-540.zip
48# Source6-md5: 4dcbeb2bc28bf86e7131fe4cae3e0dec
49%endif
50
d7493de8
JB
51Patch0: %{name}-libtool.patch
52Patch1: %{name}-libdir.patch
7a286645 53Patch2: %{name}-gcc4.patch
bb062d35 54URL: http://ffmpeg.sourceforge.net/
2a60eebe 55BuildRequires: SDL-devel
e380e18a 56BuildRequires: faac-devel
b959c224 57BuildRequires: faad2-devel
2a60eebe 58BuildRequires: freetype-devel
4bee03f0
JB
59%ifarch ppc
60# require version with altivec support fixed
61BuildRequires: gcc >= 5:3.3.2-3
62%endif
8a764e4b 63%{?with_imlib2:BuildRequires: imlib2-devel >= 1.1.0-2}
e380e18a 64BuildRequires: lame-libs-devel
b959c224 65BuildRequires: libdts-devel
f3692243 66BuildRequires: libgsm-devel
d7493de8 67BuildRequires: libtheora-devel
4814ac84 68BuildRequires: libtool >= 2:1.4d-3
e380e18a 69BuildRequires: libvorbis-devel
839e806f 70#BuildRequires: libx264-devel
22fb3118 71BuildRequires: lzo-devel
e1fe03f7 72%ifarch %{ix86}
73%ifnarch i386 i486
76243dbd
JB
74BuildRequires: nasm
75%endif
e1fe03f7 76%endif
1463656a 77BuildRequires: perl-tools-pod
593d3a64 78BuildRequires: rpmbuild(macros) >= 1.268
1463656a 79BuildRequires: tetex
9cf4d8a4 80BuildRequires: texinfo
46f2a56b 81BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 82BuildRequires: zlib-devel
57ebb8ad 83%{?with_autoreqdep:BuildConflicts: libpostproc}
54ec280e 84Requires: %{name}-libs = %{version}-%{release}
839e806f 85Requires: xvid >= 1:1.1.0
af49d6ab 86Obsoletes: libpostproc
539b540f 87BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 88
2a60eebe
JB
89%define _noautoreqdep libGL.so.1 libGLU.so.1
90
c01d7857
PS
91%define specflags -fno-strict-aliasing
92
93# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
94%define specflags_ia32 -fomit-frame-pointer
95# -mmmx is needed to enable <mmintrin.h> code.
96%define specflags_i586 -mmmx
97%define specflags_i686 -mmmx
98
9fc4ad22
AM
99%description
100ffmpeg is a hyper fast realtime audio/video encoder and streaming
101server. It can grab from a standard Video4Linux video source and
102convert it into several file formats based on DCT/motion compensation
103encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
fda3e16d 104compatible stream.
9fc4ad22
AM
105
106%description -l pl
fda3e16d 107ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
108