]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- orphaned, outdated
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
8152d6a2
JB
1#
2# TODO: only lzo 1.x is supported
b524cd99 3# - cleanup 3GPP AMR stuff (we probably do not need amr nb fixed point
4# source)
5# - make mplayer play .3gp mobile phone movies (ffplay plays them, but
6# mplayer do not see libavcodec amr_nb provided codec - probably some
7# mplayer conf will do the job)
8# - revert amr bcond when done
8152d6a2 9#
2b3b2117 10# Conditional build:
8152d6a2 11%bcond_without imlib2 # don't build imlib2 vhook module
c2a62dca 12%bcond_without autoreqdep # don't care about package name deps generated by rpm
b524cd99 13%bcond_with amr # build with 3GPP Adaptive Multi Rate (AMR) speech codec
874f67c9 14#
839e806f 15%define snap 20060129
67103923 16%define _rel 8.7
76243dbd
JB
17Summary: Realtime audio/video encoder and streaming server
18Summary(pl): Koder audio/wideo czasu rzeczywistego oraz serwer strumieni
9fc4ad22 19Name: ffmpeg
c32b589f 20Version: 0.4.9
839e806f 21Release: 3.%{snap}.%{_rel}
9cf4d8a4
JB
22# LGPL or GPL, chosen at configure time (GPL version is more featured)
23License: GPL
fde29260 24Group: Applications/Multimedia
d7493de8 25#Source0: http://dl.sourceforge.net/ffmpeg/%{name}-%{version}-pre1.tar.gz
f50f7d7c
JB
26#Source0: ftp://ftp2.mplayerhq.hu/MPlayer/cvs/FFMpeg-%{snap}.tar.bz2
27Source0: %{name}-%{snap}.tar.bz2
28# Source0-md5: d8ea09431d6c0c91bfd35e0ca74a67e1
fde29260
ER
29Source1: ffserver.init
30Source2: ffserver.sysconfig
38cf6de3 31Source3: ffserver.conf
b524cd99 32%if %{with amr}
33# AMR WB FLOAT
34#Source4: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26204-600.zip
35#Source4: http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/26204-510.zip
36Source4: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26204-530.zip
37# Source4-md5: 988060bdb18b5d64b8bd82c3507d2420
38# AMR NB FIXED POINT
39#Source5: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26073-600.zip
40Source5: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26073-530.zip
41# Source5-md5: 705f6993fbf890e92eb7a331e7c716d1
42# AMR NB FLOAT
43#Source6: http://www.3gpp.org/ftp/Specs/latest/Rel-6/26_series/26104-610.zip
44Source6: http://www.3gpp.org/ftp/Specs/latest/Rel-5/26_series/26104-540.zip
45# Source6-md5: 4dcbeb2bc28bf86e7131fe4cae3e0dec
46%endif
47
d7493de8
JB
48Patch0: %{name}-libtool.patch
49Patch1: %{name}-libdir.patch
7a286645 50Patch2: %{name}-gcc4.patch
bb062d35 51URL: http://ffmpeg.sourceforge.net/
2a60eebe 52BuildRequires: SDL-devel
e380e18a 53BuildRequires: faac-devel
b959c224 54BuildRequires: faad2-devel
2a60eebe 55BuildRequires: freetype-devel
4bee03f0
JB
56%ifarch ppc
57# require version with altivec support fixed
58BuildRequires: gcc >= 5:3.3.2-3
59%endif
8a764e4b 60%{?with_imlib2:BuildRequires: imlib2-devel >= 1.1.0-2}
e380e18a 61BuildRequires: lame-libs-devel
b959c224 62BuildRequires: libdts-devel
f3692243 63BuildRequires: libgsm-devel
d7493de8 64BuildRequires: libtheora-devel
4814ac84 65BuildRequires: libtool >= 2:1.4d-3
e380e18a 66BuildRequires: libvorbis-devel
839e806f 67#BuildRequires: libx264-devel
22fb3118 68BuildRequires: lzo-devel
e1fe03f7 69%ifarch %{ix86}
70%ifnarch i386 i486
76243dbd
JB
71BuildRequires: nasm
72%endif
e1fe03f7 73%endif
1463656a 74BuildRequires: perl-tools-pod
593d3a64 75BuildRequires: rpmbuild(macros) >= 1.268
1463656a 76BuildRequires: tetex
9cf4d8a4 77BuildRequires: texinfo
46f2a56b 78BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 79BuildRequires: zlib-devel
57ebb8ad 80%{?with_autoreqdep:BuildConflicts: libpostproc}
54ec280e 81Requires: %{name}-libs = %{version}-%{release}
839e806f 82Requires: xvid >= 1:1.1.0
af49d6ab 83Obsoletes: libpostproc
539b540f 84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 85
2a60eebe
JB
86%define _noautoreqdep libGL.so.1 libGLU.so.1
87
c01d7857
PS
88%define specflags -fno-strict-aliasing
89
90# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
91%define specflags_ia32 -fomit-frame-pointer
92# -mmmx is needed to enable <mmintrin.h> code.
93%define specflags_i586 -mmmx
94%define specflags_i686 -mmmx
95
9fc4ad22
AM
96%description
97ffmpeg is a hyper fast realtime audio/video encoder and streaming
98server. It can grab from a standard Video4Linux video source and
99convert it into several file formats based on DCT/motion compensation
100encoding. Sound is compressed in MPEG audio layer 2 or using an AC3
fda3e16d 101compatible stream.
9fc4ad22
AM
102
103%description -l pl
fda3e16d 104ffmpeg jest bardzo szybkim koderem audio/wideo w czasie rzeczywistym
105