]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- unify
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
197f4211 1#
5663f846
JB
2# How to deal with ffmpeg/opencv checken-egg problem:
3# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 4# 2. make-request -r opencv.spec
5# 3. bump release of ffmpeg.spec
6# 4. make-request -r ffmpeg.spec
7#
2b3b2117 8# Conditional build:
38cefaee 9%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 10%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
294c9b1e 11%bcond_without autoreqdep # don't care about package name deps generated by rpm
d7a39558 12%bcond_without frei0r # build without frei0r video filtering
d5aef92e 13%bcond_without openal # build without OpenAL 1.1 capture support
192f9f57 14%bcond_without opencv # build without opencv video filtering
d5aef92e 15%bcond_without pulseaudio # build without PulseAudio input support
ea09f25d 16%bcond_without x264 # build without x264 encoder
daf9a670 17%bcond_without utvideo # build without Ut Video decoder
1ef27ea1
JB
18%bcond_without va # VAAPI (Video Acceleration API)
19%bcond_without vpx # VP8, a high-quality video codec
20%bcond_without doc # don't build docs
314ef0df 21
cbdd2688
JB
22Summary: FFmpeg - a very fast video and audio converter
23Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 24Name: ffmpeg
0797daec 25Version: 0.11.1
3eef5ddf 26Release: 3
9cf4d8a4 27# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
28# (postprocessing, some filters, x264, xavs, xvid, x11grab)
29# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 30License: GPL v3+ with LGPL v3+ parts
fde29260 31Group: Applications/Multimedia
1ef27ea1 32Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
0797daec 33# Source0-md5: ff8cb914f657e164dd60ea1008b555a8
fde29260
ER
34Source1: ffserver.init
35Source2: ffserver.sysconfig
38cf6de3 36Source3: ffserver.conf
5663f846 37Patch0: %{name}-gsm.patch
3eef5ddf 38Patch1: %{name}-opencv24.patch
85f7cea1 39URL: http://www.ffmpeg.org/
d5aef92e 40%{?with_openal:BuildRequires: OpenAL-devel}
3dcb8642 41BuildRequires: SDL-devel >= 1.2.1
cbdd2688 42BuildRequires: alsa-lib-devel
38cefaee 43BuildRequires: bzip2-devel
9f9ba8ac 44BuildRequires: celt-devel >= 0.11.0
38cefaee 45%{?with_nonfree:BuildRequires: faac-devel}
3dcb8642 46BuildRequires: fontconfig-devel
2a60eebe 47BuildRequires: freetype-devel
d7a39558 48%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
49%ifarch ppc
50# require version with altivec support fixed
51BuildRequires: gcc >= 5:3.3.2-3
52%endif
d5aef92e 53BuildRequires: gnutls-devel
cbdd2688
JB
54BuildRequires: jack-audio-connection-kit-devel
55BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 56%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 57BuildRequires: libass-devel
3dcb8642 58BuildRequires: libbluray-devel
d5aef92e 59BuildRequires: libcdio-devel
9c4296c2 60BuildRequires: libdc1394-devel >= 2
f1669449 61BuildRequires: libgsm-devel
d5aef92e 62BuildRequires: libmodplug-devel
4a927f9d 63BuildRequires: libnut-devel
7571bfa0 64BuildRequires: libraw1394-devel >= 2
cbdd2688 65BuildRequires: librtmp-devel
9042663c 66BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 67BuildRequires: libtool >= 2:1.4d-3
daf9a670 68BuildRequires: libv4l-devel
64f8f109 69%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 70BuildRequires: libvdpau-devel >= 0.2
e380e18a 71BuildRequires: libvorbis-devel
065be88e 72%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.6}
660918c5
AM
73# X264_BUILD >= 118
74%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
0b43f655 75BuildRequires: opencore-amr-devel
192f9f57 76%{?with_opencv:BuildRequires: opencv-devel}
0b43f655 77BuildRequires: openjpeg-devel >= 1.3-2
d5aef92e 78%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
17a2d1a8 79BuildRequires: speex-devel >= 1:1.2-rc1
e1fe03f7 80%ifarch %{ix86}
81%ifnarch i386 i486
76243dbd
JB
82BuildRequires: nasm
83%endif
e1fe03f7 84%endif
136f0f45 85BuildRequires: perl-Encode
1463656a 86BuildRequires: perl-tools-pod
ef3c0513 87BuildRequires: pkgconfig
db8052c8 88BuildRequires: rpmbuild(macros) >= 1.470
126fb805 89BuildRequires: schroedinger-devel
64f8f109
ER
90%{?with_doc:BuildRequires: tetex}
91%{?with_doc:BuildRequires: texi2html}
92%{?with_doc:BuildRequires: texinfo}
daf9a670 93%{?with_utvideo:BuildRequires: utvideo-devel}
986e22a5 94BuildRequires: yasm
5dc039cb
JB
95BuildRequires: vo-aacenc-devel
96BuildRequires: vo-amrwbenc-devel
97BuildRequires: xavs-devel
cbdd2688
JB
98BuildRequires: xorg-lib-libXext-devel
99BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 100BuildRequires: xvid-devel >= 1:1.1.0
33a1c0f3 101BuildRequires: zlib-devel
57ebb8ad 102%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
103# overflows maximum hash table size
104BuildConflicts: pdksh < 5.2.14-57
54ec280e 105Requires: %{name}-libs = %{version}-%{release}
839e806f 106Requires: xvid >= 1:1.1.0
af49d6ab 107Obsoletes: libpostproc
539b540f 108BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 109
2a60eebe
JB
110%define _noautoreqdep libGL.so.1 libGLU.so.1
111
c01d7857
PS
112%define specflags -fno-strict-aliasing
113
114# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
115%define specflags_ia32 -fomit-frame-pointer
116# -mmmx is needed to enable <mmintrin.h> code.
117%define specflags_i586 -mmmx
118%define specflags_i686 -mmmx
1162803a 119%define specflags_ppc -fPIC
c01d7857 120
9fc4ad22 121%description
85f7cea1
ER
122FFmpeg is a complete solution to record, convert and stream audio and
123video. It is a command line tool to convert one video file format to
124another. It also supports grabbing and encoding in real time from a TV
125card.
9fc4ad22 126
cdb7b42e 127%description -l pl.UTF-8
cbdd2688
JB
128FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
129strumieni dźwięku i obrazu. Jest to działające z linii poleceń
130narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
131także przechwytywanie i kodowanie w czasie rzeczywistym z karty
132telewizyjnej.
9fc4ad22 133
54ec280e
PG
134%package libs
135Summary: ffmpeg libraries
adcc0f76 136Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
137Group: Libraries
138
139%description libs
cbdd2688
JB
140This package contains the ffmpeg shared libraries:
141- the codec library (libavcodec). It supports most existing encoding
142 formats (MPEG, DivX, MPEG4, AC3, DV...),
143- demuxer library (libavformat). It supports most existing file
144 formats (AVI, MPEG, OGG, Matroska, ASF...),
145- video postprocessing library (libpostproc).
54ec280e 146
cdb7b42e 147%description libs -l pl.UTF-8
cbdd2688
JB
148Ten pakiet zawiera biblioteki współdzielone ffmpeg:
149- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
150 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
151- bibliotekę demuksera (libavformat); obsługuje większość istniejących
152 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
153- bibliotekę postprocessingu (libpostproc).
54ec280e 154
af49d6ab
JB
155%package devel
156Summary: ffmpeg header files
adcc0f76 157Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 158Group: Development/Libraries
54ec280e 159Requires: %{name}-libs = %{version}-%{release}
38cefaee 160# Libs.private from *.pc (unreasonably they are all the same)
3dcb8642 161Requires: SDL-devel >= 1.2.1
38cefaee
JB
162Requires: alsa-lib-devel
163Requires: bzip2-devel
9c4296c2 164Requires: celt-devel >= 0.11.0
38cefaee 165%{?with_nonfree:Requires: faac-devel}
3dcb8642
JB
166Requires: fontconfig-devel
167Requires: freetype-devel
38cefaee
JB
168Requires: jack-audio-connection-kit-devel
169Requires: lame-libs-devel >= 3.98.3
3dcb8642 170Requires: libbluray-devel
9c4296c2 171Requires: libdc1394-devel >= 2
bf479bc6 172Requires: libgsm-devel
4a927f9d 173Requires: libnut-devel
7571bfa0 174Requires: libraw1394-devel >= 2
38cefaee
JB
175Requires: librtmp-devel
176Requires: libtheora-devel >= 1.0-0.beta3
177%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 178Requires: libvorbis-devel
38cefaee 179%{?with_vpx:Requires: libvpx-devel >= 0.9.6}
ea09f25d 180%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee
JB
181Requires: opencore-amr-devel
182Requires: openjpeg-devel >= 1.3-2
183Requires: schroedinger-devel
184Requires: speex-devel >= 1:1.2-rc1
185Requires: vo-aacenc-devel
186Requires: vo-amrwbenc-devel
187Requires: xavs-devel
188Requires: xorg-lib-libXext-devel
189Requires: xorg-lib-libXfixes-devel
46f2a56b 190Requires: xvid-devel >= 1:1.1.0
33a1c0f3 191Requires: zlib-devel
8152d6a2 192Obsoletes: libpostproc-devel
af49d6ab
JB
193
194%description devel
195ffmpeg header files.
196
cdb7b42e
JR
197%description devel -l pl.UTF-8
198Pliki nagłówkowe ffmpeg.
af49d6ab
JB
199
200%package static
201Summary: ffmpeg static libraries
adcc0f76 202Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
203Group: Development/Libraries
204Requires: %{name}-devel = %{version}-%{release}
205
206%description static
207ffmpeg static libraries (libavcodec and libavformat).
208
cdb7b42e 209%description static -l pl.UTF-8
af49d6ab
JB
210Statyczne biblioteki ffmpeg (libavcodec i libavformat).
211
2a60eebe
JB
212%package ffplay
213Summary: FFplay - SDL-based media player
adcc0f76 214Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 215Group: Applications/Multimedia
54ec280e 216Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
217
218%description ffplay
219FFplay is a very simple and portable media player using the FFmpeg
220libraries and the SDL library. It is mostly used as a test bench for
221the various APIs of FFmpeg.
222
cdb7b42e
JR
223%description ffplay -l pl.UTF-8
224FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
225bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
226testowania różnych API FFmpeg.
2a60eebe 227
fde29260
ER
228%package ffserver
229Summary: FFserver video server
adcc0f76 230Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 231Group: Daemons
593d3a64 232Requires(post,preun): /sbin/chkconfig
67103923 233Requires: %{name}-libs = %{version}-%{release}
2305d791 234Requires: rc-scripts >= 0.4.0.10
fde29260
ER
235
236%description ffserver
237FFserver is a streaming server for both audio and video. It supports
238several live feeds, streaming from files and time shifting on live
239feeds (you can seek to positions in the past on each live feed,
240provided you specify a big enough feed storage in ffserver.conf).
241
cdb7b42e
JR
242%description ffserver -l pl.UTF-8
243FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
244źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
245czasie dla źródeł na żywo (można przeskakiwać na położenia w
246przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
247dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 248
9fc4ad22 249%prep
aed8e8c9 250%setup -q
f1669449 251%patch0 -p1
3eef5ddf 252%patch1 -p0
9fc4ad22 253
9d4f8977
ER
254# package the grep result for mplayer, the result formatted as ./mplayer/configure
255cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
256#! /bin/sh
257_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
258_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
259_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
260_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
261_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
262_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
263_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
264EOF
9d4f8977 265cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
266
267case "$1" in
268--decoders)
269 echo $_libavdecoders_all
270 ;;
271--encoders)
272 echo $_libavencoders_all
273 ;;
274--parsers)
275 echo $_libavparsers_all
276 ;;
277--bsfs)
278 echo $_libavbsfs_all
279 ;;
280--demuxers)
281 echo $_libavdemuxers_all
282 ;;
283--muxers)
284 echo $_libavmuxers_all
285 ;;
286--protocols)
287 echo $_libavprotocols_all
288 ;;
289*)
290 cat <<USAGE
291Usage: $0 [OPTION]
292Options:
293 --decoders
294 --encoders
295 --parsers
296 --bsfs
297 --demuxers
298 --muxers
299 --protocols
300USAGE
301 exit 1;;
302esac
303
304exit 0
305EOF
306
9fc4ad22 307%build
05e1eb2f
JB
308# notes:
309# - it's not autoconf configure
d0a0ec26 310# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 311./configure \
b4680d0b 312 --arch=%{_target_base_arch} \
539b540f 313 --prefix=%{_prefix} \
9cf4d8a4 314 --libdir=%{_libdir} \
d81dfa95 315 --shlibdir=%{_libdir} \
2a60eebe 316 --mandir=%{_mandir} \
314ef0df 317 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 318 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 319 --cc="%{__cc}" \
126fb805
JB
320 --disable-debug \
321 --disable-optimizations \
6382c99d 322 --disable-stripping \
314ef0df 323 --enable-avfilter \
0797daec 324 --enable-avresample \
d5aef92e 325 --enable-gnutls \
126fb805 326 --enable-gpl \
0b43f655 327 --enable-version3 \
3dcb8642 328 --enable-fontconfig \
d7a39558 329 %{?with_frei0r:--enable-frei0r} \
2e585b44 330 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 331 --enable-libass \
3dcb8642 332 --enable-libbluray \
cbdd2688 333 --enable-libcelt \
d5aef92e
JB
334 --enable-libcdio \
335 --enable-libdc1394 \
3dcb8642 336 --enable-libfreetype \
f3692243 337 --enable-libgsm \
d5aef92e 338 --enable-libmodplug \
15c15700 339 --enable-libmp3lame \
4a927f9d 340 --enable-libnut \
cbdd2688
JB
341 --enable-libopencore-amrnb \
342 --enable-libopencore-amrwb \
192f9f57 343 %{?with_opencv:--enable-libopencv} \
cbdd2688 344 --enable-libopenjpeg \
d5aef92e 345 %{?with_pulseaudio:--enable-libpulse} \
cbdd2688 346 --enable-librtmp \
126fb805 347 --enable-libschroedinger \
da99dcf2 348 --enable-libspeex \
126fb805 349 --enable-libtheora \
daf9a670 350 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 351 --enable-libv4l2 \
5dc039cb
JB
352 --enable-libvo-aacenc \
353 --enable-libvo-amrwbenc \
126fb805 354 --enable-libvorbis \
64f8f109 355 %{?with_vpx:--enable-libvpx} \
ea09f25d 356 %{?with_x264:--enable-libx264} \
5dc039cb 357 --enable-libxavs \
126fb805 358 --enable-libxvid \
d5aef92e 359 %{?with_openal:--enable-openal} \
6382c99d 360 --enable-postproc \
d7493de8 361 --enable-pthreads \
9cf4d8a4 362 --enable-shared \
6382c99d 363 --enable-swscale \
0b43f655 364 --enable-vdpau \
75231f25 365 --enable-x11grab \
7a286645 366%ifnarch %{ix86} %{x8664}
e1fe03f7 367 --disable-mmx \
368%endif
369%ifarch i386 i486
05e1eb2f 370 --disable-mmx \
b524cd99 371%endif
0b43f655 372%if %{with nonfree}
48610c64 373 --enable-nonfree \
0b43f655 374 --enable-libfaac \
76243dbd 375%endif
75231f25 376 --enable-runtime-cpudetect
2305d791 377
da99dcf2 378# force oldscaler build
b8c60172 379%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 380
1ef27ea1
JB
381%{__make} \
382 V=1
9fc4ad22 383
b8c60172
ER
384# CC_O to add -c to commandline. makefile should be patched
385%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
386
9fc4ad22
AM
387%install
388rm -rf $RPM_BUILD_ROOT
38cf6de3 389install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 390 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 391 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 392
539b540f 393%{__make} install \
1ef27ea1
JB
394 DESTDIR=$RPM_BUILD_ROOT \
395 V=1
539b540f 396
544421b2
ER
397cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
398cp -a libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
399cp -a libavutil/bswap.h $RPM_BUILD_ROOT%{_includedir}/libavutil
400cp -a libavutil/common.h $RPM_BUILD_ROOT%{_includedir}/libavutil
401cp -a libavutil/mem.h $RPM_BUILD_ROOT%{_includedir}/libavutil
402for a in libavutil/*/bswap.h; do
403 install -D $a $RPM_BUILD_ROOT%{_includedir}/$a
404done
9d4f8977
ER
405cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
406cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
407# for lim-omx ffmpeg components
408cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 409
b8c60172
ER
410install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
411cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
412cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 413mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 414install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 415
2b2445b7
ER
416# install as ffmpeg-avconfig to avoid with possible programs looking for
417# ffmpeg-config and expecting --libs output from it which is not implemented
418# simple to do (by querying pkgconfig), but why?
b8c60172 419install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 420
9fc4ad22
AM
421%clean
422rm -rf $RPM_BUILD_ROOT
423
1ef27ea1
JB
424%post libs -p /sbin/ldconfig
425%postun libs -p /sbin/ldconfig
539b540f 426
38cf6de3
ER
427%pre ffserver
428%groupadd -g 167 ffserver
429%useradd -g ffserver -u 167 ffserver
430
593d3a64
ER
431%post ffserver
432/sbin/chkconfig --add ffserver
433%service ffserver restart
434
38cf6de3 435%preun ffserver
593d3a64
ER
436if [ "$1" = 0 ]; then
437 %service ffserver stop
438 /sbin/chkconfig --del ffserver
439fi
440
38cf6de3
ER
441%postun ffserver
442if [ "$1" = 0 ]; then
443 %userremove ffserver
444 %groupremove ffserver
445fi
446
9fc4ad22
AM
447%files
448%defattr(644,root,root,755)
660918c5 449%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
2a60eebe 450%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 451%attr(755,root,root) %{_bindir}/ffprobe
b7313442 452%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
453%dir %{_datadir}/ffmpeg
454%{_datadir}/ffmpeg/*.ffpreset
714dcf83 455%{_datadir}/ffmpeg/ffprobe.xsd
64f8f109
ER
456%{?with_doc:%{_mandir}/man1/ffmpeg.1*}
457%{?with_doc:%{_mandir}/man1/ffprobe.1*}
54ec280e
PG
458
459%files libs
460%defattr(644,root,root,755)
f50f7d7c 461%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
5663f846 462%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
d0a0ec26 463%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
5663f846 464%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
314ef0df 465%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
cbdd2688 466%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.2
f50f7d7c 467%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
5663f846
JB
468%attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
469%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
470%attr(755,root,root) %ghost %{_libdir}/libavresample.so.0
f50f7d7c 471%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
cbdd2688 472%attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
d7493de8 473%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 474%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
475%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
476%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 477%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 478%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 479
539b540f
JB
480%files devel
481%defattr(644,root,root,755)
54ec280e 482%doc doc/optimization.txt
1ef27ea1 483%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 484%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 485%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 486%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 487%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 488%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 489%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 490%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 491%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 492%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 493%{_includedir}/ffmpeg
6382c99d
AM
494%{_includedir}/libavcodec
495%{_includedir}/libavdevice
314ef0df 496%{_includedir}/libavfilter
6382c99d 497%{_includedir}/libavformat
5663f846 498%{_includedir}/libavresample
6382c99d
AM
499%{_includedir}/libavutil
500%{_includedir}/libpostproc
660918c5 501%{_includedir}/libswresample
6382c99d 502%{_includedir}/libswscale
1ef27ea1
JB
503%{_pkgconfigdir}/libavcodec.pc
504%{_pkgconfigdir}/libavdevice.pc
505%{_pkgconfigdir}/libavfilter.pc
506%{_pkgconfigdir}/libavformat.pc
5663f846 507%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
508%{_pkgconfigdir}/libavutil.pc
509%{_pkgconfigdir}/libpostproc.pc
660918c5 510%{_pkgconfigdir}/libswresample.pc
1ef27ea1 511%{_pkgconfigdir}/libswscale.pc
539b540f 512
9cf4d8a4
JB
513%files static
514%defattr(644,root,root,755)
1ef27ea1
JB
515%{_libdir}/libavcodec.a
516%{_libdir}/libavdevice.a
517%{_libdir}/libavfilter.a
518%{_libdir}/libavformat.a
5663f846 519%{_libdir}/libavresample.a
1ef27ea1
JB
520%{_libdir}/libavutil.a
521%{_libdir}/libpostproc.a
660918c5 522%{_libdir}/libswresample.a
1ef27ea1 523%{_libdir}/libswscale.a
af49d6ab
JB
524
525%files ffplay
526%defattr(644,root,root,755)
527%attr(755,root,root) %{_bindir}/ffplay
64f8f109 528%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 529
fde29260
ER
530%files ffserver
531%defattr(644,root,root,755)
532%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
533%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
534%attr(755,root,root) %{_sbindir}/ffserver
535%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 536%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
537%dir %attr(770,root,ffserver) /var/cache/ffserver
538%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.143768 seconds and 4 git commands to generate.