]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- updated to 1.1.3
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
197f4211 1#
5663f846
JB
2# How to deal with ffmpeg/opencv checken-egg problem:
3# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 4# 2. make-request -r opencv.spec
5# 3. bump release of ffmpeg.spec
6# 4. make-request -r ffmpeg.spec
7#
2b3b2117 8# Conditional build:
38cefaee 9%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 10%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
004e5628 11%bcond_with fdk_aac # AAC encoding via libfdk_aac (requires nonfree)
1c1d1368 12%bcond_without caca # textual display using libcaca
a584ded4
JB
13%bcond_without flite # flite voice synthesis support
14%bcond_without frei0r # frei0r video filtering
cbeed0a5 15%bcond_without ilbc # iLBC de/encoding via WebRTC libilbc
a584ded4
JB
16%bcond_without openal # OpenAL 1.1 capture support
17%bcond_without opencv # OpenCV video filtering
18%bcond_without pulseaudio # PulseAudio input support
05408820 19%bcond_without soxr # SoX Resampler support
a584ded4
JB
20%bcond_without x264 # x264 encoder
21%bcond_without utvideo # Ut Video decoder
1ef27ea1
JB
22%bcond_without va # VAAPI (Video Acceleration API)
23%bcond_without vpx # VP8, a high-quality video codec
24%bcond_without doc # don't build docs
314ef0df 25
cbdd2688
JB
26Summary: FFmpeg - a very fast video and audio converter
27Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 28Name: ffmpeg
41b41fcb 29Version: 1.1.3
e4405036 30Release: 1
9cf4d8a4 31# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
32# (postprocessing, some filters, x264, xavs, xvid, x11grab)
33# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 34License: GPL v3+ with LGPL v3+ parts
fde29260 35Group: Applications/Multimedia
1ef27ea1 36Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
41b41fcb 37# Source0-md5: f66eee18559ba59da63b895164a189c3
fde29260
ER
38Source1: ffserver.init
39Source2: ffserver.sysconfig
38cf6de3 40Source3: ffserver.conf
5663f846 41Patch0: %{name}-gsm.patch
3eef5ddf 42Patch1: %{name}-opencv24.patch
b80ecc89 43Patch2: %{name}-utvideo.patch
85f7cea1 44URL: http://www.ffmpeg.org/
28673856 45%{?with_openal:BuildRequires: OpenAL-devel >= 1.1}
3dcb8642 46BuildRequires: SDL-devel >= 1.2.1
cbdd2688 47BuildRequires: alsa-lib-devel
38cefaee 48BuildRequires: bzip2-devel
9f9ba8ac 49BuildRequires: celt-devel >= 0.11.0
38cefaee 50%{?with_nonfree:BuildRequires: faac-devel}
004e5628 51%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
a584ded4 52%{?with_flite:BuildRequires: flite-devel >= 1.4}
3dcb8642 53BuildRequires: fontconfig-devel
2a60eebe 54BuildRequires: freetype-devel
d7a39558 55%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
56%ifarch ppc
57# require version with altivec support fixed
58BuildRequires: gcc >= 5:3.3.2-3
59%endif
d5aef92e 60BuildRequires: gnutls-devel
cbdd2688
JB
61BuildRequires: jack-audio-connection-kit-devel
62BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 63%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 64BuildRequires: libass-devel
1c1d1368 65BuildRequires: libavc1394-devel
3dcb8642 66BuildRequires: libbluray-devel
1c1d1368 67%{?with_caca:BuildRequires: libcaca-devel}
a09e741c 68BuildRequires: libcdio-paranoia-devel >= 0.90-2
9c4296c2 69BuildRequires: libdc1394-devel >= 2
f1669449 70BuildRequires: libgsm-devel
1c1d1368 71BuildRequires: libiec61883-devel
d5aef92e 72BuildRequires: libmodplug-devel
4a927f9d 73BuildRequires: libnut-devel
7571bfa0 74BuildRequires: libraw1394-devel >= 2
cbdd2688 75BuildRequires: librtmp-devel
9042663c 76BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 77BuildRequires: libtool >= 2:1.4d-3
daf9a670 78BuildRequires: libv4l-devel
64f8f109 79%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 80BuildRequires: libvdpau-devel >= 0.2
e380e18a 81BuildRequires: libvorbis-devel
28673856 82%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.7}
660918c5
AM
83# X264_BUILD >= 118
84%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
e1fe03f7 85%ifarch %{ix86}
86%ifnarch i386 i486
76243dbd
JB
87BuildRequires: nasm
88%endif
e1fe03f7 89%endif
1c1d1368
JB
90BuildRequires: opencore-amr-devel
91%{?with_opencv:BuildRequires: opencv-devel}
92BuildRequires: openjpeg-devel >= 1.5
93BuildRequires: opus-devel
136f0f45 94BuildRequires: perl-Encode
1463656a 95BuildRequires: perl-tools-pod
ef3c0513 96BuildRequires: pkgconfig
1c1d1368 97%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 98BuildRequires: rpmbuild(macros) >= 1.470
126fb805 99BuildRequires: schroedinger-devel
05408820 100%{?with_soxr:BuildRequires: soxr-devel}
1c1d1368 101BuildRequires: speex-devel >= 1:1.2-rc1
64f8f109
ER
102%{?with_doc:BuildRequires: tetex}
103%{?with_doc:BuildRequires: texi2html}
104%{?with_doc:BuildRequires: texinfo}
1c1d1368 105BuildRequires: twolame-devel
05408820 106%{?with_utvideo:BuildRequires: utvideo-devel >= 12}
5dc039cb
JB
107BuildRequires: vo-aacenc-devel
108BuildRequires: vo-amrwbenc-devel
cbeed0a5 109%{?with_ilbc:BuildRequires: webrtc-libilbc-devel}
5dc039cb 110BuildRequires: xavs-devel
28673856 111BuildRequires: xorg-lib-libX11-devel
cbdd2688
JB
112BuildRequires: xorg-lib-libXext-devel
113BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 114BuildRequires: xvid-devel >= 1:1.1.0
cbeed0a5 115BuildRequires: yasm
33a1c0f3 116BuildRequires: zlib-devel
57ebb8ad 117%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
118# overflows maximum hash table size
119BuildConflicts: pdksh < 5.2.14-57
54ec280e 120Requires: %{name}-libs = %{version}-%{release}
05408820 121%{?with_utvideo:Requires: utvideo >= 12}
92a3edff 122%{?with_ilbc:Requires: webrtc-libilbc}
839e806f 123Requires: xvid >= 1:1.1.0
af49d6ab 124Obsoletes: libpostproc
539b540f 125BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 126
2a60eebe
JB
127%define _noautoreqdep libGL.so.1 libGLU.so.1
128
c01d7857
PS
129%define specflags -fno-strict-aliasing
130
131# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
132%define specflags_ia32 -fomit-frame-pointer
133# -mmmx is needed to enable <mmintrin.h> code.
134%define specflags_i586 -mmmx
135%define specflags_i686 -mmmx
1162803a 136%define specflags_ppc -fPIC
c01d7857 137
9fc4ad22 138%description
85f7cea1
ER
139FFmpeg is a complete solution to record, convert and stream audio and
140video. It is a command line tool to convert one video file format to
141another. It also supports grabbing and encoding in real time from a TV
142card.
9fc4ad22 143
cdb7b42e 144%description -l pl.UTF-8
cbdd2688
JB
145FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
146strumieni dźwięku i obrazu. Jest to działające z linii poleceń
147narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
148także przechwytywanie i kodowanie w czasie rzeczywistym z karty
149telewizyjnej.
9fc4ad22 150
54ec280e
PG
151%package libs
152Summary: ffmpeg libraries
adcc0f76 153Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
154Group: Libraries
155
156%description libs
cbdd2688
JB
157This package contains the ffmpeg shared libraries:
158- the codec library (libavcodec). It supports most existing encoding
159 formats (MPEG, DivX, MPEG4, AC3, DV...),
160- demuxer library (libavformat). It supports most existing file
161 formats (AVI, MPEG, OGG, Matroska, ASF...),
162- video postprocessing library (libpostproc).
54ec280e 163
cdb7b42e 164%description libs -l pl.UTF-8
cbdd2688
JB
165Ten pakiet zawiera biblioteki współdzielone ffmpeg:
166- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
167 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
168- bibliotekę demuksera (libavformat); obsługuje większość istniejących
169 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
170- bibliotekę postprocessingu (libpostproc).
54ec280e 171
af49d6ab
JB
172%package devel
173Summary: ffmpeg header files
adcc0f76 174Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 175Group: Development/Libraries
54ec280e 176Requires: %{name}-libs = %{version}-%{release}
38cefaee 177# Libs.private from *.pc (unreasonably they are all the same)
3dcb8642 178Requires: SDL-devel >= 1.2.1
38cefaee
JB
179Requires: alsa-lib-devel
180Requires: bzip2-devel
9c4296c2 181Requires: celt-devel >= 0.11.0
38cefaee 182%{?with_nonfree:Requires: faac-devel}
004e5628 183%{?with_fdk_aac:Requires: fdk-aac-devel}
3dcb8642
JB
184Requires: fontconfig-devel
185Requires: freetype-devel
38cefaee 186Requires: jack-audio-connection-kit-devel
a584ded4 187%{?with_flite:Requires: flite-devel >= 1.4}
38cefaee 188Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
189%{?with_aacplus:Requires: libaacplus-devel >= 2.0.0}
190Requires: libass-devel
191Requires: libavc1394-devel
3dcb8642 192Requires: libbluray-devel
28673856 193%{?with_caca:Requires: libcaca-devel}
a09e741c 194Requires: libcdio-paranoia-devel >= 0.90-2
9c4296c2 195Requires: libdc1394-devel >= 2
bf479bc6 196Requires: libgsm-devel
1c1d1368
JB
197Requires: libiec61883-devel
198Requires: libmodplug-devel
4a927f9d 199Requires: libnut-devel
7571bfa0 200Requires: libraw1394-devel >= 2
38cefaee
JB
201Requires: librtmp-devel
202Requires: libtheora-devel >= 1.0-0.beta3
203%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 204Requires: libvorbis-devel
28673856 205%{?with_vpx:Requires: libvpx-devel >= 0.9.7}
ea09f25d 206%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee 207Requires: opencore-amr-devel
fc1d9619 208%{?with_opencv:Requires: opencv-devel}
ae5be86b 209Requires: openjpeg-devel >= 1.5
38cefaee 210Requires: schroedinger-devel
05408820 211%{?with_soxr:Requires: soxr-devel}
38cefaee 212Requires: speex-devel >= 1:1.2-rc1
1c1d1368 213Requires: twolame-devel
05408820 214%{?with_utvideo:Requires: utvideo-devel >= 12}
38cefaee
JB
215Requires: vo-aacenc-devel
216Requires: vo-amrwbenc-devel
cbeed0a5 217%{?with_ilbc:Requires: webrtc-libilbc-devel}
38cefaee
JB
218Requires: xavs-devel
219Requires: xorg-lib-libXext-devel
220Requires: xorg-lib-libXfixes-devel
46f2a56b 221Requires: xvid-devel >= 1:1.1.0
33a1c0f3 222Requires: zlib-devel
8152d6a2 223Obsoletes: libpostproc-devel
af49d6ab
JB
224
225%description devel
226ffmpeg header files.
227
cdb7b42e
JR
228%description devel -l pl.UTF-8
229Pliki nagłówkowe ffmpeg.
af49d6ab
JB
230
231%package static
232Summary: ffmpeg static libraries
adcc0f76 233Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
234Group: Development/Libraries
235Requires: %{name}-devel = %{version}-%{release}
236
237%description static
238ffmpeg static libraries (libavcodec and libavformat).
239
cdb7b42e 240%description static -l pl.UTF-8
af49d6ab
JB
241Statyczne biblioteki ffmpeg (libavcodec i libavformat).
242
2a60eebe
JB
243%package ffplay
244Summary: FFplay - SDL-based media player
adcc0f76 245Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 246Group: Applications/Multimedia
54ec280e 247Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
248
249%description ffplay
250FFplay is a very simple and portable media player using the FFmpeg
251libraries and the SDL library. It is mostly used as a test bench for
252the various APIs of FFmpeg.
253
cdb7b42e
JR
254%description ffplay -l pl.UTF-8
255FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
256bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
257testowania różnych API FFmpeg.
2a60eebe 258
fde29260
ER
259%package ffserver
260Summary: FFserver video server
adcc0f76 261Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 262Group: Daemons
593d3a64 263Requires(post,preun): /sbin/chkconfig
67103923 264Requires: %{name}-libs = %{version}-%{release}
2305d791 265Requires: rc-scripts >= 0.4.0.10
fde29260
ER
266
267%description ffserver
268FFserver is a streaming server for both audio and video. It supports
269several live feeds, streaming from files and time shifting on live
270feeds (you can seek to positions in the past on each live feed,
271provided you specify a big enough feed storage in ffserver.conf).
272
cdb7b42e
JR
273%description ffserver -l pl.UTF-8
274FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
275źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
276czasie dla źródeł na żywo (można przeskakiwać na położenia w
277przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
278dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 279
9fc4ad22 280%prep
aed8e8c9 281%setup -q
f1669449 282%patch0 -p1
28673856 283%patch1 -p1
ae5be86b 284%patch2 -p1
9fc4ad22 285
9d4f8977
ER
286# package the grep result for mplayer, the result formatted as ./mplayer/configure
287cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
288#! /bin/sh
289_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
290_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
291_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
292_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
293_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
294_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
295_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
296EOF
9d4f8977 297cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
298
299case "$1" in
300--decoders)
301 echo $_libavdecoders_all
302 ;;
303--encoders)
304 echo $_libavencoders_all
305 ;;
306--parsers)
307 echo $_libavparsers_all
308 ;;
309--bsfs)
310 echo $_libavbsfs_all
311 ;;
312--demuxers)
313 echo $_libavdemuxers_all
314 ;;
315--muxers)
316 echo $_libavmuxers_all
317 ;;
318--protocols)
319 echo $_libavprotocols_all
320 ;;
321*)
322 cat <<USAGE
323Usage: $0 [OPTION]
324Options:
325 --decoders
326 --encoders
327 --parsers
328 --bsfs
329 --demuxers
330 --muxers
331 --protocols
332USAGE
333 exit 1;;
334esac
335
336exit 0
337EOF
338
9fc4ad22 339%build
05e1eb2f
JB
340# notes:
341# - it's not autoconf configure
d0a0ec26 342# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 343./configure \
b4680d0b 344 --arch=%{_target_base_arch} \
539b540f 345 --prefix=%{_prefix} \
9cf4d8a4 346 --libdir=%{_libdir} \
d81dfa95 347 --shlibdir=%{_libdir} \
2a60eebe 348 --mandir=%{_mandir} \
314ef0df 349 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 350 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 351 --cc="%{__cc}" \
126fb805
JB
352 --disable-debug \
353 --disable-optimizations \
6382c99d 354 --disable-stripping \
314ef0df 355 --enable-avfilter \
0797daec 356 --enable-avresample \
d5aef92e 357 --enable-gnutls \
126fb805 358 --enable-gpl \
0b43f655 359 --enable-version3 \
3dcb8642 360 --enable-fontconfig \
d7a39558 361 %{?with_frei0r:--enable-frei0r} \
2e585b44 362 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 363 --enable-libass \
3dcb8642 364 --enable-libbluray \
2362253d 365 %{?with_caca:--enable-libcaca} \
cbdd2688 366 --enable-libcelt \
d5aef92e
JB
367 --enable-libcdio \
368 --enable-libdc1394 \
004e5628 369 %{?with_fdk_aac:--enable-libfdk-aac} \
1c1d1368 370 %{?with_flite:--enable-libflite} \
3dcb8642 371 --enable-libfreetype \
f3692243 372 --enable-libgsm \
1c1d1368 373 --enable-libiec61883 \
004e5628 374 %{?with_ilbc:--enable-libilbc} \
d5aef92e 375 --enable-libmodplug \
15c15700 376 --enable-libmp3lame \
4a927f9d 377 --enable-libnut \
cbdd2688
JB
378 --enable-libopencore-amrnb \
379 --enable-libopencore-amrwb \
192f9f57 380 %{?with_opencv:--enable-libopencv} \
cbdd2688 381 --enable-libopenjpeg \
1c1d1368 382 --enable-libopus \
d5aef92e 383 %{?with_pulseaudio:--enable-libpulse} \
cbdd2688 384 --enable-librtmp \
126fb805 385 --enable-libschroedinger \
05408820 386 %{?with_soxr:--enable-libsoxr} \
da99dcf2 387 --enable-libspeex \
126fb805 388 --enable-libtheora \
1c1d1368 389 --enable-libtwolame \
daf9a670 390 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 391 --enable-libv4l2 \
5dc039cb
JB
392 --enable-libvo-aacenc \
393 --enable-libvo-amrwbenc \
126fb805 394 --enable-libvorbis \
64f8f109 395 %{?with_vpx:--enable-libvpx} \
ea09f25d 396 %{?with_x264:--enable-libx264} \
5dc039cb 397 --enable-libxavs \
126fb805 398 --enable-libxvid \
d5aef92e 399 %{?with_openal:--enable-openal} \
6382c99d 400 --enable-postproc \
d7493de8 401 --enable-pthreads \
9cf4d8a4 402 --enable-shared \
6382c99d 403 --enable-swscale \
1c1d1368 404 %{?with_va:--enable-vaapi} \
0b43f655 405 --enable-vdpau \
75231f25 406 --enable-x11grab \
7a286645 407%ifnarch %{ix86} %{x8664}
e1fe03f7 408 --disable-mmx \
409%endif
410%ifarch i386 i486
05e1eb2f 411 --disable-mmx \
b524cd99 412%endif
0b43f655 413%if %{with nonfree}
48610c64 414 --enable-nonfree \
0b43f655 415 --enable-libfaac \
76243dbd 416%endif
75231f25 417 --enable-runtime-cpudetect
2305d791 418
da99dcf2 419# force oldscaler build
b8c60172 420%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 421
1ef27ea1
JB
422%{__make} \
423 V=1
9fc4ad22 424
b8c60172
ER
425# CC_O to add -c to commandline. makefile should be patched
426%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
427
9fc4ad22
AM
428%install
429rm -rf $RPM_BUILD_ROOT
38cf6de3 430install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 431 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 432 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 433
a831ce58 434%{__make} install install-headers \
1ef27ea1
JB
435 DESTDIR=$RPM_BUILD_ROOT \
436 V=1
539b540f 437
a831ce58 438# install nonstandard, non-public headers manually
544421b2 439cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
544421b2 440for a in libavutil/*/bswap.h; do
a831ce58 441 install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
544421b2 442done
9d4f8977 443cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
444# for lim-omx ffmpeg components
445cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 446
b8c60172
ER
447install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
448cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
449cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 450mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 451install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 452
2b2445b7
ER
453# install as ffmpeg-avconfig to avoid with possible programs looking for
454# ffmpeg-config and expecting --libs output from it which is not implemented
455# simple to do (by querying pkgconfig), but why?
b8c60172 456install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 457
28673856
JB
458# fix man page
459%if %{with doc}
460install -d $RPM_BUILD_ROOT%{_mandir}/man3
461%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/lib*.3 $RPM_BUILD_ROOT%{_mandir}/man3
462%endif
463
9fc4ad22
AM
464%clean
465rm -rf $RPM_BUILD_ROOT
466
1ef27ea1
JB
467%post libs -p /sbin/ldconfig
468%postun libs -p /sbin/ldconfig
539b540f 469
38cf6de3
ER
470%pre ffserver
471%groupadd -g 167 ffserver
472%useradd -g ffserver -u 167 ffserver
473
593d3a64
ER
474%post ffserver
475/sbin/chkconfig --add ffserver
476%service ffserver restart
477
38cf6de3 478%preun ffserver
593d3a64
ER
479if [ "$1" = 0 ]; then
480 %service ffserver stop
481 /sbin/chkconfig --del ffserver
482fi
483
38cf6de3
ER
484%postun ffserver
485if [ "$1" = 0 ]; then
486 %userremove ffserver
487 %groupremove ffserver
488fi
489
9fc4ad22
AM
490%files
491%defattr(644,root,root,755)
660918c5 492%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
2a60eebe 493%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 494%attr(755,root,root) %{_bindir}/ffprobe
b7313442 495%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
496%dir %{_datadir}/ffmpeg
497%{_datadir}/ffmpeg/*.ffpreset
714dcf83 498%{_datadir}/ffmpeg/ffprobe.xsd
28673856
JB
499%if %{with doc}
500%{_mandir}/man1/ffmpeg.1*
501%{_mandir}/man1/ffmpeg-bitstream-filters.1*
502%{_mandir}/man1/ffmpeg-codecs.1*
503%{_mandir}/man1/ffmpeg-devices.1*
504%{_mandir}/man1/ffmpeg-filters.1*
505%{_mandir}/man1/ffmpeg-formats.1*
506%{_mandir}/man1/ffmpeg-protocols.1*
507%{_mandir}/man1/ffmpeg-resampler.1*
508%{_mandir}/man1/ffmpeg-scaler.1*
509%{_mandir}/man1/ffmpeg-utils.1*
510%{_mandir}/man1/ffprobe.1*
511%endif
54ec280e
PG
512
513%files libs
514%defattr(644,root,root,755)
f50f7d7c 515%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
5663f846 516%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
d0a0ec26 517%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
5663f846 518%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
314ef0df 519%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
1c1d1368 520%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
f50f7d7c 521%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
5663f846
JB
522%attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
523%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
28673856 524%attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
f50f7d7c 525%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
28673856 526%attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
d7493de8 527%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 528%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
529%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
530%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 531%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 532%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 533
539b540f
JB
534%files devel
535%defattr(644,root,root,755)
54ec280e 536%doc doc/optimization.txt
1ef27ea1 537%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 538%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 539%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 540%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 541%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 542%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 543%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 544%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 545%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 546%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 547%{_includedir}/ffmpeg
6382c99d
AM
548%{_includedir}/libavcodec
549%{_includedir}/libavdevice
314ef0df 550%{_includedir}/libavfilter
6382c99d 551%{_includedir}/libavformat
5663f846 552%{_includedir}/libavresample
6382c99d
AM
553%{_includedir}/libavutil
554%{_includedir}/libpostproc
660918c5 555%{_includedir}/libswresample
6382c99d 556%{_includedir}/libswscale
1ef27ea1
JB
557%{_pkgconfigdir}/libavcodec.pc
558%{_pkgconfigdir}/libavdevice.pc
559%{_pkgconfigdir}/libavfilter.pc
560%{_pkgconfigdir}/libavformat.pc
5663f846 561%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
562%{_pkgconfigdir}/libavutil.pc
563%{_pkgconfigdir}/libpostproc.pc
660918c5 564%{_pkgconfigdir}/libswresample.pc
1ef27ea1 565%{_pkgconfigdir}/libswscale.pc
28673856
JB
566%if %{with doc}
567%{_mandir}/man3/libavcodec.3*
568%{_mandir}/man3/libavdevice.3*
569%{_mandir}/man3/libavfilter.3*
570%{_mandir}/man3/libavformat.3*
571%{_mandir}/man3/libavutil.3*
572%{_mandir}/man3/libswresample.3*
573%{_mandir}/man3/libswscale.3*
574%endif
539b540f 575
9cf4d8a4
JB
576%files static
577%defattr(644,root,root,755)
1ef27ea1
JB
578%{_libdir}/libavcodec.a
579%{_libdir}/libavdevice.a
580%{_libdir}/libavfilter.a
581%{_libdir}/libavformat.a
5663f846 582%{_libdir}/libavresample.a
1ef27ea1
JB
583%{_libdir}/libavutil.a
584%{_libdir}/libpostproc.a
660918c5 585%{_libdir}/libswresample.a
1ef27ea1 586%{_libdir}/libswscale.a
af49d6ab
JB
587
588%files ffplay
589%defattr(644,root,root,755)
590%attr(755,root,root) %{_bindir}/ffplay
64f8f109 591%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 592
fde29260
ER
593%files ffserver
594%defattr(644,root,root,755)
595%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
596%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
597%attr(755,root,root) %{_sbindir}/ffserver
598%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 599%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
600%dir %attr(770,root,ffserver) /var/cache/ffserver
601%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.226779 seconds and 4 git commands to generate.