]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- devel requires opencv-devel
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
197f4211 1#
5663f846
JB
2# How to deal with ffmpeg/opencv checken-egg problem:
3# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 4# 2. make-request -r opencv.spec
5# 3. bump release of ffmpeg.spec
6# 4. make-request -r ffmpeg.spec
7#
2b3b2117 8# Conditional build:
38cefaee 9%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 10%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
004e5628 11%bcond_with fdk_aac # AAC encoding via libfdk_aac (requires nonfree)
1c1d1368 12%bcond_without caca # textual display using libcaca
a584ded4
JB
13%bcond_without flite # flite voice synthesis support
14%bcond_without frei0r # frei0r video filtering
cbeed0a5 15%bcond_without ilbc # iLBC de/encoding via WebRTC libilbc
a584ded4
JB
16%bcond_without openal # OpenAL 1.1 capture support
17%bcond_without opencv # OpenCV video filtering
18%bcond_without pulseaudio # PulseAudio input support
19%bcond_without x264 # x264 encoder
20%bcond_without utvideo # Ut Video decoder
1ef27ea1
JB
21%bcond_without va # VAAPI (Video Acceleration API)
22%bcond_without vpx # VP8, a high-quality video codec
23%bcond_without doc # don't build docs
314ef0df 24
cbdd2688
JB
25Summary: FFmpeg - a very fast video and audio converter
26Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 27Name: ffmpeg
1c1d1368 28Version: 1.0
fc1d9619 29Release: 3
9cf4d8a4 30# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
31# (postprocessing, some filters, x264, xavs, xvid, x11grab)
32# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 33License: GPL v3+ with LGPL v3+ parts
fde29260 34Group: Applications/Multimedia
1ef27ea1 35Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
1c1d1368 36# Source0-md5: 3ed526cea20c1bffb5a37f7730f710bd
fde29260
ER
37Source1: ffserver.init
38Source2: ffserver.sysconfig
38cf6de3 39Source3: ffserver.conf
5663f846 40Patch0: %{name}-gsm.patch
3eef5ddf 41Patch1: %{name}-opencv24.patch
ae5be86b 42Patch2: %{name}-openjpeg.patch
85f7cea1 43URL: http://www.ffmpeg.org/
d5aef92e 44%{?with_openal:BuildRequires: OpenAL-devel}
3dcb8642 45BuildRequires: SDL-devel >= 1.2.1
cbdd2688 46BuildRequires: alsa-lib-devel
38cefaee 47BuildRequires: bzip2-devel
9f9ba8ac 48BuildRequires: celt-devel >= 0.11.0
38cefaee 49%{?with_nonfree:BuildRequires: faac-devel}
004e5628 50%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
a584ded4 51%{?with_flite:BuildRequires: flite-devel >= 1.4}
3dcb8642 52BuildRequires: fontconfig-devel
2a60eebe 53BuildRequires: freetype-devel
d7a39558 54%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
55%ifarch ppc
56# require version with altivec support fixed
57BuildRequires: gcc >= 5:3.3.2-3
58%endif
d5aef92e 59BuildRequires: gnutls-devel
cbdd2688
JB
60BuildRequires: jack-audio-connection-kit-devel
61BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 62%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 63BuildRequires: libass-devel
1c1d1368 64BuildRequires: libavc1394-devel
3dcb8642 65BuildRequires: libbluray-devel
1c1d1368 66%{?with_caca:BuildRequires: libcaca-devel}
d5aef92e 67BuildRequires: libcdio-devel
9c4296c2 68BuildRequires: libdc1394-devel >= 2
f1669449 69BuildRequires: libgsm-devel
1c1d1368 70BuildRequires: libiec61883-devel
d5aef92e 71BuildRequires: libmodplug-devel
4a927f9d 72BuildRequires: libnut-devel
7571bfa0 73BuildRequires: libraw1394-devel >= 2
cbdd2688 74BuildRequires: librtmp-devel
9042663c 75BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 76BuildRequires: libtool >= 2:1.4d-3
daf9a670 77BuildRequires: libv4l-devel
64f8f109 78%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 79BuildRequires: libvdpau-devel >= 0.2
e380e18a 80BuildRequires: libvorbis-devel
065be88e 81%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.6}
660918c5
AM
82# X264_BUILD >= 118
83%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
e1fe03f7 84%ifarch %{ix86}
85%ifnarch i386 i486
76243dbd
JB
86BuildRequires: nasm
87%endif
e1fe03f7 88%endif
1c1d1368
JB
89BuildRequires: opencore-amr-devel
90%{?with_opencv:BuildRequires: opencv-devel}
91BuildRequires: openjpeg-devel >= 1.5
92BuildRequires: opus-devel
136f0f45 93BuildRequires: perl-Encode
1463656a 94BuildRequires: perl-tools-pod
ef3c0513 95BuildRequires: pkgconfig
1c1d1368 96%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 97BuildRequires: rpmbuild(macros) >= 1.470
126fb805 98BuildRequires: schroedinger-devel
1c1d1368 99BuildRequires: speex-devel >= 1:1.2-rc1
64f8f109
ER
100%{?with_doc:BuildRequires: tetex}
101%{?with_doc:BuildRequires: texi2html}
102%{?with_doc:BuildRequires: texinfo}
1c1d1368 103BuildRequires: twolame-devel
daf9a670 104%{?with_utvideo:BuildRequires: utvideo-devel}
5dc039cb
JB
105BuildRequires: vo-aacenc-devel
106BuildRequires: vo-amrwbenc-devel
cbeed0a5 107%{?with_ilbc:BuildRequires: webrtc-libilbc-devel}
5dc039cb 108BuildRequires: xavs-devel
cbdd2688
JB
109BuildRequires: xorg-lib-libXext-devel
110BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 111BuildRequires: xvid-devel >= 1:1.1.0
cbeed0a5 112BuildRequires: yasm
33a1c0f3 113BuildRequires: zlib-devel
57ebb8ad 114%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
115# overflows maximum hash table size
116BuildConflicts: pdksh < 5.2.14-57
54ec280e 117Requires: %{name}-libs = %{version}-%{release}
839e806f 118Requires: xvid >= 1:1.1.0
af49d6ab 119Obsoletes: libpostproc
539b540f 120BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 121
2a60eebe
JB
122%define _noautoreqdep libGL.so.1 libGLU.so.1
123
c01d7857
PS
124%define specflags -fno-strict-aliasing
125
126# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
127%define specflags_ia32 -fomit-frame-pointer
128# -mmmx is needed to enable <mmintrin.h> code.
129%define specflags_i586 -mmmx
130%define specflags_i686 -mmmx
1162803a 131%define specflags_ppc -fPIC
c01d7857 132
9fc4ad22 133%description
85f7cea1
ER
134FFmpeg is a complete solution to record, convert and stream audio and
135video. It is a command line tool to convert one video file format to
136another. It also supports grabbing and encoding in real time from a TV
137card.
9fc4ad22 138
cdb7b42e 139%description -l pl.UTF-8
cbdd2688
JB
140FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
141strumieni dźwięku i obrazu. Jest to działające z linii poleceń
142narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
143także przechwytywanie i kodowanie w czasie rzeczywistym z karty
144telewizyjnej.
9fc4ad22 145
54ec280e
PG
146%package libs
147Summary: ffmpeg libraries
adcc0f76 148Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
149Group: Libraries
150
151%description libs
cbdd2688
JB
152This package contains the ffmpeg shared libraries:
153- the codec library (libavcodec). It supports most existing encoding
154 formats (MPEG, DivX, MPEG4, AC3, DV...),
155- demuxer library (libavformat). It supports most existing file
156 formats (AVI, MPEG, OGG, Matroska, ASF...),
157- video postprocessing library (libpostproc).
54ec280e 158
cdb7b42e 159%description libs -l pl.UTF-8
cbdd2688
JB
160Ten pakiet zawiera biblioteki współdzielone ffmpeg:
161- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
162 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
163- bibliotekę demuksera (libavformat); obsługuje większość istniejących
164 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
165- bibliotekę postprocessingu (libpostproc).
54ec280e 166
af49d6ab
JB
167%package devel
168Summary: ffmpeg header files
adcc0f76 169Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 170Group: Development/Libraries
54ec280e 171Requires: %{name}-libs = %{version}-%{release}
38cefaee 172# Libs.private from *.pc (unreasonably they are all the same)
3dcb8642 173Requires: SDL-devel >= 1.2.1
38cefaee
JB
174Requires: alsa-lib-devel
175Requires: bzip2-devel
9c4296c2 176Requires: celt-devel >= 0.11.0
38cefaee 177%{?with_nonfree:Requires: faac-devel}
004e5628 178%{?with_fdk_aac:Requires: fdk-aac-devel}
3dcb8642
JB
179Requires: fontconfig-devel
180Requires: freetype-devel
38cefaee 181Requires: jack-audio-connection-kit-devel
a584ded4 182%{?with_flite:Requires: flite-devel >= 1.4}
38cefaee 183Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
184%{?with_aacplus:Requires: libaacplus-devel >= 2.0.0}
185Requires: libass-devel
186Requires: libavc1394-devel
3dcb8642 187Requires: libbluray-devel
1c1d1368 188Requires: libcdio-devel
9c4296c2 189Requires: libdc1394-devel >= 2
bf479bc6 190Requires: libgsm-devel
1c1d1368
JB
191Requires: libiec61883-devel
192Requires: libmodplug-devel
4a927f9d 193Requires: libnut-devel
7571bfa0 194Requires: libraw1394-devel >= 2
38cefaee
JB
195Requires: librtmp-devel
196Requires: libtheora-devel >= 1.0-0.beta3
197%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 198Requires: libvorbis-devel
38cefaee 199%{?with_vpx:Requires: libvpx-devel >= 0.9.6}
ea09f25d 200%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee 201Requires: opencore-amr-devel
fc1d9619 202%{?with_opencv:Requires: opencv-devel}
ae5be86b 203Requires: openjpeg-devel >= 1.5
38cefaee
JB
204Requires: schroedinger-devel
205Requires: speex-devel >= 1:1.2-rc1
1c1d1368 206Requires: twolame-devel
38cefaee
JB
207Requires: vo-aacenc-devel
208Requires: vo-amrwbenc-devel
cbeed0a5 209%{?with_ilbc:Requires: webrtc-libilbc-devel}
38cefaee
JB
210Requires: xavs-devel
211Requires: xorg-lib-libXext-devel
212Requires: xorg-lib-libXfixes-devel
46f2a56b 213Requires: xvid-devel >= 1:1.1.0
33a1c0f3 214Requires: zlib-devel
8152d6a2 215Obsoletes: libpostproc-devel
af49d6ab
JB
216
217%description devel
218ffmpeg header files.
219
cdb7b42e
JR
220%description devel -l pl.UTF-8
221Pliki nagłówkowe ffmpeg.
af49d6ab
JB
222
223%package static
224Summary: ffmpeg static libraries
adcc0f76 225Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
226Group: Development/Libraries
227Requires: %{name}-devel = %{version}-%{release}
228
229%description static
230ffmpeg static libraries (libavcodec and libavformat).
231
cdb7b42e 232%description static -l pl.UTF-8
af49d6ab
JB
233Statyczne biblioteki ffmpeg (libavcodec i libavformat).
234
2a60eebe
JB
235%package ffplay
236Summary: FFplay - SDL-based media player
adcc0f76 237Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 238Group: Applications/Multimedia
54ec280e 239Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
240
241%description ffplay
242FFplay is a very simple and portable media player using the FFmpeg
243libraries and the SDL library. It is mostly used as a test bench for
244the various APIs of FFmpeg.
245
cdb7b42e
JR
246%description ffplay -l pl.UTF-8
247FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
248bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
249testowania różnych API FFmpeg.
2a60eebe 250
fde29260
ER
251%package ffserver
252Summary: FFserver video server
adcc0f76 253Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 254Group: Daemons
593d3a64 255Requires(post,preun): /sbin/chkconfig
67103923 256Requires: %{name}-libs = %{version}-%{release}
2305d791 257Requires: rc-scripts >= 0.4.0.10
fde29260
ER
258
259%description ffserver
260FFserver is a streaming server for both audio and video. It supports
261several live feeds, streaming from files and time shifting on live
262feeds (you can seek to positions in the past on each live feed,
263provided you specify a big enough feed storage in ffserver.conf).
264
cdb7b42e
JR
265%description ffserver -l pl.UTF-8
266FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
267źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
268czasie dla źródeł na żywo (można przeskakiwać na położenia w
269przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
270dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 271
9fc4ad22 272%prep
aed8e8c9 273%setup -q
f1669449 274%patch0 -p1
3eef5ddf 275%patch1 -p0
ae5be86b 276%patch2 -p1
9fc4ad22 277
9d4f8977
ER
278# package the grep result for mplayer, the result formatted as ./mplayer/configure
279cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
280#! /bin/sh
281_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
282_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
283_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
284_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
285_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
286_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
287_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
288EOF
9d4f8977 289cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
290
291case "$1" in
292--decoders)
293 echo $_libavdecoders_all
294 ;;
295--encoders)
296 echo $_libavencoders_all
297 ;;
298--parsers)
299 echo $_libavparsers_all
300 ;;
301--bsfs)
302 echo $_libavbsfs_all
303 ;;
304--demuxers)
305 echo $_libavdemuxers_all
306 ;;
307--muxers)
308 echo $_libavmuxers_all
309 ;;
310--protocols)
311 echo $_libavprotocols_all
312 ;;
313*)
314 cat <<USAGE
315Usage: $0 [OPTION]
316Options:
317 --decoders
318 --encoders
319 --parsers
320 --bsfs
321 --demuxers
322 --muxers
323 --protocols
324USAGE
325 exit 1;;
326esac
327
328exit 0
329EOF
330
9fc4ad22 331%build
05e1eb2f
JB
332# notes:
333# - it's not autoconf configure
d0a0ec26 334# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 335./configure \
b4680d0b 336 --arch=%{_target_base_arch} \
539b540f 337 --prefix=%{_prefix} \
9cf4d8a4 338 --libdir=%{_libdir} \
d81dfa95 339 --shlibdir=%{_libdir} \
2a60eebe 340 --mandir=%{_mandir} \
314ef0df 341 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 342 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 343 --cc="%{__cc}" \
126fb805
JB
344 --disable-debug \
345 --disable-optimizations \
6382c99d 346 --disable-stripping \
314ef0df 347 --enable-avfilter \
0797daec 348 --enable-avresample \
d5aef92e 349 --enable-gnutls \
126fb805 350 --enable-gpl \
0b43f655 351 --enable-version3 \
3dcb8642 352 --enable-fontconfig \
d7a39558 353 %{?with_frei0r:--enable-frei0r} \
2e585b44 354 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 355 --enable-libass \
3dcb8642 356 --enable-libbluray \
1c1d1368 357 %{?with_libcaca:--enable-libcaca} \
cbdd2688 358 --enable-libcelt \
d5aef92e
JB
359 --enable-libcdio \
360 --enable-libdc1394 \
004e5628 361 %{?with_fdk_aac:--enable-libfdk-aac} \
1c1d1368 362 %{?with_flite:--enable-libflite} \
3dcb8642 363 --enable-libfreetype \
f3692243 364 --enable-libgsm \
1c1d1368 365 --enable-libiec61883 \
004e5628 366 %{?with_ilbc:--enable-libilbc} \
d5aef92e 367 --enable-libmodplug \
15c15700 368 --enable-libmp3lame \
4a927f9d 369 --enable-libnut \
cbdd2688
JB
370 --enable-libopencore-amrnb \
371 --enable-libopencore-amrwb \
192f9f57 372 %{?with_opencv:--enable-libopencv} \
cbdd2688 373 --enable-libopenjpeg \
1c1d1368 374 --enable-libopus \
d5aef92e 375 %{?with_pulseaudio:--enable-libpulse} \
cbdd2688 376 --enable-librtmp \
126fb805 377 --enable-libschroedinger \
da99dcf2 378 --enable-libspeex \
126fb805 379 --enable-libtheora \
1c1d1368 380 --enable-libtwolame \
daf9a670 381 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 382 --enable-libv4l2 \
5dc039cb
JB
383 --enable-libvo-aacenc \
384 --enable-libvo-amrwbenc \
126fb805 385 --enable-libvorbis \
64f8f109 386 %{?with_vpx:--enable-libvpx} \
ea09f25d 387 %{?with_x264:--enable-libx264} \
5dc039cb 388 --enable-libxavs \
126fb805 389 --enable-libxvid \
d5aef92e 390 %{?with_openal:--enable-openal} \
6382c99d 391 --enable-postproc \
d7493de8 392 --enable-pthreads \
9cf4d8a4 393 --enable-shared \
6382c99d 394 --enable-swscale \
1c1d1368 395 %{?with_va:--enable-vaapi} \
0b43f655 396 --enable-vdpau \
75231f25 397 --enable-x11grab \
7a286645 398%ifnarch %{ix86} %{x8664}
e1fe03f7 399 --disable-mmx \
400%endif
401%ifarch i386 i486
05e1eb2f 402 --disable-mmx \
b524cd99 403%endif
0b43f655 404%if %{with nonfree}
48610c64 405 --enable-nonfree \
0b43f655 406 --enable-libfaac \
76243dbd 407%endif
75231f25 408 --enable-runtime-cpudetect
2305d791 409
da99dcf2 410# force oldscaler build
b8c60172 411%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 412
1ef27ea1
JB
413%{__make} \
414 V=1
9fc4ad22 415
b8c60172
ER
416# CC_O to add -c to commandline. makefile should be patched
417%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
418
9fc4ad22
AM
419%install
420rm -rf $RPM_BUILD_ROOT
38cf6de3 421install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 422 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 423 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 424
539b540f 425%{__make} install \
1ef27ea1
JB
426 DESTDIR=$RPM_BUILD_ROOT \
427 V=1
539b540f 428
544421b2
ER
429cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
430cp -a libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
431cp -a libavutil/bswap.h $RPM_BUILD_ROOT%{_includedir}/libavutil
432cp -a libavutil/common.h $RPM_BUILD_ROOT%{_includedir}/libavutil
433cp -a libavutil/mem.h $RPM_BUILD_ROOT%{_includedir}/libavutil
434for a in libavutil/*/bswap.h; do
435 install -D $a $RPM_BUILD_ROOT%{_includedir}/$a
436done
9d4f8977
ER
437cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
438cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
439# for lim-omx ffmpeg components
440cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 441
b8c60172
ER
442install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
443cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
444cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 445mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 446install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 447
2b2445b7
ER
448# install as ffmpeg-avconfig to avoid with possible programs looking for
449# ffmpeg-config and expecting --libs output from it which is not implemented
450# simple to do (by querying pkgconfig), but why?
b8c60172 451install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 452
9fc4ad22
AM
453%clean
454rm -rf $RPM_BUILD_ROOT
455
1ef27ea1
JB
456%post libs -p /sbin/ldconfig
457%postun libs -p /sbin/ldconfig
539b540f 458
38cf6de3
ER
459%pre ffserver
460%groupadd -g 167 ffserver
461%useradd -g ffserver -u 167 ffserver
462
593d3a64
ER
463%post ffserver
464/sbin/chkconfig --add ffserver
465%service ffserver restart
466
38cf6de3 467%preun ffserver
593d3a64
ER
468if [ "$1" = 0 ]; then
469 %service ffserver stop
470 /sbin/chkconfig --del ffserver
471fi
472
38cf6de3
ER
473%postun ffserver
474if [ "$1" = 0 ]; then
475 %userremove ffserver
476 %groupremove ffserver
477fi
478
9fc4ad22
AM
479%files
480%defattr(644,root,root,755)
660918c5 481%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
2a60eebe 482%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 483%attr(755,root,root) %{_bindir}/ffprobe
b7313442 484%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
485%dir %{_datadir}/ffmpeg
486%{_datadir}/ffmpeg/*.ffpreset
714dcf83 487%{_datadir}/ffmpeg/ffprobe.xsd
64f8f109
ER
488%{?with_doc:%{_mandir}/man1/ffmpeg.1*}
489%{?with_doc:%{_mandir}/man1/ffprobe.1*}
54ec280e
PG
490
491%files libs
492%defattr(644,root,root,755)
f50f7d7c 493%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
5663f846 494%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
d0a0ec26 495%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
5663f846 496%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
314ef0df 497%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
1c1d1368 498%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
f50f7d7c 499%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
5663f846
JB
500%attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
501%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
502%attr(755,root,root) %ghost %{_libdir}/libavresample.so.0
f50f7d7c 503%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
cbdd2688 504%attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
d7493de8 505%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 506%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
507%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
508%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 509%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 510%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 511
539b540f
JB
512%files devel
513%defattr(644,root,root,755)
54ec280e 514%doc doc/optimization.txt
1ef27ea1 515%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 516%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 517%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 518%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 519%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 520%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 521%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 522%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 523%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 524%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 525%{_includedir}/ffmpeg
6382c99d
AM
526%{_includedir}/libavcodec
527%{_includedir}/libavdevice
314ef0df 528%{_includedir}/libavfilter
6382c99d 529%{_includedir}/libavformat
5663f846 530%{_includedir}/libavresample
6382c99d
AM
531%{_includedir}/libavutil
532%{_includedir}/libpostproc
660918c5 533%{_includedir}/libswresample
6382c99d 534%{_includedir}/libswscale
1ef27ea1
JB
535%{_pkgconfigdir}/libavcodec.pc
536%{_pkgconfigdir}/libavdevice.pc
537%{_pkgconfigdir}/libavfilter.pc
538%{_pkgconfigdir}/libavformat.pc
5663f846 539%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
540%{_pkgconfigdir}/libavutil.pc
541%{_pkgconfigdir}/libpostproc.pc
660918c5 542%{_pkgconfigdir}/libswresample.pc
1ef27ea1 543%{_pkgconfigdir}/libswscale.pc
539b540f 544
9cf4d8a4
JB
545%files static
546%defattr(644,root,root,755)
1ef27ea1
JB
547%{_libdir}/libavcodec.a
548%{_libdir}/libavdevice.a
549%{_libdir}/libavfilter.a
550%{_libdir}/libavformat.a
5663f846 551%{_libdir}/libavresample.a
1ef27ea1
JB
552%{_libdir}/libavutil.a
553%{_libdir}/libpostproc.a
660918c5 554%{_libdir}/libswresample.a
1ef27ea1 555%{_libdir}/libswscale.a
af49d6ab
JB
556
557%files ffplay
558%defattr(644,root,root,755)
559%attr(755,root,root) %{_bindir}/ffplay
64f8f109 560%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 561
fde29260
ER
562%files ffserver
563%defattr(644,root,root,755)
564%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
565%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
566%attr(755,root,root) %{_sbindir}/ffserver
567%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 568%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
569%dir %attr(770,root,ffserver) /var/cache/ffserver
570%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.361962 seconds and 4 git commands to generate.