]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- release 2 (by relup.sh)
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
197f4211 1#
5663f846
JB
2# How to deal with ffmpeg/opencv checken-egg problem:
3# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 4# 2. make-request -r opencv.spec
5# 3. bump release of ffmpeg.spec
6# 4. make-request -r ffmpeg.spec
7#
2b3b2117 8# Conditional build:
38cefaee 9%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 10%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
004e5628 11%bcond_with fdk_aac # AAC encoding via libfdk_aac (requires nonfree)
1c1d1368 12%bcond_without caca # textual display using libcaca
a584ded4
JB
13%bcond_without flite # flite voice synthesis support
14%bcond_without frei0r # frei0r video filtering
cbeed0a5 15%bcond_without ilbc # iLBC de/encoding via WebRTC libilbc
a584ded4
JB
16%bcond_without openal # OpenAL 1.1 capture support
17%bcond_without opencv # OpenCV video filtering
18%bcond_without pulseaudio # PulseAudio input support
19%bcond_without x264 # x264 encoder
20%bcond_without utvideo # Ut Video decoder
1ef27ea1
JB
21%bcond_without va # VAAPI (Video Acceleration API)
22%bcond_without vpx # VP8, a high-quality video codec
23%bcond_without doc # don't build docs
314ef0df 24
cbdd2688
JB
25Summary: FFmpeg - a very fast video and audio converter
26Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 27Name: ffmpeg
1c1d1368 28Version: 1.0
6b934e79 29Release: 2
9cf4d8a4 30# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
31# (postprocessing, some filters, x264, xavs, xvid, x11grab)
32# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 33License: GPL v3+ with LGPL v3+ parts
fde29260 34Group: Applications/Multimedia
1ef27ea1 35Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
1c1d1368 36# Source0-md5: 3ed526cea20c1bffb5a37f7730f710bd
fde29260
ER
37Source1: ffserver.init
38Source2: ffserver.sysconfig
38cf6de3 39Source3: ffserver.conf
5663f846 40Patch0: %{name}-gsm.patch
3eef5ddf 41Patch1: %{name}-opencv24.patch
ae5be86b 42Patch2: %{name}-openjpeg.patch
85f7cea1 43URL: http://www.ffmpeg.org/
d5aef92e 44%{?with_openal:BuildRequires: OpenAL-devel}
3dcb8642 45BuildRequires: SDL-devel >= 1.2.1
cbdd2688 46BuildRequires: alsa-lib-devel
38cefaee 47BuildRequires: bzip2-devel
9f9ba8ac 48BuildRequires: celt-devel >= 0.11.0
38cefaee 49%{?with_nonfree:BuildRequires: faac-devel}
004e5628 50%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
a584ded4 51%{?with_flite:BuildRequires: flite-devel >= 1.4}
3dcb8642 52BuildRequires: fontconfig-devel
2a60eebe 53BuildRequires: freetype-devel
d7a39558 54%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
55%ifarch ppc
56# require version with altivec support fixed
57BuildRequires: gcc >= 5:3.3.2-3
58%endif
d5aef92e 59BuildRequires: gnutls-devel
cbdd2688
JB
60BuildRequires: jack-audio-connection-kit-devel
61BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 62%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 63BuildRequires: libass-devel
1c1d1368 64BuildRequires: libavc1394-devel
3dcb8642 65BuildRequires: libbluray-devel
1c1d1368 66%{?with_caca:BuildRequires: libcaca-devel}
d5aef92e 67BuildRequires: libcdio-devel
9c4296c2 68BuildRequires: libdc1394-devel >= 2
f1669449 69BuildRequires: libgsm-devel
1c1d1368 70BuildRequires: libiec61883-devel
d5aef92e 71BuildRequires: libmodplug-devel
4a927f9d 72BuildRequires: libnut-devel
7571bfa0 73BuildRequires: libraw1394-devel >= 2
cbdd2688 74BuildRequires: librtmp-devel
9042663c 75BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 76BuildRequires: libtool >= 2:1.4d-3
daf9a670 77BuildRequires: libv4l-devel
64f8f109 78%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 79BuildRequires: libvdpau-devel >= 0.2
e380e18a 80BuildRequires: libvorbis-devel
065be88e 81%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.6}
660918c5
AM
82# X264_BUILD >= 118
83%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
e1fe03f7 84%ifarch %{ix86}
85%ifnarch i386 i486
76243dbd
JB
86BuildRequires: nasm
87%endif
e1fe03f7 88%endif
1c1d1368
JB
89BuildRequires: opencore-amr-devel
90%{?with_opencv:BuildRequires: opencv-devel}
91BuildRequires: openjpeg-devel >= 1.5
92BuildRequires: opus-devel
136f0f45 93BuildRequires: perl-Encode
1463656a 94BuildRequires: perl-tools-pod
ef3c0513 95BuildRequires: pkgconfig
1c1d1368 96%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 97BuildRequires: rpmbuild(macros) >= 1.470
126fb805 98BuildRequires: schroedinger-devel
1c1d1368 99BuildRequires: speex-devel >= 1:1.2-rc1
64f8f109
ER
100%{?with_doc:BuildRequires: tetex}
101%{?with_doc:BuildRequires: texi2html}
102%{?with_doc:BuildRequires: texinfo}
1c1d1368 103BuildRequires: twolame-devel
daf9a670 104%{?with_utvideo:BuildRequires: utvideo-devel}
5dc039cb
JB
105BuildRequires: vo-aacenc-devel
106BuildRequires: vo-amrwbenc-devel
cbeed0a5 107%{?with_ilbc:BuildRequires: webrtc-libilbc-devel}
5dc039cb 108BuildRequires: xavs-devel
cbdd2688
JB
109BuildRequires: xorg-lib-libXext-devel
110BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 111BuildRequires: xvid-devel >= 1:1.1.0
cbeed0a5 112BuildRequires: yasm
33a1c0f3 113BuildRequires: zlib-devel
57ebb8ad 114%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
115# overflows maximum hash table size
116BuildConflicts: pdksh < 5.2.14-57
54ec280e 117Requires: %{name}-libs = %{version}-%{release}
839e806f 118Requires: xvid >= 1:1.1.0
af49d6ab 119Obsoletes: libpostproc
539b540f 120BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 121
2a60eebe
JB
122%define _noautoreqdep libGL.so.1 libGLU.so.1
123
c01d7857
PS
124%define specflags -fno-strict-aliasing
125
126# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
127%define specflags_ia32 -fomit-frame-pointer
128# -mmmx is needed to enable <mmintrin.h> code.
129%define specflags_i586 -mmmx
130%define specflags_i686 -mmmx
1162803a 131%define specflags_ppc -fPIC
c01d7857 132
9fc4ad22 133%description
85f7cea1
ER
134FFmpeg is a complete solution to record, convert and stream audio and
135video. It is a command line tool to convert one video file format to
136another. It also supports grabbing and encoding in real time from a TV
137card.
9fc4ad22 138
cdb7b42e 139%description -l pl.UTF-8
cbdd2688
JB
140FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
141strumieni dźwięku i obrazu. Jest to działające z linii poleceń
142narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
143także przechwytywanie i kodowanie w czasie rzeczywistym z karty
144telewizyjnej.
9fc4ad22 145
54ec280e
PG
146%package libs
147Summary: ffmpeg libraries
adcc0f76 148Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
149Group: Libraries
150
151%description libs
cbdd2688
JB
152This package contains the ffmpeg shared libraries:
153- the codec library (libavcodec). It supports most existing encoding
154 formats (MPEG, DivX, MPEG4, AC3, DV...),
155- demuxer library (libavformat). It supports most existing file
156 formats (AVI, MPEG, OGG, Matroska, ASF...),
157- video postprocessing library (libpostproc).
54ec280e 158
cdb7b42e 159%description libs -l pl.UTF-8
cbdd2688
JB
160Ten pakiet zawiera biblioteki współdzielone ffmpeg:
161- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
162 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
163- bibliotekę demuksera (libavformat); obsługuje większość istniejących
164 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
165- bibliotekę postprocessingu (libpostproc).
54ec280e 166
af49d6ab
JB
167%package devel
168Summary: ffmpeg header files
adcc0f76 169Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 170Group: Development/Libraries
54ec280e 171Requires: %{name}-libs = %{version}-%{release}
38cefaee 172# Libs.private from *.pc (unreasonably they are all the same)
3dcb8642 173Requires: SDL-devel >= 1.2.1
38cefaee
JB
174Requires: alsa-lib-devel
175Requires: bzip2-devel
9c4296c2 176Requires: celt-devel >= 0.11.0
38cefaee 177%{?with_nonfree:Requires: faac-devel}
004e5628 178%{?with_fdk_aac:Requires: fdk-aac-devel}
3dcb8642
JB
179Requires: fontconfig-devel
180Requires: freetype-devel
38cefaee 181Requires: jack-audio-connection-kit-devel
a584ded4 182%{?with_flite:Requires: flite-devel >= 1.4}
38cefaee 183Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
184%{?with_aacplus:Requires: libaacplus-devel >= 2.0.0}
185Requires: libass-devel
186Requires: libavc1394-devel
3dcb8642 187Requires: libbluray-devel
1c1d1368 188Requires: libcdio-devel
9c4296c2 189Requires: libdc1394-devel >= 2
bf479bc6 190Requires: libgsm-devel
1c1d1368
JB
191Requires: libiec61883-devel
192Requires: libmodplug-devel
4a927f9d 193Requires: libnut-devel
7571bfa0 194Requires: libraw1394-devel >= 2
38cefaee
JB
195Requires: librtmp-devel
196Requires: libtheora-devel >= 1.0-0.beta3
197%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 198Requires: libvorbis-devel
38cefaee 199%{?with_vpx:Requires: libvpx-devel >= 0.9.6}
ea09f25d 200%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee 201Requires: opencore-amr-devel
ae5be86b 202Requires: openjpeg-devel >= 1.5
38cefaee
JB
203Requires: schroedinger-devel
204Requires: speex-devel >= 1:1.2-rc1
1c1d1368 205Requires: twolame-devel
38cefaee
JB
206Requires: vo-aacenc-devel
207Requires: vo-amrwbenc-devel
cbeed0a5 208%{?with_ilbc:Requires: webrtc-libilbc-devel}
38cefaee
JB
209Requires: xavs-devel
210Requires: xorg-lib-libXext-devel
211Requires: xorg-lib-libXfixes-devel
46f2a56b 212Requires: xvid-devel >= 1:1.1.0
33a1c0f3 213Requires: zlib-devel
8152d6a2 214Obsoletes: libpostproc-devel
af49d6ab
JB
215
216%description devel
217ffmpeg header files.
218
cdb7b42e
JR
219%description devel -l pl.UTF-8
220Pliki nagłówkowe ffmpeg.
af49d6ab
JB
221
222%package static
223Summary: ffmpeg static libraries
adcc0f76 224Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
225Group: Development/Libraries
226Requires: %{name}-devel = %{version}-%{release}
227
228%description static
229ffmpeg static libraries (libavcodec and libavformat).
230
cdb7b42e 231%description static -l pl.UTF-8
af49d6ab
JB
232Statyczne biblioteki ffmpeg (libavcodec i libavformat).
233
2a60eebe
JB
234%package ffplay
235Summary: FFplay - SDL-based media player
adcc0f76 236Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 237Group: Applications/Multimedia
54ec280e 238Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
239
240%description ffplay
241FFplay is a very simple and portable media player using the FFmpeg
242libraries and the SDL library. It is mostly used as a test bench for
243the various APIs of FFmpeg.
244
cdb7b42e
JR
245%description ffplay -l pl.UTF-8
246FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
247bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
248testowania różnych API FFmpeg.
2a60eebe 249
fde29260
ER
250%package ffserver
251Summary: FFserver video server
adcc0f76 252Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 253Group: Daemons
593d3a64 254Requires(post,preun): /sbin/chkconfig
67103923 255Requires: %{name}-libs = %{version}-%{release}
2305d791 256Requires: rc-scripts >= 0.4.0.10
fde29260
ER
257
258%description ffserver
259FFserver is a streaming server for both audio and video. It supports
260several live feeds, streaming from files and time shifting on live
261feeds (you can seek to positions in the past on each live feed,
262provided you specify a big enough feed storage in ffserver.conf).
263
cdb7b42e
JR
264%description ffserver -l pl.UTF-8
265FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
266źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
267czasie dla źródeł na żywo (można przeskakiwać na położenia w
268przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
269dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 270
9fc4ad22 271%prep
aed8e8c9 272%setup -q
f1669449 273%patch0 -p1
3eef5ddf 274%patch1 -p0
ae5be86b 275%patch2 -p1
9fc4ad22 276
9d4f8977
ER
277# package the grep result for mplayer, the result formatted as ./mplayer/configure
278cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
279#! /bin/sh
280_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
281_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
282_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
283_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
284_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
285_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
286_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
287EOF
9d4f8977 288cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
289
290case "$1" in
291--decoders)
292 echo $_libavdecoders_all
293 ;;
294--encoders)
295 echo $_libavencoders_all
296 ;;
297--parsers)
298 echo $_libavparsers_all
299 ;;
300--bsfs)
301 echo $_libavbsfs_all
302 ;;
303--demuxers)
304 echo $_libavdemuxers_all
305 ;;
306--muxers)
307 echo $_libavmuxers_all
308 ;;
309--protocols)
310 echo $_libavprotocols_all
311 ;;
312*)
313 cat <<USAGE
314Usage: $0 [OPTION]
315Options:
316 --decoders
317 --encoders
318 --parsers
319 --bsfs
320 --demuxers
321 --muxers
322 --protocols
323USAGE
324 exit 1;;
325esac
326
327exit 0
328EOF
329
9fc4ad22 330%build
05e1eb2f
JB
331# notes:
332# - it's not autoconf configure
d0a0ec26 333# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 334./configure \
b4680d0b 335 --arch=%{_target_base_arch} \
539b540f 336 --prefix=%{_prefix} \
9cf4d8a4 337 --libdir=%{_libdir} \
d81dfa95 338 --shlibdir=%{_libdir} \
2a60eebe 339 --mandir=%{_mandir} \
314ef0df 340 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 341 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 342 --cc="%{__cc}" \
126fb805
JB
343 --disable-debug \
344 --disable-optimizations \
6382c99d 345 --disable-stripping \
314ef0df 346 --enable-avfilter \
0797daec 347 --enable-avresample \
d5aef92e 348 --enable-gnutls \
126fb805 349 --enable-gpl \
0b43f655 350 --enable-version3 \
3dcb8642 351 --enable-fontconfig \
d7a39558 352 %{?with_frei0r:--enable-frei0r} \
2e585b44 353 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 354 --enable-libass \
3dcb8642 355 --enable-libbluray \
1c1d1368 356 %{?with_libcaca:--enable-libcaca} \
cbdd2688 357 --enable-libcelt \
d5aef92e
JB
358 --enable-libcdio \
359 --enable-libdc1394 \
004e5628 360 %{?with_fdk_aac:--enable-libfdk-aac} \
1c1d1368 361 %{?with_flite:--enable-libflite} \
3dcb8642 362 --enable-libfreetype \
f3692243 363 --enable-libgsm \
1c1d1368 364 --enable-libiec61883 \
004e5628 365 %{?with_ilbc:--enable-libilbc} \
d5aef92e 366 --enable-libmodplug \
15c15700 367 --enable-libmp3lame \
4a927f9d 368 --enable-libnut \
cbdd2688
JB
369 --enable-libopencore-amrnb \
370 --enable-libopencore-amrwb \
192f9f57 371 %{?with_opencv:--enable-libopencv} \
cbdd2688 372 --enable-libopenjpeg \
1c1d1368 373 --enable-libopus \
d5aef92e 374 %{?with_pulseaudio:--enable-libpulse} \
cbdd2688 375 --enable-librtmp \
126fb805 376 --enable-libschroedinger \
da99dcf2 377 --enable-libspeex \
126fb805 378 --enable-libtheora \
1c1d1368 379 --enable-libtwolame \
daf9a670 380 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 381 --enable-libv4l2 \
5dc039cb
JB
382 --enable-libvo-aacenc \
383 --enable-libvo-amrwbenc \
126fb805 384 --enable-libvorbis \
64f8f109 385 %{?with_vpx:--enable-libvpx} \
ea09f25d 386 %{?with_x264:--enable-libx264} \
5dc039cb 387 --enable-libxavs \
126fb805 388 --enable-libxvid \
d5aef92e 389 %{?with_openal:--enable-openal} \
6382c99d 390 --enable-postproc \
d7493de8 391 --enable-pthreads \
9cf4d8a4 392 --enable-shared \
6382c99d 393 --enable-swscale \
1c1d1368 394 %{?with_va:--enable-vaapi} \
0b43f655 395 --enable-vdpau \
75231f25 396 --enable-x11grab \
7a286645 397%ifnarch %{ix86} %{x8664}
e1fe03f7 398 --disable-mmx \
399%endif
400%ifarch i386 i486
05e1eb2f 401 --disable-mmx \
b524cd99 402%endif
0b43f655 403%if %{with nonfree}
48610c64 404 --enable-nonfree \
0b43f655 405 --enable-libfaac \
76243dbd 406%endif
75231f25 407 --enable-runtime-cpudetect
2305d791 408
da99dcf2 409# force oldscaler build
b8c60172 410%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 411
1ef27ea1
JB
412%{__make} \
413 V=1
9fc4ad22 414
b8c60172
ER
415# CC_O to add -c to commandline. makefile should be patched
416%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
417
9fc4ad22
AM
418%install
419rm -rf $RPM_BUILD_ROOT
38cf6de3 420install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 421 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 422 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 423
539b540f 424%{__make} install \
1ef27ea1
JB
425 DESTDIR=$RPM_BUILD_ROOT \
426 V=1
539b540f 427
544421b2
ER
428cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
429cp -a libavutil/intreadwrite.h $RPM_BUILD_ROOT%{_includedir}/libavutil
430cp -a libavutil/bswap.h $RPM_BUILD_ROOT%{_includedir}/libavutil
431cp -a libavutil/common.h $RPM_BUILD_ROOT%{_includedir}/libavutil
432cp -a libavutil/mem.h $RPM_BUILD_ROOT%{_includedir}/libavutil
433for a in libavutil/*/bswap.h; do
434 install -D $a $RPM_BUILD_ROOT%{_includedir}/$a
435done
9d4f8977
ER
436cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
437cp -a libavformat/avio.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
438# for lim-omx ffmpeg components
439cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 440
b8c60172
ER
441install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
442cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
443cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 444mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 445install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 446
2b2445b7
ER
447# install as ffmpeg-avconfig to avoid with possible programs looking for
448# ffmpeg-config and expecting --libs output from it which is not implemented
449# simple to do (by querying pkgconfig), but why?
b8c60172 450install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 451
9fc4ad22
AM
452%clean
453rm -rf $RPM_BUILD_ROOT
454
1ef27ea1
JB
455%post libs -p /sbin/ldconfig
456%postun libs -p /sbin/ldconfig
539b540f 457
38cf6de3
ER
458%pre ffserver
459%groupadd -g 167 ffserver
460%useradd -g ffserver -u 167 ffserver
461
593d3a64
ER
462%post ffserver
463/sbin/chkconfig --add ffserver
464%service ffserver restart
465
38cf6de3 466%preun ffserver
593d3a64
ER
467if [ "$1" = 0 ]; then
468 %service ffserver stop
469 /sbin/chkconfig --del ffserver
470fi
471
38cf6de3
ER
472%postun ffserver
473if [ "$1" = 0 ]; then
474 %userremove ffserver
475 %groupremove ffserver
476fi
477
9fc4ad22
AM
478%files
479%defattr(644,root,root,755)
660918c5 480%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
2a60eebe 481%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 482%attr(755,root,root) %{_bindir}/ffprobe
b7313442 483%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
484%dir %{_datadir}/ffmpeg
485%{_datadir}/ffmpeg/*.ffpreset
714dcf83 486%{_datadir}/ffmpeg/ffprobe.xsd
64f8f109
ER
487%{?with_doc:%{_mandir}/man1/ffmpeg.1*}
488%{?with_doc:%{_mandir}/man1/ffprobe.1*}
54ec280e
PG
489
490%files libs
491%defattr(644,root,root,755)
f50f7d7c 492%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
5663f846 493%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
d0a0ec26 494%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
5663f846 495%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
314ef0df 496%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
1c1d1368 497%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
f50f7d7c 498%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
5663f846
JB
499%attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
500%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
501%attr(755,root,root) %ghost %{_libdir}/libavresample.so.0
f50f7d7c 502%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
cbdd2688 503%attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
d7493de8 504%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 505%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
506%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
507%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 508%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 509%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 510
539b540f
JB
511%files devel
512%defattr(644,root,root,755)
54ec280e 513%doc doc/optimization.txt
1ef27ea1 514%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 515%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 516%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 517%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 518%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 519%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 520%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 521%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 522%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 523%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 524%{_includedir}/ffmpeg
6382c99d
AM
525%{_includedir}/libavcodec
526%{_includedir}/libavdevice
314ef0df 527%{_includedir}/libavfilter
6382c99d 528%{_includedir}/libavformat
5663f846 529%{_includedir}/libavresample
6382c99d
AM
530%{_includedir}/libavutil
531%{_includedir}/libpostproc
660918c5 532%{_includedir}/libswresample
6382c99d 533%{_includedir}/libswscale
1ef27ea1
JB
534%{_pkgconfigdir}/libavcodec.pc
535%{_pkgconfigdir}/libavdevice.pc
536%{_pkgconfigdir}/libavfilter.pc
537%{_pkgconfigdir}/libavformat.pc
5663f846 538%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
539%{_pkgconfigdir}/libavutil.pc
540%{_pkgconfigdir}/libpostproc.pc
660918c5 541%{_pkgconfigdir}/libswresample.pc
1ef27ea1 542%{_pkgconfigdir}/libswscale.pc
539b540f 543
9cf4d8a4
JB
544%files static
545%defattr(644,root,root,755)
1ef27ea1
JB
546%{_libdir}/libavcodec.a
547%{_libdir}/libavdevice.a
548%{_libdir}/libavfilter.a
549%{_libdir}/libavformat.a
5663f846 550%{_libdir}/libavresample.a
1ef27ea1
JB
551%{_libdir}/libavutil.a
552%{_libdir}/libpostproc.a
660918c5 553%{_libdir}/libswresample.a
1ef27ea1 554%{_libdir}/libswscale.a
af49d6ab
JB
555
556%files ffplay
557%defattr(644,root,root,755)
558%attr(755,root,root) %{_bindir}/ffplay
64f8f109 559%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 560
fde29260
ER
561%files ffserver
562%defattr(644,root,root,755)
563%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
564%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
565%attr(755,root,root) %{_sbindir}/ffserver
566%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 567%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
568%dir %attr(770,root,ffserver) /var/cache/ffserver
569%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.223383 seconds and 4 git commands to generate.