]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- updated to 1.1 (note: new libavresample,libavutil sonames; ffmpeg 1.0.x left on...
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
28673856 1# TODO: libsoxr [libsoxr, soxr.h]
197f4211 2#
5663f846
JB
3# How to deal with ffmpeg/opencv checken-egg problem:
4# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 5# 2. make-request -r opencv.spec
6# 3. bump release of ffmpeg.spec
7# 4. make-request -r ffmpeg.spec
8#
2b3b2117 9# Conditional build:
38cefaee 10%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 11%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
004e5628 12%bcond_with fdk_aac # AAC encoding via libfdk_aac (requires nonfree)
1c1d1368 13%bcond_without caca # textual display using libcaca
a584ded4
JB
14%bcond_without flite # flite voice synthesis support
15%bcond_without frei0r # frei0r video filtering
cbeed0a5 16%bcond_without ilbc # iLBC de/encoding via WebRTC libilbc
a584ded4
JB
17%bcond_without openal # OpenAL 1.1 capture support
18%bcond_without opencv # OpenCV video filtering
19%bcond_without pulseaudio # PulseAudio input support
20%bcond_without x264 # x264 encoder
21%bcond_without utvideo # Ut Video decoder
1ef27ea1
JB
22%bcond_without va # VAAPI (Video Acceleration API)
23%bcond_without vpx # VP8, a high-quality video codec
24%bcond_without doc # don't build docs
314ef0df 25
cbdd2688
JB
26Summary: FFmpeg - a very fast video and audio converter
27Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 28Name: ffmpeg
28673856 29Version: 1.1
103537b9 30Release: 1
9cf4d8a4 31# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
32# (postprocessing, some filters, x264, xavs, xvid, x11grab)
33# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 34License: GPL v3+ with LGPL v3+ parts
fde29260 35Group: Applications/Multimedia
1ef27ea1 36Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
28673856 37# Source0-md5: 578c590a0e996c1fc71acb666c0ed858
fde29260
ER
38Source1: ffserver.init
39Source2: ffserver.sysconfig
38cf6de3 40Source3: ffserver.conf
5663f846 41Patch0: %{name}-gsm.patch
3eef5ddf 42Patch1: %{name}-opencv24.patch
28673856 43Patch2: %{name}-cdio-paranoia.patch
85f7cea1 44URL: http://www.ffmpeg.org/
28673856 45%{?with_openal:BuildRequires: OpenAL-devel >= 1.1}
3dcb8642 46BuildRequires: SDL-devel >= 1.2.1
cbdd2688 47BuildRequires: alsa-lib-devel
38cefaee 48BuildRequires: bzip2-devel
9f9ba8ac 49BuildRequires: celt-devel >= 0.11.0
38cefaee 50%{?with_nonfree:BuildRequires: faac-devel}
004e5628 51%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
a584ded4 52%{?with_flite:BuildRequires: flite-devel >= 1.4}
3dcb8642 53BuildRequires: fontconfig-devel
2a60eebe 54BuildRequires: freetype-devel
d7a39558 55%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
56%ifarch ppc
57# require version with altivec support fixed
58BuildRequires: gcc >= 5:3.3.2-3
59%endif
d5aef92e 60BuildRequires: gnutls-devel
cbdd2688
JB
61BuildRequires: jack-audio-connection-kit-devel
62BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 63%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 64BuildRequires: libass-devel
1c1d1368 65BuildRequires: libavc1394-devel
3dcb8642 66BuildRequires: libbluray-devel
1c1d1368 67%{?with_caca:BuildRequires: libcaca-devel}
a09e741c 68BuildRequires: libcdio-paranoia-devel >= 0.90-2
9c4296c2 69BuildRequires: libdc1394-devel >= 2
f1669449 70BuildRequires: libgsm-devel
1c1d1368 71BuildRequires: libiec61883-devel
d5aef92e 72BuildRequires: libmodplug-devel
4a927f9d 73BuildRequires: libnut-devel
7571bfa0 74BuildRequires: libraw1394-devel >= 2
cbdd2688 75BuildRequires: librtmp-devel
9042663c 76BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 77BuildRequires: libtool >= 2:1.4d-3
daf9a670 78BuildRequires: libv4l-devel
64f8f109 79%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 80BuildRequires: libvdpau-devel >= 0.2
e380e18a 81BuildRequires: libvorbis-devel
28673856 82%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.7}
660918c5
AM
83# X264_BUILD >= 118
84%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
e1fe03f7 85%ifarch %{ix86}
86%ifnarch i386 i486
76243dbd
JB
87BuildRequires: nasm
88%endif
e1fe03f7 89%endif
1c1d1368
JB
90BuildRequires: opencore-amr-devel
91%{?with_opencv:BuildRequires: opencv-devel}
92BuildRequires: openjpeg-devel >= 1.5
93BuildRequires: opus-devel
136f0f45 94BuildRequires: perl-Encode
1463656a 95BuildRequires: perl-tools-pod
ef3c0513 96BuildRequires: pkgconfig
1c1d1368 97%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 98BuildRequires: rpmbuild(macros) >= 1.470
126fb805 99BuildRequires: schroedinger-devel
1c1d1368 100BuildRequires: speex-devel >= 1:1.2-rc1
64f8f109
ER
101%{?with_doc:BuildRequires: tetex}
102%{?with_doc:BuildRequires: texi2html}
103%{?with_doc:BuildRequires: texinfo}
1c1d1368 104BuildRequires: twolame-devel
daf9a670 105%{?with_utvideo:BuildRequires: utvideo-devel}
5dc039cb
JB
106BuildRequires: vo-aacenc-devel
107BuildRequires: vo-amrwbenc-devel
cbeed0a5 108%{?with_ilbc:BuildRequires: webrtc-libilbc-devel}
5dc039cb 109BuildRequires: xavs-devel
28673856 110BuildRequires: xorg-lib-libX11-devel
cbdd2688
JB
111BuildRequires: xorg-lib-libXext-devel
112BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 113BuildRequires: xvid-devel >= 1:1.1.0
cbeed0a5 114BuildRequires: yasm
33a1c0f3 115BuildRequires: zlib-devel
57ebb8ad 116%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
117# overflows maximum hash table size
118BuildConflicts: pdksh < 5.2.14-57
54ec280e 119Requires: %{name}-libs = %{version}-%{release}
92a3edff 120%{?with_ilbc:Requires: webrtc-libilbc}
839e806f 121Requires: xvid >= 1:1.1.0
af49d6ab 122Obsoletes: libpostproc
539b540f 123BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 124
2a60eebe
JB
125%define _noautoreqdep libGL.so.1 libGLU.so.1
126
c01d7857
PS
127%define specflags -fno-strict-aliasing
128
129# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
130%define specflags_ia32 -fomit-frame-pointer
131# -mmmx is needed to enable <mmintrin.h> code.
132%define specflags_i586 -mmmx
133%define specflags_i686 -mmmx
1162803a 134%define specflags_ppc -fPIC
c01d7857 135
9fc4ad22 136%description
85f7cea1
ER
137FFmpeg is a complete solution to record, convert and stream audio and
138video. It is a command line tool to convert one video file format to
139another. It also supports grabbing and encoding in real time from a TV
140card.
9fc4ad22 141
cdb7b42e 142%description -l pl.UTF-8
cbdd2688
JB
143FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
144strumieni dźwięku i obrazu. Jest to działające z linii poleceń
145narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
146także przechwytywanie i kodowanie w czasie rzeczywistym z karty
147telewizyjnej.
9fc4ad22 148
54ec280e
PG
149%package libs
150Summary: ffmpeg libraries
adcc0f76 151Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
152Group: Libraries
153
154%description libs
cbdd2688
JB
155This package contains the ffmpeg shared libraries:
156- the codec library (libavcodec). It supports most existing encoding
157 formats (MPEG, DivX, MPEG4, AC3, DV...),
158- demuxer library (libavformat). It supports most existing file
159 formats (AVI, MPEG, OGG, Matroska, ASF...),
160- video postprocessing library (libpostproc).
54ec280e 161
cdb7b42e 162%description libs -l pl.UTF-8
cbdd2688
JB
163Ten pakiet zawiera biblioteki współdzielone ffmpeg:
164- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
165 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
166- bibliotekę demuksera (libavformat); obsługuje większość istniejących
167 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
168- bibliotekę postprocessingu (libpostproc).
54ec280e 169
af49d6ab
JB
170%package devel
171Summary: ffmpeg header files
adcc0f76 172Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 173Group: Development/Libraries
54ec280e 174Requires: %{name}-libs = %{version}-%{release}
38cefaee 175# Libs.private from *.pc (unreasonably they are all the same)
3dcb8642 176Requires: SDL-devel >= 1.2.1
38cefaee
JB
177Requires: alsa-lib-devel
178Requires: bzip2-devel
9c4296c2 179Requires: celt-devel >= 0.11.0
38cefaee 180%{?with_nonfree:Requires: faac-devel}
004e5628 181%{?with_fdk_aac:Requires: fdk-aac-devel}
3dcb8642
JB
182Requires: fontconfig-devel
183Requires: freetype-devel
38cefaee 184Requires: jack-audio-connection-kit-devel
a584ded4 185%{?with_flite:Requires: flite-devel >= 1.4}
38cefaee 186Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
187%{?with_aacplus:Requires: libaacplus-devel >= 2.0.0}
188Requires: libass-devel
189Requires: libavc1394-devel
3dcb8642 190Requires: libbluray-devel
28673856 191%{?with_caca:Requires: libcaca-devel}
a09e741c 192Requires: libcdio-paranoia-devel >= 0.90-2
9c4296c2 193Requires: libdc1394-devel >= 2
bf479bc6 194Requires: libgsm-devel
1c1d1368
JB
195Requires: libiec61883-devel
196Requires: libmodplug-devel
4a927f9d 197Requires: libnut-devel
7571bfa0 198Requires: libraw1394-devel >= 2
38cefaee
JB
199Requires: librtmp-devel
200Requires: libtheora-devel >= 1.0-0.beta3
201%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 202Requires: libvorbis-devel
28673856 203%{?with_vpx:Requires: libvpx-devel >= 0.9.7}
ea09f25d 204%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee 205Requires: opencore-amr-devel
fc1d9619 206%{?with_opencv:Requires: opencv-devel}
ae5be86b 207Requires: openjpeg-devel >= 1.5
38cefaee
JB
208Requires: schroedinger-devel
209Requires: speex-devel >= 1:1.2-rc1
1c1d1368 210Requires: twolame-devel
38cefaee
JB
211Requires: vo-aacenc-devel
212Requires: vo-amrwbenc-devel
cbeed0a5 213%{?with_ilbc:Requires: webrtc-libilbc-devel}
38cefaee
JB
214Requires: xavs-devel
215Requires: xorg-lib-libXext-devel
216Requires: xorg-lib-libXfixes-devel
46f2a56b 217Requires: xvid-devel >= 1:1.1.0
33a1c0f3 218Requires: zlib-devel
8152d6a2 219Obsoletes: libpostproc-devel
af49d6ab
JB
220
221%description devel
222ffmpeg header files.
223
cdb7b42e
JR
224%description devel -l pl.UTF-8
225Pliki nagłówkowe ffmpeg.
af49d6ab
JB
226
227%package static
228Summary: ffmpeg static libraries
adcc0f76 229Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
230Group: Development/Libraries
231Requires: %{name}-devel = %{version}-%{release}
232
233%description static
234ffmpeg static libraries (libavcodec and libavformat).
235
cdb7b42e 236%description static -l pl.UTF-8
af49d6ab
JB
237Statyczne biblioteki ffmpeg (libavcodec i libavformat).
238
2a60eebe
JB
239%package ffplay
240Summary: FFplay - SDL-based media player
adcc0f76 241Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 242Group: Applications/Multimedia
54ec280e 243Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
244
245%description ffplay
246FFplay is a very simple and portable media player using the FFmpeg
247libraries and the SDL library. It is mostly used as a test bench for
248the various APIs of FFmpeg.
249
cdb7b42e
JR
250%description ffplay -l pl.UTF-8
251FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
252bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
253testowania różnych API FFmpeg.
2a60eebe 254
fde29260
ER
255%package ffserver
256Summary: FFserver video server
adcc0f76 257Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 258Group: Daemons
593d3a64 259Requires(post,preun): /sbin/chkconfig
67103923 260Requires: %{name}-libs = %{version}-%{release}
2305d791 261Requires: rc-scripts >= 0.4.0.10
fde29260
ER
262
263%description ffserver
264FFserver is a streaming server for both audio and video. It supports
265several live feeds, streaming from files and time shifting on live
266feeds (you can seek to positions in the past on each live feed,
267provided you specify a big enough feed storage in ffserver.conf).
268
cdb7b42e
JR
269%description ffserver -l pl.UTF-8
270FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
271źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
272czasie dla źródeł na żywo (można przeskakiwać na położenia w
273przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
274dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 275
9fc4ad22 276%prep
aed8e8c9 277%setup -q
f1669449 278%patch0 -p1
28673856 279%patch1 -p1
ae5be86b 280%patch2 -p1
9fc4ad22 281
9d4f8977
ER
282# package the grep result for mplayer, the result formatted as ./mplayer/configure
283cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
284#! /bin/sh
285_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
286_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
287_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
288_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
289_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
290_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
291_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
292EOF
9d4f8977 293cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
294
295case "$1" in
296--decoders)
297 echo $_libavdecoders_all
298 ;;
299--encoders)
300 echo $_libavencoders_all
301 ;;
302--parsers)
303 echo $_libavparsers_all
304 ;;
305--bsfs)
306 echo $_libavbsfs_all
307 ;;
308--demuxers)
309 echo $_libavdemuxers_all
310 ;;
311--muxers)
312 echo $_libavmuxers_all
313 ;;
314--protocols)
315 echo $_libavprotocols_all
316 ;;
317*)
318 cat <<USAGE
319Usage: $0 [OPTION]
320Options:
321 --decoders
322 --encoders
323 --parsers
324 --bsfs
325 --demuxers
326 --muxers
327 --protocols
328USAGE
329 exit 1;;
330esac
331
332exit 0
333EOF
334
9fc4ad22 335%build
05e1eb2f
JB
336# notes:
337# - it's not autoconf configure
d0a0ec26 338# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 339./configure \
b4680d0b 340 --arch=%{_target_base_arch} \
539b540f 341 --prefix=%{_prefix} \
9cf4d8a4 342 --libdir=%{_libdir} \
d81dfa95 343 --shlibdir=%{_libdir} \
2a60eebe 344 --mandir=%{_mandir} \
314ef0df 345 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 346 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 347 --cc="%{__cc}" \
126fb805
JB
348 --disable-debug \
349 --disable-optimizations \
6382c99d 350 --disable-stripping \
314ef0df 351 --enable-avfilter \
0797daec 352 --enable-avresample \
d5aef92e 353 --enable-gnutls \
126fb805 354 --enable-gpl \
0b43f655 355 --enable-version3 \
3dcb8642 356 --enable-fontconfig \
d7a39558 357 %{?with_frei0r:--enable-frei0r} \
2e585b44 358 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 359 --enable-libass \
3dcb8642 360 --enable-libbluray \
2362253d 361 %{?with_caca:--enable-libcaca} \
cbdd2688 362 --enable-libcelt \
d5aef92e
JB
363 --enable-libcdio \
364 --enable-libdc1394 \
004e5628 365 %{?with_fdk_aac:--enable-libfdk-aac} \
1c1d1368 366 %{?with_flite:--enable-libflite} \
3dcb8642 367 --enable-libfreetype \
f3692243 368 --enable-libgsm \
1c1d1368 369 --enable-libiec61883 \
004e5628 370 %{?with_ilbc:--enable-libilbc} \
d5aef92e 371 --enable-libmodplug \
15c15700 372 --enable-libmp3lame \
4a927f9d 373 --enable-libnut \
cbdd2688
JB
374 --enable-libopencore-amrnb \
375 --enable-libopencore-amrwb \
192f9f57 376 %{?with_opencv:--enable-libopencv} \
cbdd2688 377 --enable-libopenjpeg \
1c1d1368 378 --enable-libopus \
d5aef92e 379 %{?with_pulseaudio:--enable-libpulse} \
cbdd2688 380 --enable-librtmp \
126fb805 381 --enable-libschroedinger \
da99dcf2 382 --enable-libspeex \
126fb805 383 --enable-libtheora \
1c1d1368 384 --enable-libtwolame \
daf9a670 385 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 386 --enable-libv4l2 \
5dc039cb
JB
387 --enable-libvo-aacenc \
388 --enable-libvo-amrwbenc \
126fb805 389 --enable-libvorbis \
64f8f109 390 %{?with_vpx:--enable-libvpx} \
ea09f25d 391 %{?with_x264:--enable-libx264} \
5dc039cb 392 --enable-libxavs \
126fb805 393 --enable-libxvid \
d5aef92e 394 %{?with_openal:--enable-openal} \
6382c99d 395 --enable-postproc \
d7493de8 396 --enable-pthreads \
9cf4d8a4 397 --enable-shared \
6382c99d 398 --enable-swscale \
1c1d1368 399 %{?with_va:--enable-vaapi} \
0b43f655 400 --enable-vdpau \
75231f25 401 --enable-x11grab \
7a286645 402%ifnarch %{ix86} %{x8664}
e1fe03f7 403 --disable-mmx \
404%endif
405%ifarch i386 i486
05e1eb2f 406 --disable-mmx \
b524cd99 407%endif
0b43f655 408%if %{with nonfree}
48610c64 409 --enable-nonfree \
0b43f655 410 --enable-libfaac \
76243dbd 411%endif
75231f25 412 --enable-runtime-cpudetect
2305d791 413
da99dcf2 414# force oldscaler build
b8c60172 415%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 416
1ef27ea1
JB
417%{__make} \
418 V=1
9fc4ad22 419
b8c60172
ER
420# CC_O to add -c to commandline. makefile should be patched
421%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
422
9fc4ad22
AM
423%install
424rm -rf $RPM_BUILD_ROOT
38cf6de3 425install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 426 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 427 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 428
a831ce58 429%{__make} install install-headers \
1ef27ea1
JB
430 DESTDIR=$RPM_BUILD_ROOT \
431 V=1
539b540f 432
a831ce58 433# install nonstandard, non-public headers manually
544421b2 434cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
544421b2 435for a in libavutil/*/bswap.h; do
a831ce58 436 install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
544421b2 437done
9d4f8977 438cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
439# for lim-omx ffmpeg components
440cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 441
b8c60172
ER
442install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
443cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
444cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 445mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 446install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 447
2b2445b7
ER
448# install as ffmpeg-avconfig to avoid with possible programs looking for
449# ffmpeg-config and expecting --libs output from it which is not implemented
450# simple to do (by querying pkgconfig), but why?
b8c60172 451install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 452
28673856
JB
453# fix man page
454%if %{with doc}
455install -d $RPM_BUILD_ROOT%{_mandir}/man3
456%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/lib*.3 $RPM_BUILD_ROOT%{_mandir}/man3
457%endif
458
9fc4ad22
AM
459%clean
460rm -rf $RPM_BUILD_ROOT
461
1ef27ea1
JB
462%post libs -p /sbin/ldconfig
463%postun libs -p /sbin/ldconfig
539b540f 464
38cf6de3
ER
465%pre ffserver
466%groupadd -g 167 ffserver
467%useradd -g ffserver -u 167 ffserver
468
593d3a64
ER
469%post ffserver
470/sbin/chkconfig --add ffserver
471%service ffserver restart
472
38cf6de3 473%preun ffserver
593d3a64
ER
474if [ "$1" = 0 ]; then
475 %service ffserver stop
476 /sbin/chkconfig --del ffserver
477fi
478
38cf6de3
ER
479%postun ffserver
480if [ "$1" = 0 ]; then
481 %userremove ffserver
482 %groupremove ffserver
483fi
484
9fc4ad22
AM
485%files
486%defattr(644,root,root,755)
660918c5 487%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
2a60eebe 488%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 489%attr(755,root,root) %{_bindir}/ffprobe
b7313442 490%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
491%dir %{_datadir}/ffmpeg
492%{_datadir}/ffmpeg/*.ffpreset
714dcf83 493%{_datadir}/ffmpeg/ffprobe.xsd
28673856
JB
494%if %{with doc}
495%{_mandir}/man1/ffmpeg.1*
496%{_mandir}/man1/ffmpeg-bitstream-filters.1*
497%{_mandir}/man1/ffmpeg-codecs.1*
498%{_mandir}/man1/ffmpeg-devices.1*
499%{_mandir}/man1/ffmpeg-filters.1*
500%{_mandir}/man1/ffmpeg-formats.1*
501%{_mandir}/man1/ffmpeg-protocols.1*
502%{_mandir}/man1/ffmpeg-resampler.1*
503%{_mandir}/man1/ffmpeg-scaler.1*
504%{_mandir}/man1/ffmpeg-utils.1*
505%{_mandir}/man1/ffprobe.1*
506%endif
54ec280e
PG
507
508%files libs
509%defattr(644,root,root,755)
f50f7d7c 510%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
5663f846 511%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
d0a0ec26 512%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
5663f846 513%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
314ef0df 514%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
1c1d1368 515%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
f50f7d7c 516%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
5663f846
JB
517%attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
518%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
28673856 519%attr(755,root,root) %ghost %{_libdir}/libavresample.so.1
f50f7d7c 520%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
28673856 521%attr(755,root,root) %ghost %{_libdir}/libavutil.so.52
d7493de8 522%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 523%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
524%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
525%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 526%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 527%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 528
539b540f
JB
529%files devel
530%defattr(644,root,root,755)
54ec280e 531%doc doc/optimization.txt
1ef27ea1 532%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 533%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 534%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 535%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 536%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 537%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 538%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 539%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 540%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 541%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 542%{_includedir}/ffmpeg
6382c99d
AM
543%{_includedir}/libavcodec
544%{_includedir}/libavdevice
314ef0df 545%{_includedir}/libavfilter
6382c99d 546%{_includedir}/libavformat
5663f846 547%{_includedir}/libavresample
6382c99d
AM
548%{_includedir}/libavutil
549%{_includedir}/libpostproc
660918c5 550%{_includedir}/libswresample
6382c99d 551%{_includedir}/libswscale
1ef27ea1
JB
552%{_pkgconfigdir}/libavcodec.pc
553%{_pkgconfigdir}/libavdevice.pc
554%{_pkgconfigdir}/libavfilter.pc
555%{_pkgconfigdir}/libavformat.pc
5663f846 556%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
557%{_pkgconfigdir}/libavutil.pc
558%{_pkgconfigdir}/libpostproc.pc
660918c5 559%{_pkgconfigdir}/libswresample.pc
1ef27ea1 560%{_pkgconfigdir}/libswscale.pc
28673856
JB
561%if %{with doc}
562%{_mandir}/man3/libavcodec.3*
563%{_mandir}/man3/libavdevice.3*
564%{_mandir}/man3/libavfilter.3*
565%{_mandir}/man3/libavformat.3*
566%{_mandir}/man3/libavutil.3*
567%{_mandir}/man3/libswresample.3*
568%{_mandir}/man3/libswscale.3*
569%endif
539b540f 570
9cf4d8a4
JB
571%files static
572%defattr(644,root,root,755)
1ef27ea1
JB
573%{_libdir}/libavcodec.a
574%{_libdir}/libavdevice.a
575%{_libdir}/libavfilter.a
576%{_libdir}/libavformat.a
5663f846 577%{_libdir}/libavresample.a
1ef27ea1
JB
578%{_libdir}/libavutil.a
579%{_libdir}/libpostproc.a
660918c5 580%{_libdir}/libswresample.a
1ef27ea1 581%{_libdir}/libswscale.a
af49d6ab
JB
582
583%files ffplay
584%defattr(644,root,root,755)
585%attr(755,root,root) %{_bindir}/ffplay
64f8f109 586%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 587
fde29260
ER
588%files ffserver
589%defattr(644,root,root,755)
590%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
591%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
592%attr(755,root,root) %{_sbindir}/ffserver
593%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 594%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
595%dir %attr(770,root,ffserver) /var/cache/ffserver
596%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.205008 seconds and 4 git commands to generate.