]> git.pld-linux.org Git - packages/ffmpeg.git/blame - ffmpeg.spec
- use install-headers to install headers
[packages/ffmpeg.git] / ffmpeg.spec
CommitLineData
197f4211 1#
5663f846
JB
2# How to deal with ffmpeg/opencv checken-egg problem:
3# 1. make-request -r --without opencv ffmpeg.spec
192f9f57 4# 2. make-request -r opencv.spec
5# 3. bump release of ffmpeg.spec
6# 4. make-request -r ffmpeg.spec
7#
2b3b2117 8# Conditional build:
38cefaee 9%bcond_with nonfree # non free options of package (currently: faac)
2e585b44 10%bcond_with aacplus # AAC+ encoding via libaacplus (requires nonfree)
004e5628 11%bcond_with fdk_aac # AAC encoding via libfdk_aac (requires nonfree)
1c1d1368 12%bcond_without caca # textual display using libcaca
a584ded4
JB
13%bcond_without flite # flite voice synthesis support
14%bcond_without frei0r # frei0r video filtering
cbeed0a5 15%bcond_without ilbc # iLBC de/encoding via WebRTC libilbc
a584ded4
JB
16%bcond_without openal # OpenAL 1.1 capture support
17%bcond_without opencv # OpenCV video filtering
18%bcond_without pulseaudio # PulseAudio input support
19%bcond_without x264 # x264 encoder
20%bcond_without utvideo # Ut Video decoder
1ef27ea1
JB
21%bcond_without va # VAAPI (Video Acceleration API)
22%bcond_without vpx # VP8, a high-quality video codec
23%bcond_without doc # don't build docs
314ef0df 24
cbdd2688
JB
25Summary: FFmpeg - a very fast video and audio converter
26Summary(pl.UTF-8): FFmpeg - szybki konwerter audio/wideo
9fc4ad22 27Name: ffmpeg
103537b9
AM
28Version: 1.0.1
29Release: 1
9cf4d8a4 30# LGPL or GPL, chosen at configure time (GPL version is more featured)
38cefaee
JB
31# (postprocessing, some filters, x264, xavs, xvid, x11grab)
32# using v3 allows Apache-licensed libs (opencore-amr, libvo-*enc)
0b43f655 33License: GPL v3+ with LGPL v3+ parts
fde29260 34Group: Applications/Multimedia
1ef27ea1 35Source0: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
103537b9 36# Source0-md5: dbbb88ce5525dea22b24aaa098a9bcc2
fde29260
ER
37Source1: ffserver.init
38Source2: ffserver.sysconfig
38cf6de3 39Source3: ffserver.conf
5663f846 40Patch0: %{name}-gsm.patch
3eef5ddf 41Patch1: %{name}-opencv24.patch
ae5be86b 42Patch2: %{name}-openjpeg.patch
a09e741c 43Patch3: %{name}-cdio-paranoia.patch
85f7cea1 44URL: http://www.ffmpeg.org/
d5aef92e 45%{?with_openal:BuildRequires: OpenAL-devel}
3dcb8642 46BuildRequires: SDL-devel >= 1.2.1
cbdd2688 47BuildRequires: alsa-lib-devel
38cefaee 48BuildRequires: bzip2-devel
9f9ba8ac 49BuildRequires: celt-devel >= 0.11.0
38cefaee 50%{?with_nonfree:BuildRequires: faac-devel}
004e5628 51%{?with_fdk_aac:BuildRequires: fdk-aac-devel}
a584ded4 52%{?with_flite:BuildRequires: flite-devel >= 1.4}
3dcb8642 53BuildRequires: fontconfig-devel
2a60eebe 54BuildRequires: freetype-devel
d7a39558 55%{?with_frei0r:BuildRequires: frei0r-devel}
4bee03f0
JB
56%ifarch ppc
57# require version with altivec support fixed
58BuildRequires: gcc >= 5:3.3.2-3
59%endif
d5aef92e 60BuildRequires: gnutls-devel
cbdd2688
JB
61BuildRequires: jack-audio-connection-kit-devel
62BuildRequires: lame-libs-devel >= 3.98.3
2e585b44 63%{?with_aacplus:BuildRequires: libaacplus-devel >= 2.0.0}
d5aef92e 64BuildRequires: libass-devel
1c1d1368 65BuildRequires: libavc1394-devel
3dcb8642 66BuildRequires: libbluray-devel
1c1d1368 67%{?with_caca:BuildRequires: libcaca-devel}
a09e741c 68BuildRequires: libcdio-paranoia-devel >= 0.90-2
9c4296c2 69BuildRequires: libdc1394-devel >= 2
f1669449 70BuildRequires: libgsm-devel
1c1d1368 71BuildRequires: libiec61883-devel
d5aef92e 72BuildRequires: libmodplug-devel
4a927f9d 73BuildRequires: libnut-devel
7571bfa0 74BuildRequires: libraw1394-devel >= 2
cbdd2688 75BuildRequires: librtmp-devel
9042663c 76BuildRequires: libtheora-devel >= 1.0-0.beta3
4814ac84 77BuildRequires: libtool >= 2:1.4d-3
daf9a670 78BuildRequires: libv4l-devel
64f8f109 79%{?with_va:BuildRequires: libva-devel >= 1.0.3}
9c4296c2 80BuildRequires: libvdpau-devel >= 0.2
e380e18a 81BuildRequires: libvorbis-devel
065be88e 82%{?with_vpx:BuildRequires: libvpx-devel >= 0.9.6}
660918c5
AM
83# X264_BUILD >= 118
84%{?with_x264:BuildRequires: libx264-devel >= 0.1.3-1.20111212_2245}
e1fe03f7 85%ifarch %{ix86}
86%ifnarch i386 i486
76243dbd
JB
87BuildRequires: nasm
88%endif
e1fe03f7 89%endif
1c1d1368
JB
90BuildRequires: opencore-amr-devel
91%{?with_opencv:BuildRequires: opencv-devel}
92BuildRequires: openjpeg-devel >= 1.5
93BuildRequires: opus-devel
136f0f45 94BuildRequires: perl-Encode
1463656a 95BuildRequires: perl-tools-pod
ef3c0513 96BuildRequires: pkgconfig
1c1d1368 97%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
db8052c8 98BuildRequires: rpmbuild(macros) >= 1.470
126fb805 99BuildRequires: schroedinger-devel
1c1d1368 100BuildRequires: speex-devel >= 1:1.2-rc1
64f8f109
ER
101%{?with_doc:BuildRequires: tetex}
102%{?with_doc:BuildRequires: texi2html}
103%{?with_doc:BuildRequires: texinfo}
1c1d1368 104BuildRequires: twolame-devel
daf9a670 105%{?with_utvideo:BuildRequires: utvideo-devel}
5dc039cb
JB
106BuildRequires: vo-aacenc-devel
107BuildRequires: vo-amrwbenc-devel
cbeed0a5 108%{?with_ilbc:BuildRequires: webrtc-libilbc-devel}
5dc039cb 109BuildRequires: xavs-devel
cbdd2688
JB
110BuildRequires: xorg-lib-libXext-devel
111BuildRequires: xorg-lib-libXfixes-devel
46f2a56b 112BuildRequires: xvid-devel >= 1:1.1.0
cbeed0a5 113BuildRequires: yasm
33a1c0f3 114BuildRequires: zlib-devel
57ebb8ad 115%{?with_autoreqdep:BuildConflicts: libpostproc}
9c4296c2
JB
116# overflows maximum hash table size
117BuildConflicts: pdksh < 5.2.14-57
54ec280e 118Requires: %{name}-libs = %{version}-%{release}
92a3edff 119%{?with_ilbc:Requires: webrtc-libilbc}
839e806f 120Requires: xvid >= 1:1.1.0
af49d6ab 121Obsoletes: libpostproc
539b540f 122BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9fc4ad22 123
2a60eebe
JB
124%define _noautoreqdep libGL.so.1 libGLU.so.1
125
c01d7857
PS
126%define specflags -fno-strict-aliasing
127
128# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
129%define specflags_ia32 -fomit-frame-pointer
130# -mmmx is needed to enable <mmintrin.h> code.
131%define specflags_i586 -mmmx
132%define specflags_i686 -mmmx
1162803a 133%define specflags_ppc -fPIC
c01d7857 134
9fc4ad22 135%description
85f7cea1
ER
136FFmpeg is a complete solution to record, convert and stream audio and
137video. It is a command line tool to convert one video file format to
138another. It also supports grabbing and encoding in real time from a TV
139card.
9fc4ad22 140
cdb7b42e 141%description -l pl.UTF-8
cbdd2688
JB
142FFmpeg to kompletne rozwiązanie nagrywania, konwersji i transmisji
143strumieni dźwięku i obrazu. Jest to działające z linii poleceń
144narzędzie do konwersji obrazu z jednego formatu do innego. Obsługuje
145także przechwytywanie i kodowanie w czasie rzeczywistym z karty
146telewizyjnej.
9fc4ad22 147
54ec280e
PG
148%package libs
149Summary: ffmpeg libraries
adcc0f76 150Summary(pl.UTF-8): Biblioteki ffmpeg
54ec280e
PG
151Group: Libraries
152
153%description libs
cbdd2688
JB
154This package contains the ffmpeg shared libraries:
155- the codec library (libavcodec). It supports most existing encoding
156 formats (MPEG, DivX, MPEG4, AC3, DV...),
157- demuxer library (libavformat). It supports most existing file
158 formats (AVI, MPEG, OGG, Matroska, ASF...),
159- video postprocessing library (libpostproc).
54ec280e 160
cdb7b42e 161%description libs -l pl.UTF-8
cbdd2688
JB
162Ten pakiet zawiera biblioteki współdzielone ffmpeg:
163- bibliotekę kodeków (libavcodec); obsługuje większość istniejących
164 formatów kodowania (MPEG, DivX, MPEG4, AC3, DV...),
165- bibliotekę demuksera (libavformat); obsługuje większość istniejących
166 formatów plików (AVI, MPEG, OGG, Matroska, ASF...),
167- bibliotekę postprocessingu (libpostproc).
54ec280e 168
af49d6ab
JB
169%package devel
170Summary: ffmpeg header files
adcc0f76 171Summary(pl.UTF-8): Pliki nagłówkowe ffmpeg
af49d6ab 172Group: Development/Libraries
54ec280e 173Requires: %{name}-libs = %{version}-%{release}
38cefaee 174# Libs.private from *.pc (unreasonably they are all the same)
3dcb8642 175Requires: SDL-devel >= 1.2.1
38cefaee
JB
176Requires: alsa-lib-devel
177Requires: bzip2-devel
9c4296c2 178Requires: celt-devel >= 0.11.0
38cefaee 179%{?with_nonfree:Requires: faac-devel}
004e5628 180%{?with_fdk_aac:Requires: fdk-aac-devel}
3dcb8642
JB
181Requires: fontconfig-devel
182Requires: freetype-devel
38cefaee 183Requires: jack-audio-connection-kit-devel
a584ded4 184%{?with_flite:Requires: flite-devel >= 1.4}
38cefaee 185Requires: lame-libs-devel >= 3.98.3
1c1d1368
JB
186%{?with_aacplus:Requires: libaacplus-devel >= 2.0.0}
187Requires: libass-devel
188Requires: libavc1394-devel
3dcb8642 189Requires: libbluray-devel
a09e741c 190Requires: libcdio-paranoia-devel >= 0.90-2
9c4296c2 191Requires: libdc1394-devel >= 2
bf479bc6 192Requires: libgsm-devel
1c1d1368
JB
193Requires: libiec61883-devel
194Requires: libmodplug-devel
4a927f9d 195Requires: libnut-devel
7571bfa0 196Requires: libraw1394-devel >= 2
38cefaee
JB
197Requires: librtmp-devel
198Requires: libtheora-devel >= 1.0-0.beta3
199%{?with_va:Requires: libva-devel >= 1.0.3}
33a1c0f3 200Requires: libvorbis-devel
38cefaee 201%{?with_vpx:Requires: libvpx-devel >= 0.9.6}
ea09f25d 202%{?with_x264:Requires: libx264-devel >= 0.1.3-1.20110625_2245}
38cefaee 203Requires: opencore-amr-devel
fc1d9619 204%{?with_opencv:Requires: opencv-devel}
ae5be86b 205Requires: openjpeg-devel >= 1.5
38cefaee
JB
206Requires: schroedinger-devel
207Requires: speex-devel >= 1:1.2-rc1
1c1d1368 208Requires: twolame-devel
38cefaee
JB
209Requires: vo-aacenc-devel
210Requires: vo-amrwbenc-devel
cbeed0a5 211%{?with_ilbc:Requires: webrtc-libilbc-devel}
38cefaee
JB
212Requires: xavs-devel
213Requires: xorg-lib-libXext-devel
214Requires: xorg-lib-libXfixes-devel
46f2a56b 215Requires: xvid-devel >= 1:1.1.0
33a1c0f3 216Requires: zlib-devel
8152d6a2 217Obsoletes: libpostproc-devel
af49d6ab
JB
218
219%description devel
220ffmpeg header files.
221
cdb7b42e
JR
222%description devel -l pl.UTF-8
223Pliki nagłówkowe ffmpeg.
af49d6ab
JB
224
225%package static
226Summary: ffmpeg static libraries
adcc0f76 227Summary(pl.UTF-8): Statyczne biblioteki ffmpeg
af49d6ab
JB
228Group: Development/Libraries
229Requires: %{name}-devel = %{version}-%{release}
230
231%description static
232ffmpeg static libraries (libavcodec and libavformat).
233
cdb7b42e 234%description static -l pl.UTF-8
af49d6ab
JB
235Statyczne biblioteki ffmpeg (libavcodec i libavformat).
236
2a60eebe
JB
237%package ffplay
238Summary: FFplay - SDL-based media player
adcc0f76 239Summary(pl.UTF-8): FFplay - odtwarzacz mediów oparty na SDL
2a60eebe 240Group: Applications/Multimedia
54ec280e 241Requires: %{name}-libs = %{version}-%{release}
2a60eebe
JB
242
243%description ffplay
244FFplay is a very simple and portable media player using the FFmpeg
245libraries and the SDL library. It is mostly used as a test bench for
246the various APIs of FFmpeg.
247
cdb7b42e
JR
248%description ffplay -l pl.UTF-8
249FFplay to bardzo prosty i przenośny odtwarzacz mediów używający
250bibliotek FFmpeg oraz biblioteki SDL. Jest używany głównie do
251testowania różnych API FFmpeg.
2a60eebe 252
fde29260
ER
253%package ffserver
254Summary: FFserver video server
adcc0f76 255Summary(pl.UTF-8): FFserver - serwer strumieni obrazu
fde29260 256Group: Daemons
593d3a64 257Requires(post,preun): /sbin/chkconfig
67103923 258Requires: %{name}-libs = %{version}-%{release}
2305d791 259Requires: rc-scripts >= 0.4.0.10
fde29260
ER
260
261%description ffserver
262FFserver is a streaming server for both audio and video. It supports
263several live feeds, streaming from files and time shifting on live
264feeds (you can seek to positions in the past on each live feed,
265provided you specify a big enough feed storage in ffserver.conf).
266
cdb7b42e
JR
267%description ffserver -l pl.UTF-8
268FFserver to serwer strumieni dla dźwięku i obrazu. Obsługuje kilka
269źródeł na żywo, przekazywanie strumieni z plików i przesuwanie w
270czasie dla źródeł na żywo (można przeskakiwać na położenia w
271przeszłości dla każdego źródła na żywo, pod warunkiem odpowiednio
272dużej przestrzeni na dane skonfigurowanej w ffserver.conf).
4e0bd1da 273
9fc4ad22 274%prep
aed8e8c9 275%setup -q
f1669449 276%patch0 -p1
3eef5ddf 277%patch1 -p0
ae5be86b 278%patch2 -p1
a09e741c 279%patch3 -p1
9fc4ad22 280
9d4f8977
ER
281# package the grep result for mplayer, the result formatted as ./mplayer/configure
282cat <<EOF > ffmpeg-avconfig
2b2445b7
ER
283#! /bin/sh
284_libavdecoders_all="`sed -n 's/^[^#]*DEC.*(.*, *\(.*\)).*/\1_decoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
285_libavencoders_all="`sed -n 's/^[^#]*ENC.*(.*, *\(.*\)).*/\1_encoder/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
286_libavparsers_all="`sed -n 's/^[^#]*PARSER.*(.*, *\(.*\)).*/\1_parser/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
287_libavbsfs_all="`sed -n 's/^[^#]*BSF.*(.*, *\(.*\)).*/\1_bsf/p' libavcodec/allcodecs.c | tr '[a-z]' '[A-Z]'`"
288_libavdemuxers_all="`sed -n 's/^[^#]*DEMUX.*(.*, *\(.*\)).*/\1_demuxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
289_libavmuxers_all="`sed -n 's/^[^#]*_MUX.*(.*, *\(.*\)).*/\1_muxer/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
290_libavprotocols_all="`sed -n 's/^[^#]*PROTOCOL.*(.*, *\(.*\)).*/\1_protocol/p' libavformat/allformats.c | tr '[a-z]' '[A-Z]'`"
291EOF
9d4f8977 292cat <<'EOF' >> ffmpeg-avconfig
2b2445b7
ER
293
294case "$1" in
295--decoders)
296 echo $_libavdecoders_all
297 ;;
298--encoders)
299 echo $_libavencoders_all
300 ;;
301--parsers)
302 echo $_libavparsers_all
303 ;;
304--bsfs)
305 echo $_libavbsfs_all
306 ;;
307--demuxers)
308 echo $_libavdemuxers_all
309 ;;
310--muxers)
311 echo $_libavmuxers_all
312 ;;
313--protocols)
314 echo $_libavprotocols_all
315 ;;
316*)
317 cat <<USAGE
318Usage: $0 [OPTION]
319Options:
320 --decoders
321 --encoders
322 --parsers
323 --bsfs
324 --demuxers
325 --muxers
326 --protocols
327USAGE
328 exit 1;;
329esac
330
331exit 0
332EOF
333
9fc4ad22 334%build
05e1eb2f
JB
335# notes:
336# - it's not autoconf configure
d0a0ec26 337# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
2080d1d3 338./configure \
b4680d0b 339 --arch=%{_target_base_arch} \
539b540f 340 --prefix=%{_prefix} \
9cf4d8a4 341 --libdir=%{_libdir} \
d81dfa95 342 --shlibdir=%{_libdir} \
2a60eebe 343 --mandir=%{_mandir} \
314ef0df 344 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
1162803a 345 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
3eef5ddf 346 --cc="%{__cc}" \
126fb805
JB
347 --disable-debug \
348 --disable-optimizations \
6382c99d 349 --disable-stripping \
314ef0df 350 --enable-avfilter \
0797daec 351 --enable-avresample \
d5aef92e 352 --enable-gnutls \
126fb805 353 --enable-gpl \
0b43f655 354 --enable-version3 \
3dcb8642 355 --enable-fontconfig \
d7a39558 356 %{?with_frei0r:--enable-frei0r} \
2e585b44 357 %{?with_aacplus:--enable-libaacplus} \
d5aef92e 358 --enable-libass \
3dcb8642 359 --enable-libbluray \
2362253d 360 %{?with_caca:--enable-libcaca} \
cbdd2688 361 --enable-libcelt \
d5aef92e
JB
362 --enable-libcdio \
363 --enable-libdc1394 \
004e5628 364 %{?with_fdk_aac:--enable-libfdk-aac} \
1c1d1368 365 %{?with_flite:--enable-libflite} \
3dcb8642 366 --enable-libfreetype \
f3692243 367 --enable-libgsm \
1c1d1368 368 --enable-libiec61883 \
004e5628 369 %{?with_ilbc:--enable-libilbc} \
d5aef92e 370 --enable-libmodplug \
15c15700 371 --enable-libmp3lame \
4a927f9d 372 --enable-libnut \
cbdd2688
JB
373 --enable-libopencore-amrnb \
374 --enable-libopencore-amrwb \
192f9f57 375 %{?with_opencv:--enable-libopencv} \
cbdd2688 376 --enable-libopenjpeg \
1c1d1368 377 --enable-libopus \
d5aef92e 378 %{?with_pulseaudio:--enable-libpulse} \
cbdd2688 379 --enable-librtmp \
126fb805 380 --enable-libschroedinger \
da99dcf2 381 --enable-libspeex \
126fb805 382 --enable-libtheora \
1c1d1368 383 --enable-libtwolame \
daf9a670 384 %{?with_utvideo:--enable-libutvideo} \
d5aef92e 385 --enable-libv4l2 \
5dc039cb
JB
386 --enable-libvo-aacenc \
387 --enable-libvo-amrwbenc \
126fb805 388 --enable-libvorbis \
64f8f109 389 %{?with_vpx:--enable-libvpx} \
ea09f25d 390 %{?with_x264:--enable-libx264} \
5dc039cb 391 --enable-libxavs \
126fb805 392 --enable-libxvid \
d5aef92e 393 %{?with_openal:--enable-openal} \
6382c99d 394 --enable-postproc \
d7493de8 395 --enable-pthreads \
9cf4d8a4 396 --enable-shared \
6382c99d 397 --enable-swscale \
1c1d1368 398 %{?with_va:--enable-vaapi} \
0b43f655 399 --enable-vdpau \
75231f25 400 --enable-x11grab \
7a286645 401%ifnarch %{ix86} %{x8664}
e1fe03f7 402 --disable-mmx \
403%endif
404%ifarch i386 i486
05e1eb2f 405 --disable-mmx \
b524cd99 406%endif
0b43f655 407%if %{with nonfree}
48610c64 408 --enable-nonfree \
0b43f655 409 --enable-libfaac \
76243dbd 410%endif
75231f25 411 --enable-runtime-cpudetect
2305d791 412
da99dcf2 413# force oldscaler build
b8c60172 414%{__sed} -i -e 's|#define.*CONFIG_OLDSCALER.*0|#define CONFIG_OLDSCALER 1|g' config.h
da99dcf2 415
1ef27ea1
JB
416%{__make} \
417 V=1
9fc4ad22 418
b8c60172
ER
419# CC_O to add -c to commandline. makefile should be patched
420%{__make} tools/qt-faststart V=1 CC_O='-c -o $@'
421
9fc4ad22
AM
422%install
423rm -rf $RPM_BUILD_ROOT
38cf6de3 424install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},/etc/{sysconfig,rc.d/init.d}} \
38baa0f1 425 $RPM_BUILD_ROOT%{_includedir}/ffmpeg \
38cf6de3 426 $RPM_BUILD_ROOT/var/{cache,log}/ffserver
9fc4ad22 427
a831ce58 428%{__make} install install-headers \
1ef27ea1
JB
429 DESTDIR=$RPM_BUILD_ROOT \
430 V=1
539b540f 431
a831ce58 432# install nonstandard, non-public headers manually
544421b2 433cp -a config.h $RPM_BUILD_ROOT%{_includedir}/ffmpeg
544421b2 434for a in libavutil/*/bswap.h; do
a831ce58 435 install -Dp $a $RPM_BUILD_ROOT%{_includedir}/$a
544421b2 436done
9d4f8977 437cp -a libavformat/riff.h $RPM_BUILD_ROOT%{_includedir}/libavformat
980e7aa8
JB
438# for lim-omx ffmpeg components
439cp -a libavcodec/audioconvert.h $RPM_BUILD_ROOT%{_includedir}/libavcodec
544421b2 440
b8c60172
ER
441install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ffserver
442cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ffserver
443cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/ffserver.conf
539b540f 444mv -f $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/ffserver
b8c60172 445install -p tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
9fc4ad22 446
2b2445b7
ER
447# install as ffmpeg-avconfig to avoid with possible programs looking for
448# ffmpeg-config and expecting --libs output from it which is not implemented
449# simple to do (by querying pkgconfig), but why?
b8c60172 450install -p ffmpeg-avconfig $RPM_BUILD_ROOT%{_bindir}/ffmpeg-avconfig
2b2445b7 451
9fc4ad22
AM
452%clean
453rm -rf $RPM_BUILD_ROOT
454
1ef27ea1
JB
455%post libs -p /sbin/ldconfig
456%postun libs -p /sbin/ldconfig
539b540f 457
38cf6de3
ER
458%pre ffserver
459%groupadd -g 167 ffserver
460%useradd -g ffserver -u 167 ffserver
461
593d3a64
ER
462%post ffserver
463/sbin/chkconfig --add ffserver
464%service ffserver restart
465
38cf6de3 466%preun ffserver
593d3a64
ER
467if [ "$1" = 0 ]; then
468 %service ffserver stop
469 /sbin/chkconfig --del ffserver
470fi
471
38cf6de3
ER
472%postun ffserver
473if [ "$1" = 0 ]; then
474 %userremove ffserver
475 %groupremove ffserver
476fi
477
9fc4ad22
AM
478%files
479%defattr(644,root,root,755)
660918c5 480%doc CREDITS LICENSE MAINTAINERS README doc/{APIchanges,RELEASE_NOTES} %{?with_doc:doc/*.html}
2a60eebe 481%attr(755,root,root) %{_bindir}/ffmpeg
3a7b84be 482%attr(755,root,root) %{_bindir}/ffprobe
b7313442 483%attr(755,root,root) %{_bindir}/qt-faststart
da99dcf2
AM
484%dir %{_datadir}/ffmpeg
485%{_datadir}/ffmpeg/*.ffpreset
714dcf83 486%{_datadir}/ffmpeg/ffprobe.xsd
64f8f109
ER
487%{?with_doc:%{_mandir}/man1/ffmpeg.1*}
488%{?with_doc:%{_mandir}/man1/ffprobe.1*}
54ec280e
PG
489
490%files libs
491%defattr(644,root,root,755)
f50f7d7c 492%attr(755,root,root) %{_libdir}/libavcodec.so.*.*.*
5663f846 493%attr(755,root,root) %ghost %{_libdir}/libavcodec.so.54
d0a0ec26 494%attr(755,root,root) %{_libdir}/libavdevice.so.*.*.*
5663f846 495%attr(755,root,root) %ghost %{_libdir}/libavdevice.so.54
314ef0df 496%attr(755,root,root) %{_libdir}/libavfilter.so.*.*.*
1c1d1368 497%attr(755,root,root) %ghost %{_libdir}/libavfilter.so.3
f50f7d7c 498%attr(755,root,root) %{_libdir}/libavformat.so.*.*.*
5663f846
JB
499%attr(755,root,root) %ghost %{_libdir}/libavformat.so.54
500%attr(755,root,root) %{_libdir}/libavresample.so.*.*.*
501%attr(755,root,root) %ghost %{_libdir}/libavresample.so.0
f50f7d7c 502%attr(755,root,root) %{_libdir}/libavutil.so.*.*.*
cbdd2688 503%attr(755,root,root) %ghost %{_libdir}/libavutil.so.51
d7493de8 504%attr(755,root,root) %{_libdir}/libpostproc.so.*.*.*
714dcf83 505%attr(755,root,root) %ghost %{_libdir}/libpostproc.so.52
660918c5
AM
506%attr(755,root,root) %{_libdir}/libswresample.so.*.*.*
507%attr(755,root,root) %ghost %{_libdir}/libswresample.so.0
ee032235 508%attr(755,root,root) %{_libdir}/libswscale.so.*.*.*
cbdd2688 509%attr(755,root,root) %ghost %{_libdir}/libswscale.so.2
314ef0df 510
539b540f
JB
511%files devel
512%defattr(644,root,root,755)
54ec280e 513%doc doc/optimization.txt
1ef27ea1 514%attr(755,root,root) %{_bindir}/ffmpeg-avconfig
539b540f 515%attr(755,root,root) %{_libdir}/libavcodec.so
d0a0ec26 516%attr(755,root,root) %{_libdir}/libavdevice.so
314ef0df 517%attr(755,root,root) %{_libdir}/libavfilter.so
539b540f 518%attr(755,root,root) %{_libdir}/libavformat.so
5663f846 519%attr(755,root,root) %{_libdir}/libavresample.so
d7493de8 520%attr(755,root,root) %{_libdir}/libavutil.so
d2af4612 521%attr(755,root,root) %{_libdir}/libpostproc.so
660918c5 522%attr(755,root,root) %{_libdir}/libswresample.so
ee032235 523%attr(755,root,root) %{_libdir}/libswscale.so
539b540f 524%{_includedir}/ffmpeg
6382c99d
AM
525%{_includedir}/libavcodec
526%{_includedir}/libavdevice
314ef0df 527%{_includedir}/libavfilter
6382c99d 528%{_includedir}/libavformat
5663f846 529%{_includedir}/libavresample
6382c99d
AM
530%{_includedir}/libavutil
531%{_includedir}/libpostproc
660918c5 532%{_includedir}/libswresample
6382c99d 533%{_includedir}/libswscale
1ef27ea1
JB
534%{_pkgconfigdir}/libavcodec.pc
535%{_pkgconfigdir}/libavdevice.pc
536%{_pkgconfigdir}/libavfilter.pc
537%{_pkgconfigdir}/libavformat.pc
5663f846 538%{_pkgconfigdir}/libavresample.pc
1ef27ea1
JB
539%{_pkgconfigdir}/libavutil.pc
540%{_pkgconfigdir}/libpostproc.pc
660918c5 541%{_pkgconfigdir}/libswresample.pc
1ef27ea1 542%{_pkgconfigdir}/libswscale.pc
539b540f 543
9cf4d8a4
JB
544%files static
545%defattr(644,root,root,755)
1ef27ea1
JB
546%{_libdir}/libavcodec.a
547%{_libdir}/libavdevice.a
548%{_libdir}/libavfilter.a
549%{_libdir}/libavformat.a
5663f846 550%{_libdir}/libavresample.a
1ef27ea1
JB
551%{_libdir}/libavutil.a
552%{_libdir}/libpostproc.a
660918c5 553%{_libdir}/libswresample.a
1ef27ea1 554%{_libdir}/libswscale.a
af49d6ab
JB
555
556%files ffplay
557%defattr(644,root,root,755)
558%attr(755,root,root) %{_bindir}/ffplay
64f8f109 559%{?with_doc:%{_mandir}/man1/ffplay.1*}
af49d6ab 560
fde29260
ER
561%files ffserver
562%defattr(644,root,root,755)
563%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ffserver.conf
564%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ffserver
565%attr(755,root,root) %{_sbindir}/ffserver
566%attr(754,root,root) /etc/rc.d/init.d/ffserver
64f8f109 567%{?with_doc:%{_mandir}/man1/ffserver.1*}
38cf6de3
ER
568%dir %attr(770,root,ffserver) /var/cache/ffserver
569%dir %attr(770,root,ffserver) /var/log/ffserver
This page took 0.140811 seconds and 4 git commands to generate.